ZotFile - Advanced PDF management for Zotero

  • @darcyparks @jadoff I just pushed a new version with the fix (5.0.15). Let me know if that fixes the problem. Thanks @dstillman.
  • @Joscha Auto-update seems broken for 5.0.14. The Error Console shows these messages:

    [JavaScript Error: "XML Parsing Error: prefix not bound to a namespace
    Location: moz-nullprincipal:{...}
    Line Number 4, Column 5:" {file: "moz-nullprincipal:{...}" line: 4 column: 5
    source: " <RDF:Description about="urn:mozilla:extension:zotfile@columbia.edu">"}]

    onUpdateCheckComplete failed to determine manifest type
  • @Joscha @jadoff The new version fixes it for me. Thanks!
  • @Joscha @dstillman The fix works for me as well! Thanks so much for the quick fix!
  • Dear Zotfile experts,
    I am trying to migrate from the Zotero file structure to a custom file structure mirroring my library structure in Zotero using Zotfile. It happens that I have multiple files per Zotero entry e.g. multiple pdfs, xls, jpgs, etc. When Renaming/moving them to the new location all files get renamed and file names on the disk are differentiated by adding a number. In Zotero, however, the multiple and different file types all appear with the same same name and no possibility to differentiate foo1.pdf, foo2,pdf, foo.jpg, foo.xls etc.
    3 related questions:

    Is there a possibility to add the file extension in the name (both in zotero and in the file name) and differentiate multiple pdf - at leas as foo1.pdf, foo2.pdf within zotero?

    Renaming does not work (always) for some files (generally jpgs but I although had some scanned pdfs for which it does not work). The Dialog "zotfile: Unnamed attachments" freezes/remains gray. This happens more often using the Zotfile renaming format but also when using the standard zotero renaming format.

    How can I automatically list or exclude entries with multiple attachments for manuell treatment?

    Thank you all for your help.
  • Hi all, I recently tried to start using the save to table feature again, but I am having issues because I used it a long time ago and deleted to zotfile tablet folder in the meantime. When I reactivate it, all the old papers I have in zotfile pop up in the saved searches, and deleting the '_tablet' tag *does not remove them*. Every time I click on those saved searches, I get a string of errors, 1 for each of 343 papers, that can't be found because the new folder is empty.

    Is there any way to clean old ones out and start from scratch? Deleting all the tags is apparently not enough. Thanks!
  • @MikeDacre: You could try to suppress the warning messages by toggling the extensions.zotfile.tablet.showwarning preference in the Config Editor.
    See here: https://github.com/jlegewie/zotfile/issues/417.
  • @qqbb Thanks, that looks like exactly the same issue as mine. Unfortunately, the fix did not work for me, but I can move my comments over to that github issue since they probably make more sense there.

    It would be great if there was a way to reset ZotFile to clear all saved memory of prior on tablet files. I always thought it just used the tags to track them, but that is clearly not the case.

    Thanks again.
  • You could check the discussion here. Some similar issues might have been fixed recently, so make sure you're running the current Zotfile version (5.0.16).
  • Hi,

    I'm new using ZotFile and there's an issue with the extracted annotations. I believe the problem is because the extracted annotations are written in a language that maybe ZotFile doesn't recognise but the characters are the same as English or Spanish and I have no problems with those languages.

    Here's how it looks like:

    "Es diu que un consumidor es troba en situació�de�mercat�informat quan considera que disposa de criteris autònoms d'avaluació del producte, i en situació�de�mercat�no�informat en el cas contrari."

    Any suggestions?
  • @GabrielRobles: It seems that some characters with accents are properly extracted. Could you select the text in your pdf viewer, then copy and paste it to a text editor? If the pasted text remains of poor quality, it might be that the (hidden) text layer of your pdf is not correct. You might get better results by running OCR software on the pdf.

    Maybe the Zotero OCR add-on can do this. I would test it first on a copy of the pdf. If you are using Windows, you could check if the PDF-XChange Editor and its OCR Language Extensions could be of help. A free version for academic use seems to be offered here, but I don't know if the language files are compatible with this version.
  • @qqbb: Thanks for your help. I tried a copy paste in a text editor and the interrogations marks are still there. But in the process I realized that the problem aren't the characters. Those words with interrogations marks are bold words.
    But in the same document the titles are also written in bold letters and it's not a problem. Just in the body text.

    I ran an OCR software but it didn't solve the issue.

    Any ideas?

  • You can find some background on the "text layer" that I mentioned above here and here. For scanned documents, this is often a text that is made invisible and shown above the scanned picture. Even if your pdf is not a scanned document, it might contain invisible characters that are problematic here. It seems that you are getting the correct words and punctuation marks, but that there are unwanted characters in between words that are printed in bold font. As you already noted, bold text is normally not a problem for Zotfile. For an illustration of non-printable unicode characters see here.

    Zotfile has a feature that allows replacing unicode characters, which might help with your issue. In the Config Editor, find the preference extensions.zotfile.pdfExtraction.replacements. If you right-click it, you can modify the value to set a replacement rule. For example, a single character replacement could be [{"regex":"ò", "replacement": "o"}] or equivalently [{"regex":"\\u00F2", "replacement": "o"}], see here. So if you could find the unicode value for the unwanted character, you could replace it with a space character.

    Various ways of identifying the unicode characters on the clipboard are given here. This online tool might be useful:
    (Paste your text and click the "Identify" button.)
  • Hi,
    I met a problem with Zotfile. The "tablet files" and "tablet files(modified)" would be automatically built when I use "send to tablet" function. But I deleted the two files by mistake. I can still use "send to tablet" and "get from tablet" function to view my modified PDF, however, if I forget which PDF has been modified, I may miss it, as I don't have a "tablet files(modified)" to view what I have sent to tablet.
    So how can I get back my "tablet files" and "tablet files(modified)"?
  • You can recreate the collections manually or in the Zotfile settings window.
  • wow, it worked, thank you!@bwiernik
  • edited April 1, 2020
    I am also having the same problem with @sdknij at page 60. The bug is reproduced when i follow the steps below:
    1. I click X.pdf -> send to tablet (X.pdf is linked in google drive)
    2. I annotate X.pdf on my ipad (via PDFViewer if that matters).
    3. I click get from tablet, so i get X_annotated.pdf in zotero (annotations correctly imported).
    4. When i click X_annotated.pdf --> send to tablet (to keep annotating it), the complete filepath becomes: some_folder/false (originally some_folder/X_annotated.pdf) and no file ends up in the tablet folder. also the link to X_annotated.pdf in zotero becomes corrupt as mentioned.

    A lot of thanks to the developer for helping so many researchers!

    version => 5.0.85, platform => MacIntel, oscpu => Intel Mac OS X 10.15, locale => en-US, appName => Zotero, appVersion => 5.0.85, extensions => ZotFile (5.0.16, extension), Zotero Storage Scanner (5.0.8, extension), Zotero LibreOffice Integration (5.0.22.SA.5.0.85, extension), Zotero Word for Mac Integration (5.0.26.SA.5.0.85, extension), Zotero Scholar Citations (2.0.4, extension, disabled)
  • Hello,

    I have been using zotfile to organise my PDF with google drive and love it.

    I have recently imported some video files into Zotero, and noticed zotfile does not rename and manage these files in the same way.

    Is this expected? I just receive a pop up saying "Files skipped because they are top-level, snapshots or do not exist" when i click on rename attachments.

    Zotero: 5.0.85

  • @djhayman02: It's not that they're video files — it's that they're standalone attachments. Without a parent item, there's no metadata to use to rename the file. If you drag a PDF that Zotero can recognize, it will create a parent item automatically, but for PDFs it can't recognize and all other file types, you need to create a parent item. You can do that either by saving an item another recommended way (e.g., from the web, via Add Item by Identifier) and dragging the attachment onto it or, if all else fails, right-clicking, choosing Create Parent Item, and entering metadata manually.
  • @dstillman thanks for getting back to me. These videos are already inside a parent item in the same fashion as the PDFs but still no joy..
  • Hi, Just to add to this I have also noticed the same behaviour with .ppt, and .xls files. When testing a .txt file, it worked the same as .pdf files.

    Is anyone else experiencing the same problem?

  • @djhayman02 You can set file types that should be renamed by Zotfile in "Tools" -> "ZotFile Preferences" -> "Advanced Settings". See the discussion here for additional renaming options.
  • Amazing, thanks so much!
  • I think there is something I am not understanding with how Zotero and zotfile interact with annotated tablet files. When I add a file to Zotero, zotfile nicely renames it and puts it in a human readable directory structure I have set up. under location of files. When I "send to tablet", it successfully copies it in the dropbox folder I'm using to sync.

    But when I "get from tablet" is pulls the file into Zotero's structure with weird folder names instead of into the directory structure according to zotfile's rules. When I use "rename attachment" it moves it back to the structure I set up but loses _annotated from the copy of the PDF.

    What am I doing wrong?
  • Thank you to the developers for all the hard work.

    - For the renaming string, %a (or a new field wildcard) should only include authors, not editors. The instructions claim it does work this way, but it does instead include the editors no matter what.

    Per the instructions:
    "%a last names of authors (not editors etc) or inventors."

    This should leave off the editor name(s) and only include the author name(s).Thus if there are only editors, the file name will just be the name of the work itself, no creators at all. {%a|%e}, on the other hand, would still give either authors or editors, as usual.

  • edited April 20, 2020
    Feature Request: Separate Re-name and Move commands
    I hope the developers will allow the option that the re-naming does not move the file as well. This is especially important for those of us who utilize our own file organization systems, rather than Zotero's own internal database. Some earlier comments suggest that this used to work properly, but no longer does.

    Feature Request: Allow Move of All Item Types
    (If this is technically possible) Allow (optionally) that the Move command moves all item types, including those without parent items. So, for example, snapshots, documents stored in a subcollection (e.g. my own Word or text documents which are outlines, notes, annotated bibliographies, etc, but are not "cite-able" items).
  • Hello, everyone -

    I would like all PDFs fo open in Acrobat. However: Extracted links (open-pdf) on my system are opening in Preview, rather than Acrobat.
    This is a Mac running OS Mojave with all updates, with latest Zotero beta and latest Zotfile and Zutilo.

    I have both the System default and Zotero's preference set to use Acrobat. Regular PDF attachments in Zotero do open properly in Acrobat.

    I read elsewhere here to modify the hidden Config preference extensions.zotfile.pdfExtraction.openPdfMac

    (Thread: https://forums.zotero.org/discussion/78695/zotfile-annotation-hyperlinks-opening-in-preview-mac-instead-of-default-pdf-reader/p1)

    However, that config preference does not appear in the list. Many other options appear in extensions.zotfile.pedfExtraction, but nothing with "openPdfMac".

    Any advice appreciated.
  • @ZenonMarko: Zotfile removed its zotero://open-pdf handler. So this should not be related to Zotfile, but to Zotero on macOS. Note that the links open properly on Windows 10. There is another recent report for the same issue on macOS, see here.

    If you can provide a Debug ID for opening a zotero://open-pdf link, the Zotero developers might be able to have a look.

    This might be a macOS issue, see here:
  • I could still use some help with how zotfile interacts with file storage. Am I doing something wrong or is there a bug? Mac OS

    When I add a file to Zotero, zotfile nicely renames it and puts it in a human readable directory structure I have set up. under location of files. When I "send to tablet", it successfully copies it in the dropbox folder I'm using to sync.

    But when I "get from tablet" is pulls the file into Zotero's structure with weird folder names instead of into the directory structure according to zotfile's rules. When I use "rename attachment" it moves it back to the structure I set up but loses _annotated from the copy of the PDF.

  • @PicassoSparks: See adamsmith's comment in this discussion:
    The main reason to use the "Send to/Get from Tablet" functionality would be if you generally prefer to have files stored within Zotero (which has a number of advantages such as that you can move them to group and that they get deleted when you delete them in Zotero) but want the ability to send small batches to a synced folder and the re-integrate any changes you make into Zotero and its storage.
    (I've never used that function, so I can't give more detailed advice.)

    See also Zotero's documentation on Stored Files and Linked Files and the discussion here.
This discussion has been closed.