ZotFile - Advanced PDF management for Zotero

  • This isn’t a bug. You are correct—%a doesn’t distinguish between author and editor for books because many books only have editors. You could write your own custom wildcard to always only use authors, but that would require some fairly complicated regular expressions.
  • Rename syntax seems to have bugs in current ZotFile version (5.0.10) which previous worked fine in earlier editions (sorry, new computer, not sure of which earlier Zotfile version I had)

    When using anything but _ in the rename syntax as a spearater within {}, nothing happens between fields. For example, if I want a space after every author name before the delimiter, I'd enter {%a } previously:

    ({%a }{%y}) {%t}

    (AuthorA & AuthorB Year) Title

    But now, same formula gives:

    (AuthorA&AuthorB Year) Title

    if I try to change the delimiter between multiple authors (from & to " & ", I get no effect)

    Expected behavior is having a space (or whatever else is in the {} but after the wildcard) between each author and the delimiter just like I would do in an in-text citation

    Screenshots here: https://www.dropbox.com/s/xo3ojq4sk6pvc4z/Annotation 2019-08-13 122741.png?dl=0

    https://www.dropbox.com/s/yn9dbr2c3qx85kb/Annotation 2019-08-13 122902.png?dl=0

    (update was pressed each time, note in second one that changing the delimiter to a + has no effect at all, & seems stuck)

    Windows 10 1903 (10.0.18362 Build 18362)
    Zotero 5.0.73
    Zotfile 5.0.10
  • Greetings,

    Using Zotfile, this particular behavior has me stumped.

    "Add Attachment from Source Folder" is not storing newly renamed filename within the Zotero database for some imported PDFs. It instead stores the original PDF's filename, i.e. the original filename of the "source" PDF before having been imported. The result is that Zotero cannot link / find the PDFs in it's database.

    MacOS 10.14.5 (Mojave)
    Chrome Version 76.0.3809.100 (Official Build) (64-bit)
    Zotero Standalone 5.0.73
    Zotfile 5.0.10
    -- also tried Zotfile 5.0.9, same behavior

    My general workflow for a lot of news outlets (NYT, WSJ, etc) is to make a PDF of a particular article, which gets saved to my Downloads folder from Chrome. I typically do this one of two ways:

    1) Usually with Chrome Print dialog and choosing "Save to PDF". This PDF goes to my Downloads folder in my home directory.

    2) Sometimes for certain cites, I instead use a plug-in called "Print Friendly & PDF". Aside: I find that for a lot of sites that have a fair amount of "noise" / extraneous info, etc, this plug-in does a very good job of distilling the actual info. as well as photos. The output of this is also saved to my home directory Downloads folder.

    I then use the Chrome connector to make a database entry in Zotero, and from there, use the "Add Attachment from Source Folder" to pull in the PDF and associate it with the item's database record.

    If I use method 1 above (Chrome Print Dialog), the process ALWAYS WORKS.
    If I use method 2 above (Print Friendly & PDF), the process OFTEN FAILS.

    How things seemingly fail is that in the database record for the PDF -- instead of storing the new renamed filename -- instead reflects the original PDF's filename, i.e. the "source" filename that was input to the "Add Attachment from Source Folder". Then, when I try and trigger the PDF to open in Zotero, it is unable to find the PDF file, and shows an error message (truncated here for brevity)
    "File Not Found. The attached file could not be found..."

    This occurs whether or not Zotero or Zotfile is doing the file renaming when "Add Attachment from Source Folder" is employed.

    However, if I add the "problem" PDF to Zotero instead with Zotero's built-in "Attach Stored Copy of File", whether Zotero or Zotfile does the actual renaming, it matters not -- THE RESULT IS ALWAYS A SUCCESS.

    I've occasionally gotten the Print Friendly generated PDFs to work using imports via "Add Attachment from Source Folder", but I cannot find a pattern as to why.

    I ran some tests and screenshots, exported Zotero database records, and included an entire log file which tracks the behavior. I also included the PDF test files pre and post import for both a success and failure case, which could easily be tested on another system.

    All of the above are included in a .zip file found here.

    Please let me know if there is any more data I can provide you to help debug this behavior. Zotfile has been a great help to me, and I appreciate its flexibility.

    Any insights appreciated.


    -- madison
  • Hi, thank you for this great extension.

    I would like to know if there is a solution to @YiFongAu's question on page 54 (https://forums.zotero.org/discussion/comment/288940#Comment_288940). To restate it, I would like to be able to send multiple PDFs at once to my tablet, while keeping the folder tree structure of Zotero collections and subcollections. At the moment all the PDFs get sent to a folder corresponding to the collection path of the first selected PDF.

    Thank you!
  • edited August 22, 2019
    Hi there! I'm reporting a bug for the "(Batch) Rename and Move Attachments based on Zotero Metadata" function. I believe the batch feature is broken.

    I'm using the Standalone Zotero with ZotFile on a Windows 10 laptop. I've recently changed to a linked attachment system with my attachment folder on Dropbox.

    Therefore, I'm attempting to transfer all files attached to items in my library to this new Dropbox folder. When I go through them one-by-one via Manage Attachments --> Rename, it works, and they show up renamed and in the correct folder.

    However, when I select multiple items and try to do the same process, renames 1-3 items and never gets through the next one. There's no error message, but the name of the first file that did not sync is permanently greyed out in the "Zotfile: Rename Attachments" Pop-up. The following files do not show up on the pop-up and do not sync at all.

    Does anyone have a fix for this? Thanks!

    EDIT: This seems to always occur when a PDF file has a tag directly attached to it (as opposed to only to the parent item). Then, it breaks the renaming process and none of the attachments after it sync correctly. However, it still happens at other instances where I haven't been able to determine a common denominator.
  • I don't understand how to batch move files to a new directory. I have all my PDFs in the /storage folder in Zotero, and I want to move them to Google Drive as linked file. How do I do this? I'm on a Mac
  • Hi, I believe that the "update file modification time" syncs the file modified from the tablet folder to the zotero library. But do not syncs if the file has been modified in zotero library (after sent do tablet) in the tablet folder.
    It would be a nice feature.
Sign In or Register to comment.