View PDF not working

Expected behaviour: Double clicking pdf attachment opens pdf in system viewer.
Observed behaviour: Nothing happens on double-click.

Expected behaviour: Right-click on pdf attachment and click View PDF to open pdf.
Observed behaviour: pdf does not open.

Right click on Show File, then double-click on file does open the pdf in viewer (Skim - as set in Zotero preferences).

Error report ID: 1946396494

Zotero 5.0.66 on Mac OS X 10.13.6
  • edited May 31, 2019
    [JavaScript Error: "/usr/bin/open returned exit status 1" {file: "chrome://zotero/content/xpcom/utilities_internal.js" line: 516}]
    Have you tried changing the PDF setting in the preferences to something else and back? For some reason the built-in macOS 'open' command isn't working for you.
  • edited May 31, 2019
    If it's still not working, what's the value of the extensions.zotero.fileHandler.pdf pref in the Config Editor in the Advanced pane of the preferences?
  • Hi Dan,
    Changing PDF setting to Preview and back to Skim had no effect.

    Config Editor value is

    I will try a system reboot.

    Thanks, Chris.
  • If that doesn't help, open Terminal and run this command:

    /usr/bin/open /path/to/pdf -a /Applications/

    And copy the output here.

    (To enter the path to the PDF, you can just drag the PDF from the Finder to Terminal.)
  • Permissions were messed up on the MacBook. Had to deleted cache folders under /var/folders/ but not the zz folder itself. The issue is addressed on
Sign In or Register to comment.