ZotFile - Advanced PDF management for Zotero

1545556575860»
  • Yes, I checked it now again. When I copy the file from the mounted webdav I have the annotations, but not using 'Get from Tablet'. Thanks!
  • Hi, me again... what is different compared to before is that there are no items in the "Tablet Files (modified)" Search folder anymore. This is now completely empty.

    Though, when I open the search folder before I mount the webdav directory I get error messages, which say that the files in the webdav files are not available.
  • edited February 10, 2019
    Another information:
    The "Modification Date" in the explorer does not seem to change after ading annotations. In addition it has the exact same time as for the original file, which is still in the local zotfile directory; only the size is slighly larger.
    Could this be the problem for zotfile as it thinks the file did not get modified?
    Thanks!
  • edited February 16, 2019
    Hi. I think Zotfile is just what I need, but it doesn't seem to do what I think it does, so seeking some clarity here.

    UNTIL I INSTALLED ZOTFILE
    Use the Firefox plugin. The Zotero entry is recorded and the PDF downloaded and placed in Zotero storage accordingly.

    NOW WITH ZOTFILE
    Go to Zotfile General Settings. Did nothing in there except set Customer Location to /Users/Bob/deletemetest

    Now use the Firefox plugin. And nothing happens. No entry in Zotero, and no files put anywhere that I can see.

    Any and all help most welcome. Thanks in advance.

    Zotero 5.0.60
    Zotfile 5.0.9
  • Hello! I'm using zotfile on an ipad II. (Zotero 5.0.60, zotfile most recent update) All was great until today when suddenly I was trying to use it and there was no "send to tablet" or "get from tablet" option in the "manage attachments" dropdown menu. I realized that I am trying to do this from a group library for the first time. It seems to work from my regular library but not from the group library. Is this fixable?
  • @Larisa -- I'm afraid Zotfile currently does not do anything in groups (the send to tablet functionality could absolutely work for groups, but since Zotfile's principal function is related to linked files, and those don't exist in groups, it's never been enabled)
  • Hello Everyone - I just moved from EndNote to Zotero (waited too long) and I went through the setup outlined in the link below. However, I cannot seem to get Zotfile to move the attached PDFs to the designated folder. It keeps placing them in a "Storage" file on my computer and not in my cloud folder. Even new references are not going to the designated file. Am I missing something?

    I am using Mac OS 10.14.3 with Word and the newest versions of Zotero and Zotfile.

    https://www.researchgate.net/publication/325828616_Tutorial_The_Best_Reference_Manager_Setup_Zotero_ZotFile_Cloud_Storage
  • edited March 3, 2019
    I've successfully move my previous (storage based repo) to new linked attachment. But now I want to change the structure from '%c/%a' to '/%a'. This means I want to re-structure my attachment folder (bcz managing all those old subfolder and constantly ask about multiple assignments when paper belongs to multiple folder is disturbing).

    However, I tried to do so but just get some error complaining about top level or sth. I didn't move on since I afraid might break the system. I've an old library and more than 2000 papers. Is there a way to re-structure or update the attachment directory based on a new rule?

    Update:
    I fix the problem with reset and restart the Zotero.
  • Thanks for the work you've put into Zotfile. I have a PDF which 'extract annotations' is not working for. I get an output, however, it misses entire paragraphs which have been highlighted, or will drop a number of letters in a sentence. Any suggestions? As per the instructions here I have uploaded the relevant file here. Any assistance much appreciated. I haven't noted any other buggy pdfs yet.



  • Hey everyone, new to Zotero and ZotFile. When I add a new reference and file it is not placing it in the designated folder I put on the Zotfile preferences but instead is going into a Zotero storage folder. When I right click and "rename" the reference it does go to the designated folder. Any ideas why it doesn't move it automatically?
  • Hello,
    I am using zotfile in zotero and dropbox to sync between two computers one mac and one windows. Note that I do not sync the sensitive files of zotero, I am using zotfile to point to a folder in dropbox for a preferred storage folder and I link the files.

    In mac, I am using zotfile in zotero standalone both the latest version. I have plugin in chrome 73.0.3683.75 (Official Build) (64-bit) on macos 10.14.3

    I have setup the configuration such as I have the main zotero files in my local disk and the zotfile to link and rename the files in a file dropbox.

    The problem is that when I use the plugin in chrome, zotfile does not always work and the files are not renamed and are stored in the default zotero location.

    I have not managed to find a general pattern when this problem appears. One incidence is when zotero is minimised to dock by pressing the x-button and not the minimising (since in mac the application is still open with this action but does not show the window). However, this is not always the case that this happen. Zotfile starts working again sometimes if I close chrome and zotero and relaunch the applications, but this is of course not a solution to the problem, since I have to lose my work up to that moment.

    Do you have any idea how to fix this problem?


    Another problem in both windows and mac chrome is that when i use the zotero plugin in the webpage which contains the information for the article as well as a link to the pdf, then the pdf will be downloaded and saved follwing the zotfile settings. But when I have actually opened the pdf file then it is saved according to zotero rules.
    I wonder how I could prevent that and always be saved using zotfile.

    Thanks a lot in advance!
  • Hi,
    First, I am very happy with Zotfile and Zotero since 1 year (I moved from Papers)
    I have a problem that has been reported by other ones and I found no solution: When "renaming" in Zotfile manually to move a PDF, the notification says "attachment ignored because it has no parent file, is a capture of a web page or the file does not exist" (approximate, I translated) and the file is not moved. However, when I export to the tablet, it works.
    As it used to work, I have now my PDFs in two places: Zotero storage subfolder and Zotero attachment subfolder (that I used to sync with the cloud)
    The bug console says everything is OK: Aucune erreur n'a été enregistrée depuis le démarrage de Zotero:

    version => 5.0.65, platform => MacIntel, oscpu => Intel Mac OS X 10.13, locale => fr-FR, appName => Zotero, appVersion => 5.0.65, extensions => ZotFile (5.0.9, extension), Zotero LibreOffice Integration (5.0.14.SA.5.0.65, extension), Zotero Word for Mac Integration (5.0.18.SA.5.0.65, extension), Shockwave Flash (32.0.0.156, plugin)

    Many thanks if you can help

    Jean-Marc
  • edited April 4, 2019
    Firefox 66.0.1
    Zotero 5.0.65 Standalone
    zotfile-5.0.9-fx.xpi
    System: Linux Mint 19.1 XFCE 64-bit

    Issue: Okular highlights in PDF are not extracted
    I recently installed Zotfile, after which I tested it with a PDF file that had a few highlights. The extraction worked well.
    I now have a PDF with some 140 pages, and more highlights, though certainly not on every page, but the extraction does not work. The notification box telling me that the extraction is taking place stays there but there is no result. I left it on for more than 1 hour.
    Any suggestions?
  • I'm setting up my folder structure as "Letter/First-Author-Surname/", like:

    S/Smith/Smith, Jones, Zhang (2019) Why Zotero and Zotfile rock.pdf

    To get the first-author surname for the name of the subfolder, I've come up with the following user wildcard (linted), that chops off " etal" or everything after the first comma (which I've set my author separator to):

    {
    "1": {
    "field": "author",
    "operations": [{
    "function": "exec",
    "regex": "^([^,]*?)(,.*)?( etal)?$",
    "group": 1
    }]
    }
    }

    If this is the best way to do it, I can definitely live with it. (It even magically uses an underscore if there's no author!) Just wanted to check that there isn't some hideous problem with it that I haven't noticed and that there isn't a cleaner way to do it — like maybe an undocumented field for first author, like there is for last author (fingers crossed).

    One other issue that *might* deserve your attention. My first attempt at this was the following (linted), based on the examples in the Zotfile documentation:

    {
    "1": {
    "field": "author",
    "regex": "([^,]*)",
    "group": 1
    }
    }

    Trying to run "Rename Attachments" with the simpler wildcard in the subfolders pattern failed. The usual tooltip would pop up *saying* renaming had succeeded, but files weren't renamed and (fortunately at least) Zotero didn't believe they'd been. I only ended up with the working version by ransacking extensions.zotfile.wildcards.default for a model.

    If you *expect* that the simpler JSON should work, it doesn't.

    If you intended for the simpler version to stop working in recent versions of Zotfile, it would help to update the examples in the documentation.

    If I just made some boneheaded mistake that deserved to fail, there's no need to explain exactly what it was. But, if you've got lots of free time :-), it might help if a failure wasn't accompanied by an inaccurate "success!" message.

    Thanks for all your work!

    -- Kevin

    Zotero 5.0.64, Zotfile 5.0.9, Windows 10
  • edited April 26, 2019
    Hello,

    Batch rename and move is failing when more than one item is selected. It is failing erratically - sometimes successfully completes first reference, sometimes leaves the original (now broken) link to the PDF.

    I'm in the middle of (attempting) to transitioning my library (~4200 items, ~6 gbs) from Zotero storage to Dropbox, so this is a serious wrench in the works!

    I've been a devoted Zotero+Zotfile user for a few years, thanks y'all for all your great work!

    Here is the Zotero error log:

    [JavaScript Error: "this is undefined" {file: "resource://gre/modules/osfile/ospath_win.jsm" line: 238}]

    [JavaScript Error: "attNew.addTags is not a function" {file: "chrome://zotfile/content/zotfile.js" line: 975}]

    version => 5.0.66, platform => Win32, oscpu => Windows NT 10.0; WOW64, locale => en-US, appName => Zotero, appVersion => 5.0.66, extensions => Zotero LibreOffice Integration (5.0.14.SA.5.0.66, extension), Zotero Word for Windows Integration (5.0.12.SA.5.0.66, extension), ZotFile (5.0.9, extension)
  • Hi,

    I really like ZotFile - especially the iPad annotation feature. I only have one issue: how to handle annotation continuously.

    My workflow is like this: I have an article. Attach it to a record in Zotero. Send it to my tablet. Do some reading and annotation. And get it back in Zotero. Annotations are extracted. Success!

    ( Minor "feature": The table of content gets deleted during the import of the annotation file. )

    THEN I want to re-read the article and continue annotation.

    I have tried two approaches:

    1. To send the original pdf to the tablet. Do annotations for the 2nd time. And get it back.
    2. To send the annotated pdf to the tablet. Etc.

    Re 1) I don't get the 1st annotations with me. I'll get the 2nd annotations extracted, but end up with two xxx_annotated.pdf attachments pointing to the same file.
    Re 2) The filename of xxx_annotated.pdf is changed, and I get "Filename: false"


    What will be great - for me ;-) :

    - Two files: original and annotated. One "Extracted Annotations"-note (aggregated notes).
    - Push to tablet will only be possible from the original file.

    I use ZotFile 5.0.9 and Zotero 5.0.66 - all on a macOS 10.14.5
  • Can someone explain to me how to get ZotFile for iPad? I cannot find it in the apple app store.
  • You don't use it that way - you can have zotfile for the zotero desktop client copy files in and out of a set directory, which you can sync using something like Dropbox
  • edited 14 days ago
    Hi all,

    I'm eternally grateful to the developers for coming up with a tool that is already saving me countless hours batch renaming PDF files.

    Unfortunately I'm a complete analphabet when it comes to working with JSON and user-defined wildcards, and there are three modifications I'd like to make to the renaming rules/format but just cannot figure out how to through mere trial/error.

    Can anyone with experience modifying the wildcards help me? Again, I'd be most sincerely indebted - any hints or leads would be appreciated.

    In descending order of importance, the hoped-for changes are:

    1) Can I specify the case in which %t (title) information is presented? In my case I'd like all title information in file names to appear in title case (as in e.g. Chicago/Turabian style)

    2) Can I have the filename begin with the item type (e.g. "Journal Article", "Book Section" etc.) or, even better, a placeholder I use in my file nomenclature (01 = book, 02 = article etc.)

    3) Can I specify that characters such as "." or "?" at the end of the title be omitted, but where they appear within the title (e.g. frequently a colon ":") they be replaced by a hyphen "-" ?

    Example outputs in this format would be:

    For a book ("01" denoting item type = book; title information changed to title case):
    "01 Dickens - Great Expectations (1861)"

    For a journal article (same as above, but item type "article" indicated by "02"):
    "02 Coase - The Problem of Social Cost (1960)"

    For a book section (same as above; item type "book section" indicated by "03", and a "?" in the title replaced by a "-"):
    "03 Kripke et al. - What's in a Name - Naming and Necessity (1911)"

    Zotero should have all the necessary information, but I just cannot figure out how to create the right user-defined wildcard. Again, any thoughts would be greatly appreciated.

    Many thanks -
    Michael

    Edit: I genuinely tried to figure these out studying the "User-Defined Wildcards" instructions on zotfile.com, but couldn't figure out e.g. how to apply title case to the title.

    I fully realize it's *my shortcoming* for not having better understanding of JSON - I'm generally able to figure things out with some examples and trial & error - but here, I didn't really know where to start.

    (Are there any more detailed or beginner-friendly tutorials out there ? :-/ )

  • edited 12 days ago
    You can do all of these things using regular expressions with the “user-defined wildcards” described at zotfile.com
  • @mc288 I presume that %c is a wildcard for conference venue or something equivalent make sure that all your items in the library have the venue or conference field not empty otherwise I believe it creates the undefined folder
  • @kirk86 No, %c is the wildcard for Zotero collection
  • edited 12 days ago
    I've migrated cloud storage and in the process lost my folder with Tablet files. No problem for me (they are all still in Zotero) but it confuses Zotfile, which started to generate loads of error message (one for every missing file).

    To try and fix it I disabled the "Use Zotfile to send and get files" option and deleted the _tablet tag and Tablet saved search. Synced, then reenabled the option, selected a new folder, and started sending new files to tablet.

    The new files work and are found. But Zotfile somehow still has a record of the old files it is missing, and generates a long list of errors anytime I have a look at the Tablet saved search. I thought the tag was Zotfiles only memory for this but apparently it's also in the database. Is there a way to reset it so that it won't be looking for them anymore?
Sign In or Register to comment.