ZotFile - Advanced PDF management for Zotero

  • I recently downloaded the Zotfile extension for syncing Zotero with my iPad via my Box account. Unfortunately, Zotero and my computer crash/freeze every time I try to "rename" existing citation attachments in my library to my designated Box Account location. Silver lining, after I restart my computer I see that the documents I tried rename are showing up the Box folder I created for my citation attachments. When I set the attachment file location to my local hard drive I don't run into any issues. Appreciate any suggestions folks can offer on how I can avoid having my computer crash each time I rename a citation attachment to a Box account location. Thank you.

    System: MacOS (10.13.2)
    Zotero: 5.0.33
    Zotfile: 5.0.6
  • how long have you let the freeze run? (and it doesn't actually "crash" as in shut down any applications, right)?
  • @adamsmith I let it run for 20 min. And to be more precise the system didn't shut down but the ability to use any functions ceased.
  • How do you get to the zotfile.wildcards.default and zotfile.wildcards.user files?

    Are there any better instructions for using User-defined Wildcards? The ones on the ZotFile website are a little sparse.
  • They are preferences that you can set in the Config Editor accessible from the Advanced pane of the Zotero (not Zotfile) preferences.
  • I'm having the same issue as @Bzwingmann (described most recently 13 Dec 2017). Is there a solution to this yet?

    Ever since upgrading to Zotero 5 (I have 5.0.34 installed now, with Zotfile 5.0.6), I'm having an issue with subfolders when sending files to my tablet. I do not want subfolders for my tablet files, and I have that selected. When I send files to my tablet, though, they go to \%y subfolders. If I select any other option or try to define another subfolder structure, \%y is still added as a last layer of subfolder. Is this a bug, or do I need to set my preferences differently in the new zotfile?
  • Is this still the right page for Zotfile support? I'm hoping for a response to my question from a few weeks back (but I see that previously the question was asked as early as August and I don't think ever got a response). I really want all of the files on my tablet in one folder, but that still isn't working and hasn't been since the upgrade to zotero 5.
  • I apologize if this has been adressed before: I use the great plugin Better Bib(La)TeX and it's function for automatically generating BibTeX Cite Keys (currently according to the default scheme [auth]_[shorttitle]_[year]). It would be convenient if the generated Cite Key could be used by Zotfile to rename the attachments, keeping the Cite Keys and the attachment's names tightly linked. Is this possible?
  • Technically, the BBT database is accessible to other plugins so the citekeys can be read from it.
  • edited March 6, 2018
    This problem seems to have cropped up the past week or so. I'm not sure if it began after I updated Zotero (currently, Zotfile (5.0.7), MacOS (10.10.5), or something else. Also not sure if I'm missing something not configured properly in Zotero/Zotfile preferences or there's something else going on.

    It used to be that if I were working from my university's library site, selected an article with an attached pdf (e.g., on JSTOR), and clicked the Zotero article icon in my browser's toolbar, Zotero would download the metadata, create a bibliographic item in the Zotero database, attach the pdf, rename the pdf and ship it out to Zotfile's Custom Location file address (in my case, this is a NAS drive at home attached via WebDAV), and delete the pdf that was originally downloaded to my computer.

    Now, Zotero is downloading the metadata, creating the bibliographic item, and attaching the pdf stored locally on my computer. To rename the document, ship it out to the NAS drive, and delete the local copy, one has to select Manage Attachments > Rename Attachments. This used to be done automatically, as part of scraping the item's metadata from the library database.

    Is there a way to fix this?
  • [latest version of Zotero and ZotFile]: Nothing is happening when I try to rename multiple selected records; it works only one by one. Any suggestions? (A really great plugin otherwise!)
  • I just updated to Zotero 5.0.37 for mac (I am running High Sierra 10.13.3). Zotfile has been not working for at least a day. I have tried re-downloading Zotfile (version 5.0.7) and restarting Zotero twice, to no avail.

    When I select “get from tablet” the file disappears from my tablet but Zotfile does not create an annotated version as it used to (and the annotations are not extracted).

    When I select “send to tablet” the filename changes to “false” and the file does not get sent to my tablet. I also see this error appear: "Attachments skipped because they are top-level items, screenshots or the file does not exist." And when I click on the link to the file in Zotero, I see the "File Not Found" error message. I then select “locate” and re-establish the link to the file, but this doesn’t solve the problem. It seems the file path becomes corrupted when I try to send to tablet.

    I would really appreciate any ideas for how to fix this!
  • I use zotfile to attach a document I just downloaded to a zotero entry. With my configuration, zotfile will move the document to a specific folder and rename it.

    It works well when I download something from firefox. Zotfile will look for the last modified document in my download folder and attach this file. But if a friend give me a usb stick with plenty of pdfs, I have no way to attach them to my zotero entries.

    How can I proceed in this case?
  • Check out the new PDF features in the newest version of Zotero: https://www.zotero.org/blog/zotero-5-0-36/
  • Interesting ! but I trust more isbn/doi retrieval to add the entry, then zotfile to attach the pdf. Most of my pdfs are preprint version with no metadata for zotero to retrieve. In my experience, starting from the pdf give not good result (except if you have the last printed version of the document).
  • Yes, I agree — I usually also use isbn/doi retrieval (also note that if you have access, using the 'Add to Zotero' button will even get you the newest and official PDF).

    If they come on a USB, you get the metadata separately, and you want to use Zotfile to process them, there is no solution to get all of them into your library at once. You'd probably have to copy them one by one into the ZotFile watch folder, then right-click on the target item to tell ZotFile to look for the most recent PDF file added to that folder and process it.
  • Zotfile can't be downloaded and installed in Firefox?

    I am wanting to access my Zotero library on my ipad pro so I it seems that Zotfile is what I need. However, Firefox will not allow me to install the add-on with a message 'Sarafi has prevented the installation of an unverified add-on' or something close to that. The more information talks about apps needing to be 'signed' by Firefox, somehow verified.
    I do want to know that I can trust add-ons of course so sounds like a good idea. Is it possibly that Zotfile could work within this system?
  • You need to install Zotfile in the Zotero app, not Firefox. In Firefox, right-click on the download link and choose Save Link Target As and save the .xpi file to your computer. Then, in Zotero, click Tools -> Add-ins. Then drag the .xpi file you downloaded onto the window that pops up.
  • Ah thanks a lot. It didn't make sense it was really a problem
    Appreciate your help.
  • Hello, I use ZotFile for its ability to extract pdf commentaries and and very frustrated because since the last version of Zotfile it forces the renaming. It's very annoying because I unselected the option but it keeps renaming the files I want to join to my bibliography (I manage the folders and download and everything manually) So for now I have two choices : disable zotfile or stop joining files...
    Is it a flaw in the software I'm not aware of, or is it something I do ? Thank you !
  • I'd assume you're seeing Zotero's changed renaming behavior, not ZotFile's. You can disable that in the General tab of the Zotero preferences.
  • Hello, thank you for your answer, in fact the default options changed in zotero recently, now everything works well, i'm relieved :)
  • Hello to the thread readers,

    I've been using Zotfile for moving attachments (symlinks to pdf files) when items moved from collection to collection. Structure of my library in Zotero and on the filesystem are identical. So when I move an item to another collection I wanted to move the file on the filesystem as well. For that purpose I had "General Settings -> Location of Files" set to custom locations (my pdf library prefix under "~/Documents/Library") and the following checkbox "Use subfolder defined by "/%c".
    I also enabled "preferences.zotfile.disable_renaming" in the hidden properties.
    With this setup I could move an item to a new collection, right click on the attachment and let it be renamed by Zotfile effectively moving the linked file without any name changes.

    With the last version of Zotfile and Zotero 5 I get the file moved but additionally renamed with the "%c". The path to the file get included into the filename.
    Zotero renaming is disabled.

    Any ideas?

    Many thanks in advance!
  • Hi. I'm having a problem with zotfile renaming. My rename format is "author, year", so there are quite often filenames generated that already exist in the target folder. If this happens, the file is renamed to AUTHOR, XX where XX seems to be some sort of identifier number. However, the link in the zotero entry is updated as expected, so as a result points to the previously existing file.

    Notably, zotero renaming seems to do the same thing.

    I'm using linux zotero 5.0.25 with zotfile 5.0.7.

    I'm 100% certain this never used to happen before, as I have been using this setup for a while. I look in my attachment folders there are quite a few that look like AUTHOR, YEAR_2, when there are duplicates, and I've been using zotfile the whole time to rename these files.

    I suspect the move from firefox zotero to standalone may have been the point at which it changed.

    Sorry if this is addressed somewhere else. I wasn't able to find anything.
  • Months later, and the send to table function in Zotfile is still not working properly, or at least how it used to work. As previously described, I do not want subfolders on my tablet. I have "No subfolders" selected in my Zotfile preferences. And yet, subfolders are created (by year, which is how I have Zotfile organize my main pdf library). This has been a problem since the upgrade to Zotero/Zotfile 5. It was first mentioned in this thread in August 2017, yet the few comments about the issue have never been addressed.

    Is always creating subfolders when sending to tablet the new expected behaviour of Zotfile?
  • @orbigail -- hard to say what's going on, but no, it's not expected and I'm not seeing it.
  • @orbigail As a troubleshooting step, close Zotero and then move the file prefs.js out of your profile directory (https://www.zotero.org/support/kb/profile_directory). This will reset all of your settings for Zotero and Zotfile to their defaults. Then try to set up your tablet settings again and see if they work correctly.
  • This question was asked last year but as far as I can see has not been answered. The "download and install poppler" button does nothing. I had poppler working just a few days ago, now it's not and I can't seem to replace it.
  • Why exactly are you trying to use Poppler? In general, pdf.js is a more reliable solution.
  • Because I'm having problems with very large pdfs, and I wanted to see if poppler would give a better result. Whats happening is that further down in the document, the first line of a paragraph is often missing, and sometimes whole paragraphs do not appear if they have a stood-off page number. e.g.

    5.4 Paragraphy stuff.
    ......More stuff.
    ......Even more

    The dots represent spaces or tabs, and were necessary as this editor removes spaces.
This discussion has been closed.