ZotFile - Advanced PDF management for Zotero

1474849505153»
  • @mc288 This is fixed in 5.0.3. Just published it. You can wait for the automatic update or do it manually with "Tool -> Add-ons -> Tools for all Add-ons (the small, drop-down wheel in the top right corner) -> Update" in Zotero.
  • edited July 20, 2017
    Zotfile with Zotero Standalone is working great for extracting annotations from highlighted pdfs.

    But for some pdfs, it became blank - a note with "Extracted Annotations (20/7/2017 7:01:10pm)" but nothing appears below it. The time needed to extract annotation is taking longer than other pdfs. I found it to be happening across book chapters I download from SAGE knowledge. Is it because of some special pdf format that they created their pdf with?

    Using Zotero 5 & Zotfile 5.0.2

    I would be thankful for any cues on the problem because a number of SAGE books are waiting for me XD
  • brilliant, @Joscha, thank you!
  • @adamsmith for example, take this article http://agritrop.cirad.fr/580245/

    First I click the save to the Zotero button in firefox, I see the article is added to my Zotero library without the PDF. Then from Google scholar I download the PDF and I open it in my PDF software. After that I close the file in the PDF reader, and then I go to Zotero, right click on the article and select attached new file. The file attaches and from the zotero llibrary it shows me that it has been renamed. Then I press enter and I open again the file in the PDF reader but it still has the old name, it also has the old name when I go into the folder in my zotero storage.
  • edited 22 days ago
    Edit: Done.

    Thanks for providing a new version of zotfile. I tried to covince my colleagues to use Zotero, especially to get a good workflow with our iPads. But the "Send to Tablet" functions seems to be bugged. After using the function of getting the modified pdfs back,

    a) the files aren't named correctly: author_year_title_modified.pdf is written as author_year_title_modified$2. So the file can't be opened and has to be renamed by hand.

    b) after getting the file back from "tablet files (modified)" search the entry will stay in the search and occur a file-missing error.

    Both errors occur while using Windows 7/10 64bit, Zotero 5.07, Zotfile 5.03.
    I'm using Zotero 4.0.29.10 and Zotfile 4.2.8 and it's working like a charme.

    Would be awesome, if you could handle this.

    Best regards.
  • Dear developers

    I have a problem since updating zotero to 5.0.7 and zotfile to 5.0.3.
    Previously, my Chrome connector allowed to get a paper with a click and in the case of, e.g., a phys. rev. lett., to open the pdf later, download it, and zotfile was associating it with the open zotero item --- including renaming.

    In the new version, a new button has appeared with the pdf symbol in the chrome toolbar. I click on it, the "Saving item" box appear, the pdf is saved as standalone in the same collection of the open item, but OUTSIDE. No renaming takes place.

    Moreover, when I move the paper inside the open item by hand, no automatic renaming occurs: I have to click "rename item from open metadata".

    Any hints?

    Thank you
    Daniele
  • Addendum:

    The log of Zotero shows for a certain pdf I would like to have included in the open item and renamed, the following lines. Maybe it helps?


    (3)(+0000009): Importing attachment from URL https://www.nature.com/articles/srep07902.pdf

    (5)(+0000007): CookieSandbox: Managing cookies for www.nature.com

    (5)(+0000000): CookieSandbox: Added cookies for request to www.nature.com

    (3)(+0000007): Getting contents of /Users/psd/Zotero/storage/tmp-2PfbD7/srep07902.pdf

    (4)(+0000009): Beginning DB transaction WCGDWQQp

    (4)(+0000006): Saving data for new item to database

    (4)(+0000001): INSERT INTO items (itemID, libraryID, key, clientDateModified, itemTypeID, dateModified, dateAdded) VALUES (?,?,?,?,?,?,?) [18074, 1, 'KYAKZZWZ', '2017-08-02 19:24:56', 14, '2017-08-02 19:24:56', '2017-08-02 19:24:56']

    (3)(+0000003): Notifier.trigger('add', 'item', [18074], {}) queued

    (4)(+0000001): SELECT valueID FROM itemDataValues WHERE value=? ['https://www.nature.com/articles/srep07902.pdf']

    (4)(+0000004): SELECT valueID FROM itemDataValues WHERE value=? ['2017-08-02 19:24:56']

    (4)(+0000005): SELECT valueID FROM itemDataValues WHERE value=? ['srep07902.pdf']

    (4)(+0000004): REPLACE INTO itemAttachments (itemID, parentItemID, linkMode, contentType, charsetID, path, syncState, storageModTime, storageHash) VALUES (?,NULL,?,?,NULL,NULL,?,NULL,NULL) [18074, 1, 'application/pdf', 0]
  • Zotfile is not compatible with Zotero 5.0.10. I hope it updated soon.
  • I have since learnt that you need to install the update manually from https://github.com/jlegewie/zotfile/releases. The automatic update for add-ins does not work.
  • The automatic update works—you only need to manually install one time when switching from Zotfile 4 to 5.
  • Hi,

    It seems that Zotfile does not index the pdf bookmarks as a ToC any more, when inserting the pdf as a link.
  • edited 8 days ago
    I still have problems renaming the files. If I right click on a phd file, select manage attachments, rename attachments, I get this error "attachments skipped because they are top level items, snapshots, or file doesn't exists". If I select "rename file from metadata" then it does rename the snapshot file correctly, but it does not work on the pdf. For other files rename attachments just renames the file with the same filename.
    Here is an example image
  • I have a problem with the Tablet function. I am using Zotero Standalone 5.0.13 and Zotfile 5.0.4 and I have set the general storage preferences set to 'use subfolders defined by %A' and the Tablet folder preferences set to 'create subfolders from Zotero collections' - and deliberately NOT ticked the option for 'use additional subfolders defined by ...' because I wanted to have all the pdfs straight in the collection folder and not have any more subfolders - that used to worked perfectly well with the Zotero for Firefox and the corresponding zotfile version. However, now whenever I use 'send files to Tablet', zotfile also creates subfolders based on %A.

    Example: assuming the Zotero collection is called "Project Beta"
    - previously, I would get only "Tablet\Project Beta" with all the files in that one folder
    - now, I get "Tablet\Project Beta\Zotero storage\B etc. (folders based on whatever other last name the authors have)

    I have tried it with 'no subfolders' as well - that creates a string with 'Zotero storage\B (etc.)' directly in the Tablet folder. I have also tried ticking the 'use additional subfolders defined by ...' option and the leaving it empty. Same result as above...

    Is there anything in the preferences or the config settings I can change to get the previous system back??
Sign In or Register to comment.