ZotFile - Advanced PDF management for Zotero

15253555758
  • Perhaps DongRP refers to the fact that ZotFile no longer has a Watch folder and that you have to either drag or right-click and make ZF look for the most recent file?

    (P.S., seen the repeated reports of the added file popup persisting on Windows, by myself, cmf5 and mcv2? This is since the Z5 version and it can be pretty confusing.)
  • DongRP, please see the comment adamsmith made on 9/14. I think the functionality you are describing is still there, just no longer automatic.
  • The pop up persisting bug is fixed in the latest version of Zotfile.
  • Thanks indeed! *thumbs up emoji*
  • I am not sure whether I am experiencing a bug or whether I am doing something wrong in my configuration.
    In my Zotero library, I have all sorts of papers which are not taken from journals and I would like them to be sorted by collection as it is my main way to organize in Zotero. I guessed that the wildcard would be the one in the screencapture but Zotfile creates an "undefined" folder at the root of the collections.

    Screencapture: https://imgur.com/a/heSvn

    How may I fix this?
  • Hi,
    It appears Zotfile is not compatible with Firefox 57.0. We can now only use the standalone version of Zotero, and Zotfile "does not meet the current standards of Firefox and has been deactivated". Any plan to update Zotfile to meet the new standard? https://support.mozilla.org/en-US/kb/firefox-add-technology-modernizing?as=u&utm_source=inproduct
  • You need to install Zotfile into the Zotero 5 app, not into Firefox.

    Download Zotero 5 from http://zotero.org/download

    Download the current version of Zotfile from https://github.com/jlegewie/zotfile/releases
  • I'm having the same problem as FredericBourgeon, when I rename my papers (which I do by collection path), they go to a root "undefined" folder first.
  • Hello,

    I have the same problem as Kriskard with Zotero 5 and Zotfile. I did try to download the link provided by bwiernik but Firefox does not allow the installation of the latest version of Zotfile.

    Could anyone help?

    Many thanks.
  • You install ZotFile in Zotero, not Firefox. See the installation instructions on zotfile.com
  • Thanks adamsmith - checking the instructions.
  • Adamsmith, it worked!!!! Thank you so much!
  • I recently updated to Zotero 5.0.28 and it states that Zotfile is no longer compatible.
  • edited December 13, 2017
    On 9/13/17 I reported what seems to be a bug in Zotfile: for references having multiple attachments, Zotfile creates multiple links, but they all point to the same pdf file.

    On 9/26/17 Bruce Rusk said he was having the same problem AND that he is using "{%a_}{%y_}{%t}" as his renaming template.

    Later that day bwiernik suggested as a workaround that Bruce should use Zotero to rename files.

    This still leaves me in the cold, as in Zotfile I use "{%F} {%y - }{%t}" for my renaming template and want to stick with this naming convention.

    Can anyone suggest a workaround for this problem?
    And, can anyone confirm that this is or is not indeed a bug in the current implementation Zotfile?

    I'm currently using Zotero 5.0.30 with Zotfile 5.0.6 on a Mac running OS X 10.10.5.

    Thanks.

    Added 12/13/2017:
    P.S. IIRC, this problem started with the upgrade to Zotero 5.
  • To add to marsh's comment above: in addition to issues with renaming of multiple attachments for a single record, Zotfile messes up multiple files attached to different records if the filenames conflict. I discovered this with a multipart article in sequential issues of a journal. The articles had the same author, the same year, and the same title, but different subtitles after the colon (Part 1, Part 2, etc.). Just about any naming scheme will produce conflicting filenames in the same folder, and Zotfile will not link to them properly. So I think this is an ongoing and significant bug.
  • Hi!
    I left this comment in August 2017 and was wondering if there is an answer to this?? I have updated to 5.06 but the problem is still the same. thanks!

    ---------------------------------------------------------
    I have a problem with the Tablet function. I am using Zotero Standalone 5.0.13 and Zotfile 5.0.4 and I have set the general storage preferences set to 'use subfolders defined by %A' and the Tablet folder preferences set to 'create subfolders from Zotero collections' - and deliberately NOT ticked the option for 'use additional subfolders defined by ...' because I wanted to have all the pdfs straight in the collection folder and not have any more subfolders - that used to worked perfectly well with the Zotero for Firefox and the corresponding zotfile version. However, now whenever I use 'send files to Tablet', zotfile also creates subfolders based on %A.

    Example: assuming the Zotero collection is called "Project Beta"
    - previously, I would get only "Tablet\Project Beta" with all the files in that one folder
    - now, I get "Tablet\Project Beta\Zotero storage\B etc. (folders based on whatever other last name the authors have)

    I have tried it with 'no subfolders' as well - that creates a string with 'Zotero storage\B (etc.)' directly in the Tablet folder. I have also tried ticking the 'use additional subfolders defined by ...' option and the leaving it empty. Same result as above...

    Is there anything in the preferences or the config settings I can change to get the previous system back??
  • Thank you for Zotfile -- it's a fantastic reading and teaching tool.

    I have a small bug. Using Ubuntu linux (16.04 lts) the hyperlinks in Zotfile notes ignore my xdg-open settings (which are set for a Wine PDF editor and work fine in Zotero itself and in general) and they open using Evince. My .local/share/applications/defaults.list; .config/mimeapps.list and /usr/share/applications and /usr/share/applications/defaults.list all point to the Wine application (and do not mention Evince). Does Zotfile have its own mimetypes.list somewhere else?
  • Having problems with PDF annotations showing up in Notes.

    I just installed Zotfile, have highlighted text in a PDF in Acrobat Reader DC, saved the PDF, re-synced Zotero. I see no new information in the Notes section. I've tried both highlights and annotations, without any success.

    I can copy and paste text from the PDF, so it passes that test. Is there a known problem with this feature?
  • Correction -- annotations show up when I "manage attachments / extract annotations." But not highlights.
  • Hi

    Is there any way to get Drawboard PDF working as the default PDF viewer for Zotfile? At the moment extracted annotations only open Adobe Acrobat Reader and I can't see a way of changing it to Drawboard PDF, which is my favourite PDF viewer.
  • edited December 24, 2017
    Is Drawboard set to your default PDF viewer on your operating system? If not, start by doing that.

    If that doesn’t help, Try this. Open the Config Editor in Zotero’s Advanced Preferences. Search for the relevant pref below and change its value to the path to the Drawboard program.

    extensions.zotfile.pdfExtraction.openPdfWin
    extensions.zotfile.pdfExtraction.openPdfLinux
    extensions.zotfile.pdfExtraction.openPdfMac
  • Yep Drawboard is already default.

    I would try what you say but because Drawboard is a native Windows 10 app there isn't a normal path. The "path" is this: "drawboardpdf://" in the run window. But if I copy that into the preferences you mentioned, it doesn't work.
  • I have a PDF attached to a Zotero item with several annotations. When I select Manage Attachments > Extract Annotations a box appears with a red cross. Extracting a TOC works fine. Am I doing something wrong? What is a likely cause of the problem?

    I have Zotero 5.0.33, ZotFile 5.0.6, Okular 0.24.2, Ubuntu 16.04.

    I have Okular set as my default PDF viewer.
  • I recently downloaded the Zotfile extension for syncing Zotero with my iPad via my Box account. Unfortunately, Zotero and my computer crash/freeze every time I try to rename existing citation attachments in my library to my designated Box Account location. Silver lining, after I restart my computer I see that the documents I tried rename are showing up the Box folder I created for my citation attachments. When I set the attachment file location to my local hard drive I don't run into any issues. Appreciate any suggestions folks can offer on how I can avoid having my computer crash each time I rename a citation attachment to a Box account location. Thank you.

    System: MacOS (10.13.2)
    Zotero: 5.0.33
    Zotfile: 5.0.6

  • If I recall correctly, ZotFile had a facility to automatically change file attachments (live in the zotero data directory) to linked files (live outside the zotero data directory). Do I recall correctly? I can't find the documentation on this feature.
  • Yes. It's done as part of rename with the relevant ZotFile preferences set.
  • That's the "Location of files" options, correct?
  • yes, when set to custom location it turns attachments into links.
Sign In or Register to comment.