RTF/ODF Scan for Zotero

11718192123
  • How large a bounty do I need to offer to get this fixed in the near term? Maybe we could raise a small stipend to keep this plugin up-to-date? I'm not going to be able to turn in my dissertation without it.
  • I've submitted a patch that fixes the plugin on Zotero 5.0.78 and up. @fbennett will need to review and release.
  • Came to share a quick and dirty fix (updating deprecated XPCOM methods) but saw that the moderator already did a better one. Thanks for the great work!
  • edited December 7, 2019
    The patch has been merged and pushed out, so this should work again now in 2.0.43. (ODF Scan is now a separate menu option, since the previous version was breaking the built-in RTF Scan functionality.)
  • In macOS Catalina there is no ODF scan anymore. I have Zotero 5.0.80 and ODF Scan 2.0.43.
  • edited December 8, 2019
    @tunick: Make sure you're looking for a separate "ODF Scan" option below "RTF Scan" in the Tools menu. It's no longer in the same dialog. If you're not seeing it, provide a Report ID.
  • Nope, there is no ODF Scan option.
    Report ID: 1687788140.
  • Have you tried uninstalling, restarting Zotero, and reinstalling the extension?
  • Does anybody know how to make ZotHero (the plugin for using Zotero via Alfred) use scannable cites? Surely I'm not the first to think this! The two seem like they're made for each other!

    Here's all you'd need to do to insert a scannable cite:

    1. Press your keyboard shortcut to bring up the Alfred box.
    2. Type "zot [start typing the name of source you want to cite]" and press Command+Return. This will copy that item's scannable cite to your clipboard.
    3. Command+V to paste.

    So fast and simple!

    The problem I'm encountering is that ZotHero uses Zotero's citation styles, but scannable cites are an export style. Very frustrating!

    Has anybody figured this out? Or does anybody have any ideas?
  • I believe I figured it out, in case I was wondering. It's not hard. Here's what you need to do:

    1. Go here: https://www.zotero.org/styles?q=RTF
    2. Click RTF scan and add it to your Zotero.
    3. Press your keyboard shortcut to bring up the Alfred box.
    4. Type "zotconf" and press return.
    5. Select Default style.
    6. Select RTF scan.

    Henceforth, no matter what app you are using, just do the three steps from my previous post to quickly insert a scannable cite. Enjoy.
  • @dstillman Thank you! I've just reinstalled and it's working now!
  • It's disappeared again! There is no ODF scan menu anymore!
  • I've just reinstalled it and it works again!
  • Hi. Just having an issue with the 'scannable cite' translator not showing up as an option in the export options in zotero. I'm on linux, with zotero 5.0.81. This is a fresh install of the plugin, with the latest version from the github.

    Anyone have any ideas?
  • You could try downloading the file from here:
    https://raw.githubusercontent.com/Juris-M/zotero-odf-scan-plugin/master/resource/translators/Scannable Cite.js

    (right-click --> save link as), put it in your Zotero translator folder in the data directory (https://www.zotero.org/support/zotero_data ) and restart Zotero, see if that works:
  • Thanks adamsmith. That did the trick. I had already tried that actually, but it was something to do with getting confused about data dirs I think.

    On my arch linux system there is a system wide dir /usr/lib/zotero, and two user specific dirs ~/.zotero and ~/Zotero. I had tried putting it in the first two, but didn't know the last one existed.

    Thanks.
  • @adamsmith, I have the same problem ('scannable cite' translator not showing up as an option in the export options in zotero. Using windows 10).

    Could you provide more detailed instructions on the "downloading the file from here" (https://raw.githubusercontent.com/Juris-M/zotero-odf-scan-plugin/master/resource/translators/Scannable Cite.js)? Clicking the link lead to script which cannot be simply "downloaded".

    When you right "right click", where exactly should i right click?

    Thanks
  • edited January 14, 2020
    If you're getting the code for "Scannable Cite.js" come up literally in the browser window, you can just "Save Page as..." or whatever the equivalent option is in your browser and save it under the filename "Scannable Cite.js".

    That file then needs to go into the "translators" directory in the Zotero data directory as per https://www.zotero.org/support/zotero_data.

    Worked for me.

    Loving the plugin by the way. My scrivener workflow is now sorted.
  • I meant right-click on the link I provided, but octofish's option to just save the code page that opens works, too.
  • I noticed the following, using LibreOffice on Windows 10, without groups.

    With the default settings, ODF Scan works properly with:
    { | Smith, (2012) | | |zu:0:WQVBH98K}

    Setting "extensions.zotero.translators.ODFScan.useZoteroSelect" to "true", I get
    { | Smith, (2012) | | |zotero://select/items/1_WQVBH98K},
    which does not produce an output file. Debug output logging shows:
    ERROR (rtf-odf-scan-for-zotero): Error: Group with libraryID 1 does not exist.

    Manually changing the libraryID to "0", i.e.,
    { | Smith, (2012) | | |zotero://select/items/0_WQVBH98K},
    produces a correct output file.

    This might provide a fix for issue #29 on github:
    https://github.com/Juris-M/zotero-odf-scan-plugin/issues/29
  • Just experienced the same issue as octofish 26 days ago
    Resolved by using method suggested by adamsmith 26 days ago
  • Hello. I have recently tried the Zotero RTF and ODF scan plug-in. I have created a very long document on Scrivener while writing citations in the standard format suggested in the Zotero RTF plug-in (e.g., Reyes, 2010; Reyes et al., 2010; Reyes & Santos, 2010). I then exported the document to rtf. For my citations to be recognised, I ran an RTF scan, however, of the hundreds citations in my document only a small percentage returned results and placed in the bibliography. I read that the ODF scan is much more robust but i knew i had to re-format my citations. How do i do this, how do I generate citations in the correct format so that an ODF scan will recognise them?
  • Scrivener while writing citations in the standard format suggested in the Zotero RTF plug-in (e.g., Reyes, 2010; Reyes et al., 2010; Reyes & Santos, 2010)
    Let's start with this -- where is this from? RTF Scan should use curly brackets, not regular ones: https://www.zotero.org/support/rtf_scan

    ODF scan requires you to install the add-on and the export Scannable Cite from Zotero as described on https://zotero-odf-scan.github.io/zotero-odf-scan/ -- but that'd be a lot of work retroactively, so maybe try to fix RTF Scan first.
  • Thank you adamsmith, yes I have used curly brackets. I will re-run just in case there was a glitch with the first RTF scan, knowing now that doing via ODF scan will require more work. Thank you so much for the swift answer!!
  • Hi hope someone can help me. I've been using the workaround of going back to an old Zotero version (5.0.76) and everything was working fine.

    I've just done a Catalina update (10.15.3) and have noticed that scan no longer works. I have ODF and RTF as separate menu options (think it was RTF/ODF before).

    When I go to ODF when I try the button to select an input file it clicks but nothing happens.

    Any ideas? Not sure if the Catalina update was just coincidence when I noticed and tried to use it.

    Any workaround suggestions would be greatly appreciated.


    Cheers

    Alex
  • @alexferdi: Check Tools → Add-ons in Zotero and make sure you're running the latest version of the ODF-Scan plugin — currently 2.0.43. What you're describing would happen if you try to use an older version in Zotero 5.0.78 and up.
  • @dstillman: I was told I needed to keep Zotero at 5.0.77 or below (So I am running 5.0.76) to keep the old way of archiving or something.

    I've updated to that plugin version but it doesn't work.

    Do I need to update to 5.0.78? Will that not cause issues?
  • could you specify who told you that? You should generally avoid using old Zotero versions and there's very rarely a reason to.
  • edited February 29, 2020
    Hello,

    I have Zotero 5.0.84, ODF Scan for Zotero 2.0.43, Mac OS Catalina 10.15.3.
    My end goal is to convert a Microsoft Word Document to be useable in Scrivener with the citation markers that I can then convert back to normal in-text citations. I have installed Libre Office and ODF Scan for Zotero 2.0.43.
    I also have the problem that I only see "RTF Scan" and "ODF Scan" separately. The ODF Scan to citations seems to work. But I cannot get the reverse conversion to work (to markers) - at least nothing seems to change - when I save my Word document as ODT (with bookmarks) and then use the "to markers" conversion with the ODF Scan option... I'm not sure if I'm following the right procedure and would be happy about any tips. Thank you!
Sign In or Register to comment.