RTF/ODF Scan for Zotero

  • edited July 8, 2018
    Would it be possible to add a docx Scan feature as well, so that I do not have to convert my exported docx (from Ulysses), first to odt, then scan, open the file in LibreOffice, finish the bibliography stuff to save it als word docx again.

    Would be so much easier if the whole process could be done with a docx file within word als well...
  • It’s definitely possible, and I personally would like to be able to use it, but it requires dissecting the docx file format in the same way as @adamsmith and @fbennett dissected the ODF format. No one has yet had the time to sit down and do it, but pull requests/help from the community is certainly welcome to go through the existing code and translate it to the corresponding structures in docx.
  • but it might also be worth waiting -- my hope is that Zotero 5.1 will bring official citekey support which will then allow a very robust RTF-scan revamp that makes our add-on obsolete.
  • That’s a good point!
  • As with the complaints of flahe128 and AMomentOfMusic above, I am also now not able to drag and drop a scannable cite. Is this a bug?
  • You'd have to say more. Both users reported solving that.
  • @adamsmith Actually, I was able to resolve the reference marks issues, not the drag and drop issue - or at least not reliably so. On a fairly regular basis, drag and drop just seems to cease working. Restarting Zotero sometimes helps as well, but again, not always

    It does seem like happens exclusively when scannable cite is selected, and not other styles, though I cannot be 100% sure. I also have multiple other plugins installed (scannable cite/better bibtex/zotfile) so it's hard to know which one is the culprit.
  • Hey all,

    I've recently moved over to Zotero (from Papers3), and I'm in process of setting up my workflow.

    I'm using the RTF/ODF scan with the scannable cite export function in place. I am attempting to use Alfred to search through my Zotero Library and copy citations straight into scrivener, however Alfred can't seem to detect the scannable cite citation format?

    It seems to only detect formats that are kept in the styles folder as a .csl file (though I could be wrong here).

    Does anyone have a workaround or fix for this?

  • You would need to contact the author of the Alfred workflow about adding support for export formats, as well as CSL styles.

    Alternatively, I would recommend you just keep the Zotero app open, set Scannable Cite as your default export option, and either drag items from Zotero to Scrivener or use the Cmd+Shift+C shortcut to copy the Scannable Cites to your clipboard.

    You can also install the BetterBibTeX plugin and use its Cite as you Write feature to bring up the Zotero citation picker and insert a Scannable Cite. https://retorque.re/zotero-better-bibtex/cayw/
  • Thanks, I'll give those solutions a try!!!
  • I have installed the plugin and restarted Zotero, however it has no appeared, and the RTF scan has not changed.
  • edited October 11, 2018
    It shows in the list, however even after restarting, does not show up in tools.

    I have manually installed the translator and it shows up, however the ODF option is not showing up in the menu.
  • Only having this issue in the .56 version on windows. Installed .55 and it works fine.
  • Yes, thanks, we're aware that there are problems with the add-on in 5.0.56; might be a little while until we're able to address them.
  • I moved back to the version. However, I'm having some issues. I have a doc with this in:

    developments { | anon. New measures to unlock brownfield land for thousands of homes, no date | | |zu:2195248:89LEZZBK}.

    When I run the scan, it turns into this:

    developments anon. New measures to unlock brownfield land for thousands of homes, no date.

    When I click on the Word Zotero plugin to insert a bibliography, it tells me there are no citations. How can I get it to work properly?

  • You need to set the citation style in the document first using Document Preferences, then insert bibliography
  • Still getting an error saying that I must insert a citation.
  • Ah, sorry, didn't see the Word part. The workflow requires LibreOffice.
  • Ah, okay. Is there any way to only download the Writer part of it?

  • I think you can choose during installation, but not during download.
  • edited October 20, 2018
    UPDATE: Of course right after posting I found this: https://forums.zotero.org/discussion/comment/318258#Comment_318258

    Do I just move the Zotero app to the trash and then open the older version after downloading?

    This was my original comment (not sure if I should just erase it entirely?)

    I've read through a good deal of the posts concerning this plugin, and did just submit this issue to the GitHub as well. I havne't found a fix yet...

    I'd tested all this out a month ago when I started writing a speech that's tomorrow now—and I just went to finally export the "real thing" and scan all the citations and now the RTF/ODF isn't showing up at all as an option.

    I did have to recently restore my library from a backup. That's the only thing I can think of that changed.

    I'm in a huge time crunch as I need to have the transcript post ready tonight (ideally) for tomorrow, so I apologize if I'm missing an already-stated solution. I have no idea why this is happening when it was fine before.

    I did try removing and re-installing the add-on (with quitting and restarting Zotero in between.) I don't know if there's something with having restored the library? But I don't know why that would affect the add-on.

    I'm using Zotero 5.0.56
    On a Mac running High Sierra 10.13.6 (17G65)
    Firefox 62.0.3 (64-bit)

    I apologize for this being so panicked and I have tried searching for a solution, but am starting to become really worried given the time crunch. Would SO appreciate any possible solution!

    Many thanks
  • No need to uninstall the app first. Just download the installer from the link you gave, use it to drag the old Zotero version to your Applciations folder, and choose “Replace” when prompted.
  • Hi,
    @adamsmith , is the problem w/ the Add-on RTF-ODF (Odf does not appear even after the installation) still not resolved with the 5.0.57 version? It is the version I use and I can't see the "ODF" option added to RTF scan after installation.
    Thks in advance,
  • This isn't resolved yet -- 5.0.57 is a Zotero update, not an add-on update.
  • @adamsmith is there a way to stop Zotero from automatically updating? I've downloaded and installed the older version a few times to be able to do the ODF scan, but invariably, I'll open Zotero later and it will say it's updating and then be the newest version again.

    Apologies if I'm missing the obvious - the only thing I found in settings was to uncheck auto-updates to citation formats, but that's not the right thing.

    Many thanks!
  • @elizabethmoran84: You really don’t want to disable Zotero updates. I think we’ll push out a new Zotero version within the next day that will provide a stub to allow the extension to keep working until it’s fixed properly by the developer.
  • OK, with apologies for the delay, I've just released version 2.0.39, which has dstillman's fix and worked in a quick test.

    I think automatic update should work, but if it doesn't, you can manually update by reinstalling from https://github.com/Juris-M/zotero-odf-scan-plugin/releases

    Note that this does _not_ fix the failure to automatically install the Scannable Cite translator. I'll see if we can fix that for the next release, but until then new installations will need to manually downlod the file from https://github.com/Juris-M/zotero-odf-scan-plugin/raw/master/resource/translators/Scannable Cite.js , place it in Zotero's translator directory, and restart Zotero.
  • Thank you so much @adamsmith The manual download update of the ODF plugin now does show the ODF scan in the Tools menu. :)

    Just wanted to check RE: the Scannable Cite.js. Is that a new version? I already have a Scannable Cite.js in my translators, so just wasn't sure if I needed to replace it.

    Many thanks!
  • No need to reinstall scannable cite if you have it, no. That hasn't changed in years
Sign In or Register to comment.