RTF/ODF Scan for Zotero

1151618202123
  • Here you go:

    { | Suchman, 1995 | | |zu:458031:5AJDFV9J}
  • That's ODF Scan, not RTF Scan, so whatever you're doing is ODF Scan already
  • Hi Guys ( @fbennett, and @adamsmith),

    Thanks you your effort and support; your plug-in is great. I am using it with Zotero 5 and Scrivener 1.9.7 on Windows 7. I got the single citation reference to work. How would I include multiple references in my citation, be it in-line or in footnotes? Your direction will be valued.
  • Two immediately adjacent cites will be merged into a single citation.
  • ... and dragging/copying multiple items using the ScannableCite format will automatically do that.
  • Having problems updating a document - see here. It seems to me I've had this problem before and was able to solve it, but I can't for the life of me find back how...  Any ideas? 

  • Hazarding a guess, it might be something in prefix or suffix fields in the breaking citations that is fouling up the parse (maybe)?
  • edited April 7, 2018

    Thanks Frank. But so where would those prefix or suffix fields be then? The two citations you see on that page were { | NATO, 2018 | | |zg:2154870:E55U3S85} and { | NATO, 2008 | | |zg:2154870:7MQFKQGX} in Google Docs. And this is what it looks like in LibreOffice after doing the rdf/odf scan. Does that show you anything?

  • Not affixes then. To confirm the steps to the error, you are editing with markers in Google Docs, exporting to ODT, and then ... opening in LibreOffice, selecting an author-date or numeric style, refreshing, then switching to the footnote style, and it throws this error?
  • edited April 7, 2018
    We do scannable cite exports from Zotero (latest version) to GDoc; then export to ODT, then open in LO (version 6.0.3.2 (x64)), then select (in this case) Chicago Full Note and then refresh. This has always worked in the past, but it doesn't now. (I also emailed you copies of all the files in question)
    UPDATE: I just tried using Chicago Manual of Style 17th edition (author-date), but I still get the same error (and btw - I have also submitted the debug output - D778771980)
  • edited April 7, 2018
    I think it's the citations in footnotes entered into the table(s). You will need to paste those in as static text.

    (Edit: Actually, remove the "I think" there. That's definitely the issue here. It's not a problem with the scan, but a well known limitation of the word processor integration, not simple to fix.)
  • Ok. Thanks. But so how do I do this? What's the difference between dragging and dropping the Zotero item to the footnote (in the table) or doing Ctrl-Shift-C and Ctrl-V (as we did) on the one hand; and "pasting those in as static text"?
  • In Preferences -> Export, you would change the Default Format style used for quick copy from Scannable Cite to the citation style of the finished document, then drag and drop.
  • I just wanted to share that we had another problem like this, and that in this case it was a 'text box' (just text with a border around it) that was creating problems. With the text boxes in the Google Doc, we were unable to export the document to LibreOffice. We WERE able to take other parts of the doc, export those separately and to convert them correctly; but the parts with the text boxes never worked. Once we removed the text boxes, we were able to export the Google Doc to LO, to do the RTF/ODF scan, and then to change all of the live citations into whatever bibliographic format.
    So for all of you who want to use this add-on (as long as the more elegant integration into Google Docs is not yet available) please bear in mind that tables and text boxes won't work... Once you remove these, however, it does work.
  • @sdspieg -- that's the file you sent to Frank and me, so no need for us to look at that further?
  • Great plugin. Unfortunately, on my Windows 10 system, there is no option for "Scannable Citation" in Preferences>Export>Default Format.

    I've tried opening and closing Zotero Standalone, redownloading and reinstalling the extension, and wishing upon a star. Alas, nothing has helped.

    Zotero Standalone version: 5.0.47 (most up-to-date version
    RTF/ODF Scan version: v.0.37
    Operating system: Windows 10 Home version 10.0.17134 build 17134

    Here is a screenshot showing the problem alongside every bit of hardware and software information that my non-programmer brain can imagine you'd want: https://i.imgur.com/tKEtUzY.png (or if the link is blocked on your end for whatever reason, go to "i dot imgur dot com slash tKEtUzY").

    Any ideas?
  • That did the trick. Thank you very much!
  • Hi! I'm having two (potentially unrelated) difficulties in using the ODF scan to start in Scrivener and eventually get to Word, via LibreOffice. I've been using this process for something like five years now, so I think something broke with an update recently that I'd like to figure out. I'm using Windows 10, with Zotero 5.0.48

    1) Most pressingly, it appears I can no longer get the end result of footnotes (Chicago style) in Word. Previously, I would open my scanned .odt file in LibreOffice, switch to an in-text style, change to Bookmarks, then save a copy as .doc. When I opened it in Word, I could then change from Bookmarks to Fields and switch to footnotes. (aka this solution: https://github.com/Juris-M/zotero-odf-scan-plugin/issues/7)

    The last time I tried this was a few months ago (dissertation progress is slow, y'all), and it worked then. Today, however, when I opened the .doc file in Word and went to my Zotero add-in document preferences, the Full Note format only has an option for ReferenceMarks, not Fields, and thus when I try to change the format, I get an error "Field type not implemented."

    2) Less importantly but still annoying, the "drag and drop" feature does not work for ScannableCite. I can copy/paste them, so I can still get a scannable cite into my Scrivener file, but if I click on a Zotero entry and try to drag it, I just get the crossed out circle.

    Any help would be VERY appreciated. Thanks!
  • I've had the same problem with drag and drop as well - all of a sudden the options seems to completely stop working. I think it will *sometimes* start working again when I restart Zotero, but 99% of the time, drag and drop seems to completely fail.

    I had the problem you mentioned above with ReferenceMarks as well. What solved the issue for me was closing Zotero and relaunching and then trying again the plugin again in word. It's almost like the option window was stuck in the libreoffice mode, even in the word plugin.
  • Thank you! Closing Zotero between using it with LibreOffice and Word worked for me -- that'll do for now, if whatever's causing it can't be fixed. It sounds like the drag/drop thing is a bug; I hope it'll be able to be fixed, too -- it's far more convenient than copy/paste.
  • When I copy a citation, it simply shows the user name and date in the export. How can I get it to show the article name, author, date, URL etc automatically?
  • How are you copying citations exactly and with which citation style?
  • I'm using control, shift and copy, and pasting them in. It says its using the full Chicago style for citations.
  • This doesn't seem like your question ins about ODF scan at all. Please start a new discussion (red button at the top left). Note that the drag&drop or copy&paste style depends on the quick format settings in export.
  • My issue is that when I am scanning the document, it only produces the name for the reference, not everything. How can I get it to scan and have all the information, usch as URL, in the scan.
  • It sounds like you are using Chicago (note) style, not Chicago (full note).
  • edited June 20, 2018
    How can I set the export style then? I do control + shift + c, paste it in, run the scan, and it just gives me a short version of the citations without domain etc. How can I get it to show the full version?
  • Click the document preferences button in the Zotero toolbar in LibreOffice after running the scan and change the style.
Sign In or Register to comment.