RTF/ODF Scan for Zotero

  • Hi @adamsmith, did you have a chance to look at this?
  • Sorry, I never replied to this -- it's going to be a mess to fix this in the scan, I'm afraid, given how that works. I think you're also literally the only person who works with the zotero select links in the markers, so I'm honestly not sure this makes economic sense for us to fix (though @fbennett may disagree and would be easier able to fix this anyway).
  • Thanks @adamsmith! I know that most people use the default settings, but the hyperlink function is extremely useful and saves a lot of time. I've been using it for many years, so all my notes are reference in this style and I'm pretty heavily committed to it. I'd really, really appreciate if you or @fbennett might be able to have a look, as when the ODF scan manifests itself, I lose hours of time! @fbennet, can you shed any light on the issue?
  • Can't you just check for & remove the hyperlink? That's one of the reasons I thought this wasn't all this important to fix.
  • I suppose now I know that this is the likely cause, I could find a way to search for hyperlinks. It's tricky to find in the ODF scan, which is why it took me so long. However, somebody else facing the same problem wouldn't know that this was an issue, so could end up quite frustrated.
  • right, but that brings me back to point 1) -- there's, as far as I know, no one else who uses that format for the scans, certainly no one who has ever posted with an any issue with ODF Scan, and since you now know the cause of the problem, you can avoid it pretty simply.
  • Hi everyone, and thanks for making these great programs!

    I'm testing the RTF scan, and also the ODF scan, and I've discovered that the ODF scan doesn't create footnotes (for Chicago footnotes style) or brackets (for in-text references). All it does is change the placeholder citation to the correct citation style format and leave the raw text in the middle of my paragraph. By way contrast, using RTF scan or using the Zotero plugin in LibreOffice will create the appropriate footnotes or in-text brackets, according to the demands of the selected style.

    So is this working as intended, or is my ODF Scan broken? Thanks!
  • Actually, never mind. I realised that I just have to click on the Zotero bar in LibreOffice and change the style to a footnote or bracket style, and it will generate the footnotes and brackets. Sorry to waste your time! Thanks!
  • Just to explain what happened in case you're wondering:

    If I do an ODF Scan, open the created document and then select 'refresh' on the Zotero toolbar, and select 'Chicago Manual of Style 17th Edition (full note)' in the popup, it will bug out slightly and give me the citations in the middle of my paragraph rather than in footnotes.

    But if I do an ODF scan, open the created document and then select 'set document preferences' on the Zotero toolbar and select 'Chicago Manual of Style 17th Edition (full note)' it will give me the proper footnotes.

    The first minor bug can also be rectified by using 'set document preferences' to change it to another style and then back to Chicago 17th Full note.

    I'll just avoid 'refresh'ing a document created in ODF scan, so it's no issue at all.
  • I'm using a MacBook Pro and Zotero.0.96.2. I downloaded the .odt plugin (zotero-odf-scan-v2.0.43.xpi, not the two source code zipfiles. When I go to Export in preferences, "scannable cite" doesn't appear, though ODF Scan does appear under Tools. I want to produce Chicago 17 long notes (with shortened form for subsequent citations) and a bibliography. It's hard for me to go through 23 pages of comments. Could I pay for a Zoom session to get this working? I will be very grateful. Thanks, Rob.
  • You'll likely need to manually download the scannable cite "Translator" as described here: https://forums.zotero.org/discussion/comment/346328/#Comment_346328 and then restart Zotero.

    I'm not completely unwilling to get on a Zoom call, but my consulting rates are not really in line with the relative simplicity of the fix here (i.e., you don't really need to pay $150/h for highly specialized consulting if all you need is to download a file & put it in the right place).
  • I will try to do as you suggest, but if I fail again (I'm not totally incompetent, but all my attempts to do this—with this fix and others—have failed miserably) I will gladly hire you for an hour. I've just never been the type of person to be able to figure things like this out. I just write, teach, and administrate.
  • I'm using Zotero and want to use ODF scan to convert my references (going from Scrivener to Libre). I have downloaded all the software today so is the latest version of everything. I downloaded and experimented with the RTF Scan add on first which works fine but I wasn't happy with how many ambiguous references it was giving so thought I'd see if the ODF scan was a better option. I downloaded the ODF scan add on and successfully added it to my Zotero toolbox. However, when I run the ODF scan it does not let me choose an input or output file (by that I mean that the button does not activate the pop up window to choose the file as it does in the RTF scan). Some of the wording on the add on references selecting an RTF input file which presumably is incorrect.
    Since this functionality all works fine in the RTF scan add on can you please have a look at this issue in the ODF Scan?
    Many thanks, Linda
  • I am having the exact same problems as Linda. It ODF scan worked flawlessly two weeks ago but now it won't let me to chose a source or destination file. Many thanks!
  • ODF-Scan needs to be updated for the current Zotero beta.
  • edited October 2, 2021
    RE: "zg:undefined" as unique item identifier (also logged as issue on github)
    Debug ID: D1685013483

    Hi everyone,

    I had a search but couldn't find any related information.

    When I use "RTF/ODF Scan" plugin to convert active citations in an odt file back to markers the last field, i.e. the unique item identifier shows "zg:undefined" for all references.

    Any help would be highly appreciated.

    PS: Tested with:
    - Linux Lite (based on Ubuntu 18.04), Zotero with ODF Scan 2.0.43

    - Linux Lite (based on Ubuntu 16.04), Zotero 5.0.60 with RTF/ODF Scan 2.0.39*)

    *) version 2.0.43 not working in Zotero 5.0.60. File can't be chosen.
  • Am I really the only one running into this problem?
    Any hint/help would be highly appreciated as I'm heavily stuck - and copying all references by hand again would be a nightmare....
  • This is on my list to look at -- it's certainly possible it's generally broken: I don't think that feature sees a ton of use.
  • Thanks for letting me know, and more importantly having a look.
    Am surprised that this wouldn't be used a lot, considering that it allows universal use of references in all kind of text based (collab) tools...
  • I've just followed the process for adding RTF/ODF scan to Zotero, and everything is working fine except the citation markers. I inserted various citation markers in footnotes in Scrivener. The citation markers were preserved in the exported ODT doc when I opened it in LibreOffice. Then when I converted the doc using ODF scan in Zotero, all of the citations were in their original state, without the modifications I indicated using citation markers. Any suggestions?
  • So you're just getting "Smith 1776" instead of "see Smith 1776, p. 23"?
    That sounds like you haven't actually set a citation style under Document Preferences in LibreOffice.
  • Yes, that's what I'm getting. Same for trying to remove the author and add a prefix.

    I hadn't done that, but I have now, and it didn't seem to fix the problem.
  • Can you switch to a completely different style like Vancouver? You should just see numbers then, no references. If that doesn't work, can you describe exactly how and where you are selecting a citation style?
  • Ok, I changed to Vancouver, and still no change. What I'm doing is clicking on 'Set Document Preferences' in the Zotero toolbar in LibreOffice, on the original ODT file that I export from Scrivener which still has the coded citations in footnotes. A window comes up asking me to change citation style, just as I've seen before in Word, and I select one and press 'Ok.'

    Then when I convert the doc using ODF scan, it becomes plain footnotes with no modifications.
  • Ah no, you want to set the citation style in the scanned output file, not before scanning
  • Yes, that's it! Thank you!! It works now just fine.
  • edited November 3, 2021
    Hello, I have a bit of an unusual situation. I am citing a number of newspaper articles from the late 1870s, which are all anonymous (and several of which have the same title - the main of disambiguation is date). I can scan a document with these citation markers no problem in Zotero but then once I open the document in libreoffice and try to select a style, Zotero encounters an error and all I can see is [citations].

    This is not a case of a particular document being broken - I have this issue after compilling multiple different times from Scrivener, so it's a fresh document every time.

    If I delete all of the anonymous newspaper citations prior to picking a style, then there is no issue at all and Zotero happily converts the citations. Any thoughts on what is happening?
  • Can you insert a reference to those documents directly in LibreOffice from Zotero?

    If so, could you please send me via email
    a) a minimal copy of a document that triggers this problem (the shorter the better)
    b) an export to Zotero RDF to 1-2 such items (without files ore notes).

    Email is here https://www.sebastiankarcher.com/curriculum-vitae/ (sorry, I meant to post this last week and forgot).
  • edited November 10, 2021
    @adamsmith No worries, I'm sure you are very busy! So I've done more testing and I have managed to narrow down what triggers the error - as it turn out it has nothing to do with ODF scan but some even stranger error to do with the libreoffice plugin. It just didn't appear to be the case at first because of how wierdly specific the conditions are. This also explain why the error was happening when I went to select a style in libreoffice and not beforehand.

    These are the conditions that trigger the error
    1. The item in Zotero needs to have no author.
    2. The paragraph style has the property "next style" selected, so that the following paragraph is set to automatically use a different style.
    3. The citation is being added as the final thing to the paragraph in question
    4. The citation style uses in-text citations, rather than footnote citations.

    As soon as these conditions are met, the error triggers, and I cannot insert the citation, even directly from libreoffice. I notice that when I insert a citation with these conditions, that the citation marker briefly moves to a new line before moving back - my guess is that libreoffice then tries to style it using the "next style" set and that is what is causing the error. Though why it matters that its an item without an author completely beats me.

    Some other notes
    1. It doesn't matter whether it is a custom style or not. As soon as I change "next style" so that its set to a style different from the current one, the error triggers.
    2. Adding an author to the item in zotero and trying to insert again fixes the error.
    3. Similarly, deleting an author from a non-problematic item causes it to subsequently trigger the error
    4. There is no issue with inserting anonymous citation in other parts of the text.
    5. I can succesfully insert a citation in this position using a footnote style (like Chicago), but if I try to then change the citation format to one that uses in-text citations, the error occurs again.
    6. The error does not seem to happen when I set up the same conditions in Word, though I haven't tested it thoroughly.

    If you'd still like me to send you documents, please let me know. I am willing to concede that this is a strange enough edge case that it might not be worth the effort of fixing - I can get around it for now by changing the style so that it doesn't have a "next style" selected.

Sign In or Register to comment.