RTF/ODF Scan for Zotero

  • @adomasven -- the above sounds like it might be relevant for you? Do you want to split off into a new thread & troubleshoot?

    @AmomentOfMusic -- right, if this is reproducible in the LibreOffice add-on without ODF scan, it's not something I'd be able to fix (Adomas who I tag above mainly develops and maintains that), so no need to send the document. Thanks for the detailed steps to reproduce.
  • Hi there,

    I'm working with Zotero and Scrivener. I've just exported a doc to LibreOffice, and I've gotten the citations to work, except my modifications to the citation markers don't show up (page number, withhold author, etc.). I followed the format shown on the 'RTF/ODF-Scan for Zotero' site (http://zotero-odf-scan.github.io/zotero-odf-scan/), and I tried modifying the citations both within Scrivener before export, and after export in LibreOffice but before ODF Scan. Any suggestions?

  • Almost certainly you've just not done the last step, i.e. set a citation style in Document Preferences. The page numbers etc. don't show up in the initially converted markers, only once a citation style is set. (That's under "Setting a Citation Style" on the page you link to)
  • Yes! Thank you -- that makes the difference. Wonderful, I think I'm all set up to use Zotero in Scrivener now! I'm delighted.
  • I have followed the installation instructions (by downloading and pasting the .js file in the right place), I have copied and pasted the scannable cites in Scrivener, I have I have exported an ODT file with the expected marks in the right place but when I try to scan the file from Zotero... the Tools menu doesn't have the ODT option. What am I missing?

    I will note that in the middle of all this Zotero quite unhelpfully auto-updated to version 6 -- not sure this matters or not.
  • Just realized I had over interpreted the "auto install doesn't work right now, just grab the .js and drop it in the Translators directory". I still needed to install the .xpi.

    Did so, everything works fine, and the surprise auto upgrade was just a red herring.
  • I'm using the Scrivener and the Scannable Cite citation format with Zotero.

    When I Compile my Scrivener project, an ODF-file is created, and the format of the footnotes (using Scannable Cite) are matching the format of my Scrivener project (Times New Roman).

    When I run the Tools->ODF Scan from Zotero, the Scannable Cite citations are converted to nicely looking citations, replacing the Scannable Cite format with my format of choice (Chicago Author Date). However, the procedure changes the font of the Footnotes from Times New Roman to a non-serif font, probably Calibri.

    This adds another step in this workflow, as I have to change the font of the Footnote format.

    Is there something I can do to avoid having to change the Footnote font manually after each execution of the Tools->ODF Svan function?

  • You could try adjusting the default or normal style in LibreOffice to TNR. ODF Scan doesn't apply any fonts and neither does Zotero, but Zotero does interact with the word processor's styles.
  • @adamsmith Thanks, that's a workable workaround.

    Another minor cosmetic glitch that I noticed is that when a work has multiple authors/creators, they are separated by an ampersand "&", but the first name is also followed by a comma-sign ",".

    For example:
    { | Buswell, & Lopez, 2014 | | |zu:5100435:WUDSM9EM}
    and if there are more authors:
    { | Buswell, et al., 2014 | | |zu:5100435:WUDSM9EM}

    and after the Tools->ODF Scan the comma remains:

    Buswell, & Lopez, 2014

  • Remember that what's in the marker is just a placeholder. It'll turn into a proper citation once you set a citation style in the document preferences (and that affects the absence/presence of punctuation, ampersand vs. and, etc.)
  • Thanks again. Of course you are right, and that's why I was confounded by this behavior. I don't understand how my citation notes came to have the format "Buswell, & Lopez, 2014" as exemplified above (I can't even find a citation style that produces an ampersand) — now I can no longer re-create it. And whatever other format/template I choose, it looks just fine. All good!

  • edited June 10, 2022
    Hi there, I seem to have found a bug which I am unsure how to resolve. Basically whenever a prefix includes more than one instance of italics (formatted with asterisk as per documentation), the second instance does not italicizes and instead passes the asterisk as-in to citation without rich text formatting. The first instance, however, is not an issues.

    { | Smith, 2007 | |. Unlike “leitmotif.” Wagner did use the term *Gesamtkunstwerk* on a handful of occasion, most notably in “The Artwork of the Future.” Interestingly, however, it does not appear in the later publication *Opera and Drama* even if the concept remains. Wagner was principally concerned with art theory, not with giving his compositional approaches names. |zu:3351120:N2W4UWZK}

    So in this example "Gesamtkunstwerk" comes out properly italicized and "Opera and Drama" appears as *Opera and Drama* in the citation.

    This happens whenever I have more than italics in a citation. I have tried testing with a fresh document and new citation, and the result is the same every time.

  • We can look at that, but I'd probably recommend just using regular text rather than affixes for those cases.
  • @adamsmith thanks. Because I'm importing text from Scrivener to markdown then libreoffice (via pandoc) - and my citation markers are in-text and then changed by Zotero to footnote later - it would be nice if everything played nice together, but yes, I can probably find a way to append the text using footnotes in Scrivener, so will do so for now.
  • Thanks so much for putting this together. But its not working as I expect.
    I've followed the instructions as best I can. This gets me as far as opening an .odt in Libreoffice with correctly formatted citations. However, as soon as I try to get zotero to do anything further, a dialogue comes up stating the source is missing, with an option to locate it. Without doing that, the citation is no longer live. Am I missing something?
  • @mattwtsn -- make sure you're using the latest version, 4.0.27 -- there was an issue with this in 4.0.26
  • @adamsmith thanks so much for the speedy response - yep, the latest version makes it work. Having been pulled in by the promise of Scrivener for writing, and invested a good bit of time to shifting a project into it, I'm so relieved to have a functional way of working with citations in the app.
  • I celebrated a bit too soon
    With the new version, I can now convert the markers to live correctly formatted fields, and generate a bibliography, but only when ticking the 'Reference' option in the Libreoffice zotero preferences.
    If I click 'Bookmark' the fields are not recognised as citations (despite what looks like a zotero reference popping up if I mouse over).
    If I save as .docx and open in word, the citations are just plain text.
    I've tried saving to .docx at different points in the process, and with closing down zotero at various points, but cannot get live fields in word.
    I can try the learning curve of working with long form documents in Libreoffice and doing it all in .odt, but the outlining functions seems behind Word, so I would prefer to be able to work in Word with live citations if it can be done.
    Thanks for any help with this last step.
  • That's expected. The Workflow for Word is:
    - Run ODF Scan
    - Open in Libre Office
    - Set a citation style in Document preferences (still set to Reference marks)
    - Make sure the citations look right
    - Then either change the document to bookmarks under Set Document preferences or use the transfer document option. The latter is the only viable option if you have any citations in footnotes (Libre Office does not support Bookmarks in footnotes)
  • Thanks again so much, and apologies if I've failed to follow instructions already available (but I don't recall seeing anything so clear as this). Yep, this works great now.
  • I don't think we have the Word instructions spelled out clearly in any centralized place.
  • Hi @adamsmith

    I am trying to create a bibliography from footnotes, but although I followed the transfer document option that was referenced on this post, I get a pop-up message on word saying: You must insert a citation before performing this operation.

    Here is what I did.
    1) I have a document in Scrivener, in which citations were dragged and dropped from Zotero with a code similar to this one: { | Garland, 2002 | | |zu:5288534:L72PJCLF}.
    2) compiled the document into LibreOffice, ran the ODF scan after selecting the desired citation style, and save the document as .docx.
    3) got a pop-up window in Word saying: Zotero cannot update this document because it was created by a different word processing application with an incompatible field encoding. In order to make a document compatible with both Word and LibreOffice, open the document in the word processor with which it was originally created and switch the field type to Bookmarks in the Zotero Document Preferences.
    4) redid the process following the suggestion and saved the document in docx.
    5) opened the word doc and under the Zotero tab, clicked on document preference, and selected “switch to a different word processor” followed by “refresh”

    Thank you and sorry for the long explanation.
  • Step 2 isn't right -- see the steps above .
  • I rechecked and my disconnect is on the steps for transfer document option, particularly following the instructions from LibreOffice to Word and get the same message I referenced in Step 3.
  • The short version is that you need a fully functioning LibreOffice document with Reference Marks and an active citation style. Then use the Transfer option. Do you see the fully formatted citations (not just the author-date placeholder) in LibreOffice at any point?
  • After I run the ODF and select the citation style in LibreOffice, I see the code fields populated with the citation format I picked. From there I follow the instructions on the transfer option that begins with saving as docx, changing the file type in the drop down menu in the center of the pop-up screen. Then the next pop-up asks me to confirm format: This document may contain formatting or content that cannot be saved in the currently selected file format “Word 2007–365”

    I then opened the doc in word and follow the rest of the instructions. Getting the message: Zotero cannot update this document because it was created by a different word processing application with an incompatible field encoding. In order to make a document compatible with both Word and LibreOffice, open the document in the word processor with which it was originally created and switch the field type to Bookmarks in the Zotero Document Preferences.
  • When you click on "Switch Word Processor" Zotero displays a warning with "Continue" "More Info" "Cancel" -- if you click "Continue" you get a file with Zotero_Transfer_Document at the top and code instead of citations. Are you seeing that?
  • Yes, I see that.
    I saved the doc and reopen followed by "refresh" and at this point, I get a pop-up titled: Transferred document... Would you like to restore the Zotero citations in this document for use in Word? Once I select continue, Zotero hangs and I have to force quit.
    When I try to reopen Zotero, I get a message: Zotero experienced an error updating your document. Would you like to view troubleshooting instructions?
  • Once I select continue, Zotero hangs and I have to force quit.
    Two things on this:
    1) Let this run long enough. There's a lot going on, so this can easily take 5-10 minutes in a long document, potentially longer on a Mac.
    2) If you're sure it's not going through, post just this part to a new thread on the forums. At that point, it is unrelated to ODF Scan and I'm not the right person to troubleshoot it.
  • Ok, so I see potentially what is going on...
    From the code that substitute citations in LibreOffice, I saved into Word and refresh. It takes a while but when is done, I go to the end of the document and click on the add/edit bibliography. I get this message: The current bibliographic style does not define a bibliography. If you wish to add a bibliography, please choose another style. I chose Bluebook as the citation style.

    However, when I change the citation style, to, for example, Chicago, The add/edit bibliography button in Word works just fine.

    Do you have a suggestion to make it work with Bluebook?
Sign In or Register to comment.