Available for beta testing: Zotero Connector for Safari 13

  • The Zotero installed in my Mac is 5.0.85. Is it the beta version? If not, how can I get it? MacOS Catalina 10.15.3 and Safari 13.0.5
  • Andre: See the first post in this thread for information on the beta version.
  • "@wrrrr Could you close Safari, delete Zotero.app from /Applications, open Safari, go into Safari Preferences -> Extensions and check to make sure Zotero Connector is not listed there? After that download the latest beta version, close Safari, copy the beta from the image file to Applications and run Safari. Do you still get the same problem?"

    This is just to say thanks - this worked for me to restore the previously-disappearing Z icon in Safari.

    Mac OS 10.15.3
    Safari Version 13.0.5 (15608.5.11)
    Zotero 5.0.86-beta.6+e9ea9ae17
  • Similarly. Following these instructions carefully today fixed again losing access to Zotero Connector. Thanks a lot. You guys are great.
  • I have dowloaded and installed the Zotero beta for Mac, but I don't know how to save articles directly from the web into Zotero using safari. please help with instructions, this is urgent
  • @eu00462 See adding items to Zotero. If you don't see the Zotero button in Safari and this is urgent then you might want to use Chrome or Firefox for now since the Zotero Connector is very stable on those browsers.
  • In case this isn't a known issue, I've noticed that the most recent beta works in macOS 10.13 (the most recent system available for my MacBook), but the connector does not appear as an extension in Safari 13.1.
  • edited April 13, 2020
    In case others are having trouble after the 10.15.4 update:

    - When I opened Zotero beta today, it installed updates and then the Safari Zotero extension no longer worked (in Safari 13.1)—it intermittently appeared in my extension bar for milliseconds at a time. If clicked when it appeared, it would repeatedly attempt to add a page (always as a webpage) until I shut down safari.
    - I tried disabling and re-enabling the extension. Problem persisted.
    - I tried restarting Safari. Problem persisted.
    - I tried restarting the computer. Problem persisted.
    - I tried uninstalling and reinstalling Zotero beta (into my downloads folder). Problem seemingly solved—extension no longer disappears intermittently and seems to successfully add items to my Zotero library.
  • Yes, until further notice, you can assume that, if the connector button disappears when the app is updated, the solution is to quit Safari, delete the Zotero beta app from Applications, redownload the beta, copy the app to Applications, and run it once to reinstall the connector into Safari.

    If we can fix that, or it's fixed in a macOS update, we'll release this into production, but at the moment we don't have a fix.
  • I am seeing very high CPU usage by the Safari Zotero Connector slowing the machine down. Force quitting the connector seems to be the only remedy.

    Zotero 5.0.86-beta.9+36afe4573

    MB mid 2017, 1.4. ghz i7, 16GB ram, Mojave 10.14.6 (18G4032)

    Thx for your great work!
  • @NoisyNarrowBand Do you see the high CPU usage right after restarting Safari, or is it after running it for a while, perhaps visiting some specific page?
  • After running for a while - not sure about specific page, too many tabs :D

    Will test and see if I can identify specific pages.
  • edited April 15, 2020
    thanks for the update! -- the desktop client is now in beta (5.0.86), while the safari connector shows still the previous one (5.0.60) (all fine in macOS 10.15.3 and safari 13.0.5)
  • @gianroccolazzari: Those are unrelated version numbers.
  • Does this mean that if I use safari on Catalina and Zotero 5.0.81 that there will be an update after beta testing that allows me to have a safari connector? Should I just keep downloading pdfs to my Desktop folder and save each file to Zotero manually?
  • @breanne.kisselstein: We're certainly hoping to release the new Safari connector with the main version of Zotero. At the moment there's still some instability during app updates that's preventing us from bringing it out of beta. Unfortunately, it's not clear that we can fix that on our end. It may need to be fixed by Apple.

    For now, if you don't want to run the beta, you should use the Zotero Connector in Firefox or Chrome to save to Zotero. While you can download PDFs from Safari and drag them to Zotero, that's really not giving you the proper Zotero experience.
  • I'm getting the high CPU usage with the connector too. Just started 3 or so days ago. Connector 5.0.60. Zotero is 5.0.86-beta.11+da529d0d3
  • @cptwomey: Does it happen after restarting your computer? Is the connector actually working, or is it nonfunctional?
  • edited April 17, 2020
    I haven't restarted the computer, and needed to restart Safari to get the connector to stop loading. Umm, the 96 tabs all reloaded (that's a personal issue about which I'm deeply ashamed...but I'm going to read them all real soon) and no more spinning beachball... Happy to send logs if it would be useful.

    When I had initially installed in a few months back, it was not working. But I'm not sure if it was yesterday...I kind of forgot it was there (and had been manually reopening tabs in Chrome/Firefox when I wanted their articles in my DB
  • Is it working now, though?
  • Can someone tell me how to get the download for the safari connector? It keeps running me around in circles and does not download to my MacBook Pro.
  • @wkp2014: The first post in this thread explains how to use the beta. If you're having trouble with that, I'd strongly recommend just using Firefox or Chrome to save for now. This is beta software and not intended for general use.
  • dstillman, I just tried after the update (5.0.64) and get both lots of fan activity/heavy CPU use and only sporadic appearance of the Z icon (I tried 3 diff articles; it appeared briefly only for 1 of them, then it would disappear)
  • @cptwomey: Right, that's just the same issue we've mentioned — the extension repeatedly crashing after an update, causing the button to appear and disappear. It has no connection to the site you're viewing. Delete the app and reinstall it.
  • Redownloading the app, installing, and rebooting seemed to work. CPU usage steady and modest. Extension functionality seems to work! 5 articles added to my DB. Thanks and sorry I missed that in the message traffic here.
  • Today is April 22, 2020. I have been attempting to install the Safari Connector for Safari 13.1. I am running version 10.15.4 of Catalina. I believe that is the latest, and Zotero 5.0.85, but the Zotero "Z" does not appear in my Safari toolbar nor does it appear in the Preferences>Extensions tab. It seems I might be missing some critical step. Zotero works fine on Firefox, however I have certain research tools and proxies toggled to my Safari account, so it would be marvelous to get Zotero to work with Safari. Any tip would be much appreciated.
  • @lisaleine: See the first post in this thread. The connector for Safari 13 is currently only available as part of the Zotero beta. Unless you're comfortable running beta software, we recommend continuing to use Firefox or Chrome for now.
  • I think I will avoid possible additional issues by continuing to use the FF connector. However, how soon do you think the beta version will be finalized?
  • I'm new to Zotero but familiar with Evernote and web clipping . I've installed Zotero yesterday.. I cannot initiate the connector. I do not see anything to click. I'm on OS10.15.3 Safari 13.05 Zotero 5.0.85 . Connector does not appear in my Safari extensions pane. The client installed on my MacBook Pro fine. Thanks for your help. Do I need to enter the betta program to use tithe onn
  • @lahnice: See the first post in this thread. If you're not comfortable using beta software, you should use the Zotero Connector for Firefox or Chrome to save to Zotero for now.
Sign In or Register to comment.