Available for beta testing: Zotero Connector for Safari 13

  • Update: the connector just appeared on the Extensions pane suddenly -- strange. Thank you anyway!
  • (You should still update to Safari 13, since Safari 12 won't be receiving further security updates.)
  • Working pretty decently here (Mojave+Safari 13.0.4), but I had to remove the beta and reinstall it a couple of times before it started working...

    One bug that I'm noticing is that it's not able to download pdf embedded in an iframe (a.k.a. *cough* sci-hub *cough*)
  • Hi there,

    I'm struggling to install the Zotero connector for safari. I have the latest 2019 MacBook Pro and Safari. If someone could please provide simple step by step instructions for how to get the connector, that would be superb!
  • Hi all, Hi @dstillman. I have read the forum and I have the same problem as other. Mac Book Air, Safari 13.0.4., High Sierra (cannot upgrade to more than this as computer is old). Deleted Zotero App, installed both Beta version and Production Version (latest updates) and I cannot see the Connector. I opened the Zotero Beta, closed it, and opened the Zotero Production and still cannot see the Connector.. This drives me nuts as I need to upload soon my PhD thesis and it worked fine until one month or two ago. Please help, I am desperate!
  • @IanBroon, @Henrim I have the same issue on January 27th - cannot update from High Sierre futher - please! How did you solve it? Does the Connection appear now?
  • Hi all - update: I could upgrade to OS Catalina and now the issue seems solved. However, I did not want to do the upgrade (not for now) to wait a bit for the bugs in this sytem to be fixed. I hope someone will find a solution for the High Sierra though.
  • @rpeverati: I can reproduce that — thanks. Issue created.
  • I have Safari 12 running on Mojave. University IT does not want me to update either the OS or Safari. Is there any way to get an older version of the connector that I could use with Safari 12? Or am I stuck without one til I can update my OS?
  • @Imsteer -- you can run the beta connector on Mojave. Safari 12 isn't officially supported, but appears to work (see https://forums.zotero.org/discussion/comment/347387/#Comment_347387 ) though you should absolutely insist that IT let you update your browser. Safari 12 is no longer receiving security updates on Desktop machines and using outdated browsers puts you, your personal data (and others) at risk.
  • I am seeing the Zotero extension in Safari extensions, but I see not button in the safari menu bar?
    I am on MacBookPro, running the Zotero Beta, on an up to date 13.0.1 Safari on Catalina Beta 10.15 version 19A573a
    I've overwritten, reinstalled, deleted, and reinstalled Zotero
    I really need that button back.
    My research proposal with deadline on monday use websites, not anything doi... such a freaking pain without Zotero. Please help.
  • edited February 7, 2020
    @mariabachmann: Not sure why you think that's up to date. That's an early beta of Catalina from September and an outdated Safari version. Start by upgrading to current Catalina and Safari versions.

    Beyond that, while we can help you debug this if you're still having trouble, if you can't get it working and have a deadline, you should just do your saving from Firefox or Chrome rather than relying on beta software while you're on deadline.
  • I can't get connectors to work on Firefox or Chrome either
  • Start a new thread for that with more details, then. Those are stable production versions.
  • FAIL
    Had a previous beta version installed -> updated the app using help->updates from within Zotero -> the extension did not work for me in Safari even though it was enabled in Safari preferences. The icon would appear very briefly in the Safari toolbar and then disappear again upon disabling/enabling the extension.

    Deleting Zotero from my MacBook completely and reinstalling the latest beta app did the trick though. The extension works again for me.
  • A Safari extension is listed but following the links takes me in circles, I end up back at the promise. There is no extension from the Safari extension menu. I have reinstalled Zotero several times. What am I missing?
  • @pchilders: It doesn't take you in circles. The Safari connector download link on the download page takes you to this support page, which says at the top that there's a beta version and links to the first post of this thread that you're currently posting to, which links to another support page with the beta version of Zotero that installs the beta Zotero Connector into Safari 13.

    You can read the first post of this thread for details, but if you're not comfortable running beta software, I'd recommend using the Firefox or Chrome extension until we release the new Safari extension with the normal version of Zotero, which will happen soon.
  • Thank you. Installed without difficulty. Working well in early attempts.
  • Trouble today. In Safari, the button for the connector, in the form of a Z, now is labeled (on hovering over it with mouse) simply "Your button". And, it does nothing. Moreover, I had to go to Firefox to make this report, as in Safari, though I'm shown as logged in, on the Forums page it indicates that I'm not and therefore cannot comment there. Instead, on that page only, it presents Log In. When I follow that, I'm taken to: https://www.zotero.org, where I'm shown as logged in. If I then click on Forums, I'm taken back to: https://forums.zotero.org/discussions, where I'm shown as not logged in - a loop I cannot exit within Safari. So now, within Safari, I'm reduced to capturing doi numbers and using Add item(s) by identifier, where I was before installing the Beta.
  • edited February 19, 2020
    Have you tried restarting Safari and/or your computer?
  • I am having the same issues. Yesterday, I was presented with a dialogue box to install the latest version: 5.0.83-beta.16+a9dee2f48 by restarting Zotero. After restarting Zotero, the Zotero Connector button for Safari no longer worked. I restarted Safari, but that didn't fix it. As a last ditch effort, I took dstillman's advice to restart my computer. Now the Zotero Connector button for Safari is back. Phew!
  • Just piping up to say I suspect a lot of people (very much including me!) would appreciate an attempt to get this working on High Sierra -- there are a lot of Macs out there that are working fine but can't upgrade beyond that.
  • Now I find that the button in Safari for the connector appears as a page with a turned down corner, if I search in PubMed, and it works appropriately. Sensing it likely that it is source page dependent, I next checked an article presented on ResearchGate. Again the page with the turned corner icon, again worked to put an entry into MyLibrary. Fwiw, the entry has several shortcomings, including not identifying authors. Reluctantly, I resort to a familiar pattern, copy the title and paste it into Google Scholar, then click on the connector there and it gets populated correctly into MyLibrary. This is a nuisance, but not I think new to the Beta.

    Strange thing is I do not think I've done any software update in the last two days that could account for the change in behavior of the connector. Perhaps I was on some other source page when I encountered the earlier problem (non-active Z icon only), though these are the main sources I've been using.

    So, regarding the non-active Z icon, no trouble found at present.

    On the other matter, I have again had to go to Firefox to participate in this forum - same behavior in Safari as reported above.
  • edited February 22, 2020
    As much as I respect the frustration @eudinaesis, I expect this to be some extra effort to develop, test and maintain. It is not clear how it is directly adding much for future og Zotero on Mac. So I do not think it is too much to ask by the maintainers that High Sierra users to use Chrom og Firefox for Zotero connector. It is clearly up to them, but I have lived this speed bump for a while, it is a bit of a pain, but...
  • edited February 24, 2020
    @james.k.russel Likely Troubleshooting Issues with Zotero Translators applies for you. Please start a new thread if you continue having problems

    @eudinaesis unless someone from the community attempts to make this work I don't think it will happen. Chrome and Firefox are an option on High Sierra and given how difficult to work with the new Safari extension framework is and how lackluster it is in earlier versions of Safari and macOS it would require too much effort to get this working. We have given it a fair attempt at getting it working but cannot dedicate any more resources toward that.
  • edited February 24, 2020
    Hello. Safari 13.0.4, Mac Book Air, OS Catalina 10.15.2 (19C57), Zotero beta 5.0.83-beta.4+4e11c7927.

    I finished one chapter of my dissertation, closed zotero, opened it agained, waited for the update (not long) and now the connector button on Safari dissapeared. It is replaced with a Z-button that does nothing. Restarted again Zotero and Safari and it was unsucessful. I upgraded to OS Catalina last month and I had no problem in this last month, but today this appeared. How can I fix this? is it related to me closing the application? If yes, I will never close it again until I submit this thesis.

    Thank you,
  • @AlexandraAndreea: Have you tried restarting your computer? Unfortunately we're still seeing some instability on app updates — the system replaces the extension (which hasn't changed) and it sometimes doesn't start up again properly. Restarting seems to generally fix the problem.
  • Well now we've gone backwards. Per habit, when Zotero offered an update, I installed it. Now 'About Zotero' shows 5.0.84-beta.2+8170cf09d. Even in well-supported sites, like PubMed, no icon for access to Zotero appears at all. The preceding item suggested a reboot, so I did that. It helped some. Some tabs of a particular page of a journal site of interest, which always worked flawlessly in the (now rather distant) past, showed an icon with a turned down corner and a bar across the bottom that offered nothing beyond Customize Toolbar. Other tabs showed an icon of a page with a turned down corner and lines suggesting text that also did nothing, and others showed that same icon but actually worked. Moreover, when I went back to a tab that on first inspection showed the icon with the bar, it had changed to the icon with lines, but still did nothing.

    Something obviously is unstable. That's understandable with a Beta release, but, the developers should be aware of this erratic behavior, in order to be able to fix it. In any case, thanks to them for trying.

    Fwiw, I still have to use Firefox to access this forum.
  • @james.k.russell Per my post before did you try the Troubleshooting Issues with Zotero Translators steps? If they don't resolve your issue, please create a new thread and describe precisely which URLs are causing you trouble.

    Note that right-clicking on the Zotero extension button does not work to access alternative translation options in Safari -- it's a Safari limitation. You have to right click on the page itself.
  • Thanks for the tip about needing to right click on the page rather than the button. Today I updated, at Zotero's recommendation. After the update, I observed the useless Z button when I went to a source page. I rebooted. I logged into Firefox so I could see this forum. I quit Zotero (local app). I went back to Safari, to the source page. Then, it had the turned-down corner page with lines icon. I restarted Zotero and it worked just fine.

    There seems to be some install-time initialization issue that perhaps could use attention, perhaps something that requires system reboot. But, once it is up and working, it works fine.

    Thanks for the effort - I appreciate the connector. I'm just trying to help identify a Beta issue. As of now, it is a minor inconvenience.

    Incidentally, the issue about needing to go to Firefox to access the forum seems to have been resolved. I went there by habit initially, but I can now see the forum from Safari. Thanks for fixing that.
Sign In or Register to comment.