Available for beta testing: Zotero Connector for Safari 13

123578
  • This works great-- Thanks so much.
  • @james.k.russell Thanks for the steps. We are aware of the issue and are looking for a fix.
  • @dstillman , I have fixed that, thank you!
  • Just to flag that it worked straight out of the box for me (once the extension was enabled). Further, I installed it as the capture was not working in Chrome for one paper, but did work via the extension in Safari.
  • Hi! Safari 13.0.4, Zotero 5.0.85-beta.3+da5e8c549, Mac Book Air, Word. This is so annoying, button Zotero keeps dissapearing and I need to hand in the PhD thesis in 4 weeks. Any minute trying to solve this costs me a lot!

    I experienced the problem also last week but I solved by disabling and enabling again the Zotero extension. Now I did that + restarting and nothing...

    Would be nice if this bug can be solved. Meanwhile what shall I do?
  • @AlexandraAndreea you can use the Zotero Connector on Chrome or Firefox if you're struggling with getting the Safari one to work. To help in fixing this for the future when the button disappears, could you open Console.app, select Crash Reports on the right, then type "ZoteroSafariExtension" in the search, copy the latest crash report, paste it on pastebin.com and post a link to the paste here?
  • Just installed beta. Zotero connector installed itself magically in Safari and so far everything works great (knocking nearest wood). Many thanks to the Zotero team for bringing back this valuable component.
  • Hi,

    Thank you for the great work ! I also experience the regular crash with the icon disappearing in the first few second after having safari open. Here is one of the crash report: https://pastebin.com/uDrZ5T0c

    Hopefully this will help fixing the issue :)
  • @wosk Could you submit a couple more copies of recent crashes if there are multiple? Does restarting Safari, Zotero, or your Mac, as well as reinstalling the Zotero Beta help to alleviate the crashing?
  • edited March 12, 2020
    You'll find 16 reports here: https://www.dropbox.com/sh/3cul98kk2qdaqgx/AABvv87kdqiKeHbO6Pf7Q3q4a?dl=0
    (one per time I've started safari in the last few days I guess).

    I never managed to avoid the crashes, be it with restarting (Mac, safari, zotero) or reinstalling (just zotero). I'll try again though, we never know.
  • As with wosk, I am experiencing the extension crash moments after it starts. I have pasted one crash report here: https://pastebin.com/BgM6FbnP

    The extension does work before it crashes, I was able to successfully save a document with it (this does not drive the crashing) before it then disappeared.

    Note to other mac users: The directions to find your CRASH REPORT may not work for you (it doesn't for me, on Mojave FWIW). I find them (in the Console) under User Reports (the latest crashes are toward the bottom). I don't have a 'crash reports' section.
  • I have the same issue as @AlexandraAndreea. I updated Zotero last month and the Safari Extension constantly crash and disappear since then. Today I update Zotero to the latest beta version and the Zotero Connector disappear problem is still there. Any plans to take care of this bug?

    I'm now running Zotero 5.0.85-beta.6+b0de59fe8 and Safari 13.0.5 (15608.5.11). Here's my latest ZoteroSafariExtension Crash Report: https://pastebin.com/x8NbA1gW
  • An issue with saving from Amazon has been fixed in the latest beta.

    We're still debugging a problem where the button disappears after updating Zotero until after a computer restart.
  • I updated Zotero & Zotero Connector disappeared. Please fix so we can continue using Zotero. Thanks.
  • edited March 19, 2020
    @CMW2018: Restart your computer. If that doesn't work, reinstall the Zotero beta.
  • A web page for the Zotero Connector pop up when I install the Zotero Beta but nothing appears on my Safari tool box when I click to install the connector.

    I tried to close and open Safari, to restart laptop and I check the previous version of Zotero was well delete.

    Do you have a solution
    Thanks
  • Hi,
    Safari 13, installed the Zotero for Safari with connector which does appear in extensions, but unable to check to box to activate it - so no Z icon available. Any experiences anyone?
    Tried re-installing, restarting multiple times...
  • @ktoljan: What macOS version and Safari version?
  • @Hugo95120: You have to enable the extension from the Extensions tab in the Safari preferences.
  • @wosk, @wrrrr: We believe the specific crashes you reported — in com.apple.root.utility-qos — are fixed in the latest version.
  • What's the current status on the Safari extension? I've held off on upgrading to Safari 13 specifically because I need the Zotero connector.
  • @jasonlustig: At this point we believe it should be pretty stable while in use, but there's still a problem where after a Zotero update the extension can become disabled until after you restart your computer (and/or redownload the app). Until we've figured out a fix for that, we won't include this in the release version of Zotero. But if you're OK with that annoyance, it should be usable.
  • Safari 13.0.5 and macOS Catalina 10.15.3.
    I'm able to see Zotero in extensions under preferences, but the checkbox does not switch to on (ticked) if clicked on it, and the side menu offers only uninstall for the extension
  • @ktoljan: Have you tried restarting your computer and/or redownloading the beta?
  • reinstalled and redownloaded at least 3-4 times, restarted Safari, tried various combos
  • You need to restart your computer, not just Safari.
  • Yes, did that as well. Multiple times.
  • Hi @dstillman , glad to hear com.apple.root.utility-qos issue is fixed in the latest version. So I updated to the latest version this morning and restart my Mac several times but the extension still crashes. It seems this fix is not working for me. Here's my latest crash report: https://pastebin.com/6jBjAnHP
  • @ktoljan Could you open Console.app, select Crash Reports on the right, then type "ZoteroSafariExtension" in the search, copy the last crash report, paste it on pastebin.com and post a link to the paste here?

    @wrrrr Could you close Safari, delete Zotero.app from /Applications, open Safari, go into Safari Preferences -> Extensions and check to make sure Zotero Connector is not listed there? After that download the latest beta version, close Safari, copy the beta from the image file to Applications and run Safari. Do you still get the same problem?
  • edited March 22, 2020
    @adomasven I did what you told me to do and re-installed Zotero and the problem is now gone! It Just Works™.
Sign In or Register to comment.