RTF/ODF Scan for Zotero

11314151719
  • but I cannot see it in the list - even after closing and re-opening Zotero (see here).
    Are you looking in the right place? Scannable Cite wouldn't show in the part of the list you have in that image. It'd be all the way towards the bottom among the export translators, between RIS and Wikipedia
  • edited July 18, 2017
    I guess the screenshot didn't capture it fully, but yes, it is not among the export translators. It goes from RIS to Simple Evernote Export to TEI to Wikipedia. No Scannable Cite...
    Final Update: I rebooted my machine and now things do look again the way they did. Not sure what happened there, but I'm back in business.
  • I'm having trouble with Zotero 5.0.4, specifically installing the RTF/ODF Scan for Zotero. I have found and installed one for Firefox, but the one for Zotero itself won't install. It remains with a large button with a blue border on the left-hand side labelled "Downloaded", but nothing happens. I have restarted both Zotero and my MacBook, to no avail. Is anyone able to help me with this?
  • @claudcameron you need to install the beta version here to work with Zotero 5 as of now: https://github.com/Juris-M/zotero-odf-scan-plugin/releases/tag/v1.0.34beta

    @sdspieg -- have you tested a full workflow with ODF scan on version 5? I'd like to release this to everyone, but want to make sure it's been tested by a couple of folks.
  • Hi there!

    I am trying to dowload the add-on, but the download just won't start.. Would you be able to help me?
  • The beta version linked above? The file is there; try with a different browser or on a different network if this doesn't work for you.
  • edited July 27, 2017
    @adamsmith - re: your comment above, I tested the v1.0.34 beta version on MacOS. I'm using Zotero in the Dutch localisation. Here's what I see:

    - The scannable cite format does not show up in the Cite tab of Zotero preferences. Like SDSpieg I rebooted my system. But the "scannabel cite" format did not show up.

    - Converting an earlier ODT document with the scannable cite markers in it, did result in a correctly formatted document.


    If there is anything else I can do, please let me know.

    --edited to add: I had "scannable cite" selected when I uninstalled the format from Firefox and installed the new Zotero version. I decided to try "Cmd-Shift-C" to copy a reference in any style, to see if that worked. But, as it turned out, I had not yet selected a style from the list.

    I was very surprised to see that the contents of my clipboard were in the scannable cite format! Like so: { | World Economic Forum, & Boston Consulting Group, 2013 | | |zu:187232:IKZFBTHB} (look that up if you want. I believe that this is correct.)

    I'm a bit confused but I won't be selecting any styles in the preferences window anytime soon.

    Best regards, Michiel
  • I am having difficulties installing the RTF/ODF Scan for Zotero (version 4.0.29.10 on a Surface tablet running Windows 10). I have successfully installed Zotero and the the RTF/ODF Scan for Zotero on a PC laptop running Windows 10, but it's not working this time. I have tried both the normal plug-in and the beta version. I think I"m having the same problem as Valeriya_Kitsina above: I click to install, it asks me if I'm sure it's safe, I say yes...and then nothing happens. I've tried re-starting Zotero and the machine; nothing happens. Bizarrely, when I go looking for the Translators folder, I can't find it (and I am viewing hidden items, so that's not the problem). Any ideas? I'd really like to be able to use Scannable Citations when being mobile (which my laptop isn't anymore because of a dead battery).
  • Bizarrely, Scannable Citation just suddenly showed up in my list of options by magic.
  • Hello @adamsmith

    I have a problem with the RTF/ODF Scan for Zotero: quite simply, the "scannable cite" option for the quick copy does not appear in the drop-down list. This functionality is an important part of my Scrivener/Zotero/Libreoffice workflow, and thus I am seeking your help.

    I use:
    version 2.0.34 of the add-on.
    standalone Zotero 5.0.18.
    macOS Sierra 10.12.5

    I have restarted the machine several times already. Nothing has changed.
    Is there any solution? Shall I remove v2.0.34, and install v1.0.34beta instead?
  • edited September 17, 2017
    @sdspieg I downloaded https://github.com/Juris-M/zotero-odf-scan-plugin/raw/master/resource/translators/Scannable Cite.js and installed it by placing it in the translators forlder in the Zotero data directory.

    It works out!
    Quick copy works, as markers are properly produced.
    RTF scan works also, converting markers into citations.
    Thanks!
  • Curious if @adamsmith or @krhanshew got to the bottom of what the issue was (December 20, 2016) with the 'reverse conversion' problem...i.e. from active zotero references back into Scannable Cite the style? I am in the same situation of trying to bring a modified draft (in .docx) w/ revisions and comments from my supervisors back into Scrivener to work on. It seems that the Scannable Cite exists in my Zotero>translators folder (.js), but not in my Zotero>styles folder as a .csl.

    Did you figure out a solution to this back in December?
  • I don't think I ever received the document, but note that this will not work in docx, you'd have to convert the citation format to bookmarks, save as .odt, open in LibreOffice convert to reference marks, and then reverse conversion should work.

    (Scannable cite isn't used for that conversion at all, and it's correct that it would only show up in the translators folder)
  • Ah, I see. That last piece - converting back into Scannable Cite - is the key issue I'm having. I can convert to RTF scan style, but that style doesn't display the page numbers information I've input to each individual citation. Which means that data gets lost when I try to import my .odt document with supervisors comments/revisions, and converted into RTF scan style citations into Scrivener.

    My hope was that I could convert my citations into Scannable Cite to preserve the page number information I had input into each individual citation in the paper.
  • You can, as described above (it just doesn't use the Scannable Cite code; but is built into the reverse scan), but it's rather involved when coming from .docx
  • Yeah, the Scannable Cite code is the one I want because it would allow the quickest route to moving a draft again from Scrivener to a file format that I can share with others (.odt, .doc., .docx, etc), that has active Zotero references.

    When I convert a revised file (.odt, for example, with active Zotero references) back to RTF scan citation format, the page numbers get dropped from the actual text that is displayed, which means they don't make it when I pull that document into Scrivener for revisions. When I use another style format - like any of the author-date styles that preserve the page numbers - the brackets are not compatible with the RTF Scan feature.

    It looks like 'reverse conversion' works, but not into a citation style that I can move in and out of Scrivener with that preserves all the information in the citation. I could be missing something, though. Is there another citation style I should be using for this? I'm guessing this is related to the previous discussion in this thread about a pandoc-like citation marker for 5.1...?

    BTW, thanks for all the development work you do!
  • edited September 25, 2017
    I think you're just misunderstanding how this works. ScannableCite has never been a citation style. Conversion and reverse conversion _only_ work through scanning .odt files (you change the direction by selecting "to citations" and "to markers"). But that method _does_ work to include page numbers, prefixes, etc.

    RTF scan is completely separate from our tool (though I think it should be possible to modify the citation style to include page numbers); it's just in the same menu for simplicity.
  • Long story short, I figured it out. Thanks @adamsmith !

    Longer version...Turns out my RTF/ODF scan add-on tool in standalone Zotero was corrupted. When I had thought I was updating it, it turns out I wasn't. And in assuming that I had updated the tool, I had gone on a goose-chase trying to convert my citations to Scannable Cite using the 'Set Document Preferences' option inside my word processors because the 'RTF scan' option was not showing me the 'RTF/ODF scan' tool Doh! After your comment, I realized that my assumption about what tool was working (or not) might be my issue. Redownloaded your tool, installed it manually from within the standalone Zotero add-on manager, and restarted everything. Now it works. Brilliantly. Using the RTF/ODF scan tool, I can (reverse) convert document 'citations' to 'markers' (scannable cite) in order to pull revised chapters back into Scrivener for editing. And all the citation information is preserved...page numbers, suffixes, etc. Brilliant.

    I feel like a bonehead. My fault. Thanks for pointing the way through this, @adamsmith.
  • Hi! Zotero has just released an update 5.0.35.1 that it pretty foisted upon us and which "breaks" the RTF/ODF scan tool. Any news when you'll have an update compatible with the new version? I write in Scrivener, and without your tool, I'll lose a lot of time updating citation markers once I import into a full word processor.
  • Yet I see no issue report from you on https://github.com/Juris-M/zotero-odf-scan-plugin/issues strangely enough? Why not talk to the people who can actually fix this? And nothing is "foisted" on you here. Zotero puts out upgrades very carefully and well-tested, and you're offered the option to upgrade. Interactions with plugins do indeed break sometimes, and the volunteers mind you who make them are most likely very willing to help people not accusing them of malfeasance (and usually even to help people who do accuse them).
  • @"Kristen Sukalac" as @emilianoheyns points out, the ODF Scan plugin is a third-party tool separate from Zotero. I wrote it, so I can probably help.

    I maintain another "third-party" project that is essentially a clone of Zotero with some added bells and whistles. I bundle the ODF Scan plugin with it, and as far as I can tell it's working fine there (I just tested it again to be sure). So the good news is that if the plugin is not installing or not working for you in Zotero 5.0, the problems are likely minor.

    If you can take a few minutes to explain what you are doing to install or run the plugin, what happens (including any error messages), and what you expect to happen, I'll take a look.
  • Hi @emilianoheyns and @fbennett,

    Thanks for your messages. I posted here because on the page https://zotero-odf-scan.github.io/zotero-odf-scan/, it says, "Support
    Please ask any questions and report problems to the RTF/ODF - Scan thread on the Zotero forums" and links here.

    Despite the Zotero update coming through as "strongly recommended", I did resist it for a few weeks, because it announced that it would not be compatible with the plug-in. But I finally updated Zotero because the language used implied it was very important and given the fact that security breaches to software not being updated regularly has become a common problem, I finally decided to update.

    After spending a half day trying to do self-support despite my non-existent technical knowledge about how these things work, I finally found a tutorial explaining how to use the RTF scan independent of that plug-in, so I have a work-around. @fbennett, the drag-and-drop coding stopped working for me. Since that's my point-of-entry into using it, that confirmed the incompatibility announced to me before the upgrade. Perhaps I didn't go far enough in my testing. I appreciate your offer to help. These tools are great, but getting them up and running stresses me about as much as doing my taxes.
  • Yeah, this was the right place to ask -- so when you say the drag&drop coding stopped working, does that mean you don't have "Scannable Cite" as an option under Export anymore?
  • You're right - my mistake, and I apologize.
  • Wait - did you just upgrade from Zotero 4 to 5?
  • @adamsmith Scannable Cite is still there, but when I click on an entry in Zotero and drag it over to Scrivener, nothing happens. Before, the citation coding would automagically appear in the text. I didn't try ctrl-shift-C because, to be honest, I only learned about that when I found the other RTF Scan tutorial. So I found a solution that works, but it's a little clunkier to insert a reference than before, but definitely workable.
  • But you're still interested in troubleshooting this for ODF scan, right? (happy to do so, but if you're going to keep using RTF Scan either way there's also no need for either of us to spend time on this)

    Note that the two aren't substitutes -- RTF Scan is simpler, but also less precise&reliable.
  • Yes, I'd be interested because unless I'm mistaken, it's easier to keep the output document up to date with the ODF scan. However, the field codes being inserted look identical to the ones using Scannable cite, so I deduced that I could keep working while waiting for the troubleshoot. I'll also see if I can use the ctrl-shift-c command directly with Scannable cite and test whether the exporting still works and get back to you. I'm an executive student, so I'm having to juggle thesis writing with running a business, which is all the more reason why time-saving tools like these are so essential.
  • The field codes being inserted look identical to the ones using Scannable Cite
    Not, that'd definitely not the case; they're not compatible with each other and look differently. Do you have an example of what a citation marker looks like as you're inserting now?
Sign In or Register to comment.