RTF/ODF Scan for Zotero

1111214161725
  • no, sorry, that's not easy to do.
  • @ fbennett

    It works, fantastic! Instructions were really easy to follow and voila, the filepicker works.

    Thank you very much for the prompt support, great work on the plug-in, I very much appreciate the help!
  • Hi, I have a strange problem. I have a fully referenced document in LibreOffice (.odt). Everything with Zotero citations works fine inside LO: I don't get any errors when I refresh citations or add bibliography. Converting to markers works fine as well, but not back! I can convert it back using the plugin, but after I open the document and try to apply a citation style I first get errors about several citations (Item <#> in the highlighted citation no longer exists in your Zotero database. Do you want to select a substitute item? ...) with no actual option to substitute the item. Then I get an error "Zotero experienced an error updating your document. A bibliography in this document is corrupted." and sometimes LO even crashes. What could be the problem here?
    I should note, that first I was only getting the first errors, then I tried re-adding these broken citations, and at some point it became even worse...
    I'm using LO 5.1.3.2, Zotero 4.0.29.10 on Firefox 47.0 and plugin from the link a few posts above. All of this is on Ubuntu 14.04.3.
  • I'll test this when I have a chance. If you don't hear back within a week, ping this thread to wake me up.
  • @fbennet, I was on holiday myself for the last 2 weeks, but it's been 3 weeks now :)
  • Thanks for the nudge - I'll run a trial today.
  • edited July 18, 2016
    I cannot install the plugin neither from Juris-M nor from Zotero, neither for OpenOffice, nor for LibreOffice. Installing the plugin for LibreOffice from the Zotero/Juris-M leads to an error that I have to install the plugin manually. However the folder that opens up at after I hit "Ok" does not contain this plug-in.

    When I try to install the plug-in from the LibreOffice extension manager it always leads to the total freeze of the app.

    When I try to install the plug-in from the OpenOffice extension manager, program says I need to install the old version of Java software. Ok, let's do it... No, Java didn't help, it still doesn't work. Multiple reinstalling of Zotero, Juris-M, Open Office, Libre Office and multiple reconsiderations of what am I doing with my life didn't help at all...

    OS X El Capitan, latest version. Latest versions of Zotero and Juris-M, as well as the office packages...
  • Kostiantyn: From your description, it's not clear what you are trying to do. The RTF/ODF Scan plugin does not install anything into LibreOffice. If you are trying to install a LibreOffice Integration plugin for use with Zotero or Juris-M, please start a separate thread.
  • Honestly, never felt myself that stupid... So ashamed :)
  • You shouldn't feel bad. I've spend most of the day working on a little problem (not related to Zotero), with no success at all, and no prospect of any. As between the two of us, you are several steps ahead!
  • So I tried Zotero and im not lucky with it, so I want it enhance a little bit with the RTF/ODF Scan for Zotero. But it dosn't work. The first one, the Menu Item will not changed (this was the minor) the other is, that when I call the RTF Scan I have no way to enter the source and the target file. Also there was almost no differences in the dialog (only 2 select buttons was inserted). Has anybody an idea?

    I work with mac 10.11.6 with the German version, the present version of zotero and RTF/ODF Scan and want it use standalone.
  • The menu doesn't always change in Standalone, that's correct.
    The dialog doesn't look much different, so that's OK, too.

    When you say that you can't enter the source and the target file, could you describe that? No browse window at all, no Choose button, something fails?
  • There is the choose button, but when I press them, nothing happens. When I enable the plugin so I can't choose the input or the export file. When I disable the plugin, than I can choose both, but it isn't so flexible.

    Have you any idea?
  • edited August 30, 2016
    Frank fixed this but you need to download from his site:

    https://juris-m.github.io/downloads/#auxiliary-plugins

    The Tools menu item does not change but the action menu item does change to RDF/ODF Scan.
  • Thank's. It works fine.
  • Thank's. It works fine.
  • So I have just another question, when I go to the RTF dialog they will provide me a list on the cite style and if I want foot- or endnotes. On the ODF version, I miss this dialog. Hast anybody an idea because its happened?
  • read through the instructions https://zotero-odf-scan.github.io/zotero-odf-scan/
    you select the citation style via Zotero's LibreOffice add-on in the scanned document.
  • edited September 5, 2016
    Hi,

    I have the same problem as DiveSailPhoto from 6 days ago. I'm using Zotero Standalone. I have followed directions here: https://zotero-odf-scan.github.io/zotero-odf-scan/.

    When I get here:

    "Then, in Zotero, click on RTF/ODF Scan in the gears/action menu. Select "ODF (to citations)" as file type and select your saved file as the input and your desired output file. Click "Next" and the plugin will convert your document."

    I cannot select any input/output files, and I cannot enter a file path manually into the fields. I click on the buttons and the fields and nothing happens.

    above, erazlogo says that I need to download another plug-in from this site to solve the problem. is that true?
    https://juris-m.github.io/downloads/#auxiliary-plugins.

    I am not sure which plug-in I would need to install.

    Thanks.
  • The same plugin, RTF/OFF scan--the updated version is on that site only
  • Hello,

    I had the same problem as DiveSailPhoto and tdenmead.
    I updated to Juris-M standalone version and was able to create my .odf with citations.

    But, now, when i add a Bibliography at the end of my document, there is no title of article in the bibliography using the same CSL as before.

    How to get back titles in Bibliography ?

    Thanks !
  • The formatting isn't done by the add-on. Which style are you using? It might have changed.
  • Hello Adam,

    Thanks for the quick replay !

    In fact, it is a custom build CSV based on "International Union of Crystallography journals".

    I am not really good with CSV but my university ask for something specific and this one is the closest i find...

    You can find it here : http://chaussenot.net/csl-remi-these.csl
  • Yeah, that's a problem with the style -- it has never printed titles for journal articles and book chapters in the bibliography. Any more on that (and we can try to help you with that) please take to a separate thread as it's unrelated to the ODF Scan add-on.
  • Strange behavior, because until today, i had titles.

    I will open a new thread, i thought it was related to the upgrade, thanks adamsmith !

    R.
  • I am unable to suppress the author using RTF/ODF Scan.

    Any advice on what I am missing? It looks like this in Scivener / Libre Office in odt format:

    { |-Lindsay, 2011 | | |zu:3083314:VUQVQ5K3}

    So I want it to look like this eventually "2011" but I get the full reference "Lindsay, 2011". When I hover my mouse over "Lindsay, 2011" in writer it even looks like it recognises that I have asked it to suppress the author: "suppress-author":true

    Any help much appreciated.
    Am I missing something obvious here?
  • You need to actually apply a citation style (under set document preferences) for any formatting (including suppress author, prefix and suffix) to show.
  • Excellent, got it. Thanks for prompt reply.
  • Hi there,

    I'm having some trouble converting a Scrivener project. I have installed RTF/ODF scan add on. After compiling the Scrivener project as an ODF file, I then go to Zotero in FF and click the gears/action menu and select ODF (to citations) as file type I am unable to click on the 'choose file' button in either the input or output sections.

    Any help would be gratefully appreciated.

    Cheers

    Aaron
Sign In or Register to comment.