communicating with Zotero [from Word/OO]

  • I had the problem where the Word Zotero add-in could not communicate with Firefox to put in new citations into the body of the document, so I deleted the bibliography. Subsequently I was able to add it back no problem, and also to add new citations.
  • I wanted to endorse/remind everyone about Dan's word processor plugin troubleshooting page to deal with this issue. If you have reasonably up-to-date versions of everything (firefox, zotero, plugin) and you suddenly encounter the communication error, do NOT immediately reinstall a bunch of software or crawl back to Zotero v1...troubleshoot your Word/OO document first then move on to the other instructions if necessary.

    For me the problem was I had been editing a Word 2007 doc with track changes enabled. Bad idea. The fix: a select all/copy/paste of the entire contents of the problem document into a new document with no change tracking, followed by a "Zotero Refresh" via the plugin's toolbar. Two of the plugin's "add citation" windows popped up during the refresh and I had to hit "cancel". Problem solved...thanks Dan!
  • edited September 11, 2009
    Hello, I am using Openoffice 3.1, and the latest Zotero plugin (2.0a2), as well as an up to date version of firefox.

    When I click the insert citation icon in the toolbar in OO, nothing happens.

    I have tried uninstalling / reinstalling the plug-in and it hasn't helped. Have also looked through the troubleshooting pages and nothing seems relevant to my situation as I'm not getting any error response.

    I am new to both Zotero and OpenOffice and feeling a bit lost at the moment. Any help would be great!
  • hi
    i'm having trouble to install the plug-in

    Mac OS X 10.5.8
    Word 2004 (Mac)
    Firefox 3.5.3
    Zotero 2.0b6.5

    i tried both plug-ins 1.0b3 and 2.0a2, just in case

    but 1.0b3 says, when i try to drag "" :
    "the volume for "drag here to install" cannot be found."

    though 2.0a2 installs succesfully, nothing happens, since it's not meant for my word version.

    what else can i do?

    thank you
  • This thread is no longer relevant for Zotero 2.0b7 and later.

    All the information we have for the Zotero 1.0–era communication error is on the troubleshooting page. If none of the suggestions there work for you, consider upgrading to Zotero 2.0.

    This thread is now closed. It will be missed.
This discussion has been closed.