communicating with Zotero [from Word/OO]

  • I tried to open the Firefox profile manager with firefox.exe -ProfileManager and all I get is a new page instead of the Profile Manager window
  • Any news on this problem? I've had the same problem, with the same error message, for about two weeks (I'm using Office 2004 on a mac). I've tried creating a new profile in firefox, completely uninstalling office and reinstalling it, uninstalling and reinstalling zotero--all with no effect. I still press the citation button in word, the screen flickers over to firefox, but then the error message pops up--but the citation window never does.

    Very frustrating. I've started using neooffice in the meantime, which works fine. But I'm not thrilled about the fact that (I assume) the citations made in Neooffice will be screwy if or when I go back to word.

    I'd be grateful for any help or advice.
  • edited December 13, 2007
    I am running Zotero with Word 2003 and WinXP (SP2) and initially encountered this problem which has been resolved.

    There are really two parts to the installation: Firstly, installing the browser plugin via the ‘Download’ link on the home page (, secondly, installing the document template (

    The communication error is most likely a result of having an unsupported and/or out of date browser – in my case, Firefox 0.8 instead of the required version 2.0 or later. Browser version can typically be determined through the ‘help’->’about’ menus; the earliest browser versions supported by Zotero listed via the home page given above.

    Essentially, I’d recommend to all experiencing this problem to:
    (i) Download latest browser of choice supported by Zotero
    (ii) Uninstall existing browser, replacing with that browser downloaded in (i)
    (iii) Install the Zotero plugin & document template.

    As an aside, the browser plugin installation process ‘appears’ to complete successfully with the older browsers…

    I have only experienced the Windows setup, but I suspect the same applies to Mac users.
  • Hello, I am encountering the same problem. I just submitted a request using the button in Zotero (the cog thing). I am running Zotero 1.0.1 with Word 2003 and WinXP (SP2).

    I was switching different styles of citation to see how they look on my document and I started to get the problem. I tried all the suggestions above but nothing seems to work. I have a paper due soon and this is a disaster for me. I hope someone can get back to me ASAP.

    I want to use zotero for my dissertation so a more stability is highly desired!
  • And my Firefox is the latest version,

  • I'm with springchild74. Though I appreciate turnip's desire to help, his/her suggestions do not solve the problem. I had checked all of things several times, uninstalled and reinstalled the programs, and all of that several times before posting.

    I will say that one of the times that I reinstalled word, it somehow worked again for about an hour. But the error message began appearing again, and it hasn't gone away.

    Perhaps it's a glitch in my version of word (for mac), but it looks to me like the problem is bigger than my computer alone.

    I would be VERY grateful for a solution to this. Perhaps the next update of zotero or of the word plugin will solve the problem. When might those be coming out?
  • You know, it is very strange, but now this is working. What I did was that I typed a few words in the documents that were not responding, and then boila it started to work again. I have NO idea why it's now working and I am having my fingers crossed that this won't happen again.

    I wish you luck Cantabrian.
  • Hi springchild74

    I suddenly started to encounter the same issue, but unfortunately, typing a few words did not help. Have you come to target it more precisely?

  • Ok, I found my problem. Due to a synchronization issues (non zotero related) between my two computers, my zotero database was missing an item used in the bibliography...
    However I must point that the error message "communication error" was rather misleading.
    I'm also eagerly waiting for the online storage that shall solve my main synch issue!

  • I've got a similar problem. Suggestions?

    I'm running Firefox with Zotero 1.0.2 & Word plug in 10.0b2 on Mac OS 10.3.9.

    When I insert a reference in a Word document, I get a Word window that says
    "Zotero - Updating
    This citation no longer exists in the Zotero database. Delete it?"

    If I respond "no," not to delete it, then the reference seems to be placed correctly in the document.

    I've tried inserting various references, put into my Zotero database on various dates, with the same result.

    I get the same Word window when I try to insert a bibliography. Again, if I respond "no" don't delete, then the bibliography is inserted correctly into the Word document.

    I've restarted both Word & Firefox; same thing happens after those restarts.

    Thanks - I'm really appreciating Zotero.
  • Hi here are my error log #s
    latest zotero & firefox installs
    windows xp
    word 2003 english

    I had all the latest downloads, then 1/2 through my work today (which of course is due tomorrow) i got the zotero couldn't communicate error. I uninstall ed closed down restarted everything 2x, once reinstalling using the plug in installer, once copying the plug in from the download directly into the word\startup folder.
    I believe i updated last week when the update came out(my browser auto checks and i have been working in zotero every day for a few weeks) but have not had a problem until a few hrs ago. although i have noticed in hanging recently, but that could be another issue.

    this version of the document was opened on a mac, via email, then downloaded via email back on my pc today. I check with the pre email version, and that version seems to have no problems with zotero. unfortuneatly i have almost 12hrs worth of work in the new version. As it is a chapter going under review, there will be many more edits to make, so i hope we can get zotero to work smoothly on it again.

    thanks for any assistance
  • edited January 14, 2008
    Hi, i have gone to an earlier version of my document, and the zotero fields are being recognized, however i have two new issues:
    1. hanging, zotero is hanging for 20-40 seconds with each action
    2. no communication with ucb library, the icon for a book or journal article appears at the end of the url bar, and a red box shows up in the right section of the zotero screne, however no record is down loaded.- google books works fine however.

  • I ditto Marple, since a few days ago zotero plugin is kind of freezing everytime I ask the plugin to "communicate."

    At first I thought this was due to spyware but I ran the scan and I could find nothing. The other programs are fine too.
  • update to my comment of 1/11/08:
    The problem is specific to the Word file I was working on. I opened a couple of other Word files, & Zotero worked fine with them. However, the file that has the problem is the master document for a project. Copying and pasting the contents of that document into a new file doesn't help -- the new file has the same problem.

    Dan, any ideas about what to do?

    Thanks very much
  • edited January 20, 2008
    Hmmm... yes, similar problem with the communication error message--Zotero simply doesn't work. Just downloaded the plug-in, updated Zotero and Firefox, and am running 2007 MS Office suite with the most recent updates. Suggestions welcome.
  • The same connection problem. Firefox, Zotero 1.1 and MS word plugin 1.0b2. Using WinXP Pro + MS WORD 2007. And nothing mentioned on the forum helped.
    Report ID: 1950391608
    This all happend regardless of firewall, antivirus...

    Thanks for any suggestions.
  • benshaine and others experiencing this problem: If you don't mind sending the document you're working on to, we can probably figure out what's going on here. If you're able to copy a small section of the document (single citation, paragraph, etc.) into a new document and reproduce the problem, that would also work just fine.
  • edited January 21, 2008
    Thanks to Ben for sending in an excerpt from his document. We think we may have already fixed most of the causes of these communication errors in the latest dev build and will be releasing a new version in the next day or two, but for those trying to do work in the interim, if the plugin works in a new document, you should be able to fix a broken existing document quite easily by copying a page or so at a time into a new document and seeing if the error still occurs. Once you reproduce the error, you should be able to narrow down the text until you find the problematic citation. Remove that citation from the original document and the problem should go away (unless there are multiple problematic citations, in which case you'd have to repeat the process).

    If you are able to find a problematic citation, you should also send that document excerpt to so we can take a look at it.

    Hope that helps.
  • Hi I am also having a problem. I'm not sure if I am using dev version and in need of a new plug in. I once used dev version and firefox keeps automatically updating the zotero -- of which I'm not sure if it is dev version or the ordinary version. Do I need a new plugin for the word?
  • I have the same problem (with MSWord 2003 under XP as well as with 2.3 under XP, the newest available versions of Zotero and of the respective plugins. I also followed all advices I could find: deleted and re-installed the plugin, updated reset translators and styles). The problem does not depend on specific documents, it also appears with new ones. However, while the OpenOffice-plugin does not work at all, within MSWord the communication-errors only occur when I choose for certain citation styles. I did not check all of them, but "Modern Humanities Research Association (Note without Bibliography)" is one of the problematic ones.
  • Error Report: 1128291751

    I had the same problem as miluska who began this thread. Namely, after updating Zotero and then updating the Word plugin, I could no long use Zotero in Word. I only got the error message about "problem communicating with Zotero". I read the thread and created a new Firefox profile, reinstalled Zotero on that profile as Dan suggested to miluska some time back, and this finally allowed me to insert new citations into my document with Zotero.

    Having fixed this problem I have a new problem which has been mentioned in this thread. Namely, All of my older citations (pre-New Firefox profile) bring up a message: "This citation no longer exists in the Zotero database. Delete it?" I say "No" and everything seems to be OK, but getting this message for every citation, every time I add, update, or edit citations in a growing dissertation is obviously not going to work.

    I have exported my older library and imported it into my new Zotero installation. I've closed and re-opened programs, rebooted and so on with no changes.

    Perhaps the coming update will fix this... I very much welcome any suggestions. Thanks.
  • I read the thread and created a new Firefox profile, reinstalled Zotero on that profile as Dan suggested to miluska some time back, and this finally allowed me to insert new citations into my document with Zotero.
    Trying a new profile was intended only as a test before we knew the causes of the problem. Currently, documents are tied to a particular Zotero database, so you can't use existing documents with a new profile. You'll need to go back to your previous database in order to use existing documents.

    In your original profile, first make sure Zotero's translators are up-to-date by going to the Zotero prefs and clicking Update Now on the General pane. (This should only be necessary after an upgrade to 1.0.2 and before a daily auto-update.) Then, if you're able to insert citations into a new Word document, follow the steps in my previous post to isolate any problematic citations in your existing documents.

    Alternatively, there's now code on the dev branch that may repair existing documents. We'd appreciate feedback from anyone running a dev build who can test existing documents currently exhibiting the communication error.

    Please note that dev builds are not intended for general use, so please test only if you know what you're doing and have backups of your Zotero database and existing documents. We'll be releasing 1.0.3 from this branch within a day or two.

    To everyone else, thanks for the patience. The word processor plugins are still in beta, but we're hoping to be able to declare them as stable in the near future.
  • edited January 27, 2008
    Ok, I'm running 1.0.2.r2168 and I am not sure if this is development version or not, Firefox keep updating this.

    I still get the same error message.

    How can I revert back to the normal zotero if the one I'm using is a development version?
  • Ok, I'm running 1.0.2.r2168 and I am not sure if this is development version or not, Firefox keep updating this.
    That's the dev version. You can switch to the official version by installing Zotero from the front page of over your current copy.
    I still get the same error message.
    Do you get the error in a new document, or only in existing documents?

    If you still get it in existing documents with the latest dev version, can you 1) send in an error report via Report Errors (under Zotero's Actions menu) if it's activated (non-gray) after you get the communication error and post the Report ID here and 2) follow the steps I outlined two posts ago and send us an excerpt from a document that triggers the error?
  • I'm having real problems with citations in MS Word. I've installed the 1.0.3 update, and reinstalled my MS word plug in, but the thing just seizes up -- I get an error message that scripts are taking too long, and if I allow them to continue SOMETIMES I will eventually get the cite to take in the document. But it makes footnotes rather than endnotes, and most recently seemed to go through and change about half my cites to footnotes, leaving the others as endnotes. I'm not an expert user, but I've followed the instructions here and still, I've got something of a disaster on my hands.
  • I'm suffering the same problem as bjn.

    Following the 1.0.3 update, Firefox and OpenOffice was seizing up. After removing Zotero and the extensions, and importing my backed up library it works fine on new documents. However, it's now saying that the citation no longer exists on older documents with more citations than I'd prefer to have to manually replace.
  • After removing Zotero and the extensions, and importing my backed up library it works fine on new documents. However, it's now saying that the citation no longer exists on older documents with more citations than I'd prefer to have to manually replace.
    As I told bjn, citations in documents are currently tied to ids in the Zotero database. If you import a backed up library, your items get new ids, and there's no way to link them.

    If Zotero works fine with new documents, the only thing to do is to follow the steps I outlined a few posts ago and isolate a problematic citation in your document and send it to us at
  • Same Problems as everyone else. I just download Zotero this evening. Zotero 1.0.3 and Word2003 SP3 on a PC with Windows XP. The error statement is "An Error occurred communicating with Zotero. Please ensure Firefox is open and try again." Firefox is open and I have tried with the Zotero window open and closed, with no success. I am able to drag and drop individual citation entries, but I would like to use the Window plug in. I downloaded the installer 1.0b3 and installed it. The Zotero tool bar appears but I just get the above error. I tried to report an error, but the report error section is grayed out. Anything I have missed?
  • edited March 6, 2008
    Error report: 207124337

    Same problem, including with new documents but a few caveats.

    I'm using Word 2007, Windows XP, Firefox, Zotero 1.0.3 and plug-in downloaded 2/4/2008.

    I have found that I can insert citations with no problem when I don't insert a page number into the insert citation dialog box. When I do insert a page number, that's when I get the communication error.

    So I can insert a citation, open up the editor, and manually insert my page number and that seems to work fine for sources where I have this problem.

    Also, I find that with some sources I can insert page numbers the proper way. At first I thought the trouble was with sources I imported from EndNote but this does not seem to be the case--it happens with freshly imported sources from the web. At this point, with just a few tries, it seems that it may depend on the repository. LOC sources do not work, EBSCO sources do.

    Will citations continue to be linked to ids? That seems a little scary to me.
  • tadoslav: Ticket created, thanks.

    Can you export one of the references that triggers the error in a new document and send the RDF file to
    Will citations continue to be linked to ids?
This discussion has been closed.