communicating with Zotero [from Word/OO]

  • I am using Firefox on Linux with the latest version of the Zotero extension and OOo plugin, and trying to use it with v3.

    I am getting the "An error occurred communicating with Zotero. Please ensure Firefox is open and try again" message. I have checked the debug output and I get the same "zotero(3): Not initializing integration HTTP server" message, no matter what I do: uninstall/delete profile/reboot/relaunch firefox/reinstall Zotero. If I set the "Work Offline" option, and then unset it, the debug output repeats the zotero(3) message. This happens also if I run firefox as root (which I tried as a last resource). I have tried this all on a new profile, with Zotero as the only extension, without success.

    What's going on? Only a couple of months ago Zotero worked flawlessly on this machine, with the same configuration (kernel/browser/OOo), I have only installed security updates (debian)...

    Thanks in advance,
  • I just solved the previous problem.

    For some strange reason, the loopback device was not properly started. I only noticed when I started an IM client and it complained that it could not connect to localhost... restarting the loopback device solved it! Now I have Zotero working flawlessly with OOo v3 :-)

  • System:
    Windows XP Pro
    MS Word 2003
    Firefox 3.0.10
    Zotero 1.0.10

    When Firefox is opened and connected to network I can cite refs in MS Word. When Firefox is not open/firefox open but not connected to internet I get the message: 'error communicating with Firefox etc.,'. I have tried most of the suggestions in the troubleshooting page but they have not worked. I need zotero to work when I am not connected to the internet.

  • paddy83:

    From the troubleshooting page:
    Make sure Firefox is running and Work Offline mode is not checked in the File menu. You do not need to be online to use Zotero word processor integration, but Firefox's Work Offline mode cannot be enabled.
  • Dan,

    I tried that but it still doesn't work.

  • I'm afraid we don't have any more information than what's on that page. Testing just now with the same specs you provided, the plugin works when online, disabling the network causes Firefox to go into offline mode and the plugin to give the communication error, and unchecking Work Offline in Firefox's File menu causes it to work again.
  • hello,

    I would appreciate your help! Since I updated zotero some days ago the word plug-in does not work anymore. Everytime I try to add a footnote firefox/zotero is not answering anymore but instead crashes after 30 seconds time. I tried it several times (on different days), nothing changes. - What can I do???

    Mac OS X 10.5.6
    Word 2004 (Mac)
    Firefox 3.0.10
    zotero 1.10.

    Thanks a lot!
  • error : 1025784861
    Windows 2000
    word 2000
    Firefox 3.0
    zotero 1.1

    Word hangs immediately any zotero tab is cliked (new, old, copied documents) have tried all recommedations in posts (even Mac ones if poss) without success : communitcation error, ensure firefox is on and retry. Some assistence would be appreciated
    Works beutiful on firefox, plugin is a nightmare - 4hours wasted!!!
  • Output: 1307297270
    No help from previous forums, have looked and tried them
  • soulsista, adenijik: We don't really have any information other than what's on the word processor plugin troubleshooting page, and you don't provide all the information requested there. (soulsista: Does this happen in new documents as well? If not, have you tried the Debugging Broken Documents steps? adenijik: Is the integration server listed as running in debug output?)

    Note that very few of the communication errors people are getting have anything to do with Zotero code, so there's a limited amount we can do to fix these issues, but if you try everything on that page and provide all the necessary information we might be able to help.
  • edited May 21, 2009
    No communication from OO3.1 with extension 2.2a2 to FF3.0.1.

    Additional add-in on FF include Status Bar Scientific Calculator and Ubuntu Mods for Firefox 0.7.

    Here's the debug console:

    Kubuntu 9.04
    OO 3.1
    Firefox 3.0.1
    zotero 2.0b3

    debug console on:

    [extra output removed — D.S.]

    zotero(3): Integration HTTP server listening on

    [extra output removed — D.S.]
  • oops, I should have noted that this is a new document, with no content. I have not tested with other documents yet.
  • edited May 21, 2009
    Hi Dan,
    Thanks for writing back. Debug suggests intergration server not intializing as you surmised. No other zotero processes running in task manager and no difference on restart computer. Have inputed error message into forums - not sure how to edit zotero zip based on your intructions to another user with a different OS.

    Using ESET output from another user:
    "unknown" = "||LISTEN" adeniji:50001|adeniji:51320|LISTEN ; 0 ; ( 5: Unknown ) ;


    [extra output removed — D.S.]

    zotero(3)(+0000004): Not initializing integration HTTP server

    [extra output removed — D.S.]

    Your assisstance is much appreciated -i don't like refmanager half as much as zotero.
  • Thanks for your support, Dan! --- Nothing works, though...

    I think, I respected all indications given (I hope!), and tried everything that is suggested on the pages. Furthermore, I uninstalled the Word-Plugin and installed it again. It happens with new and old docs for whatever citation-style I choose.
    Some more suggestions? And to conclude with an odd question: Would it work again if I'd downgrade back to zotero 1.0.09? (How does it work?)
    Thanks in advance!

    PS: Numbers of Error reports: 527521315 & 1036004463.
  • Hi,

    Just as a general remark, I also get this error box when an incorrect style sheet is used (It happened to me when I was trying to create a new style sheet). Using Office 2007, a mistake in the style sheet would generate the error, and then the only thing you can do is get a previously stored version of your document that did not use the incorrect style sheet.
    I am using zotero 2.0 b4

  • After upgrading Firefox and Zotero, I keep encountering this error message in Word 2007 when I click on any of the Zotero add-ins button:

    "This version of the Zotero Word plugin (1.0b3) is incompatible with the currently installed version of the Zotero Firefox extension (2.0b4). Please ensure you are using the latest versions of both component."

    My configurations:
    Win XP (also Window Vista in another pc)
    MS Word 2007
    Firefox 3.0.10
    Zotero v2.0b4

    Where can i get a compatible update to the Zotero Word plugin? Can someone please help!

  • caseyng:
  • edited May 23, 2009
    I've just been tearing my hair trying all the solutions and just about ready to give up on Zotero - finally found that colinb's solution above worked for me. Please add to the troubleshooting page as it should be tried before other things:

    - make sure *Internet Explorer* is NOT set to *Work Offline*
  • marcus: Thanks. Added to the troubleshooting page.
  • Hi Dan,
    Would have written back earlier but had to submitt summative assessment the old way
    I haven't managed to get past the:
    ' zotero (3) 'Not initializing integration HTTP server'
    I have tried everything in all the forums even those for different operating sytems - I am very keen to use zotero, my debug output has remained the same.
    NEW ERROR if useful 439851616
  • Hi all,

    I was having a similar problem to those mentioned in this forum with an existing document. I had updated to the new zotero but had a document that I had used the old zotero to cite in. When I updated the word plug in and tried to add a new references to the document it kept on coming up with the error message mentioned (cannot communicate with firefox). I solved it by downloading the relevant (added) reference pack (in my case ACM CHI) to the new version as it does not seem to carry reference templates over.

    Might not help but I thought I'd let people know if they (like I) were having trouble with that sort of thing.
  • Hi All,

    Maybe this may give a clue. I often get this problem when I am changing citation styles and I make a mistake there, such as an XML error or -as happened a few minutes ago- I entered an incorrect value in a variable. When this happens, the document in word will no longer allow zotero to open, update, refresh or anything similar.
    I don't know if its possible to change a configuration file or so, to make the zotero plugin point to another citation style?

  • I had the same problem as here described. My solution was deleting the complete bibliography from the concerning document and creating it new.

    I think this happened because I cleaned up my library inside the FireFox addon. A few similar citations where deleted during this process.

    Try it out! I hope I could help.
  • edited July 13, 2009

    I've been trying for an entire week to solve the problem of communication. My zotero was working fine until I upgraded to the Beta version because I was going for a trip an wanted to have my Library at hand. I've tried everything suggested in the forums: Uninstall and re-install everything (firefox, plugin, open office) several times, created a new firefox profile. Switched my firewall and antivirus off, restored my internet advance settings, tried new and old documents, and finally, I tried also deleting the bibliography and creating it again. I don't really know what else to try and I desperately need to have this working. I just work with open office so I cannot use Endnote.

    I work with the latest version of everything:
    Firefox 3.5
    Open Office 3.1
    Zotero 2.0b6
    Open Office Plugin 2.0a2

    This is the output from my debug log. I know this is a lot, but I've really tried everything. I am sending more in the next comment:

    [extra output removed – D.S. ]

    zotero(3): Integration HTTP server listening on

    [extra output removed – D.S. ]
  • edited July 13, 2009
    msa073: Is there any output from Zotero when you click Add Citation in OpenOffice? If so, paste it here. Is there an error in Report Errors under Zotero's gear menu? If so, post the Report ID here.
  • Hi, I just get the same message that everybody else has reported : "An error occurred contacting Zotero. Please ensure firefox is open and try again".

    Report ID: 1313851475

    Thanks for your quick response!
  • I mean debug output.
  • No. There is not any debug output when I do that.
  • Hi, I wonder if you found something in my debug output. I tried a couple of things more but nothing happens. What is that makes the "zotero.sqlite" different between the Beta and the 1.0 version? I would be glad to go back to the 1.0 version but unfortunately, I didn't back my library before upgrading. I did export the library to other formats. But when I open them again in the 1.0 version, they are all contained in a single folder, they basically lose all clasification. And when you have hundreds of references this becomes in a big issue.
  • msa073: You can't revert to 1.0 without losing data if you don't have a backup. (If you exported to Zotero RDF you should still see subfolders in the import, but it's not a recommended backup/restore method.)

    There's nothing for us to look, unfortunately. I excerpted the only relevant line from your debug output, which indicates that Zotero is working properly. The problem is on the OpenOffice side or somewhere else in between on your system (firewall, etc.). You can try the latest development plugin, but it's not particularly likely to make a difference.
This discussion has been closed.