communicating with Zotero [from Word/OO]

  • Do you only have a problem when you are "offline"? If so, check out this thread:
  • ID: 837560372

    Hi -- I'm still having problems with getting Firefox 3 and Word 2007 to work on my PC (running XP, SP3). I can now get Zotero to insert refs (although it won't include page numbers) but ONLY if I click the "Show Editor" button before clicking "OK". If I don't do this and try to insert the ref without clicking "Show Editor" everything locks up and I get the same error message I posted about earlier. I then have to restart Word to be able to insert a ref. Any tips?
    Many thanks for your help.
  • eg1man: What style are you using? It looks like it's an old-format style using the old CSL processor, which is no longer maintained and which will be discontinued in 1.5. If this is a style from, check the styles page for a more up-to-date version.
  • Dear Dan Stillman,
    Many thanks for your suggestion. I've been trying to use the Modern Humanities Research Association (MHRA) style. I've checked that I've updated to the latest version of this style, but it's still happening. It seems to be a problem with that particular style since other styles work fine, I now notice. The last error generated this report:
    Best wishes,
  • I just had the same problem (Zotero 1.0.7) -- also on my doctoral dissertation due next week!

    But I solved it.

    I was using "Track Changes" in Word 2007 when the problem happened. I turned off "track changes", accepted all the revisions in the document, and Zotero worked again!

    I hope this helps some of you with this problem.

  • When using this citation style:
    Modern Humanities Research Association (Note without Bibliography)
    , the problem happened.

    Of course, the switching of styles in Writer cause some problems.
  • When using this citation style:
    Modern Humanities Research Association (Note without Bibliography)
    , the problem happened.
    MHRA (Note without Bib) is in an older CSL format that isn't supported in 1.5, so it definitely won't work in the 1.5 Sync Preview, and the compatibility-mode processor in 1.0.7 hasn't been updated in a long time and is likely buggy.

    We'll try to get out an updated MHRA style soon. I don't think any of the other styles are in the older format.
  • I found solution to this problem for XP users...

    Go to Control Panel-->Network and Internet Options-->Internet Options-->Click on Advance--> Click on Restore Advance settings.

    Start your word document and then Zotero should work fine.

    This had nothing to do with version of firefox or plugin long as they are compatible, zotero should work fine.

    So, basically its microsoft internet explorer settings which is creating all this problem..... :-) (restore all the advance settings).

    Hope this works for others as well....cheers....

  • I'm struggling with the same problem. I've been using the plugin happily for quite a while (Zotero 1.0.7, OOo 2.4, Firefox 3.0.3 on Ubuntu 8.4) until, out of the blue, it stopped working earlier today. When I try to insert a citation now, even in a fresh document, OOo Writer seizes up and suggests the usual: "An error occurred communicating with Zotero. Please ensure Firefox is open and try again". Firefox in Zotero debug mode doesn't say "Not initializing integration HTTP server", so should be fine. The browser isn't offline either. Zotero.oxt and its sub-items are all enabled under Tools > Package Manager > My Packages. There is no firewall.
  • anark: Do you see any debug output in Zotero when you attempt to insert a citation?
  • When I configure Firefox for Zotero debugging and launch the browser from the command line, I get some 144 lines similar to the following three:

    zotero(3): Translate: executed detectCode for Embedded RDF
    zotero(3): Translate: executed detectCode for COinS
    zotero(3): Translate: running handler 0 for translators

    No further lines are added when I open OOo Writer and try to insert a citation into a document.

    I found and dispatched an error report under _Actions_. ID: 560167826.
  • As mentioned, OOo Writer freezes when I try to insert a citation and it takes a long time for the "Please ensure Firefox is open and try again" message to pop up. In two test runs measuring the time lapse, one with Firefox running and one with Firefox not running, I found in either case that the time lapse amounted to three minutes and ten seconds. The System Monitor reported CPU usage to be zero or negligible during both test runs.
  • edited October 5, 2008
    I have since downgraded the OOo plugin to the previous version, to no avail.

    I have also noticed that the problem isn't limited to inserting citations: OOo freezes up whenever I click on _any_ of the Zotero buttons.

    Firefox in Zotero Debug mode stops writing to standard output once it has finished starting up -- also, however many times I manage to crash OOo, none of the crashes produces a new error report in Zotero --"Report Errors" remains greyed out.

    Could you be a bit more detailed about your statement: "If the PYTHONPATH environment variable is set by another application, you may need to remove it"? Would the following output indicate that the path has been modified by another application?
    anark@cressid:~$ ooffice
    javaldx failed!
    anark@cressid:~$ pythonloader.Loader ctor
    pythonloader: interpreting url$UNO_USER_PACKAGES_CACHE/uno_packages/xEepRw_/Zotero.oxt/Scripts/
    pythonloader: after expansion file:///home/anark/.openoffice.org2/user/uno_packages/cache/uno_packages/xEepRw_/Zotero.oxt/Scripts/
    checking for existence of /home/anark/.openoffice.org2/user/uno_packages/cache/uno_packages/xEepRw_/Zotero.oxt/Scripts/
  • I am having the same problem and have lost a LOT of time over it!

    Word 2007, Firefox 3.03. O/S Vista

    Everything was working fine but I had to reinstall Word and reinstall for various reasons. When I reinstalled, Zotero appear as an Addin but when I tried to use it Word became unresponsive, eventually reporting communication problems with Zotero in Firefox. I uninstalled Zotero in Firefox and reinstalled it, downloaded and reinstalled the plugin. Same Problem.

    I copied Zotero plugin to the Word plugin folder, same problem.

    I examined Zotero in the Word Plugin application window. It doesn't behave the same as other plugins like Snagit.

    When a plugin is checked, ie Snagit, the dialogue window activates a "remove" button, there is no remove button active when Zotero is checked which means there is no way other than deleting the Zotero plugin file to remove and reinstall the Zotero plugin.

    Also, when doing the plugin install, the unpacking reports 100% then completed and the next button is active but the thermometer is not completely at the end which usually means the installation is not complete.

    As it stands right now, Zotero plugin in Word doesn't work and I NEED a fix for it. My estimate so far is that I have spent 4 hours on this bug.

  • Apparently there is a new and improved plugin to be released real soon now. If you can afford to wait or find some stopgap measure that allows you to keep going for a short while without the plugin, I'd say sit tight until the rewrite arrives. The alternative is likely to be a good deal of grief.
  • Thanks for the update. I moved all my work to another computer where the Word plugin is working correctly.

    This problem just happened at the wrong time...
  • I am finding the "an error occurred while communicating with Zotero. Please ensure Zotero is switched on and try again" message. It occured when i tried to change the citation style, but now occurs all the time.
    i tried pasting the doc into a new file one citation at a time, and managed 22 citations before it stopped working. Removing last citation did not help.
    I tried restoring advanced settings, but that made a difference for about one minute.
    I have tried reinstalling everything. I'm in Open Office.

    I'm not the most computer literate person in the world.
    What is the currently agreed solution to this problem? Wait?
  • I have just downloaded the new version of open office, and reinstalled Zotero and all plug ins. No good at all.
    This is very frustrating. With my mphil due in a week, I haven't got whole days to waste banging my head against a brick wall.
  • I forgot to add. I did come across one difference. Now, instead of telling me it is not communcating, it jumps straight to my macros and I get this.

    While (True)
    i = i + 1
    sPropertyName = sProperty & "_" & i

    #If MSWD Then
    fnGetProperty = fnGetProperty & ActiveDocument.CustomDocumentProperties(sPropertyName).Value
    sPropertyValue = thisComponent.DocumentInfo.getPropertyValue(sPropertyName)
    If sPropertyValue = "" Then GoTo EndOfFunction
    fnGetProperty = fnGetProperty & sPropertyValue
    #End If

    The line:

    sPropertyValue = thisComponent.DocumentInfo.getPropertyValue(sPropertyName)value

    is highlighted for me.

    Does this help?
  • edited October 17, 2008
    If you're using OpenOffice 3, you need to use version 1.0b4 (for Windows/Linux only) of the plugin, which was released yesterday and which is available on the download page.

    Note that this is still the old (primarily) VBA plugin with a compatibility fix for OO3, not the rewritten all-Python version.
  • New problem:

    I want edit a citation, but have a message:

    Run-time error '5891':
    That property is not available on that object.

    What can I do?
  • I reset the localstore.rdf file in the Firefox profile folder. After a restart the OOo plugin worked again (FF 3.0.3, OOo 2.4, Ubuntu 8.4).
  • Help! Trying to insert citation in text. I'm using Fire fox 3.0.3 and Zotero 1.0.7. and Word 2003. Not sure if these are compatible. Have read some of the history behind this problem, but am a little overwhelmed and confused as to what the ultimate solution is. Have tried restoring advanced settings via the control panel, as was suggested, but it didn't work. I'm aware that some people have previously been able to accomplish in text citations and then lost the ability, but I have not been able to since recently downloading the software, even while connected to the internet. Can someone please advise me, in simple terminology, about other potential solutions? Thanks
  • edited October 22, 2008
    Report ID 699259320

    I got "an error occurred while communicating with Zotero. Please ensure Zotero is switched on and try again" in Word with the 1.0b3 plugin and Zotero 1.5-sync2.2 ...

    Communication seems to be working but I get the error in the report in the firefox error console...
  • I had already downloaded that. Did it again anyway, still no joy.

    Uninstalled and reinstalled Zotero. Still no joy.

    How do I uninstall the plug-in from open office?

    Is there really no solution to this? If that really is the case I will just scrap it. I mean, its free, so I can't complain. Shame though.
  • Hi,

    I have a similar problem. When I try to add a new citation in MS Word, I get "Run-time error '5891': That property is not available on that object." I can edit existing citations, but I can't add new ones. I tried copying and pasting existing citations where I want to add a new one, and then editing the pasted ones, but that doesn't work - I get the same error message.

    I do have a TOC in my document, but I tried removing it and get the same problem.

    Also tried re-installing Zotero and also deleting Mozilla's localstore.rdf file in Mozilla's Profiles folder, but to no avail.

    What does work is if I copy the relevant paragraph (in which I'm trying to insert the citation) into a new blank Word doc, insert the citation using Zotero, and then paste it back into the original doc. But that's a pain...

    Any suggestions would be appreciated. Thanks.

    Windows: XP, SP2
    MS Word: 2002, SP3
    Firefox: 3.0.3
    Zotero: whatever version I just downloaded yesterday (10/21/2008)
  • edited October 22, 2008
    Ryan: This thread is about the communication error. See a thread on error 5891 or start a new one.

    Alan: If you're no longer getting a communication error, please start a new thread. Upgrade/removal instructions are on the OO plugin page.
  • Only for the statistic: I had the same problem described above, Zotero wasnt able to refresh or insert new citations. After I´d accepted all track changes in the Word document Zotero was as helpful as ever.

    Word 2004 for Mac 11.5.0
    Zotero 1.0.7
    Mac OS X 10.5.5

  • Two things. First of all, I am still getting a communication error, but sometimes I am also going to the macro screen, as pasted for you above. So I think I am still part of this dialogue, but wanted to give you all the relevant information possible.

    Secondly, I went to the page you suggested and could not find the removal instructions. Sorry.
    I would like to reiterate that my computer literacy is not terribly high...
  • Have now found how to remove Zotero! But if I do that, will I lose all the citations I currently have?

    The plan was to uninstall and reinstall it. But if I lost all my references it would be a disaster.
This discussion has been closed.