Help with ZotFile - Not moving PDFs to designated folder

2»
  • @bruderj Please read my post right above yours carefully. E.g., your point 2 is already answered. Zotfile does not automatically grab files from the Download folder.

    For troubleshooting the main issue, you could follow these steps:

    A) If you right-click on an item and use "Manage Attachments" -> "Rename Attachments", does the attachment end up in the correct folder?

    If so, check if you have these settings and adjust them if not:

    B) Zotero: "Edit" -> "Preferences" -> "General" :
    No check mark for "Automatically rename attachment using parent metadata".

    C) Zotfile: "Tools" -> "ZotFile Preferences..." -> "Renaming Rules" :
    No check mark for "Use Zotero to Rename".

    D) Zotfile: "Tools" -> "ZotFile Preferences..." -> "Advanced Settings" :
    Enable "Automatically rename new attachments", e.g. "Only ask if item has other atts".

    If you have confirmed A) to D), check what happens if you click the browser connector button directly from this site. (Don't open up the pdf file in the browser before importing.)
  • edited January 23, 2020
    Thanks for your reply, @qqbb! Really appreciate it.
    And apologies, I wasn't entirely clear: the issues 1-3 in my previous post were simply copied from Anna's post to let you know that I repeated her steps to see if one would work for me. Grabbing files from Zotero storage, however, wasn't my issue.

    I've checked A-D and tried to add the suggested ref via the browser button and without opening the pdf. Same result. Zotfile reports that is has changed the name of the file, the ref shows up in my group library and I can add a PDF after the fact, but Zotero keeps saving to the a Storage subfolder that holds this one file only.

  • @bruderj For groups, linked files do not work. You might need to use official Zotero storage. See e.g. here:
    https://forums.zotero.org/discussion/79437/pros-and-cons-of-attach-link-to-file-vs-attach-stored-copy-of-file
  • Oh, well, that explains it all. Too bad.
    Thanks again for your help, though.
  • I am so relieved that someone else (bruderj) is experiencing the same thing - I thought I was going crazy... But I'd prefer to have it solved obviously... :)

    I checked my settings again as according to *qqbb* and also unchecked the relative paths, but no change.

    If i rename the attachment after downloading it moves it to the right folder, but is that supposed to be necessary?
  • @Anna%20Rossander: The last suggestion I can give you is to try to exclude issues related to your library location or syncing. First, use a local (not synced) directory as your Zotfile custom file location, e.g., C:\Users\...\Downloads\. If this works, you could try to map your network drive to a drive letter. Your Zotfile custom location should then e.g. be Z:\...\Zotero Library\. Finally, you could check if switching off syncing makes a difference.

    BTW, settings B) and C) above are not essential. However, it's important that you don't import from a PDF view, but rather from the main journal page, as pointed out by adamsmith above.
  • Hi all. I've done some more testing.
    Part of my problem with the wrong files was that I clicked the Zotero-icon in Mozilla whilst reading the pdf, not the page before. I realise this is explained above, but I didn’t get it at first, partly because the first links to example pages didn’t work for testing (no access).
    So downloads now work – thank you! I am looking forward to the eventual fix by zmg48 et al to download after opening the actual PDF though.

    But there is still the issue that if I drag and drop a PDF into Zotero it ends up in a new subfolder in the old storagefolder. I can manually trigger a move with ZotFile by renaming the attachment, but it leaves the subfolder and two files in the storage-folder, so it keeps building up even though no PDFs are there. Is this the way it is supposed to be?

    Thanks a lot. / Anna
  • The files you are referring to should be related to Zotero's full-text cache. That's the way it's supposed to be. See the forum discussions here and here. If you don't want them at all, you would need to disable full-text indexing by setting "Maximum characters to index per file" to 0, see here:
    https://www.zotero.org/support/preferences/search
  • I am late to the party here, but I seem to be having this exact same issue now.

    I have used Zotero for years but was a late convert to Zotfile. I installed Zotfile and was able to use the magic "Manage Attachments/Rename Attachments" to correctly sort and rename hundreds of documents to a cloud storage folder just this morning.

    Now, seemingly out of nowhere, it's completely stopped working. New additions are automatically routed to my Zotero/storage folder - not the cloud folder I set up. I get the popup titled "ZotFile: Renamed Attachments" but it just stopped moving them to the cloud folder.

    Curiously I also noted that it will rename the file in Zotero storage, but doesn't update the filename that appears on the attachment in the Zotero item.

    I feel like I need to delete my cache or something because this WAS working and just...died.
  • I forgot to add technical info:

    Zotero 5.0.90
    ZotFile 5.0.16
    Mac OS Catalina
  • Sorry for the triple post but this was really bugging me. I ended up completely deleting Zotero (and all of the associated folders in Application Support and Preferences) and re-syncing with my remote library and now it's working again.

    I have no idea what's going on, but I'm tech-savvy and willing to help debug if anyone wants to use me as a guinea pig.
  • Curiously I also noted that it will rename the file in Zotero storage, but doesn't update the filename that appears on the attachment in the Zotero item.
    That's perfectly normal. The attachment title isn't the same as the filename.
    I ended up completely deleting Zotero (and all of the associated folders in Application Support and Preferences) and re-syncing with my remote library and now it's working again.
    We strongly discourage this sort of thing, particularly if you've already posted here — it's way overkill, it can cause other unexpected problems, and it prevents us from actually figuring out what the problem is. This was almost certainly just something about your ZotFile settings.

    While we don't official support ZotFile here, to debug this we'd need a Debug ID for when it was happening, along with a screenshot of the relevant settings (uploaded to Dropbox or similar with a link here).
  • Dear @qqbb,

    I followed the path from A to D, and you are right, B and C were different in my settings. I corrected them accordingly and it worked perfectly! Thank you!
  • Dear community,

    Zotero worked smoothely for a few months - until now.

    I have been using ZotFile to rename my attachements, however they are stored in the default Zotero storage. There I have folders with cryptic names which contain less cryptically named pdf (thanks to ZotFile). I have now changed the ZotFile settings to move new files to a certain folder ("literature"). This works fine if I use the Zotero-Connector to create a new item. However, if I go to an older collection where the linked files are in the storage folder, I get an error message when trying to let Zotfile rename and move theses files. They are recognized by the system, i.e. I can open the pdf by double clicking it, so the link is not broken, but ZotFile refuses to move the pdf.

    The error-message:

    Anhänge ausgelassen weil es sich um Eigenständige Objekte oder Schnappschüsse handelt oder weil die Datei nicht existiert.

    I don't quite get it, as these objects are neither standalones, snaps or defective...

    Any help on this issue is highly appreciated, thanks in advance!

    Thomas

  • I have folders with cryptic names which contain less cryptically named pdf (thanks to ZotFile
    (Just to clarify, Zotero itself uses perfectly readable title/author/year filenames by default.)
  • I don't quite get it, as these objects are neither standalones, snaps or defective...
    If you're not selecting a top-level PDF, the error might be related to issues with your cloud storage. There's a related discussion here.

    Also note that working with linked files can have downsides, see here.
  • edited March 3, 2021
    Hello

    I am unable to find the solution to my problem in the thread above - not sure if I've misunderstood, or whether my problem is different.

    To start with, this is a new problem, that affects a workflow that has worked until now (including after the most recent updates to zotfile)

    I am working between a desktop at work which runs Zotero standalone on a windows 10 system (v 5.0.96) + the firefox connector (I don't think this is relevant) + zotfile v 5.0.16

    and

    zotero 5.0.96.1 for macOS mojave + zotfile 5.0.16

    plus an ipad to read the file

    my shared folder for linked files is on dropbox (I've checked that the paths for base directory on both systems is correct)

    Here's what happens:

    1. I add an item to zotero using the browser connector
    2. I also acquire the PDF acquired separately, using right click-->attach new file
    3. I do right click-->manage attachments -->send to tablet

    Problem(s)
    - the PDF does not show up on the dropbox ipad folder I've designated

    - on trying to access the file through zotero, it says "file not found" and says that it was unable to find the file in a sub-folder of my zotero library called "~/zotero library/false" [there is no such sub-folder I have designated]

    - the get from tablet option doesn't work (obviously) but a repeat attempt to send to tablet does not work because it says there's no attachment

    (nb: if it helps:

    -at step 2, I am able to access the linked folder via Zotero
    - for open access PDF files that zotero finds directly from browser connections, this works variably - it works for the Ligo et al article that was used as an example above; but not for
    - my zotero library now contains multiple versions of the PDF that was attached in this way

    https://journals.lww.com/academicmedicine/Fulltext/2019/06000/Clinical_Reasoning_Assessment_Methods__A_Scoping.52.aspx

    which was the article where I first ran into this problem - there's an open access PDF that comes on linking; the main text PDF has to be attached manually)


    ---

    addendum: it seems to me that this may be a problem with renaming - I tried again by attaching a file directly, in addition to the one identified by the browser connector. Both files end up with the same name exactly. from the timestamps, the one that came from the browser connector can be sent to the tablet, but not the one that came from attach new file)
  • edited April 1, 2021
    edit: issue solved. The items were in use in another application. Once I closed it, zotfile started working again.
  • Thank you @qqbb for your post on January 23, 2020!! New user here, spent the entire morning in despair but you solved my problem!
Sign In or Register to comment.