ZotFile - Advanced PDF management for Zotero

  • @mc288 This is fixed in 5.0.3. Just published it. You can wait for the automatic update or do it manually with "Tool -> Add-ons -> Tools for all Add-ons (the small, drop-down wheel in the top right corner) -> Update" in Zotero.
  • edited July 20, 2017
    Zotfile with Zotero Standalone is working great for extracting annotations from highlighted pdfs.

    But for some pdfs, it became blank - a note with "Extracted Annotations (20/7/2017 7:01:10pm)" but nothing appears below it. The time needed to extract annotation is taking longer than other pdfs. I found it to be happening across book chapters I download from SAGE knowledge. Is it because of some special pdf format that they created their pdf with?

    Using Zotero 5 & Zotfile 5.0.2

    I would be thankful for any cues on the problem because a number of SAGE books are waiting for me XD
  • brilliant, @Joscha, thank you!
  • @adamsmith for example, take this article http://agritrop.cirad.fr/580245/

    First I click the save to the Zotero button in firefox, I see the article is added to my Zotero library without the PDF. Then from Google scholar I download the PDF and I open it in my PDF software. After that I close the file in the PDF reader, and then I go to Zotero, right click on the article and select attached new file. The file attaches and from the zotero llibrary it shows me that it has been renamed. Then I press enter and I open again the file in the PDF reader but it still has the old name, it also has the old name when I go into the folder in my zotero storage.
  • edited August 2, 2017
    Edit: Done.

    Thanks for providing a new version of zotfile. I tried to covince my colleagues to use Zotero, especially to get a good workflow with our iPads. But the "Send to Tablet" functions seems to be bugged. After using the function of getting the modified pdfs back,

    a) the files aren't named correctly: author_year_title_modified.pdf is written as author_year_title_modified$2. So the file can't be opened and has to be renamed by hand.

    b) after getting the file back from "tablet files (modified)" search the entry will stay in the search and occur a file-missing error.

    Both errors occur while using Windows 7/10 64bit, Zotero 5.07, Zotfile 5.03.
    I'm using Zotero and Zotfile 4.2.8 and it's working like a charme.

    Would be awesome, if you could handle this.

    Best regards.
  • Dear developers

    I have a problem since updating zotero to 5.0.7 and zotfile to 5.0.3.
    Previously, my Chrome connector allowed to get a paper with a click and in the case of, e.g., a phys. rev. lett., to open the pdf later, download it, and zotfile was associating it with the open zotero item --- including renaming.

    In the new version, a new button has appeared with the pdf symbol in the chrome toolbar. I click on it, the "Saving item" box appear, the pdf is saved as standalone in the same collection of the open item, but OUTSIDE. No renaming takes place.

    Moreover, when I move the paper inside the open item by hand, no automatic renaming occurs: I have to click "rename item from open metadata".

    Any hints?

    Thank you
  • Addendum:

    The log of Zotero shows for a certain pdf I would like to have included in the open item and renamed, the following lines. Maybe it helps?

    (3)(+0000009): Importing attachment from URL https://www.nature.com/articles/srep07902.pdf

    (5)(+0000007): CookieSandbox: Managing cookies for www.nature.com

    (5)(+0000000): CookieSandbox: Added cookies for request to www.nature.com

    (3)(+0000007): Getting contents of /Users/psd/Zotero/storage/tmp-2PfbD7/srep07902.pdf

    (4)(+0000009): Beginning DB transaction WCGDWQQp

    (4)(+0000006): Saving data for new item to database

    (4)(+0000001): INSERT INTO items (itemID, libraryID, key, clientDateModified, itemTypeID, dateModified, dateAdded) VALUES (?,?,?,?,?,?,?) [18074, 1, 'KYAKZZWZ', '2017-08-02 19:24:56', 14, '2017-08-02 19:24:56', '2017-08-02 19:24:56']

    (3)(+0000003): Notifier.trigger('add', 'item', [18074], {}) queued

    (4)(+0000001): SELECT valueID FROM itemDataValues WHERE value=? ['https://www.nature.com/articles/srep07902.pdf']

    (4)(+0000004): SELECT valueID FROM itemDataValues WHERE value=? ['2017-08-02 19:24:56']

    (4)(+0000005): SELECT valueID FROM itemDataValues WHERE value=? ['srep07902.pdf']

    (4)(+0000004): REPLACE INTO itemAttachments (itemID, parentItemID, linkMode, contentType, charsetID, path, syncState, storageModTime, storageHash) VALUES (?,NULL,?,?,NULL,NULL,?,NULL,NULL) [18074, 1, 'application/pdf', 0]
  • Zotfile is not compatible with Zotero 5.0.10. I hope it updated soon.
  • I have since learnt that you need to install the update manually from https://github.com/jlegewie/zotfile/releases. The automatic update for add-ins does not work.
  • The automatic update works—you only need to manually install one time when switching from Zotfile 4 to 5.
  • Hi,

    It seems that Zotfile does not index the pdf bookmarks as a ToC any more, when inserting the pdf as a link.
  • edited August 16, 2017
    I still have problems renaming the files. If I right click on a phd file, select manage attachments, rename attachments, I get this error "attachments skipped because they are top level items, snapshots, or file doesn't exists". If I select "rename file from metadata" then it does rename the snapshot file correctly, but it does not work on the pdf. For other files rename attachments just renames the file with the same filename.
    Here is an example image
  • I have a problem with the Tablet function. I am using Zotero Standalone 5.0.13 and Zotfile 5.0.4 and I have set the general storage preferences set to 'use subfolders defined by %A' and the Tablet folder preferences set to 'create subfolders from Zotero collections' - and deliberately NOT ticked the option for 'use additional subfolders defined by ...' because I wanted to have all the pdfs straight in the collection folder and not have any more subfolders - that used to worked perfectly well with the Zotero for Firefox and the corresponding zotfile version. However, now whenever I use 'send files to Tablet', zotfile also creates subfolders based on %A.

    Example: assuming the Zotero collection is called "Project Beta"
    - previously, I would get only "Tablet\Project Beta" with all the files in that one folder
    - now, I get "Tablet\Project Beta\Zotero storage\B etc. (folders based on whatever other last name the authors have)

    I have tried it with 'no subfolders' as well - that creates a string with 'Zotero storage\B (etc.)' directly in the Tablet folder. I have also tried ticking the 'use additional subfolders defined by ...' option and the leaving it empty. Same result as above...

    Is there anything in the preferences or the config settings I can change to get the previous system back??
  • As more and more text (including academic articles and books) are available in parallel in .epub format (which I personally always prefer for reading, in tablet), is it possible to make Zotfile to extract annotation also from highlighted .epub files?
  • Hi,

    I have to report what I think it might be a bug. When exporting articles from Zotero to a designed folder on my desktop, automatic subfolders (such as year/author) and/or "created subfolders from zotero" are not created anymore.
    Zotero 5.0.17
    Zotfile 5.0.4
    Windows 7

    Thank you!
  • Hello,
    Your zotfile tool is really great.

    I report here what seems a bug (as already reported in the github site, don't know where is best) :

    I've firefox 54.0.1 on W7, with zotero 5, zotfile 5.0.4. I have updated from V4 of zotero/zotero for firefox/zotfile versions and after reinstalled from scratch : the same issue arises :

    When I use "firefox connect" to get a new entry in "My library",Zotfile renames the attached PDF and moves it to my custom location: everything goes fine.
    But when I do that in a group library, the attached file gets renamed (it's ok) but stays in the zotero folder (currently C:\Users and setting\/Zotero/Storage/\ : it isn't moved to my custom folder.
    Seems like a bug.

    It is exactly the same issue when I drag/drop a file on an entry : whether it's in my library or in a group library, the file gets renamed & moved or stays in zotero storage.

    Could you, please, fix that ? Or is there any workaround to obtain a proper behaviour from ZotFile ?

    Thanks in advance and cheers for your great job.
  • Group libraries don't currently support linked file attachments (only stored attachments), so Zotfile can rename files, but not move them to a different location. What you are seeing is the expected behavior.
  • OK. No workaround ?
  • No. You can see that you are not able to manually add linked attachments to groups, either. Linked attachments don't currently work in groups because a system to set a different base file directory for each group doesn't currently exist, so linked files would generally break for different members of the same group.

    See a discussion here:
  • Thank you very much for this information. Hope a system may be found in the future because sharing files on a shared bay while working on a group library would be a really nice situation ;-)

  • Is anyone having my same problem (see 6 posts above)? I am starting to think there is something wrong with my zotero library...

  • edited September 7, 2017
    I don't know if I am the only one with this issue but it is recent. I use Zotfile to attach downloaded files to Zotero from my downloads folder. It is set to attach the most recent file in this folder.

    When I right click and "attach new file", the PDF seemingly attaches. However, the attachment icon (the dot in the clip column) then turns white, not blue. When I click on the attachment, the file cannot be located. If I try to locate, it is in the first folder, it is just not connecting for some reason.

    Any help would be greatly appreciated.
  • @mgiblin Hi,

    yes that happens to me as well, not often but let's say once every 4-5 articles. Plus, the squares that pop up on the right of the screen stay on the screen forever. I need to click on them to make them vanish.
    Are you using zotero on a usb by any chance? I am wondering if all these bugs are related to the usb, since it doesn't look like lot of people are having these issues.
  • @Breath

    I don't use Zotero on a USB, just a Windows desktop. I encounter the problem randomly, every few attachments, and sometimes several in a row. It only started in the past few months with the upgrades (as best as I can tell).

    I don't have squares pop on on the screen, though.
  • edited September 28, 2017
    Hello, I was wondering if someone could help me with this issue with Zotfile.

    I'm trying to use the tablet functionality using a shared folder on my iCloud Drive. The problem is that LiquidText (the PDF annotator I'm using) automatically renames files with a _LT suffix when you export. There's no way to change it. It means that Zotfile doesn't recognise the new file when it comes back and just reimports the old version of the PDF instead.

    Is there anything I can do?

  • I have used Zotero for Firefox for years (most recently and upgraded to Zotero 5.0.17 (standalone) with the Firefox extension a few days ago. When I had Zotero 4.0, I used Zotfile to link all my records to PDFs in Dropbox (this way I can easily access my PDFs from any computer). I set up Zotfile to automatically create a link when I added a new article to my Zotero library. Now that I have migrated to Zotero 5.0 and installed the latest Zotfile (5.0.4), these links have stopped working for everything that was added to my library after March 11, 2017 (several hundred records.) When I click on the link under the parent item, I get the message: "The attached file could not be found. It may have been moved or deleted outside of Zotero, or, if the file was added on another computer, it may not yet have been synced to or from zotero.org." The PDF files are still in the same place in my Dropbox. I do not want to manually fix the old links because that would take many hours.

    When I add new records, the new links work as expected. Any ideas? Should I just revert back to Zotero 4.0?
  • The first thing to check would be where zotero is actually looking. The easiest way to do this is probably with the zutilo add-on. (This doesn't seem like a zotfile issue to me, so I'd start a new thread. I'd also be very surprised if the links weren't also broken in zotero 4)
  • Thanks, @adamsmith. I found my problem. I had to go into Zotero Preferences - Advanced - Files and Folders and choose the base directory where I have all my PDFs in Dropbox. (I had forgotten that I did this when I initially set up my Zotero 4.0 and Zotfile configuration.)
  • edited September 13, 2017
    I'm having a problem which may be a bug in Zotfile. Suppose I access a source on Google Scholar: Doe, John. 2008. Conundrums: History and Prospects. It comes with a pdf, and so the Zotero connector adds the item to the Zotero database and attaches the pdf. Zotfile then moves the attachment to storage on a WebDAV-connected device.

    But I also have a hard copy of this item, which I've marked up and annotated. I scan it, and it becomes a pdf with hand-written annotations. So with Add Attachment > Attach Link to File ... I attach the marked pdf to the reference item. Then with Zotfile's Manage Attachments > Rename Attachments I now add the second version to the WebDAV-attached device.

    If one looks at the attached device, one sees two versions of the file:

    Doe, John. 2008. Conundrums: History and Prospects.pdf


    Doe, John. 2008. Conundrums: History and Prospects2.pdf

    But if one inspects the reference item in the Zotero database, it does indeed have two attachments, but they both point to the first version of the document. To make the second attachment point to the second, marked version, one has to go back and Add Attachments all over again, only this time link to the second version of the pdf on the WebDAV-attached device.

    It appears that Zotfile is correctly moving and renaming both versions, but it's not updating and renaming the links in the Zotero database correctly.

    This is with Zotero 5.0.18 and ZotFile 5.0.4 running on an iMac with Yosemite.
  • edited September 14, 2017
    I recently upgraded Zotero to ver. 5.0+ and Zotfile to the latest version as well. Since the upgrade, Zotfile no longer automatically scans the download folder and asks to attach the file to the selected record in Zotero. I observe this behavior in four different installations on Mac, Windows and Linux platforms. Looking at the error output in Zotero does not indicate any error being logged. I've checked the Zotfile preferences, and the download folder is set.

    I'd love to see this functionality again.
This discussion has been closed.