ZotFile - Advanced PDF management for Zotero

14849505254
  • edited July 11, 2017
    Yes, that's correct. ZotFile beta currently has to be built from source as described here:
    https://github.com/jlegewie/zotfile/tree/5.0
    It definitely works like that, but people have been struggling with the instructions. If @Joscha were willing to put a build xpi on his site or the github, that'd be a big help

    edit: corrected link.
  • Zotfile 5.0.03beta can be downloaded here.
  • adamsmith was faster. Instructions are on Zotfile's github site and in this thread: https://forums.zotero.org/discussion/65578/solved-zotfile-for-beta-not-working#latest
  • I will put an easy to use xpi online shortly...

    @adamsmith Do you know more about the best way to handle the update? What happens when Mozilla approves the new version? The best solution would be that people on Zotero 5 get an automatic update and people who stay on zotero 4 do not get updated (because Zotfile 5 is not compatible with Zotero 4). Here is my install.rdf
  • I don't, really -- but I imagine you may want to move the add-on out of mozilla anyway, since they probably won't approve "Legacy" add-ons anymore going forward, so why not just release 5.0 with an updateURL under your control
    (see e.g. https://github.com/Juris-M/zotero-odf-scan-plugin/blob/0760cce85b936c6726a1cae05f6e5d9c714db910/install.rdf#L13 for an example) and require that people re-install it.

    Not ideal, but I'm pretty sure you'll have to do this in the medium run anyway, so why not now?
  • Zotfile 5.0.1 for Zotero 5 is now online and the webpage was updated with new instructions. Just go to the zotfile webpage www.zotfile.com to get it.

    Note that I was not able to resolve all issues with zotfile 5.0 but I think it's mostly running smoothly. You can post bug reports here but please follow the instructions for reporting bugs: http://zotfile.com/#reporting-a-bug
  • Important: If you installed in the last 30 min, please reinstall. Just follow the steps again.
  • Hi, @Joscha Thank you very much for the great work to update Zotfile for Zotero 5

    One question... I have installed Zotfile 5.00b2 for Zotero 5-beta. It seems there is no option to update it, but reinstall. Is there any way to prevent the loss of configuration at this time?
  • I will attemp an automatic update down the line but not sure whether it's going to work. In any case, i don't think you loose your zotfile setting with a manual update but I can't guarantee it.
  • Thank you for the prompt answer, @Joscha

    For your information... I have just updated Zotfile (from 5.0.0b2 to 5.0.1) and everything ran very well. I did not lost any preference when installing the new version over the older one (without unstalling it).
  • @warguelles, can you get updated to 5.0.2? Just open Zotero, go to Tools->Add-ons, select the little settings wheel in the top right corner and click on "Check for Updates". Thanks!
  • Yes! It worked fine for me. (Windows 10)

    Thank you @Joscha !!
  • How do you install Zotfile 5.0.2? It's unsigned so FF blocks it...
  • Tried installing the signed version and updating it through the addon page, and also on the Zotero addon page but to no avail (Zotfile is not listed there).
  • @Tsau017:

    1. Go to https://github.com/jlegewie/zotfile/releases download the XPI file to your PC

    2. In Zotero 5, go to Tools->Add-ons, select the settings wheel in the top right corner and click on "Install Add-on from File..."

    3. Select the XPI file you downloaded in the step 1, and go ahead...
  • @warguelles Thank you! Just saw that those instructions were put on the zotfile page. I knew I was missing something obvious!

    @Joscha Thank you so much for continuing to develop Zotfile - In my view it's the most important addon in the zotero ecosystem.
  • Wanted to express my thanks for everyone, particularly to @Joscha and @adamsmith, for your help. I've got everything loaded and working. As for me, now back to work... :-)
  • @Joscha This does not work for me. I am at 5.0.0b3.
    "Just open Zotero, go to Tools->Add-ons, select the little settings wheel in the top right corner and click on "Check for Updates". "
  • gurdas -- pretty sure updates will only work from 5.0.1 forward (which Joscha asked to test above)
  • Ok, thanks. Just in case someone is wondering how to do a manual update:

    Zotero 5.0.x > Tools > Add-ons > Zotfile (Options) > General Settings, Zotfile website (at the bottom) > Download
  • Many thanks for the update!

    Just wondering, how to open zotfile links from Freeplane now, when there's only Standalone left in Zotero 5? I used to have my system configured so as to open external links via Zot. FF.
  • I can't figure out what seems to be a conflict. When I use the option 'attach new file' the file is correctly attached and in zotero I see the pdf correctly renamed, however when I look at the file in file explorer, the actual file name has not been changed. Is this a default behavior, can it be changed? Or is it an issue with my zotfile not working properly?
  • @xxtraloud -- I think you´re expecting the original file to change names. ZotFile wouldn´t do that. It renames the attached copy of the original file (and potentially moves it). You can use "Show File" to see the file Zotero is pointing to in Explorer.
  • @adamsmith No I am referring to the files stored in my zotero storage folder, I did use the show file menu and the file that has been moved from the download folder to my storage folder still has the old name, but the name displayed in zotero is the new name.
  • That's quite odd. Could you say what exactly you're clicking in what order and give us an example filename.
  • Just echoing others' appreciation for the excellent work on zotfile 5 - all went very smoothly for me.
  • Ironically, the only place I'm having problems is trying to make a donation -- clicking on the Donation button takes me to a PayPal page with a large $0.00, but I can't change that amount (which wouldn't help you much).
  • @Heckscher -- have you tried just typing numbers? I'm not seeing a cursor, but typing works for me (Firefox on Windows)
  • I certainly should have thought of that! The problem was that I *do* see a cursor (Chrome for Windows), and so I was trying to backspace over the numbers. That didn't work, but typing the number does. So that's taken care of ...
  • hi, zotfile has been working perfectly for me in previous versions (I've been using it in zotero for firefox), a real life-saver, thank you!

    But on updating to Zotero5 for mac and zotfile 5.0.2 something strange is happening to the custom subfolder preference: I use %c, as before, but zotfile now moves files to a folder named correctly, but within a new folder it calls 'undefined'.

    not sure if this is a Zotfile problem or a zotero problem or my doing something wrong...?
Sign In or Register to comment.