RTF/ODF Scan for Zotero

  • See erazlogo's post above
  • Hi

    I have these same problem as aarontimo. The "choose file" button in RTF/ODF scan does not respond. I am using latest Zotero standalone for MacOS Sierra.


  • Hi Adam,

    Thanks for taking the time to point this out for me even though it was clearly answered (at least twice) before. All working now.

    I will follow the threads more closely next time.


  • edited October 3, 2016

    Whenever I use cmd+shift+c in zotero, it does not copy/export the citation, I need to go to edit>copy bibliography. Any idea why it isn't working?

    Thank you!
  • Two options -- either some other program is overriding you shortcuts, or you don't have the right default set under Export --> Default output format.
  • Is scannable cite the correct one? If so, then it must be another program overriding the shortcuts.
  • yes, that's right. You could try with a different output (e.g. a bibliography style) see if that works.
  • It doesn't. Its weird, because if I go to edit>copy citation or copy bibliography there isn't any shortcut, as there is for copy (cmd+c) and so on.
  • no, Zotero doesn't list shortcuts in the menu, so that isn't surprising (the ones that are listed are inherited from Mozilla). The only other thing I can think of is to check in the advanced tab of the Zotero preferences under Shortcuts that this is still set to cmd+shift+c -- for anything beyond that, please start a new thread since it doesn't appear to be an issue particular to the add-on and you'd want a regular Zotero dev to look at it.
  • edited October 3, 2016
    Thanks, will do!

    Okay, so I actually changed the shortcuts to some random letters, such as cmd+shift+b, and it started to work. I suppose that menas it must be another application overriding the usual shortcut?
  • Hi everyone,

    I've been using RTF/ODF a lot. It's awesome! One problem I've just run into involves abutting citations. In my document I have this:

    { | Elliott, 1937 | 507 | |zu:871534:9SJ9HPSZ}{ | anon. Proposed Revision of Entrance Requirements, 1921 | 2 | |zu:871534:759JPZ5N}

    And when I run it through RTF/ODF and convert to Chicago citations, I get this:

    Elliott, Stanford University, the First Twenty-Five Years, 507.“Proposed Revision of Entrance Requirements,” February 14, 1921, 2, Wilbur Papers, Series 5, Box 45, Folder 5.

    My understanding was that abutting citations should be treated as a group, and so these two citations should be separated by a semi-colon and then a space. Instead there's a period and no space.

    This only seems to be happening with some of the citations. For instance, this group:

    { | Becker, 1964 | | |zu:871534:CU63XFDR}{ | Rostow, 1960 | | |zu:871534:PIZAHFXZ}{ | Gilman, 2003 | | |zu:871534:ZQFM86W2}{ | Bell, 1973 | | |zu:871534:49FGCPWE}{ | Brick, 2006 | | |zu:871534:PEGN2M36}

    Produces this output:

    Gary Stanley Becker, Human Capital: A Theoretical and Empirical Analysis, with Special Reference to Education (New York: National Bureau of Economic Research, 1964); W. W. Rostow, The Stages of Economic Growth, a Non-Communist Manifesto. (Cambridge [Eng.]: Cambridge University Press, 1960); Nils Gilman, Mandarins of the Future: Modernization Theory in Cold War America, New Studies in American Intellectual and Cultural History (Baltimore: Johns Hopkins University Press, 2003); Daniel Bell, The Coming of Post-Industrial Society: A Venture in Social Forecasting (New York: Basic Books, 1973); Howard Brick, Transcending Capitalism: Visions of a New Society in Modern American Thought (Ithaca: Cornell University Press, 2006).

    Maybe there's a difference between how RTF/ODF, or Zotero itself, handles different kinds of citations?

    Any help much appreciated. Thanks!
  • edited November 14, 2016
    Style not recognised after export from scrivener to odt **Amended with workflow**

    1. References are inserted in Scrivener as a citation marker. Eg.
    { -| Lockwood, & Le Gouais, 2011 | | |zu:3083314:EW8UGN3Z} in Scivener

    2. Document is compiled into .odt format

    3. I use RTF/ODF Scan to scan the .odt document; with settings of "ODF (to citations)" checked and create the new .odt document. NB. "default output format" is set to "scannable cite" under Zotero preferences

    3. When I open the document in open office references are showing as

    (greyed) Lockwood, & Le Gouais, 2011

    4. I go to "set document preferences" in librewriter and ensure the style I want is chosen, and "bookmarks is selected"

    Nothing happens. Additionally when I choose insert bibliography nothing comes up. If I add a citation in the odt document directly it is recognised by libre office and formatted correctly. I have tried alternative styles to check that is not the issue.

    I have recently reinstalled java on my computer and have a 32 and 64 bit version on this PC (I'm using windows 10).

    Any suggestions?

  • could you describe your exact workflow? This really should be working and the way in which it isn't is quite odd.
  • Is there a version of this plugin for the Zotero 5 beta? It currently won't install. The Scannable cite output style is already there in Zotero 5 but the RTF scan does not have the ODF option from the plugin.
  • I haven't done any testing or re-writing for Zotero 5 -- @fbennett , have you looked at this at all?
  • @adamsmith I've amended my comment to add the workflow in.
  • It's the bookmarks. You need to run this with Reference Marks at least the first time.
  • I just installed this, and it's working great for in-text citations! Is there any way to generate/compile the bibliography/references list based on what have been cited in the text?
  • After running the ODF scan, use the LibreOffice plugin to generate the bibliography.
  • My bad, it's really simple, isn't it! Thank you for pointing this out!
  • Hello, I used to have this solution which allowed me to use Scrivener really well with Zotero (+ Open Office for final formatting). However, my old MacBook Air died on Sunday and I got a new Pro just yesterday. I've been trying to reinstall the same workflow, but I cannot get the RTF/OTF to work. It doesn't give me 'scannable cite' as an option in the Export Output Format. I believe I am following the steps correctly, and I just cannot figure out what is going wrong. Please help! I really don't want to have to abandon Scrivener as a writing tool. Thanks so much!
  • There is currently a bug in the installer for the ODF scan plugin, and the Scannable Cite translator isn't getting installed properly. The developers of the plugin are working on fixing it. In the meantime, you can install the translator manually:
  • Ah @bwiernik thank you so much!! it's working!!!
  • edited November 23, 2016
    hi @bwiernik,
    I'm using OS Sierra 10.12.1 and I can't get the standalone to choose files.
    I've gone thru the steps to put the .js file in my Translator folder and restarted Zotero, but the standalone still won't allow me to choose a file to scan. I also tried to download the plugin, but Firefox keeps telling me that the plugin is incompatible with the version of FF I'm using (which is up-to-date). Any ideas?
    I'm in a bit of a time crunch because I need to scan the docs to deposit my dissertation, so any advice is welcome.
    Thanks :)
  • edited November 23, 2016
    There is currently a bug in the installer for the ODF scan plugin, and the Scannable Cite translator isn't getting installed properly. The developers of the plugin are working on fixing it.
    Has this problem really been diagnosed, and is there a ticket? (I just ran into the same issue)
  • edited November 28, 2016
    I think the plugin has some errors concerning translated books...

    For books translated in Korean, plugin treats translator as another author.

    2 authors and 1 translator but, maybe, plugin treats as 3 authors.
    e.g) Renwick, A. M., & Harman, A. M. (1999). 간추린 교회사. (오창윤, Trans.). 서울: 생명의 말씀사.
    -> { | Renwick, et al., 1999 | | |zu:473105:T8W49IMW}

    1 author and 1 translator, but plugin treats as 2 authors
    e.g.) Rabelais, F. (2006). 가르강튀아 팡타그뤼엘. (유석호, trans.). 서울: 문학과 지성사.
    -> { | Rabelais, & 유석호, 2006 | | |zu:473105:KSXX7JJQ}

    With English book, plugin works properly.
    e.g.) Prior, R. E., & Wohlberg, J. (2008). 501 Latin verbs: fully conjugated in all the tenses in a new easy-to-learn format alphabetically arranged (2nd ed). Hauppauge, N.Y.
    -> { | Prior, & Wohlberg, 2008 | | |zu:473105:A3MFNNAM}

    With Korean book, it works properly
    e.g.) 김진수. (1994). 가장 알기쉬운 기초 프랑스어 회화. 서울: 삼지사.
    -> { | 김진수, 1994 | | |zu:473105:7VRVTASH}

  • edited November 28, 2016
    as we've said many times throughout this thread, the way the citation looks right after the scan is irrelevant. You need to apply a citation style to get properly formatted citations.

    edit: or, for that matter, the exact content of the placeholder in the scannable cite. Also irrelevant.
  • @compunk That's a bug, but not a critical one. You can edit the text between the first and second | dividers if you find it distracting -- the text there is only for show, and it's completely replaced when the citation markers are converted.

    @Rintze Just saw this. I'll try to look at this tomorrow. Ping if you don't hear anything in a day or two, in case I forget.
Sign In or Register to comment.