New plugin: ZoteroQuickLook

  • "Add-on installation failed. The add-on "%S" could not be installed. it may be incompatible with this version of Zotero Standalone'

    while trying zoteroquicklook.xpi from

    i am using Standalone 3.0b2.1

    any suggestions?

  • There is a new version now. Just updated my Standalone to the latest version and tested that it works.
  • hmmm, I am running Standalone 3.0b2.1 windows XP and just tried your latest (33 minutes ago!) and get the same message on install....

    are we running same version of Standalone?
  • I am running 3.0b2.1 on Mac

    Here is a direct download link to the latest installer file
  • Hmmm - I tried installing with 3.0b2.1 on my Mac at home this morning and got the same problem.

    Installing from you link on my XP (at work) and I now get a little further...

    Instead of a modal dialog informing me

    "Add-on installation failed. The add-on "%S" could not be installed. it may be incompatible with this version of Zotero Standalone'"

    It only says "The add-on "ZoteroQuickLook" could not be installed. it may be incompatible with this version of Zotero Standalone"

    and then displays it among the list of Extensions in the Add-On manager, however with error message next to it (this is new).

    Getting closer?

    What else can I tell you?


  • Try this link

    If it does not work, the open it in notepad (It is not compressed, so you should be able to do that) and toward the end of the file there should be a part that looks like this

    <!-- Support for Zotero Standalone -->


    If the version numbers are the same as in what I posted above, it should work. If it does not, then I really have no idea why.
  • I still get same installation errors. Thanks so much for all the efforts. I'll try it from home on my mac.

    Anyone else have success/failure installing this besides you and me?

  • There is now a new version available for testing at

    There are no bugs that I would be aware of and would be able to reproduce on my computer. However, I have only tested it on Mac.
  • regarding the recent version for standalone: works fantastically on Mac, but on Windows 7, it gives me the following error: "The add-on "ZoteroQuickLook" could not be installed. It may be incompatible with this version of Zotero Standalone."
  • Thank you for the bug report. I will look into it.
  • mronkko - I'm still getting "This plugin is incompatible with this version of Zotero Standalone" for the xpi downloaded from
    and the current 3.0 version of Standalone under Ubuntu.
  • Problem fixed and pull request opened. Thanks, Simon, for finding this.
  • yep, that's it - thanks sean.
  • I just uploaded a new version to Mozilla extensions directory. Changes include:
    -compatibility with Zotero 3 and Standalone
    -QuickLook from citations in Word, Mac only. (see
  • @mronkko: for zotero 3, under Win7 and FF10, I can't install zotero quicklook plugin: FF says, in short, error!
  • What is the exact error message?
  • edited February 23, 2012
    @mronkko: "une erreur s'est produite lors de l'installation de zotero quicklook"
    with another way the error msg is: "ZQL n'a pu être installé car FF ne peut modifier le fichier nécessaire"
  • There is something wrong with ZoteroQuickLook that makes it uninstallable on Windows.

    It will be some time before I can take a look at this because I do not have a Windows computer and my virtual machine that was running Windows requires a reinstallation before it can be used (It does not boot for some reason). The problem is that I do not have an installation media, but need to have our computer support to do the installation and have not had time for that.
  • @ mronkko: thanks for the information! I'll wait. Let me say that previously (under FF 9.x), i used ZQL to run maComfort on windows7.
  • There is now a new version that at least for me works on Windows 7 and Zotero Standalone 3.0.3

    After I get some confirmation that this does solve the Windows problems, I will publish this to Mozilla Extensions directory.
  • edited March 7, 2012
    for me, it's running ok for pdf files! HTML files open but often with signalized script errors. As previously, doc & xls files don't open (it may be a maComfort limit?). I apologize not telling you if I use Zotero standalone or FFintegrated: I don't know how distinguish?!
    Anyway: lot of thanks for your ZQL creation & managing! ;)!
  • HTML file previewing is a problem with maComfort and there is nothing that I can do about it.

    Thanks for testing.
  • I was really excited about installing Zotero QL on my Win7 machine . . got maComfort installed, but then QL refused to install. I cam here, hoping there might be a fix, but see that there is not. It sounds as if it might be dead on Win7. That is too bad. If there is some chance you could get it to work, I am willing to contribute to the cause, if it will help.
  • you'll have to provide more details on how it fails to install - you'll note that mronkko says above he tested on Win7, so at least in general this works.
  • rfinney: I need more details from you. Where did you download ZoteroQuicklook? What kind of error message you get?

    When I last tested with Windows 7, I had no problems using the plugin.
  • I got Zotero QL from Firefox Addons:

    Error message: Zotero QuickLook cannot be installed because Firefox cannot modify the needed file.

    I am running Win7 Ultimate, 32-bit and Firefox 12.0
  • "cannot modify the needed file" is a mozilla issue with Windows filenames - it's unrelated to Zotero QL. See the last post here for a workaround:
  • I created a new profile with a very short path (and filename), and I still got the same error. I tried several other profiles, all with the same result. Also, I tried installing a bunch of other addons but had no problem . . so far it is only Zotero QL that throws off this error.
  • I am wondering if folks are able to get QL working fine with more recent versions of FF, say 12 or 13? I just can't seem to get this to work, always getting the same error (from earlier post), even on different machines.
  • Greetings,
    thanks for this very useful plugin.
    I'm having a problem with it though: while it works fine in Zotero/FF, it does not seem to work in Standalone.
    I'm on a Mac.
Sign In or Register to comment.