RTF/ODF Scan for Zotero

1235719
  • Hi Frank, Adam -- beautiful plug-in, and a real time-saver. Thanks for all your hard work on this. A quick question that I can't seem to figure out, either through my own tinkering or the Zotero forums or the LibreOffice forums.

    Upon compiling a document, running the ODT scan, and then switching to my preferred format (Chicago full-note) in RDT, I get a bizarrely formatted set of footnotes that I can't seem to get into anything standardized. The sizes are all off, and some of the text is set to footnote style and other to default style (same as the text.) A snapshot is here:

    http://imgur.com/5hBTWvv

    This being LibreOffice, I can't select all in the footnotes. I've played with the style settings constantly, and no matter what I do, some text is bigger than others and in different styles. I sense that this might have something to do with the way the text is being compiled from Scrivener, but if it's something I might be able to fix by using the plugin differently, I'd love to know. I've noticed a few other people online reporting similar issues; would be grateful for your help!
  • Hi,

    Thanks for this great tool.

    I have a problem when I use RTF/ODF Scan with a .odt file that I created with Scrivener. Once I press Continue in RTF/ODF Scan, I get this message: "There was an error processing this file".

    I am using the MZL version of Zotero (http://citationstylist.org/). May this be the cause of the error?

    Looking forward to your comments. Thanks!
  • @benjamin -
    1. When you first open the document in LibreOffice, i.e. before you select a citation style, is the font already weird/off?

    2. My guess would be that you could get around this by having Zotero insert the entire footnote - i.e. you insert the citation in the text, not in the footnote and Zotero will convert it to a footnote when you're choosing Chicago Manual as the style. This will be a bit messy in the text, but you can use the prefix/suffix field for each item to create even complex footnotes with comments like "See also" etc.

    @lucas - would you mind sending the document to my e-mail at the bottom of this post? http://www.zotero.org/blog/summer-zotero-workshops/ This almost certainly isn't MLZ related, the scan works exactly the same way with the two.
  • @benjamin: What happens if you select the text in a faulty footnote and then right-click for the context menu and select "Clear Direct formatting"? If that patches things up in the document, there might be scope to compose a macro that automates the repair. (That would be beyond our reach as maintainers of ODF/RTF Scan, but certainly doable by someone who knows their way around LO macros.)
  • @lucas: If you are able to share your document with adamsmith we'll certainly take a look. Conversion of an ODF document straight from Scrivener should not fail.
  • Frank - right now lucas's problem looks like a Scrivener bug - his .odt documents don't contain any text even without any scannable cite interaction. I referred him to Scrivener support.
    It does say "><!-- Generated by Aspose.Words for Java 11.10.0.0 -->", though, does Scrivener use Aspose?
  • Oh, that's interesting. So much for my thinking that Aspose and Scrivener were different conversion engines. I haven't yet had test results back on the cite-merge fix, but I'm pretty confident it can be pushed out.

    If there isn't text in the exported document, I guess there's not much we can do. :-)
  • Adam, Frank, thank you very much for these thoughtful replies.

    1. Adam, the citation style seems normal upon the initial compile from Scrivener (both before and after the ODT scan in Zotero); the footnotes are all the font and size specified in my export format. It's only upon changing to my required format (Chicago, full-note) that they get strange. Everything outside of a citation market remains fine. Everything that has been converted gets strange, however. There is some consistency in what happens: the first item (author, in most cases, but where there is no author, just a title) remains correct vis-a-vis size. The other items get enlarged by two font sizes, however. To the best of my knowledge, this strangeness is consistent throughout the text.

    2. I think for short documents, the in-text formatting might work, but this is a 100,000+ word dissertation, and the footnotes number in the several thousands. They tend to be long, with discussion of sources, etc., within them, so putting them in-text wouldn't work for something of this length, I think.

    3. Frank, the Clear Direct Formatting command strips the footnote of all its formatting -- size, italics, etc -- and simply gives me text which seems to be the same as the body text. Since it gets rid of the italics of the source title, this seems not to work as a workaround.

    I have since discovered a fairly cumbersome workaround by exporting the ODT to DOC, and working with the file in Word, but this requires reformatting of the footnotes, since the conversion process has many bugs in it. I'm happy to send relevant documents to one of you if this helps! Many thanks.
  • benjamin -
    we have just released a new version of the plugin. Make sure you have the most recent version - 1.0.12 (use check for updates under tools-->add-ons if not) and try scanning again. There is a chance that fixing a tangentially related bug will have fixed your formatting issue as well.
  • Hi Adam -- ran the new version again, and the same problem crops up. I'm a bit stumped!
  • that was a long shot, so I'm not that surprised it wasn't fixed, worth a try, though.

    I don't understand Scrivener footnotes. How do you insert a footnote that exports into an .odt file at all?
  • Hi Frank and Adam,

    Thank you for this plugin! It convinced me of trying out scrivener and I'm loving it.

    The plugin works well when I use OpenOffice, however I does not work for me when using MS Office. When I open the odt file I get and error that says: The file ... cannot be opened because there are problems with the contents. (In the details it says: the file is corrupt and cannot be opened).

    MS Office gives me the option to fix the file, but unfortunately it removes all the links to zotero.

    Any ideas?

    Thank you.
  • this won't work with MS Office. If you do need to get Zotero link in MS Office, you need to first open this in AOo/LO, convert citations to bookmarks in set document preferences, save the document as .doc or .docx, open it in Word and set the citations to fields (again in the document preferences).
  • Thank you Adam. The work around did it.
  • Hello,

    I am not entirely clear about how does this extension actually facilitates the use of Zotero with Google Docs.

    Does this extension change the way how I add a reference?

    What I currently do is ALT+Shift+C/A to copy and paste a reference into Google docs.

    Does this extension allow me to automatically update my references in Google Docs?
  • edited October 2, 2013
    This extension allows you to insert "reference marks" into Google documents that will refer to items in your Zotero library. Once you are ready to finalize your document, you would export it as an ODF file and pass it through this extension. The extension will recognize the "reference marks" and will replace them with live citation links, like the ones used directly inside Word or LibreOffice. You would then open the document in LibreOffice and select the citation style you want to use as well as insert the bibliography.

    The "reference marks" can be inserted into Google docs via quick copy (as you are doing right now), but you should have Scannable Cites selected as your output style in Zotero preferences under Export.

    Edit: essentially, this allows you to write in Google docs and insert "citations" as you go. If you choose to insert reference after you have written your document, then you could bypass this extension and simply convert the Google docs document into ODF or DOC and use Zotero word processor integration to insert citations with exactly the same result.
  • edited October 2, 2013
    > The "reference marks" can be inserted into Google docs via quick copy (as you
    > are doing right now), but you should have Scannable Cites selected as your
    > output style in Zotero preferences under Export.

    Thanks aurimas. So basically, there is no direct benefit when writing in Google Docs. I still have to "manually" update my reference in the Google Docs if my reference is changed.

    > Edit: essentially, this allows you to write in Google docs and insert
    > "citations" as you go.

    Isn't that already the case without the extension? I mean, I can already insert citations as I go via Zotero's Alt+Shift+C/A shortcut.
  • No, because if you simply insert static citations (I assume we're talking author-date) they will always remain static and you will not be able to (1) change styles, or (2) have Zotero disambiguate citations with same authors and publication year (there are probably other reasons that don't come to mind right now). And if you need to use a numbered style, then inserting static citations is not even an option.

    With the Scannable Cites, you will eventually convert them into dynamic, linked citations, which will have the benefit of being automatically updated.
  • to re-phrase what Aurimas is saying, ODF scan is basically giving you the same functionality you'd get when using the Word or LibreOffice plugin.
  • Thanks, now it is much clearer!

    But as I said before, the full benefit is only gained once the Google Docs is exported to ODF. As long as I just work in Google Docs, I will not have any benefit from using this extension.
  • edited October 2, 2013
    that's correct.
    edit: actually you get less than nothing when you're using this in GD without then taking advantage of the actual scanning feature: While you're writing you don't see citations but the scannable cite markers with curly brackets and pipes.
  • Pinpoint Markers. Do the pinpoint markers still work in RTF/ODF Scan? I must be terribly confused or behind or something. I thought that I could drag a note containing certain markers and see these parsed out in the target application. I was getting complete gibberish [pyramids, triangles, crazy symbols] when dragging notes, until I discovered that "Default Output Format" must be set as "Scannable Cite." Now dragging sources works fine, but dragging a note does not parse out the page or suffix pinpoints. And it's treating the note as a source rather than "knowing" that the note is a child of the source. mbruffey
  • Quotations in Prefix Field. I want to put the following in the prefix field:

    "It was in a debate with a Universalist . . . that Finney first stated his understanding of the atonement," for instance.

    but when I do, I get a corruption error message. If I remove the quotation marks, the error goes away. As you can see, only part of the prefix is an actual quotation, so it won't do to treat the entire field as a quotation.

    mbruffey
  • the note thing has only ever worked with MLZ - fbennett has to chime in on this.

    On the second issue, could you give us more detail on what you're actually doing? Where is that prefix? What is the exact message you're getting and when?
  • @adamsmith, here's the "defective" form:

    { "It was in a debate with a Universalist . . . that Finney first stated his understanding of the atonement," for instance. | Charles E. Hambrick-Stowe, Charles G. Finney and the Spirit of American Evangelicalism, Library of Religious Biography (Grand Rapids, Mich.: William B. Eerdmans Publishing Company, 1996) | 33 | | zotero://select/items/0_8E5BTHHI}

    It's in an odt doc opened in LibreOffice following RTF/ODF conversion. The error pops up after selecting "set document preferences." Most other citations in the same doc refresh just fine. I've isolated this one as the first of several with problems. I noticed that removing the quotation marks in the prefix field (in the source application--Scrivener) causes the error to go away.
  • thanks, I'll have a look.
  • It looks like straight quotes in the affixes break things, because they are used internally for quoting the data. We can address this by converting quotes in the string to open- and close-quotes, which we ultimately want anyway. Bear with: we'll need to cast a fix and test the revision before releasing.

    Meanwhile, you can avoid this bug by using open- and close-quotes (“quotes”) instead of straight quotes ("quotes").
  • Thanks on the quotes.
  • A simpler interim workaround would be to use single quotes ('quotes') instead, which results in proper double-quotes in the output (the processor does the conversion, so the quotes will be single- or double- as appropriate to the style).
  • Quotes. Well we're only talking about the prefix field here. Sometimes you need to be able to use single quotes within doubles, so I don't know if it's a good idea to automate anything with respect to single quotes in prefix/suffix fields. Don't they need to remain pretty much free form?
Sign In or Register to comment.