RTF/ODF Scan for Zotero

1246718
  • I've only just become aware of this great initiative, so forgive me for not commenting on this thread sooner. I think it may be quite important that one of the key reasons behind the original idea for this idea is not forgotten, namely: outlining. Otherwise, well done everybody, I think it is excellent and I am extremely grateful for all your work so far!

    All of the focus in the discussion has been on how useful this plugin is for writing and the revisions in the format have been aimed at this end (eg making the citations look tidy and easy to read). This is a very important aspect, and probably the function that most people will use. The plugin makes it possible to use Zotero with any text editor.

    However, it neglects the function of outlining, which is equally, important in academic writing. This may be because everybody writes, but probably fewer people outline. Outlining is avoidable for short documents and articles, but unavoidable for longer texts such as theses. The second function of the original initiative was to simultaneously make it possible to use Zotero with any outlining software, or any form of outlining in addition to just wordprocessing.

    During outlining there is of course no carefully written text to accompany a reference, just a short note to provide a reminder of the point/idea. It is therefore frequently necessary to refer back to the original source, both during outlining and also during the writing of text from an outline. The crucial function of the URL functionality was to enable a person outlining to click back to the original source. Without the URL functionality, it is a waste of time to search through the Zotero database and find the source from the author and year.

    I note that the option to use the URL type format (eg zotero://select/items/0_J9KE6PTZ) has been retained for the time being, which is great.
    However, to enable the outlining use, the URL functionality has also to work. Frank's MLZ Zotero did this very nicely and reliably. I have been using it for some time. You could just click on the 'zotero://select/items/0_J9KE6PTZ' and it would open the exact item in the Zotero library quickly. I know that this functionality is not yet incorporated in Zotero plain, but could I please ask for it not to be forgotten? I am worried that in the rush to celebrate the fantastic improvement of Zotero for word processing, the equally necessary functionality for outlining is falling by the wayside.
  • Frank's MLZ Zotero did this very nicely and reliably. I have been using it for some time. You could just click on the 'zotero://select/items/0_J9KE6PTZ' and it would open the exact item in the Zotero library quickly.
    Unless I'm misunderstanding you, that part absolutely works in vanilla Zotero, too. The thing that Frank had added in MLZ (and has since replaced with this plugin) was the ability to easily create the select links via drag&drop.
  • @adamsmith: aha, thank you for pointing this out. I had assumed that that had not been implemented as it would have required changes to vanilla Zotero. I've now used the URL functionality and can confirm that it does work very effectively. Well done and thank you very much everyone!
  • Hi folks, I am using the rtfscan feature of Zotero to write in Scrivener. After I export to odt, I am getting the following error when I click on the "Set Document Preferences" to MLA in LibreOffice.

    "The highlighted citation no longer exists in your Zotero database. Do you want to select a substitute item? Clicking "No" will delete the field codes for citations containing this item, preserving the citation text but deleting it from your bibliography."

    BTW, the default setting appears to be ALA format. Is there a way to change this?

    I am on
    OS 10.6.8
    Zotero Standalone 4.0.9
    LibreOffice 4.0.4.2

    Any ideas on how to resolve this.
  • It'd be helpful to see if this applies to one or all of your citations - i.e. select substitutes for some citations and see if Zotero keeps asking for more or if it's just one or two.

    If this seems to affect all citations in question, what is a sample citation as you see it in Scrivener?


    by default they don't really appear in any citation style - it's basically just a generic author date and it doesn't come with any bibliography setting.
  • Thanks for your suggestions, Adam. It gives the same error message even if I change the citation. Here is how the citation appears in Scrivener:

    { | -Levinson, (2007) | 559 | |zu:692935:UNWXXJHE}

    What is strange is that I see all the generic author date cites after I do an RTFscan from Zotero. So I know that it is finding the references!
  • edited August 2, 2013
    no, the plugin generates those from the code in the marker, so that doesn't mean it finds the reference.

    Are you sure the group you're using is fully synced on the computer where you try to set the citation style?
    If you're using Zotero for Firefox, paste
    zotero://report/items/692935_UNWXXJHE/html/report.html
    into the URL bar and see what happens.
    If you're using Zotero Standalone, find the Levinson citation in your group and re-create the scannable cite (as you'd insert in Scrivener). What is it?
  • I'm not sure what you mean by groups in the question: "Are you sure the group you're using is fully synced on the computer where you try to set the citation style?"

    But if you mean is my instance of Zotero synced with the server, then the answer is yes.

    I'm using standalone. The scannable cite is:
    { | Levinson, (2007) | | |zu:692935:UNWXXJHE}

    Thanks again, Adam!
  • Odd, that should work.
    And the Levinson citation gets highlighted when the error message comes up?
    If so, hover over the grey-shaded citation in LibreOffice - you'll see a black box with some code-y stuff. It will include a uri and uris for that item. What are they?
  • Yes, the Levinson citation is highlighted, but it looks like all of them are. Codey-stuff when I hover is:

    Reference:ZOTERO_ITEM{"properties": {"formattedCitation":"Levinson,(2007)"},"citationItems":[{"suppress-author":true,"prefix":"","locator":"559","suffix":"","key":""}]} RNDWgrc3RV9sd RNDdCxX8pCd8Q
  • could you confirm you're running version 1.0.10 of the ODF scan add-on (under tools->add-ons in Zotero)?
    If so - if you don't mind sending the whole document prior to the scan (i.e. with the { |||} markers in it) to my e-mail, which you can find at the bottom of this post,
    http://www.zotero.org/blog/summer-zotero-workshops/
    that'd be ideal.
    If you'd rather not send the whole doc, try to create a minimal test document that doesn't work in the same way and send that.
  • Aha! I am running 1.0.08 of the the ODF scan add on. I have poked around for an update but can't find it. Do you have the link?
  • edited August 4, 2013
    OK, got the file from David, that wasn't the issue.
    So I'm a little confused about what exactly you're seeing. Let me briefly describe what the scan is doing:
    It takes the code from the file and converts it into Reference Mark in LibreOffice that Zotero can read. The key component of that reference mark is a uri. To create that URI, Zotero uses the item ID and your library ID from the code (it checks whether that library ID exists locally, that's why I can't do this for you). It should look like this:
    http://zotero.org/users/692935/items/UNWXXJHE
    When you paste that URL in any browser, it will take you to that item in your Zotero online library.

    When you click "Set Document Preferences" in the LO plugin, Zotero then looks up that item in your local database and creates the citation from the data there.

    In your post above, the uri was completely absent, so this couldn't possibly have worked. But now you say you do see a URI?
  • I think I have figured it out. My original scannable cite had a "-" in front of the last name because the name was attributed in the text itself and so should show up in an MLA cite. If I take out the "-" it works fine, except for one of my cites in a footnote. And I can live with that! :)
  • I am experiencing a few problems with citations not merging. I am using version 1.0.11 with Zotero standalone and Scrivener. For example: { | Gigerenzer and Engel, 2006 | | 1| zotero://select/items/0_9RWIABUS}{See also | Leiter and Weisberg, 2009 | | 61| zotero://select/items/0_62VJ9AZS} becomes two separate citations next to each other without a space. When I export / compile from Scrivener, there does not seem to be a space inserted between the two. I note that I have not put the text in the correct areas of the citation, but I don't think that should affect behaviour.

    Incidentally, is there an easy way in Zotero standalone to see what version of the ODF scan one is using?
  • edited August 25, 2013
    Incidentally, is there an easy way in Zotero standalone to see what version of the ODF scan one is using?
    Tools-->Add-ons should show that, no?

    Probably doesn't matter, but which citation style for the non-merging issue?
  • @adamsmith

    I'm using the MLZ OSCOLA style, perhaps this is something to do with it.

    I'll check the add ons when I can use my laptop.
  • which Zotero version? MLZ or regular Zotero?
  • Regular Zotero
  • (as an aside, would it be a good thing to have a dedicated MLZ forum category?)
  • try with a different citation styles. MLZ styles aren't compatible with regular Zotero, using them can lead to all types of weirdness.
  • Sorry for being slow on the uptake here. I've taken a look, and the failure was in the document conversion, before application of the style.

    The ODF document was produced with with the Aspose tool kit, which apparently sets additional span wrappers around some runs of text. I've adjusted the code to handle them, and after confirmation from Paul that it's working correctly we can make a fresh release.
  • @rintze: For this particular tool, there shouldn't be any difference in behaviour between MLZ and official Zotero, since both use the same word-processor plugin format in the document.

    (Style issues and client bug reports are indeed separate though. We're asking MLZ users to include "[mlz]" in the subject line; if that proves too cumbersome, I'm happy to follow Dan's lead on whether to open a separate category for reports.)
  • Hello Frank and Adam,

    Thanks so much for your work. I have a reasonably large scrivener file that contains what I have done of my dissertation. I added footnote references in rtf style.

    Should I go and re-enter all of the footnotes in scannable cite style or is there a way of converting them within scrivener?

    I think your plug-in is a massive game changer by the way.
  • I don't believe there's a way to convert RTF-scan cites to scannable cites, unfortunately, no, so you'll have to manually re-enter (i.e. drag) them.
  • oh well. Such is life. Thanks anyway, I'll be spreading the word of this great scrivener/zotero tie up.
  • All footnotes re-entered - it works a charm, (I find scrivener's placement of footnotes a bit tricky to get used to though).

    However, in libreoffice - all my footnote numbers start again each page, despite 'footnote numbering restarts each page' button not being checked. Is this a style sheet issue or a scrivener/zotero/libreoffice communication issue?
  • Only thing I can say is that it has nothing to do with Zotero/ODF scan, which doesn't touch footnotes. You can place citation in the text and Zotero/ODF-scan will convert them to footnotes, but the numbering of the footnotes is handled entirely by the word-processor.
    You're almost certain to see the same numbering issues when you don't run the document through the scan. See if LO and/or Scrivener support can help further. If you report this to them, you'll want to reproduce it without Zotero/ODF-scan - that'll just cause confusion.
  • Thanks again Adam. It was a setting in LO. I should have checked.
Sign In or Register to comment.