Upload accepted - waiting for sync server

  • I just tried it again now, and it went through within a couple of minutes. You're becoming too popular! Thanks.
  • To test this feature, I am trying to sync just 54 items, and it's taking a VERY long time (more than 10 minutes so far, and the green arrow is still spinning with the "waiting for sync server" message).
  • Karthick - I had issues at about the same time of day yesterday. If you can't get it to go through, I would try again in 10 hours from now - at that time of day, I had no problems.
  • I'm having the same problem with both small and large updates.

    How long is reasonable to wait for a restore to server (about 300mb)? I wanted to change my username, so set up a new account. I waited for about 4 hours for the restore to server, but nothing happened.
  • My last successful sync was on January 10. Since then, my upload (about 50-100 MB) seems to be queued, according to the debug log, even though the browser has mostly remained open since then.
  • Hi all,

    An update--the sync wasn't as bad as I thought. I thought I was only syncing to my group folder, but it was also doing a first-time sync on the library (I guess it's automatic if you want to group sync)? My individual library was ~1200 records, and it took about 3 hours. Subsequent syncs have taken a few minutes.
  • Current message from spinning arrow: "Upload accepted - waiting for sync server." Has been like that for more than 30 minutes.
    (Am syncing a second machine, after having finished with the first one recently.)
    Syncing has been interrupted by two error messages, and hanging. "Databases of this size can not yet be synced." (No. 291356608.) And the same complaint about a tag being too long as appeared on the other machine a couple of days ago -- although this time clicking on the arrow did not give the opportunity (as before) to split or delete the tag; instead, Firefox hanged. (67146802.)

    Now the arrow has stopped spinning, and gives the message "Last sync - not yet synced." The error message reads: "Databases of this size cannot yet be synced. Please check back soon. (Report ID: e7f95b98)". There then a different error number in red, which vanished.

    I see that the old tag problem was included in the list of reports. I'd delete the tag if I could -- but there is no opportunity for that this time.
  • Following up on the previous comment:
    1. The database does seem to get updated anyway.
    2. But now all the folders have been duplicated: there are now two copies of each folder. (How can I consolidate them?)
    3. At a fresh start-up I get the same error message about the database being too large.
  • MH - there's a string on databases being too large for syncing. Is this what you think the issue is? http://forums.zotero.org/discussion/8413/syncing-large-collections/#Item_0
  • MG6
    edited February 18, 2010
    Correction: this continues under 2.0, having been a problem under the last rc. It seems to happen only on my XP netbook and never on my Macbook, even though I do all my big changes and uploads on the faster machine. I sync manually on the netbook, but it doesn't appear to matter how often or recently I have synched. The arrow continues to spin even after the "Last sync: xx minutes ago" message shows up, when I would expect it to stop?
  • edited February 19, 2010
    I too seem to be having this issue, even after upgrading to 2.0. My library <200 items, so >30 minutes to do a sync is surprising. Enabling logging shows that "Associated libraries are locked waiting Xms before next check". X started at 30000, then went to 60000 and is now at 120000. Specifically, I'm seeing this:

    [output removed — D.S.]

    (3)(+0000000): Associated libraries are locked — waiting 120000ms before next check

    [output removed — D.S.]

    Any ideas? I tried resetting the whole sync process, but it doesn't seem to have helped.

  • Hiya!
    I'm getting the same kind of problem. The green arrow keep spinning with the message "Sync from Zotero server: getting updated data from sync server". I have a fairly large library of about 430 items. While I do understand that it is normal that the first time I sync it should be longer, I find it strange that every other time I try to sync (after adding a few items) it's still very long. I might be doing something wrong, just can't figure out what it is.

    Since my library took more than the 100megs allowed by default by Zotero Server, I also use another WebDav application. I was wondering if it was possible to sync only with that application and not the Zotero server? Since I don't really need it, I guess there is no point in clogging the server.

  • I tried resetting the whole sync process, but it doesn't seem to have helped.
    No, it made it worse. This issue is simply due to a busy data server due to a lot of people upgrading to 2.0 and syncing. We're working to speed things up, but just be patient, and don't use the Reset options.
  • Even at it's slowest, any idea how long a sync should take for a smallish library? I'm simply wondering if I should undo my power saving settings and leave my computer on all night.
  • Hello,

    First of all, thank you very much for Zotero.
    I have the same problem "waiting for sync server" for at least 30 minutes, not finished yet. My library has 2296 items, but only 23 changed since las sync.

    Windows XP. Service pack 3.
    Firefox 3.5.8 with Noia theme.
    Pentium 4 2.4 GHz. 512 RAM
    Connecting to internet in workplace(I mean it should be a firewall, router or somethig similar).

  • I'm not sure if it is related to the problem, but for some time I had two firefox add-ons (Java Console 6.0.01 and Java Console 6.0.02) which were updated, and when firefox restarted, an error message popped-out and canceled the upgrade. Every once in a while, I would be ask to upgrade those add-ons, and the upgrade was always canceled on restart. I tried to delete both of them and now my sync is working perfectly and it was not working correctly 30 minutes before I deleted them. I don't know if those 2 add-ons had anything to do with Zotero in the first place.

    I'm not very good with informatic so I hope that this makes some kind of sense.
  • I don't know if those 2 add-ons had anything to do with Zotero in the first place.
    They didn't.
  • I assume others are having problems with the syncing feature? I know last time it was the server so I believe it to be the same as before? I am wrong?

    I hate to sound mean because I really do love Zotero, I am just curious about the syncing issues.

    Additionally, if extra space were bought by the customer (me) would this clear up the syncing issues? Or would I still experience the same problem?

  • Dido on the spinning wheel, three hours on 50 some items for a first time fresh sync up. Any hope this resolves spontaneously?
  • Aaron: I don't see any reason you'd be queued right now. Is it still spinning?
  • The same problem for me. The spinning sync arrow and "upload accepted - waiting for sync server". Yesterday I had the problem of empty server response. This seems to be resolved now. But the sync Arrow is now turning for about 2 hours and won't stop. I now made a backup of my local database and will import it manually on my other computer until this issue is resolved.
    Thanks Dan for the great support!
  • "The spinning sync arrow and "upload accepted - waiting for sync server". Yesterday I had the problem of empty server response."

    I've had this issue for the last 48 hours. But literally as a type this it seems to be working, perfectly. Thank you for Zotero.
  • edited February 26, 2010
    Hello, I have been having the same "upload accepted - waiting for synch server" problem for the past couple of days. I have been trying to synch the libraries on my pc and macbook, while I've been able to synch the citations, I cannot synch their associated pdfs.

    I looked at my storage settings and I had used 89.7% of my 100 MB quota, yesterday I bought 1 GB in the zotero file server hoping that this would solve the problem, but I am out of luck.

    The arrow has been spinning for more than 2 hours now and my library is less than 200 MB. Any comments?
  • Yeah, same issue for me. I suppose it should be possible to store my Zotero library on a flash drive and just direct my Mac and PC instances of Firefox appropriately? Or are the Zotero files different in Mac and PC? Now that server issues have become more common (since the mass upgrade to 2.0), it would be great to have a way to do offline syncing.
  • edited February 26, 2010
    We're aware of these issues, and we're working to resolve them. Don't use the Reset options—you'll make things worse for yourself and for others.
  • It finished up after I enabled and submitted the debug messages, weird, now it is working fine, but that first bout took 3 hours.
  • I suppose it should be possible to store my Zotero library on a flash drive and just direct my Mac and PC instances of Firefox appropriately? Or are the Zotero files different in Mac and PC?
    This should work fine. I take a similar approach for my dual-boot Windows/Linux laptop-- I just set the Zotero directory to the one in my Windows install when I installed Linux and the Linux Zotero. The main thing to worry about is that you always completely close Firefox before removing the flash drive. The other concern is that two copies of Firefox should never be using the library simultaneously, but that's not a problem with dual-booting or using a flash drive (but network drives are risky).

    If this doesn't work for you, start a new thread.
  • Dan: thanks, now I am able to synch both the citations and files.

    Gotta love zotero! :D
  • all seems to be working now
  • issue resolved! Thx Dan!
This discussion has been closed.