Upload accepted - waiting for sync server

I open Zotero, it starts to sync and then displays this message indefinitely.
  • Your upload has now gone through.
  • Great!! Sorry to be impatient. This was the error I would receive constantly prior to this upgrade.
  • You weren't impatient—there was a bug we had to fix.
  • Same problem now here: Upload accepted - waiting for sync server. For some minutes now...

    Zotero 2b7.6, problem for WinXP & MacOSX 10.5.8, firefox 3.5.5

    Edit: never mind, upload got through when I was typing this message. But it is strange, because since the upgrade to 7.6 the syncing process seemed much smoother and I never had to wait longer than a few seconds!
  • I am now having the same problem trying to sync to my collection through the server. The sync arrow is continuously spinning when it did not used to take this long. The mouse roll-over has the same message "Upload accepted - waiting for sync server" and the progress bar for files has not appeared at all (I am using a WebDAV server to sync my files). When I exit Firefox and re-open, the arrow has stopped and it appears that the collection is synced.

    Should I just let it go, or is there something wrong? I am very interested because I am trying to show a couple of colleagues the benefits of Zotero, but I want to make sure that the sync is going to work before I show it to them so that they will want to use it!
  • m_bader: Still?
  • No, it finally downloaded. I tried it again and it synced very quickly, like it has in the past. Thank you for following up -- I'm sorry that I didn't post that it had resolved earlier, I got distracted...
  • I'm also having the same issue. It's been sat at "Upload accepted - waiting for sync server" for around the last half hour. Should I wait more, or can something else be done?
  • Me too. The spinning sync arrow and "upload accepted - waiting for sync server" has persisted for about an hour now. Other web sites working fine (as evidenced by this posting!).

    I've had similar problems the past two days, except that it did start the WebDAV sync, but wanted to upload everything (some 1GB - which would take some time on my puny 1Mbps line).

  • Same for me. Syncing lasts "forever"and I dont know what is going on. When I shut down ff and restart ist, last sync is this morning, when it worked and finished ok. D2067127091 Can I do anything about it?
    regards, GR
  • 2 hours later sync worked normally.
  • Same issue here. My last sync to go through was yesterday and I have been working 5 hours today. Restarting Firefox had no impact. Just being patient but any advice is welcome.
  • Having the same problem here today. I can see that my uploads are making it to the server, or at least they aren't showing up when I view my library and storage quota on the zotero web site.

    I actually had a whole mess of errors while uploading my almost 3 GB collection last week. (Downloading to my laptop afterward worked like a charm, though.) Not sure whether posting that info would be of any use, given that everything did eventually sync.
  • We've updated the prioritization of queued uploads to allow smaller syncs to go through much faster. Larger syncs will take longer. If you're still having trouble, please let us know.
  • That's worked for me - it completed very quickly. Thanks.
  • Still problems here. Submitted an error report (1187870117). I got the (now) usual slow sync, though this time it attempted storage sync, but stalled at 45% on uploads, giving an error icon that says "Unexpected status code 502 in Zotero.Sync.Storage._getStorageModificationTime()".

    Because it's (incorrectly IMHO) trying to upload everything, it's about 1Gb in total.

    I'll restart FF, turn on debug, and submit the output now.
  • Debug ID: D1933527762 - for what it's worth ...

    Well, after the restart (and enabling debug) it synced and completed. Perhaps the problem is the puny ADSL upload speed here?

  • alandsloane: First, it looks like the metadata sync (which is what this thread is about) completed within 22 seconds for you, after saving a bunch of items.

    For the rest (which isn't related to this thread), it's not actually uploading many files for you—it thinks they've changed (likely due to a reset of some sort), but it's ultimately skipping almost all of them with "File mod time matches remote file -- skipping upload". This shouldn't happen regularly.

    The 502 error is from your WebDAV server or somewhere in between: the implicit description of a HTTP 502 error is "The server, while acting as a gateway or proxy, received an invalid response from the upstream server it accessed in attempting to fulfill the request." It's not something that Zotero servers return.

    If you have other problems unrelated to metadata sync speed, please start a new thread.
  • Hi,
    I'm trying to sync a library with about 300 entries, but get the same error as in the original posting.
  • edited January 7, 2010
    I'll hop on the bandwagon here! I'm having the same problem just now with a library of ~600 items. It seems to sit for a while saying "getting update data from server", then eventually "upload accepted - waiting for sync server". I left it doing that for probably an hour or two with no success.

    I tried doing a "restore to server" reset for the metadata, but I'm still having the same problem. Checking my library on the website still shows it as empty.

    EDIT: btw, I purchased Zotero file storage space earlier today, but was having the same problem yesterday, so I assume it's unrelated.
  • edited January 9, 2010
    Same problem as several people in this thread. It is my first sync, and the library is pretty big. Zotero says "Upload accepted - waiting for sync server". I had time to go and buy some pasta, cook the sauce and eat the whole : the green arrow is still turning. In, fact, I have tried several times this afternoon. Is there some debug information somewhere ?

    EDIT : Ok, now (next day), it is working. Must have been a server issue, because I have not changed anything. As a feature request, a message saying in these cases "server is down/overloaded" would be nice.
  • I'm having this problem now too. I'm stuck on Upload Accepted - waiting for sync server. I tried it a few times yesterday, and figured maybe I should wait a day. Still same problem this morning. We have 1103 citations in our group library.
  • The green arrow is still spinning. Is there a certain time of day that is low traffic, that might be better?
  • Hi,
    I get an error while sync, this is the report number of the error 22537824.
    This is my first attemp to sync, so maybe i just need to try later.
    Hope you can help me, because i'm getting very used to zotero but i need to upload
    the database.
  • Catlynnl - I'm no expert, but I thought I'd mention that I've found several times that zotero gets "stuck" and I need to restart my browser and let it restart the sync from the beginning. This has happened to me at the file transfer stage, though, so I'm sure it's relevant to your situation. Might be interesting to try that, if you haven't already, though.
  • I will try. I've let it spin for 3 hours, though - I hate to let go...
  • I've tried restarting the browser application four times. I'm not getting any errors - the arrow just keeps spinning and gets stuck at a step. I think I just might have low sync priority because my database is somewhat large? I might try at 1 a.m. tonight and see what happens...
  • Hi, again,
    The library was uploaded, and i can see my references in it (Thanks!!!!)
    But i'm still have an error ( 1684143579 ).
    I'm only sending this because it may help to fix some
    Thanks Again!!!
  • As I noted above, we're now prioritizing by upload size, so small uploads (e.g., single-item edits) will generally complete right away. Larger uploads may take longer. We'll be making some changes to speed up syncing of larger uploads in the next few days.

    If your upload is queued, do not use "Restore to Server"—all that'll do is create a much bigger upload (i.e., the size of your entire library) for the server to process.
This discussion has been closed.