Zotfile not working correctly?


Reference: I'm using Windows 10 with Zotero standalone and google chrome.

I'm trying to set up zotfile so it automatically renames attachments into a designated folder, but can't seem to get it to work.

I recently installed zotfile and have been in the process of dumping previously stored PDFs into zotero and using zotfile to relocate the attachments onto a google drive folder that is on my desktop via backup & sync. From my understanding based on zotfile's website and youtube videos I've seen, part of zotfile's function is to *automatically* take downloaded PDFs from a designated folder and drop them in another designated folder, but yesterday when I was testing this out (on Jstor), it wasn't renaming the attachment automatically. At first I had the folder set to downloads, but I also tried changing it to Zotero > storage where the PDFs normally go and that didn't work either. I had to manually click 'rename attachment' for each citation. I tried searching the forums on this, but haven't seen anything on this recently. Google brings up stuff from previous years, but I wonder if I'm just doing something wrong? I was watching a youtube video by Robert Karl: https://www.youtube.com/watch?v=HBynXko1wUU 3:40-4:00 and he doesn't even use a Source Folder, but zotfile still moves the attachment to his designated folder automatically. I have the same set up with zotfile going to a google drive folder, but it wasn't working.

Part of me is wondering if I messed something up with zotero yesterday trying to dump a bunch of PDFs into it at once. I had to delete a bunch of stuff because it didn't occur to me at first that it wouldn't be able to recognize the difference between articles and ebook PDFs (I know). So I'm wondering if reinstalling Zotero might help clean things up, but I'm not sure how to go about it correctly if that's what I should do so that it syncs correctly when I reinstall it.

Any help would be appreciated!
  • These two features of Zotfile seem related to your questions.

    1. Automatically move and rename attachments:

    When using Zotero's browser connector for importing items, you should generally try to import articles from the main journal website. If you do this, Zotfile should be able to automatically move attachments from Zotero's storage folder to a custom location. You could try to follow these steps for troubleshooting related issues. See the discussion here: https://forums.zotero.org/discussion/76181/help-with-zotfile-not-moving-pdfs-to-designated-folder/p1.

    See also Zotero's documentation on Stored Files and Linked Files. Note that for linked files, it's recommended to set up a Linked Attachment Base Directory.

    2. Zotfile's source folder:

    Currently, Zotfile adds an "Attach New File" function to the item context menu, accessed by right-clicking. This function can grab files from a source folder, e.g., your Downloads folder. The Zutilo add-on provides keyboard shortcuts for Zotfile. You can set a keyboard shortcut that triggers the "Attach New File" function.

    (Note that Zotfile's "watching folders" function was removed in Zotfile 5.0.2, see the changelog for details. Zotfile doesn't automatically grab files from its source folder.)
  • Thank you for the response! I tried posting a second comment before, but it wouldn't find the page. This issue has been resolved and was linked to another post I made related to my institution's (evidently outdated) library proxy. As of now everything works as it should and I'm not sure exactly why the proxy is working right now, but this was what was preventing zotfile from functioning properly.
  • My zotfile is refusing to move things to my tablet folder, with a message that states:

    Attachments skipped because they are top-level items, snapshots or the file does not exist.

    Well the files do exist because I can open the pdf in Zotero. How can I fix this
  • I might have cracked it up a little.

    For it it wasn't working because I set up folder preferences as /%g/\%t/
    So each time I had a document made by a company (only last name field was filled) it refused to work. By temporally changing it to /%a/\%t/ works as intended.
Sign In or Register to comment.