Help with ZotFile - Not moving PDFs to designated folder

Hello Everyone,

Fully disclosure, I am new to Zotero and a move over from EndNote (I finally had enough) and I am computer illiterate. I must admit I am sad I did not discover Zotero earlier (multiple papers with over 400 references!).

Anyways, I was migrating my EndNote library, along with attachments, to Zotero. I was using the link below as a guide (very nice guide!). They show the steps to set up the program with Zotfile saving the PDFs to a cloud service (I use iCloud). The important worked perfectly as far as references go, but it placed the PDFs in a different location on my computer than the cloud folder I designated in Zotfile. I also changed the based directory to the cloud folder. I am doing all of this because I want to be able to work with my library from at least two devices.

So my question is, why is Zotfile not working for me? Even when I import a new reference it is placing the PDF is some Zotero storage folder. Am I missing something to do this automatically?

Thanks again for all of your help!
Chem Prof
  • I should have stated in the original post, I am using a Mac OS 10.14.3 and Word 2016 as word processor.
  • What happens when you right click on an item, then choose Manage Attachments -> Rename and Move Attachment?
  • Hi- completely different person here- but have this exact problem. I did what you said- (right clicked on an item and then chose "manage..." and then "rename"... then a dialogue popped up in the lower right corner of zotero, and then suddenly the attachment (pdf) appeared in my dropbox folder that I had previously specified. Why did this work when I go to rename the file? And how can I make sure that new pdfs get saved there automatically (so I don't have to click rename each time)? Thanks! :)
  • Thanks for the reply bwiernik. When I right click and go to rename an attachment it does send it to the specified folder. However, it appears that I can only do this to one reference at a time? I tried to selected more than one and it will not move the attachments then.

    Also, as adamgblake, said, when I still add in a new reference it places the attachment in the "storage" folder and not the cloud folder. Any suggestions on how to move new files to the specified folders and the old ones there?

    Thanks again for your help!
  • Hey everyone, any update on this? I am pretty desperate to get this to work. Thanks again for your help!
  • So two issue: 1. PDFs from new references and 2. Batch moving existing PDFs.

    1. How exactly are you adding references to Zotero?

    If you add the PDF and rely on Zotero to retrieve metadata, ZotFile doesn't register that action and you have to manually use rename to move it.
    If you use the Save to Zotero icon in your browser (the main method for importing), ZotFile should pick up and move the automatically attached PDF

    2. Selecting Multiple items and using Manage Attachments --> Rename should work. What exactly happens when you try? The file gets renamed but not moved or something else?
  • Hi adamsmith, I have been adding pdf's from the browser extension in firefox.. it imports the reference but places the pdf in zotero's own storage- not the path to my dropbox folder that I specified..
    2 works for me- I'm able to select multiple items and rename to move the pdfs to dropbox..
    My main problem is issue 1.: Zotfile is not automatically moving the pdf to the path and so I have to do it manually each time...
    I'm not sure what you mean by "If you add the PDF and rely on Zotero to retrieve metadata, ZotFile doesn't register that action and you have to manually use rename to move it" what is an alternative to this (besides doing what I'm already doing- clicking on the broswer extension button to import the pdf to zotero)

    Thanks for your help
  • edited March 5, 2019
    What's a sample page you're clicking the browser icon on? (i.e. what's the URL?)
  • Hello Adamsmith. Answers are below.

    1. As with Adamblake, I am adding them using the Safari Zotero extension. It adds the reference and PDF automatically, but it is still placing them into the "storage" folder and the note specified folder in ZotFile.

    2. I have no idea why, but this seems to working now! Yesterday it would literally not do anything when I selected multiple references but would move it if I selected individually. Seems to be working perfectly now! Now just need to figure out 1 if possible!

  • Thanks, yes, the PDF auto-attached from the ACS page should definitely be moved by ZotFile. I'll take a look (but don't maintain ZotFile, so won't be able to repair if it's broken, so no promises).
  • Excellent, thank you so much adamsmith. I really wish I would have this community years ago!
  • here is the sample page that I'm clicking on (the pdf is sitting in the browser when i click the zotero broswer extension in firefox, unlike the example dprofessor1 gave which is a website with a link to a pdf but not a pdf itself)...
  • Right, so that behavior is expected. Try saving from instead (that will also give you better metadata and ZotFile should move the PDF automatically)
  • when i tried the link you posted adamsmith, it still didn't move it the pdf automatically- it also didn't rename the pdf using metadata (the link I sent, zotero renamed the pdf in the browser using the metadata from the article to rename the pdf).
  • I'm using zotero 5.0.60 and zotfile 5.0.9
  • Hmm -- this works for me (with both the Sage and ACS examples) using the current Zotero beta and ZotFile 5.0.9 and I don't think it has anything to do with the difference between 5.0.60 and 5.0.61beta

    Which operating system are you on? I'm testing on Windows.

  • I'm using MacOS Mojave
  • I have no explanation for this, but now the Safari extension seems to be working for me. It is uploading it to the proper folder on both machines. I restarted everything and it is working.

    I have run into a slightly different problem now that I will continue to look into. On my main computer ZotFile is working perfectly and has moved all of the files to the cloud folder. However, one the second machine it finds about half of the PDFs but cannot locate the other half even though they are in the cloud folder. Any guesses on that?

    Thanks again for your help!
  • I have no idea what happened, but I just restored everything, including both computers, and now everything is working great! Thanks again for your help and this program so far is amazing!
  • Glad its working for you dprofessor1. I took a look at my settings and followed the instructions at
    Mine seems to be working normally now too. I realized I needed to uncheck the zotero sync options as I think it was overriding zotfile's pdf syncing
  • Hi, I have observed a similar problem. When using the firefox addon directly on an opened pdf (i.e. it creates an entry which cannot be renamed with zotfile. However if I go back a step and use the addon on the overview arxiv-page (i.e. The entry is correctly handled with zotfile. Why is that? Can I change that behaviour? I often find myself clicking on the pdf and skimming parts of it to decide if I want to add it to my library. The additional step to go back is really inconvinient.
  • Do you have automatically retrieve metadata for PDFs checked in the general tab of the preferences? If so, at least the item you linked to should automatically attach to metadata in Zotero after import (and then allow you to rename the entry with ZotFile) - ZotFile doesn't, though do this automatically as opposed to saving from the abstract page.
    This is due to a combination of issues with Firefox and ZotFile (the behavior in Chrome/Chromium is different) outside of Zotero's control.
  • @adamsmith Thank you for the quick reply! The zotero option to rename attached files using the meta data was activated for me but the suboption to rename linked files wasn't activated. After activating this I could manually tell zotfile to rename the attachment. Which is something I can deal with. Is there a issue open for that on github? I would like to dig deeper into this issue.
  • There's a relevant ZotFile ticket, yes
    (when you import a PDF directly, Zotero runs retrieve metadata automatically, so this is what's going on here in the background)
  • I am having a similar problem. I am old to Zotero and ran out space for Sync. Following the tutorial qouted above I installed Zotlib. I run Windows 10, Mozilla Firefox with Connector and Zotero Standalone. They are all updated.
    1 - new files end up in the old folder, not in my chosen sync folder. I have followed the instructions in the tutorial and triplechecked that I did as instructed. Is there anywhere else i should adjust the settings?
    2 - I don't understand how I can get my old PDFs into the new folder. Just move them in File Exporer? (with Zotero shut down)
    3 - When (if) this gets functional, will Zotlib only grab PDFs that i Download via the addon in Mozilla? What happens to PDFs that I manually drag into Zotero?

    very grateful for any tips and tricks here...

    / Anna
  • You could check if this helps:

    (a) Enable Zotfile's automatic renaming of new entries. This setting might be somewhat difficult to spot in Zotfile's settings. It can automatically move attachments to a custom location. See "Tools" -> "ZotFile Preferences" -> "Advanced Settings" -> "Other Advanced Settings" -> "Automatically rename new attachments".

    (b) Use the Zutilo add-on, which provides keyboard shortcuts for Zotfile. You can set a keyboard shortcut that triggers Zotfile's "Move and rename attachments" function.
  • edited January 22, 2020
    a) I changed this setting from 'only ask if item has other atts' to 'always' but the new file still ended up in the old folder.
    the new folder is
    \\\Hem\GOT-015\annro60\Mina dokument\Zotero Library
    which is a subfolder under My Documents that is synced automatically. Is that the problem? I could move it to a OneDrive-folder as well. The computer is corporate so Dropbox is a no-no.

    I've now tried three ways of importing with the following results
    1 - use Zotero button in Firefox. Reference ok, PDF in wrong folder.
    2 - download PDF in Firefox. Nothing happens. PDF stays in downloadsfolder ( I hoped Zotfile would pick it ut)
    3 - drag and drop PDF into Zotero Standalone. Reference ok, PDF in wrong folder.

    b) thank you! that's sorted, the existing PDFs are in the correct folder. I am very happy also to get rid of the messy filstructure that Zotero did previously.

    Running Windows 10 and installed Zotero, Zotfile, Mozilla etc during the last two weeks (computer swap)
  • Please check Zotero's documentation on stored vs. linked files, backups, syncing, etc.:
    (I cannot help with the specifics of your setup.)

    If you want ZotFile to rename your files, the check box here should not be checked:
    "Tools" -> "ZotFile Preferences..." -> "Renaming Rules" -> "Use Zotero to Rename".

    Note that ZotFile adds an "Attach New File" option to an item's context menu, accessed by right-clicking. Zutilo has a shortcut for this function. ZotFile will not automatically grab files from ZotFile's source Folder.
  • edited January 23, 2020
    Hi all,

    I have the same problem as Anna Rosander. I've worked with the recommended documentation (, tried various combinations of settings and triple-checked every single setting, Quit Zotero, restarted Zotero, etc. etc.

    Also, I did what Anna did:
    I've now tried three ways of importing with the following results
    1 - use Zotero button in Firefox. Reference ok, PDF in wrong folder.
    2 - download PDF in Firefox. Nothing happens. PDF stays in downloadsfolder ( I hoped Zotfile would pick it ut)
    3 - drag and drop PDF into Zotero Standalone. Reference ok, PDF in wrong folder.

    To no avail. Zotero keeps saving all Files to the Zotero > Storage > ... and what is worse, it adds a new subfolder for every PDF I save. DEVASTATED.

    I really don't know how to proceed. Was trying to set up a group library with colleagues and save PDFs to the Google Drive account. Using Mac OS Mojave, Zotero Standalone with Zotfile, and Brave Browser (I also tried Chrome & Firefox, should anyone wonder)

    Eternal gratefulness awaits those who can help solve this issue!
Sign In or Register to comment.