Available for beta testing: Zotero Connector for Safari 13

  • @adomasven yes I tried, but still nothing in the extensions pane as IanBroon
  • Zotero 5.0.81-beta.2 & Safari 13.0.3, works well. Thank you so much!
  • I'm having the same issue as IanBroom - nothing in the extensions pane, after deleting the original app, installing the Beta, rebooting the computer...
  • @mikeross, @Henrim, @rstrauch: Are you all on High Sierra, like @IanBroon?
  • @dstillman Yes - High Sierra with latest updates.
  • @dstillman yes High Sierra 10.13.6. Couldn’t update to Mojave or Catalina, my computer from 2010 is too old for that.
  • OK, I suspect this just isn't working on High Sierra. We haven't tested on that yet, but we'll see what we can do.
  • edited December 7, 2019
    Really nice of you ! At least it ll avoid to other to struggle with it before it ll be fixed if possible.
  • @dstillman I updated the MacOS to Catalina (I had been on High Sierra), and the extension is working fine. So I think the issue must be with High Sierra.
  • I'm on an iMac + High Sierra (Version 13.0.3 (14608. and the latest Zotero (5.0.81-beta.2+bbbd02444).
    @jwjwj: I'm pretty sure you're running Mojave (10.14), not High Sierra (10.13).

    I was able to reproduce the extension not showing up in High Sierra. We'll investigate.
  • I'm also on High Sierra and none of the previous pieces of advice worked... I really miss the Connector... is there any new update ?
  • There's nothing to try — the beta connector just won't currently work with High Sierra. We're not sure if we'll be able to support it, but we'll post here with further updates.
  • So far so good - seems to be working fine and bookmarking items correctly with Safari 13. Many thanks!
  • It was working so well! Then, before my very eyes, the connector disappeared from the tool bar when I restarted Zotero :(
  • What were you doing when it disappeared? Does it reappear if you restart Safari? Is is still present in Safari Preferences?
  • I went to save a paper to Zotero and Zotero suggested I restart to update. I said later, but then the icon on Safari looked a little odd, so I did restart. As I did the icon disappeared, then reappeared, then disappeared. There was no extension in Safari, preferences, extensions.

    I had to deal with household stuff (Son, chickens, lunch) and when I got back to the computer I restarted both Zotero and Safari and this time the icon appeared but didn't work, but the extension had re-appeared, so I unchecked it, checked it again, and now it is working again, Phew! Have successfully downloaded another paper to Zotero!
  • Second that -- also no Zotero in extensions pane of Safari after uninstalling and reinstalling the beta
  • @evasnyder: On what macOS version?
  • @dstillman macOS High Sierra 10.13.6 and Safari 13.0.3
  • Right, see above. This doesn’t currently work in High Sierra, and we don’t know if it will. There’s no need for further reports about High Sierra.
  • Thanks @dstillman I didn't see the second page of forum comments!
  • I just tried it on Safari 13.0.4 unfortunately it seems to have stopped working?
  • @smoxey: It's working here in 13.0.4. Try removing and redownloading the beta.
  • I tried removing and reinstalling the beta. The zotero connector 5.0.60 is installed but when you open a webpage with references nothing happens it does not recognise the items or open the Zotero selector. It was working correctly on Safari 13.03 and does work on Chrome!
  • but when you open a webpage with references nothing happens
    Meaning what, exactly? What does the icon show?

    Have you tried restarting your computer?
  • I just tried disabling and enabling the zotero connector and that seems to have made it work, even though it was enabled after installation of the beta. So working now thank you for your help.
  • We're looking into crashing of the extension after Zotero updates, which we can reproduce (though for us it just shows a crash notification and then continues working). We'll post when we have more info.
  • It is working now but to answer your question. The icon was just showing the large 'Z', whereas normally the icon is a folder which shows 'save to zotero' if you hover over it.
  • Thanks again for your help, I will remember to chic and uncheck the connector in Safari preferences if I get the problem again.
  • Great to see this under active development and progress. How reliable is the beta version of Zotero? (I don't see any mentions above of issues)
Sign In or Register to comment.