Zotero 5.0 Beta

  • edited February 7, 2017
    @adamsmith: my mistake indeed (I am using this config to run ZS 4.0.x and ZS from Git without trouble on Windows, but that's perhaps specific - in any case it's not common). I'll edit my post above.
  • It was also possible - and I assume that's what you were doing - to view and edit the HTML source of a note, thanks to the HTML button. It has been removed in 5.0, so you can't access it anymore.
    Still there — just in the context menu now.

    Images with external src values should still work.
  • To test out the beta, you could install it on one of your comptera (home or office), but not the other. The two versions can both sync to the same account.
  • in the pre-5 versions of Zotero, I could run two different Firefox profiles which would allow me to have two different Zotero libraries. Is there any equivalent way I could do that with the Standalone?
  • absolutely -- Standalone has the same profile manager built in as Firefox. You can use it the same way to run separate libraries. The only thing that doesn't allow is to run one beta version and one regular version the way you could with Firefox profiles.
  • Thanks for the comments on the image. One last question: how is it possible to use at the same time zotero5 and 4 (on two different computers) with a same account, but at the same time not being able to roll back to zotero4 once we updated to zotero5?

    (more details: I think I read somewhere that once we switched to zotero5 beta, there is no way to roll back to zotero4 (my understanding of the reason is that Db may be structured differently so once the DB have been ported to zotero5, zotero4 can't read it anymore.) But according to Gracile, it seems possible to use the different versions (on two different computers) to sync on the same account so my reasoning seems to not be correct -at all-)

  • Because each computer stores its own Zotero database locally. The first one will store a zotero4 db; the second one a zotero5 db. They both sync with the server.
  • @Gracile: but then which format does the server use?

    Technically it is thus possible to roll back: if I update one of my computer to Zotero5 but not the other. Then if I want my computer with the updated version to switch back to zotero4 I can simply copy/paste the "zotero4 folder" from the other compyter and reinstalled zotero4. Is this reasoning correct?
  • Yes, that's correct. That's how backups work: https://www.zotero.org/support/zotero_data
  • @bwiernik My question was if I can "try" 5.0 on a computer running 4.0.29.x. I am not too sure I want to switch my home or work computer since I use Zotero daily on both. The fact that they can sync to the same account is a double edged sword. Overall, it seems my only option is to bite the bullet and switch one computer to 5.0 Beta.
  • You can also save a copy of your Zotero database (follow the link above by @Gracile) and then return to that if you want to roll back to 4.0.29 (if you do, immediately start with a full sync to get back up to date with your changes to your library).
  • I don't quite understand the reluctance of the large number of experts writing on the forum to move to the beta. I'm not generally an early adopter but after weeks of early testing 5.0 because of the RSS option, I've been using it exclusively now for everything. I find it better than 4.0.x in all ways. Is it because of plug-in issues? Is it because it isn't yet 5.1? I'm on the Mac OS and use the 5-beta standalone and LibreOffice (using the LO configuration recommended elsewhere on this forum). I have fewer issues than I had with 4.0.x. While I'm most certainly not an expert in the programming/coding side of Zotero, I actively use it 8-9 hours a day 6 days a week. It is currently as stable as any software can be. I have utmost respect for the philosophy of holding back a major upgrade until it is fully baked. However, in my opinion, 5.0 has (for weeks) been out of the oven, iced, decorated, and thoroughly enjoyed.

  • Thanks a lot. I just updated and I can confirmed that "Images with external src values" are still working. Zotero5 is wonderful!
  • edited February 8, 2017
    @DWL-SDCA it's perfectly reasonably for people to not do major upgrades -- let alone to a beta version -- when they're at a critical point in their work.
    There's been a steady trickle of bugs that Dan and co. have been fixing -- admirably quickly, but still.

    E.g. Brenton's initial upgrade didn't work at all initially. Which is fine, that's what beta testing is for, but there is an expectation that beta testers are OK with experiencing issues like that (as Brenton was). But if you're writing a grant or a dissertation due in a month, you may not have that patience.

    There are other issues (no BBT, no Scaffold unless you're running the git source in Firefox developer edition), so yes, assume that people posting here regularly have good reasons not to be on 5.0.
  • (I, for one, held off on trying upgrade at all for months until my dissertation was done just to be sure nothing stopped working, particularly the groups I was relying on for my research.)
  • edited February 8, 2017
    (I, for one, held off on trying upgrade at all for months until my dissertation was done just to be sure nothing stopped working, particularly the Word integration I was relying on for my research.)

    (back in the day, when I was still a whippersnapper, I finished my PhD thesis with Zotero 2.0.9 as a safety precaution, forgoing the switch to citeproc-js and CSL 1.0 made in Zotero 2.1, and even then Word 2003 still managed to corrupt my thesis .doc file)

  • @DWL-SDCA At my end, 5.0 Beta does not provide a much needed missing feature or fix a troubling bug in 4.0.29.x. On the other hand, the Prevent Duplicates and Google Scholar add-ons do not work with 5.0. Thus, I am eagerly waiting for 5.0, but there is no burning need to jump my stable 4.0.29.x ship. Also, I trust Dan and the development team - if they are calling it Beta, I am going to treat it as Beta (wicked logic) :)
    BTW, I love your passionate defense of 5.0 Beta, it has brought me really really close to switching over!

    @bwiernik Thanks. I take regular backups. My concern with one computer on 4.0.29.x and another on 5.0 Beta is if somehow the Beta ends up corrupting all three databases (incl the online), forcing me to roll-back to my pre-upgrade database. This is probably a very far fetched situation, but still.
  • When is 5.0 going to be released?
  • word on the street is "within days"
  • mxn
    edited February 10, 2017
    Removing items from "My Publications" doesn't work.
    Edit: works now, installed an update to 5.0-beta.136+469d689
  • I would like to backup the files where zotero5 save the about:config. When I was using the Firefox addon, I simply had to save the pref.js in the profile folder but I can't find the equivalent of pref.js in the zotero.jar of zotero5.
  • Zotero creates a profile folder that looks almost exactly like the Firefox one. Exact location depends -- as it does for Firefox - on your OS (e.g. in linux it's typically in ~/.zotero).
  • I tried the latest beta (Zotero-5.0-beta.136 linux-x86_64) on Ubuntu 14.04. It works, but I'm unsure of a couple of things:

    1) Running `./zotero-bin` seems to start another Firefox instance, nothing happens. What's the correct way to run/upgrade Zotero5?

    2) Running `./zotero`: this does start Zotero 5, offers to upgrade the database, and seems to work, but with these messages:
    zotero:1882): GLib-GObject-CRITICAL **: g_object_ref: assertion 'object->ref_count > 0' failed
    (zotero:1882): GLib-GObject-CRITICAL **: g_object_unref: assertion 'object->ref_count > 0' failed

    I saw some forum threads regarding similar errors pointing to possible permissions problems with .cache, .zotero, .gnome2 etc., but I didn't find any such issues on my system. I'm running Zotero5 from ~/Programs/zotero/.

    3) I had Zotero for Firefox 4.0.29 installed. I believe this thread mentions the addon should be upgraded automatically to Zotero Connector when updating to Standalone 5 beta? This didn't happen. I uninstalled the old addon and installed the connector from zotero.org/download/. But the connector extension seems to be the same as "Zotero for Firefox" (namely zotero- Is there a different connector version to be used with Standalone 5.0? (I get this message when starting ZS5 beta: "This Zotero database requires Zotero 5.0-beta.136+469d689 or later. Current version: Please upgrade to the latest version from zotero.org.", although the program subsequently does work.)

    Otherwise, Zotero Standalone seems to work nicely. Am I doing something wrong, or should I file some issues? Thanks!
  • 2.) don't worry about GLib errors in the terminal as long as Zotero works
    3.) The Firefox connector for the beta is listed here: https://forums.zotero.org/discussion/comment/267549/#Comment_267549

    The auto-update would have happened if you started by installing that (and it may still do that). Note that this is obviously more clumsy given the beta nature and the continued availability of the 4.0 versions. This should be obvious once 5.0 is actually out.
  • Oh, I'd actually also tried that link, but I get "Firefox prevented this site from asking you to install software on your computer." I've added https://www.zotero.org to the allowed sites list in Firefox, but still no luck. (Also tried disabling "Block dangerous and deceptive content", no change).

    Since I didn't see any version string in the https://www.zotero.org/download/connector/dl?browser=firefox url, I tried removing the "?browser=firefox" and the "dl" parts to see if those would work, and then I got just the regular 4.0 download page.

    Is there a direct link to the correct download?
  • That link is correct -- you don't get an "Allow" option with the "Firefox prevented..." dialog? That should appear. The warning appears (reasonably) whenever you try to install an add-on from anywhere but the mozilla add-ons page.
  • No, normally I get the "Allow" option for instaling addons, but it doesn't appear at the Zotero URL. The message looks exactly the same as normally, with the same icon, except that the "Allow" / "Not now" dropdown on the bottom is missing. On other sites the message does include the "Allow" option. I'm using Firefox 51.0.1. Very strange.
  • Oh, found it: https://forums.zotero.org/discussion/62420/cannot-install-5-0-beta

    It doesn't work when opening the link in a new tab, or copy-pasting. But following the link in the same tab does work.

    And thanks for your quick answers, much appreciated!
  • that was going to be my next question. New tab or copy&pasting of URL links doesn't work to install Firefox add-ons for security reasons.
This discussion has been closed.