Zotero 5.0 Beta

  • What is the approximative date of Zotero 5.0 official released? This summer? This fall? Thanks.
  • To add to the above - how stable is the current beta, for a database with 30000+ items? I've been getting weird errors with the current 4.x release: Z hangs up indefinitely on elementary actions (such as editing a tag, adding a PDF to an item, etc.) and I have to restart each time. The database still checks out after the restart as not corrupted, so these bugs must not be serious. But it slows down the work. If 5.0 is stable enough for large databases, I should probably just switch to beta.
  • I haven't checked the latest beta release, but the 5.0-beta.156+a35d903 was causing delays at my end. See these posts for behavior with my library:
  • Don't forget that some add-ons do not yet work with 5.0-beta. It may be better to test it with a new profile.
  • I don't know if it's a bug or if this behavior is intended but local file (that are stored outside of zotero/storage) aren’t deleted when I delete the entry in zotero. If I delete a .pdf that that has been move with Zotfile or added using add attachment/attach link to file, I can still see the file in my Windows folder. If this behavior is intended and not a bug, it would be great to have a confirmation pop up when deleting an item (would you like to also delete the local file?) and/or an option in the settings to always delete local file.
  • (The only issues that should go into this thread are directly related to the release of 5.0. Specific questions or bug reports should get their own thread each, please, so that this one remains somewhat manageable).

    @Whateverr that's on purpose, since those are links to the files, not actually attached files under Zotero's control. There has been some discussion within ZotFile of adding that option, but I think its maintainer said he'd likely not have the time to add it but would take other people's code.
  • Please make in possible to paste images into notes again. This is a crucial feature for working with literature. For me, I usually want make notes which consist of formula and diagrams from the pdf. It is not possible to type this kind of information. So for now, with 5.0 beta I cannot make reports for the papers with images and formula to see the most important information at once. You can skip the sync part and make it optional so anyone can decide on their own...
  • edited March 22, 2017
    @erazlogo I would like to stress the need of Zotero 5 to handle the interaction with large databases with as little delay as possible. I am "only" at 12k items and experience significant hiccups too (on Zotero 4 though). @gurdas seems to suggest that this has not yet been successfully solved in Zotero 5 Beta. I hope you find an appropriate solution for the upcoming 5er release. Keep up the good work!
  • edited March 22, 2017
    how stable is the current beta, for a database with 30000+ items?
    @erazlogo: For stability I'd recommend upgrading, if only because we can actually fix problems in 5.0, and there won't be any more 4.0 releases. But I'd hold off a few days — I'm testing on a 30K-item database now, and we should have some performance improvements soon.
  • I just started using the beta, and noticed a difference in the way tags are working. In the previous version, selecting one tag would produce in the center panel a list of all items with that tag and would produce in the lower left tag panel a list of only those other tags applied in common to that subset - the tags that did not match the subset would be removed, so I could see at a glance which other tags applied to the set. Now selecting one tag produces the list of items, but the tag panel continues to display all the tags represented in the library whether or not they are applied to the subset. I have to go through and select any other tag that I think might apply, resulting in a list of no items if I guess incorrectly. It makes the tags much less useful than they were before.
  • That behavior hasn't changed, you just have a different setting chosen. Click on the options icon in the lower right corner of the tag selector box and uncheck "Display All Tags in Library".
  • bwiernik, that's what I had assumed, but in fact I never had "Display All Tags in Library" checked. Keeping it unchecked does remove from the tag list any tags that don't appear in the library, but selecting items within the library no longer filters out tags that don't apply to the selection.
  • Ah, I see that the tag filtering is working for collections, but not for selected tags.
  • That has to be a bug, right? Tag selections are still working in AND mode, so the display must too, else there is a mismatch in what is shown in the middle pane versus what is shown in the Tag selector.
  • It's a display bug with the "Display All Tags in Library" not adjusting when tags are filtered
  • The tag selector issue should be fixed in build 170.
  • Hi,
    When Zotero 5 will be realised :( I have been waiting it for 5 months.
  • @umitgunes Hi, there is a lot of answers on your question on the forum. Last from yesterday. If there is no ETA so you cannot get an exact answer. If you can use the new version of Zotero then use Beta. Beta 5.0 is stable enough for everyday usage, but there are still some issues which have to be developed or improved, and of course there is sometimes any error. So take to developers time for work, they get no many for their efforts, they will receive only our thanks.
  • Sorry for posting in the wrong place.

    These are two features requests concerning Zotero 5 :
    - It would be great to have a search fonction in the window "Source Code" of the note and also in the window “generate report from items”

    - Also, it's difficult to read in the tag windows, the tags containing several words because they are cut off (one way is to right click and select rename tag). It would be great to have a pop up showing the whole tag when hovering it.
  • I have installed Zotero 5.0 beta (for somebody else, on their laptop). Upon starting it requests that a user profile be created (something I have never seen before, including with my own installation of Zotero 5.0 beta). When I accept the default user location (in this case it is '/home/username/.zotero/zotero/rsedvz9h.Default User' I receive a message 'Profile couldn't be created. Probably chosen folder isn't writable...'.

    I have also tried to use another folder (such as '/home/username/Documents/Library', which in this case is the location the person will keep their Zotero library. Everything is then fine, the profile appears in the dialogue box, and Zotero starts. However, when one starts Zotero again, it asks for a profile without suggesting in the dialogue the previously created profile (the dialogue is blank and the only option is to create a new profile, again).

    I am mystified and unsure how to proceed.

    With grateful thanks.
  • This is on linux, yes? Which distro?
  • Apologies, I should have mentioned that: Ubuntu 16.10
  • Another useful feature that has changed: When sorting items into collections, in the previous version, hovering over a collection with an item would provide instant feedback that the item was already in the collection or not. If not, the collection would be highlighted. Now the collection is highlighted even if the item is already in it.
  • I add my vote to @zurpher suggestion about handling very large databases and to the two feature request from @Whateverr

    I would like to add another features request for Zotero 5: it would be great to be able to remove the formatting in a note with the shorcut ctrl+space. Actually it would be great to be able to add custom shortcut
  • yusuf martin:
    Upon starting it requests that a user profile be created (something I have never seen before, including with my own installation of Zotero 5.0 beta). When I accept the default user location (in this case it is '/home/username/.zotero/zotero/rsedvz9h.Default User' I receive a message 'Profile couldn't be created. Probably chosen folder isn't writable...'.
    This just sounds like an issue with either permissions or security software. The profile code (which we inherit from Firefox) creates a profile automatically, so the fact that it prompted at all likely just meant that it didn't have write permission to the default directory. And since it can't write to the default directory, it also can't store any preference pointing to another profile folder, which is why it's prompting again on the next startup. They'll have to figure out why Zotero can't write to ~/.zotero.
  • Thank you: I am unable to figure this out and have therefore installed Zotero Standalone and will wait for 5.0 to be released - perhaps the upgrade will solve the problem.
  • Today the Firefox plugin for 5.0 beta mysteriously disappeared (on Ubuntu 16.10, Firefox 52.0.2). I do not know why, or where to obtain it from (nor do I recall where I obtained it from upon installation). Is it part of the installation and should I therefore reinstall Zotero?

    With thanks, and apologies if I am missing something obvious (which is highly likely).
  • Very kind, thank you.
  • Thanks in advance for the upcoming Zotero 5.0 release.

    I just wonder whether there will be any issues if some users of a group library keep using Zotero 4.x while others make the switch to Zotero 5.x. Due to missing super user rights, this will be the situation for a medium/long term in our case (The firefox add-in does not need super user rights).

    Furthermore, I would like to encourage you to take your time with the Zotero 5.0 release to make it a good experience with regard to stability and performance.
This discussion has been closed.