ZotFile - Advanced PDF management for Zotero

  • Hi Everyone, I have a problem:

    My set up is - the Zotero source file is in the default folder, but I put the attachments (pdfs) in one folder of dropbox. But the problem is at work the dropbox was installed in the D drive, but at home the dropbox was installed in the C drive. I am not sure if it is the reason, but at home the files are not longer linked with the references, and I have to manually locate the files one by one.

    Any ideas? Thanks a lot!!!!
  • Hi - I'm a new user transitioning from Mendeley, and Zotfile's tablet features are potentially a big improvement. But, I'm getting these crashes too, so perhaps I can help with data points:

    Zotero Standalone 4.0.4
    Zotfile 2.3.4

    EzPDF on Cyanogenmod 9 (ie Android 4.0.x)

    When Zotfile tries to extract annotations it freezes with the progress bar and "press ESC to cancel", maxing out one CPU core.

    The file is not OCRed, and it has notes and highlights. Adobe Reader XI shows them all fine.
    If I try opening the PDF in pdf.js (the version in Firefox 21 beta), the notes appear but not the highlights.

    So, it looks as though there's a problem in pdf.js?

    I can forward a copy of this PDF if it helps - just let me know where to send it. Happy to help with further information as well.
  • Hi Joscha,
    first, thanks for this nice addon.

    Concerning the extraction of annotations, is there a possibility extracting annotations in single notes instead in one "big" note?

    Best regards
  • Creating huge amount of notes is currently discouraged in Zotero, so we'd ask Joscha not to do that. They affect sync performance significantly.
  • OK, it's clearly more complex than "highlights in EzPDF crash it", because I just did a test with a clean PDF and one note and one highlight in EzPDF and it was fine :-/
  • edited April 16, 2013
    First of all thanks for providing this great tool for the already great tool of Zotero (in my case the standalone version).

    My two questions are (as of now):

    Does zotfile actually move all the files from the original zotero standard directory to my new directory or does it creaty a second, renamed copy of it in the new directory? (I know that someone already asked, but only got an "I assume this is how it works" answer, as far as I looked through).

    If it creates a copy, do I have to leave the entire zotero structure as it is to be able to sync with zotero online or is there a way to get rid of all those ridiculously named subfolders?

    Thanks and best regards.

    [EDIT]: Actually, I tried to follow a particular file and it seems that the folder is actually removed from the original zotero storage folder and the file is indeed moved and not copied. If anyone could confirm that this is not a bug, I would be really glad. [/EDIT]
  • Hi Josch,

    first, thanks for the nice add-on. Me and some of my colleagues are looking for a solution to easily manage files outside of the Zotero database, that is, have Zotero move them to a specified location and store a link to that location in its database (instead of attaching a copy of the file). And since that would be similar to the tablet sync feature of ZotFile, we wondered whether we might just file a feature request. Is there a chance that you could include a feature along these lines in the next version of Zotfile?

  • Thi is exactly what Zotfile does. I, and many others, I guess use Zotfile to store our attachments to a Dropbox folder... So no need for a feature request, if I understood you correctly.
  • What ZotFile does is quite similar, yet not quite the same; at least that was my impression after playing around with ZotFile for a while.

    ZotFile takes an existing attachment and copies it to another location.

    What we need is something that takes a file that is not yet attached to an entry, copy it to a defined location, rename it, and then add a link to that file to an entry.

    I hope that clarifies it a bit.
  • I believe Zotfile does exactly what you wish it to do.

    If you open Zotfile settings, the first thing you see is "Source folder for attaching new files". Then, just right-click any entry, and select "Attach new file" (second to last in the menu, do not use functions in the "Add attachment" submenu, which is higher up).
  • Sorry, I wasn’t clear enough about what we need. The function you mentioned takes a file and moves it into the Zotero storage hierarchy, but what we’d like is that a file is copied into a folder of our choice that is *outside* of the Zotero storage hierarchy (and that this file is linked to an entry and renamend according to metadata).
  • hwileniu is right - that is possible. Check the Zotifile preferences and select "Custom Location" under "Location of Files"
  • Now I get it! Apparently my attempts to reduce my caffeine intake show side effects ;-). Thanks a lot!
  • I am having the problem discussed several pages back on this forum concerning Zotfile not moving pdfs to the tablet transfer folder. I get exactly the same error message as mentioned before: "attachment skipped because it is a top level item, snapshot or the file does not exist.

    I am running Zotero 4.0.5 with Zotfile 2.3.4 on Windows 8 64 bit. I have spent several hours double checking my set up and searching the web for a solution but so far all I have found is this forum which states that the problem was fixed in an earlier version of Zotfile.
  • When trying to use a tablet to mark up a paper today, I'm finding that every time I add an annotation, ezPDF saves the PDF and Dropbox syncs it... and Dropbox decides that it has a sync conflict, and creates a new copy of the file.

    Has anybody else experienced this? It makes the Zotfile tablet workflow pretty much unusable :-(

    I've made sure that Firefox and Zotero are closed everywhere, so no other machines should be interfering with Zotfile's Dropbox folder.
  • Before the update to zotero, I used to be able to extract annotations with zotfile, but now doesn't work anymore. I'm using the most recent version of zotfile, 2.3.4;zotero for Firefox 4.0 .5;zotero standalone 4.0 .6. When I tried to extract annotations, I get the progress bar that says it's extracting, but when it finishes, there are no extracted notes. I'm using a PDF annotator for iPad – PDF notes – to make the annotations; I also tried good reader for iPad to make the annotations, and that didn't work either, though it used to. Is there any solution to this problem? Thank you
  • ekcheng2, are all pdfs not working or only some? Did you try with the same pdf that used to work? IF you tried with the same pdf that used to work, I need a reproducible error and might be able to do something.

    David Pollard, I can't reproduce this. Any chance you are selecting "top level item, snapshot or the file does not exist"?

    swaldman, this does not seem to be related to zotfile...
  • Can anyone send pdfs for which the extraction of annotations does not work with pdf.js (extraction fails or the spaces are screwed up)? I am testing a new version with improved extraction of pdf annotations.

    But please only send files for which (a) you can copy & paste meaningful text from the pdf file in your pdf viewer (open your pdf viewer (not the browser plugin), select text, copy and paste it somewhere) and (b) the pdf annotations follow the normal standard (skim, for example, has an own annotation standard).
  • Strictly speaking no, my issue is more one of EzPDF and Dropbox. I was hoping that others here who use Zotfile with Dropbox might have encountered the same.
    Apologies if that's considered off-topic here.
  • extraction worked with PDFs where it had worked before the update, but doesn't seem to work on any newly added annotated PDFs
  • edited April 23, 2013

    I have a straightforward PDF for which extractioon of annotations is not working, with version 2.3.4 (script is unresponsive) or the beta version on github (script just seems to stop). Linux, FF 20, Zotero 4.0.6.

    But how do I send it to you for testing?


    Just to add, I checked the error log:

    [JavaScript Error: "TypeError: file is undefined" {file: "chrome://zotfile/content/zotfile.js" line: 252}]

    This was a PDF I downloaded from IEEE, then annotated with EZPDF.
  • ekcheng2, I am not sure whether I understand you correctly. Extraction does work with "old" pdfs or not? If it does, the new pdfs are most likely not supported. If it does not, I need a reproducible error with the pdf.

    scottcampbell, you can join the zotfile group here https://www.zotero.org/groups/zotfile. I will confirm your membership so that you can upload files, add comment etc. Please attach pdf files to zotero items and not just as independent attachments.
  • Hi Joscha, Life saving program btw :) I've a pdf I can't extract- happy to upload, have requested debug group membership
  • You are both members now and can upload files...
  • When I extract annotations (highlighted text) from PDFs, only the first highlight on any given page is displayed. Here is my info:

    Zotfile 2.3.4
    Zotero 4.0.6
    Firefox 20.0.1
    Windows 7

    If I had three highlighted segments on page 1 and four highlighted segments on page 2 when I select extract annotations in Zotero I will have a note that only has two segments (the first segment from each page).

    I have tested new and old annotated PDFs, PDFs marked up on an iPad in GoodReader, as well as PDFs marked up by Acrobat and by Adobe Reader. I have tried the same on two different PCs. The result is always the same: one highlighted segment per page is displayed in the note.

    I am not getting any error messages in the Error Console when I run “extract annotations”
  • ZotFile is a fabulous thing. I've been using it to sync between the Mac and the iPad, but when I recently added the notes-column to those being shown on the Mac, I discovered that all the files I've sent to the iPad show up as having an extra note (or just one, if there are no notes). This seems suboptimal. Is it a ZotFile problem? If it is, any chance of a fix?

    Mac OSX 10.8.3
    Zotero standalone 4.0.6
    ZotFile 2.3.4
  • LauraBaum, this is already fixed in zotfile 3, which is under development. But it's going to take some more time so I just sent 2.3.5 to mozilla with just this fix. You can also download it from here.

    gpatten, I guess that is because zotfile is storing some information in the notes field of attachments (you can see it when you click on the attachment). Do not remove this information! Unfortunately, fixing this would require rewrite a lot of the tablet-related zotfile code so that there is no easy fix and it won't happen for now.
  • edited May 5, 2013
    Since the new updates to Zotero and ZotFile, I was just wondering what zotfile does that Zotero still cannot do? Can Zotero download/attach/rename/move pdf's yet?
  • edited May 5, 2013
    I recently upgraded (versions below), and now I can't rename attachments (nothing at all happens if I right-click and choose "rename attachments"). Extracting annotations seems to be fine.

    I'm running:
    Zotero 4.08
    Zotfile 2.3.5
    Firefox 20.0
    Mac OS 10.6.8

    My rules for renaming are:
    Location of files: /Users/[myname]/Desktop/Zotero attachments
    Use subfolder defined by /%T

    Format: %a %y %t
    and normal settings under renaming rules.
    "Use Zotero to Rename" is not checked.

    Any tips on how to get this working again?
  • Hi Joscha, I use both the OS of Ubuntu and Windows7 in my PC, it seems the PDF attach added by Zotfile is not compatiable with dual-system. For example, I add a attach in Windows and switch to Ubuntu, the attach is lost, though I have specified the custorm storage place of the exact same folder. By contrast, while using 'storage a copy' method which is provided by Zotero itself, everything is OK.

    I guess that the absolute (or relative) path used to specifying a file in this plugin take responsible of this issue.

    My zotero version is: 4.0.8
    Zotfile version is: 2.3.5
    Firefox version is: 20.0.1

    Thanks for your great contribution, the plugin is really helpful.
This discussion has been closed.