ZotFile - Advanced PDF management for Zotero

1161719212261
  • edited January 21, 2013
    I alway define short title, because the automatic short title is often really useless...

    I juste see youe answer, Joshua. Thanks!

    edit: It works fine for me!
  • Further to my comment in the General thread (advanced attachment renaming: ZotFile alternative), I would like to suggest the following changes:

    1. Add a "ZotFile" submenu in the menu that pops up when an item in the Zotero item pane is right-clicked. This submenu should contain the "Attach New File" and "Manage Attachments" buttons/links (and possible forthcoming new ones...). Look at how "Zutilo" does this.

    2. In the "Renaming Rules" of the "Zotfile Preferences" only "Patents" has its own format. I would very much like to have specific formats for "Journal Article", "Conference Paper", "Book" and "Book Section". By the way, there is a typo in the current heading "Format for all item types...": The word "expect" should be replaced by "except".

    3. In order to implement what I describe in 2. above, one would need a new wildcard for Editor(s): "%E", say.

    Thanks once again for "ZotFile"!

    PS. When can we expect v. 2.3 to become available?
  • I found the problem with the none-working shortcut cmd+shift+E. It is Zotero itself causing the trouble, when the option "try to overwrite conflicting shortcuts" (I am on a german system so this is my translation) in Zotero's preferences is active. It is strange, as I don't have E assigned to any of Zotero's shortcuts. I'll ask the devs.
  • edited January 24, 2013
    As a follow up on my previous postings, I can report very successful applications of the new, enhanced naming convention introduced in 2.3Beta (a.k.a. 2.2.99). This is a major step forward in the usefulness of Zotero. After spending several hours playing around with the new wildcards, including the conditional (optional) rules, I would like to suggest the introduction of a negation operator, "!", say, that can be put in front of an appropriate wildcard character to test whether the corresponding descriptor is not present. For instance "%!n" would be true if a patent number is not present as is the case for a patent application (not approved yet) and could be used in a construct something like Pat_{appl%!n} to produce "Patent_appl" when there is no patent number. A more elaborate example would be Pat_{no_%n|%!nappl} which would produce "Pat_no_123456" if the patent number is 123456 (you get the idea), but produce "Pat_appl" if there is no patent number.

    In addition to introducing an %E% wildcard for Editor(s) that I suggested earlier, I would also like to see a null wildcard, "%0" say, that can be very handy in certain situations.

    Finally, I would like to report what I think is a misfeature and a bug in 2.3Beta. It is related to the functionality of "Zotfile Preferences..."-->"Renaming Rules"-->"Update". A changed naming format for anything but a patent does not have effect unless one hits "OK" to leave the menu and then opens it again. In fact, for a patent hitting "OK" seems not to update the content of the "Update" window at all (whereas the naming of the actual patent attachment file seems to work fine). It would be nice to have an "Apply" button in addition to the "OK" button and the patent update bug fixed (if indeed it is a bug).

    This is on Windows pro 64 and on Xubuntu 12.10 using Firefox 18.0.1 on both of these OS's.
  • Joscha, thanks for your reply. I installed the beta and completely emptied my library, including deleting my group library I used previously. Now, everything works fine.
  • Hi folks, hope this hasn't been discussed already, but I have a small (big?) issue with syncing my files between two different computers:
    both computers are mac s so that is not the problem, however, for organisational reasons I have a different username for one mac so that the folder where the pdfs are stored:
    (/users/username/documents/zotero/library )
    is different because of the different usernames...
    is there any work-around here? I have no idea and would be devastated if that could be the end of my happy sync experience...

    cheers, obsrvng_obsrvrs
  • that would work well with Zotero's file syncing: http://www.zotero.org/support/sync#file_syncing using either webDAV or Zotero file storage, but not with files linked to Zotero (e.g. using Zotfile, which is why I assume you're posting here?).
    Relative paths for links are planned and may be in the next major release of Zotero, but the patch hasn't been accepted yet:
    https://github.com/zotero/zotero/pull/51
    (though Dan sounds positive about its general prospects).
  • obsrvng_obsrvrs: You can create symbolic links to recreate the folder structure from oner computer on the other. Then this would leave you with only the problem of keeping the two computers in sync.

    I would recommend using stored files instead of linked files.
  • I've used Zotfile to rename attachments and move them, so they've now become links. However, I want to move them again (into a folder on Dropbox)...if I use the "rename attachments" feature, the pdfs get moved, but the link in Zotero doesn't update, so I'm left with a pile of items that can't find their attachments. Is what I'm trying to do even possible, or am I out of luck (short of removing all the items, re-importing them, and moving/renaming the fresh entries, which I'm not willing to devote the time to do)? Thanks!
  • edited January 29, 2013
    I've used Zotfile to rename attachments and move them, so they've now become links.
    They are probably not "links" but attachments in your Zotero library ("storage" subdirectory of your Zotero dir) as it's the default. You can check in the Zotfile prefs (under "general setting" tab; "Location of file" heading).
    I want to move them again (into a folder on Dropbox
    "Tablet Settings" tab; "Use Zotfile to send and get files from tablet" option; the "Base Folder" can be a dropbox folder. Then you just have to right-click on an item to send it/ get it back from the dropbox folder.
  • you could also look at the Zutilo plugin for Zotero, which allows you to batch change filepaths:
    https://addons.mozilla.org/en-us/firefox/addon/zutilo-utility-for-zotero/
    (I'm not using Zotfile's rename and move feature, so I don't know much about it, but it seems to me that using the tablet function for that isn't great, no?)
  • @adamsmith: I might have misunderstood mbanzovino's request but if s/he wants to get her/his attachments back later, the tablet function seems a solution to me..? Otherwise, Zutilo deserves a try.
  • It's possible the tablet function will work for what I'm trying to do, but I'd rather they sync automatically from within Zotero rather than having to send/get each file. In playing around with Zutilo, I realized I had spaces in my folder-creating hierarchy (within the rename/move function of Zotfile), which was causing the problems. Removing the spaces from the folder names allowed me to do what I was trying to do! Thanks for your suggestions.
  • A few days ago someone reported a problem with the "Extract Annotations" command. They were getting text with no spaces. I have the opposite problem - text with spaces where they don't belong. For example:

    "Fir st, th e Court left unr esolved th e ten sion between pr ivate in dividuals' con stitutional r ight to for m expr essive association s pr edicated in par t on discr iminator y dogma, an d th e legislative power of th e major ity to expr ess its disappr oval of th ose beliefs by declinin g to fun d such discrimin ation"

    I've tried different PDF files (some scanned from existing texts, others created directly from word processors) and have used two different PDF readers (PDF-Xchange and Acrobat Reader). When I manually copy the text it comes through fine. I even loaded a file into
    http://mozilla.github.com/pdf.js/web/viewer.html
    and the copying worked fine there too.

    I understand that there is a problem with pdf.js. Is there any work-around to make this command function properly? Is there a way of creating the PDFs so that the text can be extracted properly?
  • IIRC, the extracting code used by ZotFile comes from an older version of pdfjs. Someone has to update it...
    https://github.com/jlegewie/zotfile/pull/8

    In other cases, even pdf.js is still at fault, e.g.: https://github.com/mozilla/pdf.js/issues?labels=4-text-selection&page=1&state=open
  • Thanks for that quick reply. So, if I understand correctly, help is on the way? If so, I'll keep annotating my PDFs in the hope that I can extract the annotations correctly someday soon.
  • "Soon": I really don't know...
    How did you create those PDFs?
  • Some are scans, which were OCR'd either by the scanner or through PDF-Xchange. Others were created by printing a word processor document using doPDF.

    Is there a way of creating PDFs which would avoid this problem?
  • Version 2.3 of zotfile is now under review at mozilla with quite some changes. Here is a changelog. A lot of the new features were implemented by community members and the future development of zotfile largely depends on such contributions!
  • @mronkko - that solved the problem THANKS! Just figured it out and wanted to come back telling the good news just to find you having given me the information days ago...
    Big thanks...
    Basically I set up a fake user using the user name of my other computer and put the symbolic link into the folder of the fake user account where it is on the other mac. That solved the problem.

    However one question I might ask: why would you prefer stored files over linked files?
    I use zotfile to rename them and store them in folders - combined with quicksilver and its mindblowing file manipulation features ;) this is a very powerful pdf-storage system!!
    The Library folder I keep in sync with dropbox - with macdropany - works perfectly!
    Now with symbolic links all my problems melted away...

    The thing I don't like about stored files of zotero is that it stores them in cryptic folders and under cryptic names... and when I search for the pdf but don't want to use zotero (like with quicksilver, finder, whatever..) then I've got a problem, right?
  • The main advantage of stored files is that they work with Zotero Storage, which means you can access them through zotero.org, you can share them in groups, you have a better workflow using mobile devices (e.g. the bookmarklet will attach files to items if you're using storage), you can use them across different OS (the symbolic link solution won't work with a Mac and a PC, e.g.).

    While files are stored in cryptic folders using storage, Zotero does automatically give them reasonable names (or you can have Zotfile rename them while leaving them in storage - the difference really is a matter of taste) and if you want them in a human-accessible place you can easily enough set-up a virtual folder with all PDFs in one place (no folder structure, though), so no, you don't really have a problem if you want to find a PDF with Finder or Quicksilver.

    Obviously YMMV and dropbox/ZotFile may be a perfectly suitable solution for your purposes.
  • edited February 6, 2013
    When using the rename attachments feature of Zotfile, it copies the files instead of moving them, so there are 2 copies of the file instead of one. Is this what is supposed to happen? The documentation seems to indicate that it should be moving them.

    I'm using Zotero Standalone 3.0.11.1 and Zotfile 2.2.4 on Mac OS X Lion (10.7).

    I'm also using the feature where the files are moved to a specified folder and linked in Zotero. I'm not storing them in the Zotero db.

    Thanks.
  • As far as I know, yes, it is supposed to happen. ZotFile behaves like Zotero on this point.
    Are you referring to the message in the General Settings tab of the ZotFile prefs?
    ZotFile can move new and existing attachments to different locations. You can either store a copy of your attachment files in Zotero, which allows you to sync files to the Zotero server, or move the file to a custom folder and link to that location from Zotero
    That's true that "move" is not accurate in this description.
  • Hi there,

    I'd like to use Poppler to extract PDF annotations. I'm on a mac, running Zotero standalone. Unfortunately, when I go to 'Advanced Settings' and click on the button to install Poppler, it changes to "Downloading Poppler Tool...", which never actually completes. Is this a known bug? I've tried this many times over several weeks, and Poppler has never been installed. Is there some way to download and install the Poppler tool manually? This would be a big help to me. Thanks!
  • Yes, there is a bug in the last versions, which is fixed in 2.3. You can download it from here or wait until it passes the Mozilla review.
  • Hello! I am writing to tell you that when I try to add a bibliography to Zotero zotfile not rename or place the file in the folder that I assigned. I get the following error:

    New Attachment File Automatically renamed to "undefined"

    Zotfile untreated gets an error while moving the attachment with name "articulo.pdf. Error details: [Exception ..." Could not convert JavaScript argument arg () [nsIFile.move.To] "nResult: 0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)" location: "JS frame :: chrome :/ / zotfile / content / zotfile.js ::
    :: Line 1032 "data: no]

    I'm using Firefox 18.0.2

    I hope you can help me.

    regards
  • I am not the developer, but I am sure it would be useful if you can list the exact steps that lead the error so that others can reproduce it.
  • HI Greg!

    The error occurs when I try to manually attach a file to a bibliography of my Zotero library and also, when I add a bibliography automatically from the icon located on the navigation bar.

    The plugin can not rename my files, or store them in folders that I pointed out, showing the error I indicated above.

    Probably because it does not support zotfile firefox 18.

    I would like the plugin author could find out this error.

    regards
  • Hi,

    When I try to use %F as part of a subfolder, what returns is a folder called "F" and not a folder with LastNameFirstInitial.

    Is this a bug?

    Thank you!
  • The automatic adding of attachments isn't working for me, using Zotero Standalone, Mac OSX and Chrome.

    I'm printing to PDF from a webpage with the relevant entry selected in Zotero, but nothing happens, not even a notification or error message.
Sign In or Register to comment.