ZotFile - Advanced PDF management for Zotero

1222325272861
  • edited August 20, 2013
    Hi Joscha. As always, a huge thanks for your efforts to create zotfile.

    I am having a new issue that cropped up in the past week. Every time I open firefox, I get my homepage plus a new tab with the zotfile page and the zotfile changelog. I also get two popup notices in the lower corner saying something about not deleting files manually. Any thoughts? I am using Zotero standalone and all files/updates are up to date.
  • Help! After the millionth Firefox prompt, I installed the newest version of Zotfile, and now pdf extraction doesn't work, period. I've tried it in Standalone and Firefox, and I've tried it on pdfs where it worked before.
  • lplummer, zotfile should just open the changelog once after you update to 3.0. Anyone else having this problem?

    rahulm82, without more details and an error message I can't really do anything: http://www.columbia.edu/~jpl2136/zotfile.html#bug
  • There are no details. There is no error message. It says "Extracting annotations" and then the little task-bar thing stops moving and it hangs up forever, until I hit Esc. My system is Windows 7.
  • Hi Joscha

    I have same problem as Iplummer with a tab opening every time I open Firefox. I also have everything updated.
  • What is your FF version, OS and can you check about:config for the preferences 'extensions.zotfile.version' and 'extensions.zotfile.zotfile3update'? I need that information from both of you.

    rahulm82, you can upload a pdf somewhere that used to work in zotfile 2.x and doesn't work in 3.x. In general, without a reproducible error, I can't do anything.
  • Hi Joscha/Iplummer

    I solved the problem of the tab continuously opening every time I open Firefox by going into about:config and changing the extensions.zotfile.version value to 3.0.2. I'm not sure why it didn't update automatically when installing the latest version of zotfile. This is probably not the best way of fixing the problem I guess.....
  • It would still be good to have the info? Which FF version and what was it before you changed it manually?
  • Joscha

    I've got FF 23.0.1 and the previous value for the parameter was 2.3.5. Hope it helps.
  • Is there any way to have Zotfile use a consistent numbering convention for sequential PDFs such as volumes of a book or journal? I realize that attachments currently can't have metadata of their own, but perhaps Zotfile itself could keep track of the order in which PDFs were added? Currently, I can drag multiple volumes in one by one, but if I click "rename attachments" at any point afterwards, the numbering gets totally screwed up. This is the case for any item that has more than one PDF attachment.

    Sorry if this has been posted before.
  • I also had the same problem as lplummer and ifest with the Zotfile tab and popup appearing everytime I opened FF. This started after the update last week. I am using Win 8, FF 23.0.1. When I checked about: config I saw that extensions.zotfile.version was set to 2.3.5. I changed to 3.0.2 (as iftest did) and it appeared to fix the problem.

    Hope that helps and thanks for the plugin!
  • I will try to fix it tomorrow. Can anyone report whether there is an error message in the console after startup before manually changing extensions.zotfile.version (or after changing manually changing it back)?
  • Hi joscha, fantastic plugin.

    There is an irrelevant CSS error in the console before changing: "Unknown property 'box-sizing'. Declaration dropped. " but there's no mention of preferences etc.

    FWIW, I've also got FF 23.0.1 and the previous zotfile version was 2.3.5
  • @scottcampbell

    I've run into exactly the same issue: Zotfile corrupts highlighted text when extracting it. Comments/Stickies are extracted fine. Did you find a solution?

    Zotero 4.0.11 Standalone on Ubuntu 13.04 x64
    Zotfile 3.02
    GoodReader 3.10.2 on iPad4

    Opening the same annotated PDF in Acrobat Reader (iPad), Okular and Evince renders highlights and comments without a problem. Cut/paste of highlighted text into external editors works fine, so there doesn't appear to be an issue with the PDF encoding...
  • @scottcampbell and johnhill, the pdf format is very complex and some files will always make problems. On Mac OS, you can try the poppler based extraction, which might work. You can upload an example file somewhere and I can see whether it works. If the file is incompatible with the pdf.js based extraction, I won't be able to do something about it. An update of pdf.js might solve the problem at some point but that is going to take time and I will only update zotfile to the most recent pdf.js version once a year if at all. Takes a lot of time and nobody was willing and able to help so far.

    repeated opening of zofile page: Anyone with an error message? I have problems pinning it down without an error...
  • @Joscha
    As you say I think the problem stems from how this PDF was created. It was converted from Kindle azw to pdf using Calibre. I suspect the additional (within word) spacing is something to do with text justification. Perhaps pdf.js is is reading a different "layer" of text to other viewers, who can read/cut/paste without a problem.

    Re poppler: I believe Okular uses a poppler backend on Linux, unfortunately it lacks any export/extract tool.
  • @scottcampbell I was able to recover my highlighting from GoodReader (iPad) > Export (box arrow out) > Email Summary
  • @ifest Thanks for the fix!

    @Joscha I am using FF 23.0.1 and the previous zotfile version was also 2.3.5. Again, a huge thank you for all your hard work.
  • EXTRACT POP-UPS AS WELL AS STICKY NOTES FROM PDFXCHANGE DOCS?

    I want Zotfile to extract "pop-ups" as well as sticky notes from PDFXChange modified PDFs. Currently sticky notes do not extract. Thx for consideration!
  • This is not strictly a zotfile problem, but I don't know where else to post, apologies in advance.

    I previously set zotfile to save attachments to f:\pdf\zotfile (Windows xp), but recently had to reconfigure my hard disks so that zotero's linked attachments are now on d:\pdf\zotfile.

    I reset the zotfile custom location (general preferences \location of files) to d:\pdf\zotfile, and when I store a new file, zotfile puts it into d:\pdf\zotfile, so zotfile custom location is changed, no problem.

    Here is the catch: Zotero shows the recently saved d directory file no problem, but does not show any of the old attachments, all located in the same directory!

    I re-reconfigured the hard disks to put back f:\pdf\zotfile directory, and the old attachments all show up again.

    So I see that zotero has saved these attachment names under the f directory, and the zotfile preferences aren't able to change this.
    My misunderstanding.

    Is there a way I can make zotero change all the attachments saved under f:\pdf\zotfile to d:\pdf\zotfile? I have tried setting the linked attachment base directory under zotero's file and folder preferences to the d directory and it didn't help.

    Don't really know where else to put this question, would appreciate any references you could give.
  • you should be able to do this with zutilo:
    https://addons.mozilla.org/en-us/firefox/addon/zutilo-utility-for-zotero/
  • Yes, zutilo is the answer!
  • I use the tablet (synchronisation) feature to send my PDFs to the tablet and retrieve them back into Zotero (v3.0.2) through annotation extraction to get my highlights et al [I use DropBox to send/receive files]. It has been working fine except today when my wireless connection dropped out on my laptop.

    I had made various annotation changes to the files on my ipad and synchronised them to Zotero. I then selected each file in Zotero and chose the 'get from tablet' menu option. What I did not notice was the (as the laptop was disconnected) there were no files for it to retrieve - so Zotfile marked the file as retrieved from tablet without any annotations (understandably).

    After I worked out that my laptop was disconnected I connected it and then went to re-retrive the files - but Zotfile would not let me. The option to 'get from tablet' was disabled.

    I've tried copying the (changed) PDFs from my dropbox off to another directory (to keep them safe) and then sending/getting the PDFs via Zotfile (copying over the files before retrieval) without success.

    1. First question is - how to fix my immediate problem?
    2. Second question - why is the 'get from tablet' function disabled (esp. considering the use of a third-party storage / synchronisation service)? Shouldn't I be able to determine if I want to re-retrieve the files (because I've copied them again from my ipad)?

    Thanks for a great and very useful tool.
  • Hello there,

    I have a feature proposal for Zotfile: it would be very useful if one could set different renaming rules for different file types.

    As an example, my use of this feature woulb be renaming PDF files as 1stauthor-year-title.pdf and keeping title unchanged for other file types.
    I store in Zotero PDB files of structures published in http://www.pdb.org in same parent items as PDF files of articles describing the structures, it's very useful to have quick and easy access to both an article and the related PDB file. The proposed feature becomes useful because I would like to move all attachements outside of Zotero storage directory, but with PDB files keeping their PDB id as names and not being renamed the same way PDF files are.

    This feature could be useful in other fields, as managing different file types is certainly common.
  • edited October 3, 2013
    Hello,
    Thanks a million for Zotfile. Has rahulm82 solved the annotation issue? I'm experiencing the same issue as rahulm82 posted on Aug 20th 2013, whereby the 'extract PDF annotations' message hangs infinitely, but can be cancelled with ESC. This behaviour started ~mid-August 2013. I'm running firefox 23.0 with Zotero 4.0.12 and zotfile 3.0.2 (extensions.zotfile.zotfile3update = TRUE) on GNU/Linux Ubuntu 12.10. UPDATE: I'm also experiencing the same problems in Windows7 running Zotero/Zotfile in 'Waterfox' (i.e., firefox 64-bit version).

    Also, a note on the origin of the pdfs: they are being sent through Zotfile to a dropbox folder on my Ubuntu desktop, then synced to an android tablet, highlighted/annotated with Acrobat, re-synced to my desktop, and then I have Zotfile monitor my desktop Dropbox folder for updates to PDFs (i.e., the annotations). The cross-syncing of highlists/annotations works fine.

    Just curious if any progress has happened. I have an example PDF that used to work but now fails.

    UPDATE: this problem still occurs on Zotfile 3.0.3
  • edited September 14, 2013
    About the replace blanks function, it is set to replace blanks with underscores "_" however, I am also using zotero together with jabref for some reason and like to replace the authornames spaces/blanks with "nospace" I did not find the setting for this in about:config. Is this configurable at all? and if so, where?

    I have an author "de Duve" publication date 2005, it should be deDuve2005.pdf but it creates either "de Duve2005.pdf" or "de_Duve2005.pdf"

    It would be best in my opinion to make the setting a string option instead of a boolean, so there will be a field to define the character for replacement, I could also choose "-" or leave it empty for no space or placeholder.
  • I have been using Zotfile for 2 years -- brilliant, Joscha, thanks for all your work -- to read and markup on my ipad (pdfexpert) and then import highlights and annotations back to zotero standalone on my win 8 laptop.

    I am now about to buy a windows 8 tablet (not RT) and will read the pdfs on there. My question is: how do I get the highlights all rounded up like zotfile does so nicely in zotero without the round trip to the reader on ipad? There is no "app" on win 8 for reading pdfs equivalent to pdfexpert or the like and acrobat does list highlights I think but does not link them with zoter. If all that is clear. Any thoughts appreciated.
  • So you'll be running Zotero directly on the tablet, correct?
    In that case, open the PDF directly from Zotero (if necessary using right-click "open in external viewer") just annotate in your preferred PDF reader (acrobat, foxit, pdfXchange) and save. The annotation will then be saved in the file in Zotero. You can then use right-click--> Manage Attachments --> Extract Annotations for the item (This is a Zotfile feature).
  • great! thanks adamsmith
  • Joscha,
    Thank you so much for the new update to Zotfile--the Goto annotation feature is wonderful. When I have used it for articles it has worked perfectly. However, there is one issue that has come up with PDF books where I wondered if there might be a fix. Frequently, when I extract annotations from a book, the page number listed doesn't equal the page number in the book, as there's usually front matter (Table of Contents, etc) at the beginning. So p. 1 of the book might be the 20th page of the PDF. This means that, in some cases, clicking on the "Goto annotation" link takes me to the wrong page. With some files it works well, with others, not so well.

    (FWIW, from what I can tell, the Goto annotation links work well when I using a book that I have scanned myself. When I use an ebook I have purchased that came with an outline in the PDF, things can get wonky.)

    Any help would be appreciated.

    John
Sign In or Register to comment.