The new Note Editor is very slow

Hi,

I just wanted to let you know that the new Note Editor is way too slow. Sometimes it takes more than a minute for it to respond when I open it or write something new.

Sometimes the whole Zotero freezes.

Otherwise, I am enjoying the new functionality very much. Thank you very much for introducing all this.
  • Is this in long notes or just in a new note? Could you submit a debug ID for an action that takes a long time and post the ID here?
    https://www.zotero.org/support/debug_output
  • Sure, thanks.

    Here we go: D1111671235.

    This happens with/in both existing and new notes.

    Thank you!
  • edited 21 days ago
    I want to confirm this. Using 5.0.97-beta.18+1eb888d02 on Linux (Debian-based distros) and comparing to the non-beta, old note system, notes:

    *) take longer to load
    *) and suffer from lag -- a period of a second or so between typing and characters appearing on the screen.

    EDITED TO ADD: The lag is intermittent. I can type out perhaps 15 characters with no lag, then it will lag for about 1.5 seconds, then I can type again, repeat. It reminds me of what used to happen in the old note system when Zotero was syncing, but the lag happens regardless of syncing or not.

    I've been using the beta for the past month and have been updating regularly, and the note-taking lag is still there. I'm now taking notes in a text editor and pasting them in.

    However, I love all the new functions (though I still request highlighting colors be brought back in notes). The lagginess reminds me of when Zotero first went "standalone" so I'm confident this will improve.

    Let me know if you need more information.
  • edited 21 days ago
    I think what octavabasso describes is related to my experience with the note editor: https://forums.zotero.org/discussion/89257/beta-new-note-editor-frequently-freezing

    The lag is just a second or a few seconds in my case.
  • @auster @octavabasso @enozkan How many notes, approximately, do you have in your libraries? You can see the number in a PDF reader tab's all notes list inside the "x more..." button. As it's likely that notes count correlates with the lag.
  • @martynas_b I have about 9000.
  • edited 18 days ago
    I have >5,000. And all but a few of them are from an automated EndNote import, and have the following structure:
    The following values have no corresponding Zotero field:label: r05257
    accession-num: 28775344
    auth-address: Allen Institute for Brain Science, Seattle, Washington, 98109, USA.number: 9
    work-type: Review
    They are all in one collection, and I don't need the notes. I'll have to look into deleting them with a script.
  • (I don't want to re-start the Extra vs. Note wars, but this may be a reason to dump these into Extra?

    Also, all the accession-num here are PubMed IDs, and auth-address and work-type are self explanatory. Maybe they can be matched better to an existing or soon-to-exit CSL field during EndNote import?)
  • @enozkan -- I don't think you'll even need a script to delete these. You can just do an advanced search for note contains auth-address, create a saved search, select all, and delete.

    The PMID I'm pretty sure is specific to your Endnote export. I don't think that's more generally true for the accession-num field, and since PMIDs don't have a specific pattern, we can't check.
    auth-address is just something that Zotero genuinely doesn't cover, and while it's debatable whether Zotero should, I think it's pretty clear that it's not something CSL would need (you may want affiliations in your metadata, but you definitely wouldn't cite them)
  • Thanks @adamsmith . I'll make sure not to accumulate notes in the future through bulk actions like these.
  • edited 18 days ago
    I have about 1700 notes, and experience the same 'lag' when typing. All notes are 'real' notes, though many of them come originally from Zotfile extraction. But deleting them is no option.

    debug ID: D1827161246
  • edited 16 days ago
    After more testing (on an Ubuntu 20.04 machine), the note system is just fine working on a standalone note. In my case, I'm taking notes on a web page.

    I think the problem is the note-PDF reader combo.

    EDITED TO ADD: Testing a note with the PDF reader and the lag is happening. So: note-taking without PDF reader is working fine; note-taking with PDF reader open lags and freezes for a second or two every 40 seconds or so. I've seen this while sync is running and while it is idle.

    EDIT #2: Now, the standalone note is lagging, despite the PDF reader tab being closed. This is all on the same session:

    *) open up a note, have it in a separate window. Take notes and all is well. Close the note.
    *) Open a PDF in a tab. Open a note associated with the PDF. Lags, freezes, etc. Close the note. Close the tab.
    *) Open a new note. Open it in a separate window. There is lagging, though it is less frequent.
  • I can confirm octavabasso's observations.

    Note taking is only difficult if one has started the PDF reader in that Zotero instance. If I freshly start Zotero beta with new PDF reader/note editor enabled, and go straight into editing a standalone note, there are no repeated freezes or lags.

    When the note editor is experiencing freezing/lagging, it also happens in the pdf reader as I try to scroll or annotate in it. The whole experience is effected.
  • @auster @octavabasso @enozkan @ppraet We've just rolled out a new update. Please try it out and see if notes freezing/lagging still happens.
  • Thanks! I tested it. The problem persists -- in fact, it might be a bit worse. Note-taking works without the PDF reader tab open. With the tab open, the reader and note freeze up when I try to scroll the PDF, and note-taking lags considerably from that point on.
  • Same experience here, though I don't find it worse than before. But I've tested only very briefly.

    D1915113408
  • Same as the other users. No improvements on usability when PDF reader and note editor are both in use. Debug ID: D1385816763
  • edited 12 days ago
    Hi, I've had the lag/freeze issue with the new note editor since the beginning and logged Debug reports then but didn't find any solutions. It sounds very similar to what others are experiencing.

    I have about 8.500 notes.

    Since the latest update, the lag is so bad in the whole of Zotero that it's unusable. I can't even create a log to send to you. The coloured circle (on Mac) just turns and turns. It takes a minute to open a document.

    I'm going to try uninstalling the Beta version and see if the fully released version works. Any help welcome - I'm really enjoying the new note editor and the iOS iPad version, but this is causing too many workflow problems now.

    UPDATE

    I can't revert to version 5.0 because the database has been saved in a format that is only readable by the beta.

    I reinstalled the beta version and the problem seems to be the pdf reader. If I don't open any pdfs, I can use Zotero without any lag. As soon as I open a pdf in the reader, I get massive lag and Zotero is unusable again.

    This is a bit of a disaster for me as the only way I can access my research library is now on my iPad. Please can you help?
  • @mossposs While I can't help with the bigger issue, if the issue is the pdf reader in the beta version, can you try changing the preferences so you unselect the 'Enable the pdf editor' option, which should revert you back to opening PDFs the old way? That should at least mean you get access to your database while they are figuring it out.
  • @joycekwc thanks - yes this is what I’ve done for now. Also if I keep the pdf reader enabled, but only open documents on the iPad, That works. Very puzzled by why this has suddenly become such a big problem though.
  • edited 11 days ago
    The latest Zotero beta should speed up the note editor when the PDF reader has been opened in a library with many notes.

    If you've been seeing this, let us know if the new version fixes the problem for you.
  • Thanks @dstillman
    I downloaded and installed the latest beta version yesterday, and it’s still unusable if I open any pdf documents in the new pdf viewer. Is there a more recent version available?
  • Help → Check for Updates
  • Ok thanks will check later when I’m home
  • While I've only tested for a limited time, the most recent update to the beta (5.0.97-beta.22+12b100fd4) seems to have resolved the issue for me. Thank you!
  • The latest update seems to have fixed both the original lag problem with the notes / pdf viewer, and the more recent drastic problem that made it unusable. Thank you!! Looking forward to using the notes functionality even more extensively now. Brilliant!
  • Yeey! Looks good now! Thank you so much.

    What I've noticed though is that the Notes lags slightly when Zotero synchronises, and it does so after each new entry in the Notes.
  • Same here! I tested only very shortly, but seems ok now. Thx!
  • Happy to also report that 5.0.97-beta.23+d27b622f9 is working well with the PDF reader/note taking combination. I just read and annotated a 30 page PDF with no issues. Thank you!
This discussion has been closed.