[SOLVED] Zotfile for Beta not working

edited May 9, 2017
I installed Zotero 5.0 so that I could print report records... only now that I have this I can't generate report records for my purposes, as I did this from exported annotations (per Zotfile). Zotfile is not compatible with 5.0, so I have attempted to install Zotfile 5.0 and it won't work. The error I get is:

"The add-on "%S" could not be installed. It may be incompatible with this version of Zotero Standalone."

This is likely a user error... can you please check that I've understood correctly:

1. go to github
2. download 5.0 from the 'Clone/Downoad' dopdown menu
3. Extract files
4. Cut and paste files from 'zotfile' to root
5. Rezip
6. Rename extension to .xpi (I've tried just renaming the zip file, but Zotero can't see it to add)
7. Go to Zotero>tools>add-ons
8. Click on cog icon, select 'install add-on from file'
9. Navigate to xpi file and upload

I've tried this with and without the empty zotfile folder. Help!!
  • The procedure you describe accurately produces a successful zotfile install (v5.0b3) for me. (MacOS, Zotero 5.0beta193). After having unzipped the zotfile-5.0-folder just re-zip from "chrome" down to "readme.md" rename the new zip with "zotfile.xpi". Then proceed exactly as you describe.
    Not quite sure what you mean with the empty zotfile folder but you should end up with a folder called zotfile-5.0 that contains a) the unzipped content of the original zip you downloaded and b) the new zotfile.xpi that you just created. The latter should be importable to Zotero via Tools>add-ons.
  • edited May 9, 2017
    Thank you for your response.

    I just zipped 'from "chrome" down to "read.me" and then changed the filename to Zotfile and extension to .xpi, it didn't work. I've also tried only zipping the single files, and not folders contained in the extracted Zotfile Master folder. That doesn't work either. The error I am getting is:

    "The add-on "ZotFile" could not be installed. It may be incompatible with this version of Zotero Standalone."

    This is really problematic. This error has halted my work completely and I'm on a serious deadline.
  • edited May 9, 2017
    Edited: [SOLVED]

    For those that are unfamiliar with this, don't repeat the errors I made:

    1. Select the files and folders at root level and zip from there, don't place in another folder
    2. Make sure that the 5.0 branch is selected on github and not Zotero Master (when I went back this morning, I mistakenly selected the latter, thus the mistake).

    So, the steps above work - so long as you don't make the mistakes I made.

    Thanks once again to the community for their help!!! :-)
  • Hi All,
    I am running Zotero stand alone 5.0 beta and am hoping to use Zotfile 5.0 with it. I have a mac with Sierra running and I primarily use safari with zotero. I am not able to follow your instructions above and so am wondering if you can give more simple instruction for someone who is not a "computer wiz."

    I have tried this so far:
    1. I downloaded zotfile 5.0 from GitHub. It simply appears on my desktop as a "zotfile-5.0" There is no zip file as far as I can see.
    2. I clicked the folder "zotfile - 5.0" and then clicked "Makefile" within, and here's what pops up in Terminal:

    Last login: Fri May 26 15:40:00 on ttys000
    1375-Smith-MacBook-Pro:~ christophermiller$ /Users/christophermiller/Desktop/zotfile-5.0/Makefile ; exit;
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 1: all:: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 3: -include: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 5: shell: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 5: RELEASE:=: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 7: zotfile.xpi:: command not found
    zip warning: name not matched: chrome.manifest
    zip warning: name not matched: defaults
    zip warning: name not matched: install.rdf

    zip error: Nothing to do! (chrome.zip)
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 11: zotfile-%-fx.xpi:: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 12: $@: ambiguous redirect
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 14: Makefile.in:: command not found
    /Users/christophermiller/Desktop/zotfile-5.0/Makefile: line 17: FORCE:: command not found
    Saving session...
    ...copying shared history...
    ...saving history...truncating history files...

    [Process completed]

    3. I try to add the file in zotero by going to tools, add ons, install add-on from file, and then clicking on the zotfile-5.0 file from my desktop, and I get this error: "The add-on "%S" could not be installed. It may be incompatible with this version of Zotero Standalone."

    Any help is greatly appreciated. Working on a dissertation.

    Chris M.

  • edited May 26, 2017
    "Makefile" isn't something you can actually run.
    Open the terminal and use
    cd /Users/christophermiller/Desktop/zotfile-5.0/
  • (That would be make, not ./make.)
  • fixed, thanks
  • Sorry, but I am still not sure what you mean by that in terms of my end goal of getting zotfile running with zotero.

    I inserted what you said into terminal, and the computer had me install some kind of developer tool, but it's still not clear to me what to do next.

    Step by step would be greatly appreciated.
  • Nevermind! I figured it out. I was accidentally downloading Zotfile master so the "make" in terminal never ran.

    All good to go. Thanks for the help.
  • Is there an xpi available, or do I have do run the make command on a mac? Would rather not install the developer tools.
  • as Joscha says in the main ZotFile thread, he's going to release an easy .xpi soon. If you're in a hurry, you can also use the other method, i.e. just repackage and rename, though you'll need to follow them very closely (for some reason, most people seem to struggle with the instructions).
Sign In or Register to comment.