ZotFile - Advanced PDF management for Zotero

1131416181961
  • @Star7

    yes, I think that's what they are saying. Here are the instructions: https://sugarsync.custhelp.com/app/answers/detail/a_id/18

    @Joscha

    That's bad news. I was really hoping to get this working. I forgot to say that I'm running Zotero Standalone from within a DropBox folder on a TrueCrypt drive within a win7 Enterprise SP1 environment.

    Maybe I'll try the Firefox extension and see if that works as an alternative solution. Could Google Chrome be interfering with Zotero in some way? I have the Zotero Connector installed but I haven't gotten into the habit of using it yet.
  • @allegorical8

    I've have the zotero storage folder on sugar sync and have all computers point at it. However, double clicking on any item will not open the pdf file. This function only works on the computer where I move and rename the pdf files (i.e. localised).

    Any ideas?
  • @ Star7:

    Is the full file path to the files (e.g. C:\my\stuff\here) the same on each machine? If not, that's likely the problem.

    @ Joscha:

    I got the PDF annotation extraction working using Firefox (YEAH!) but now I'm having issues with the file attachment renaming (BOOH!)

    Here are some screenshots and an error report: https://dl.dropbox.com/u/2232125/Troubleshoot/Zotfile rename error.rar

    For the Location of Files setting on the General Tab of ZotFile Preferences (see settings 2 jpg), I want to set the Custom Location to be the current folder (i.e. I don't want to move the files). What is the correct syntax for this? These errors were generated when I put a "." in the "Custom Location" field.

    Thanks for your help.
  • edited August 20, 2012
    First of all, congatulations for the great add-on and iPad app.

    I am using Windows 7, Firefox 10.1, Zotero Firefox 3.0 and Zotfile 2.0, with "Use Zotero to rename" checked.

    If I 1) create a new item, fill the data (author, title, etc.)2)then I attach a PDF file and 3) then I try to rename it, it appears in the Zotero window with the new name, but the file's name does not change really. In order to have the file "truly" renamed I must 1) attach the file to a blank item, 2) fill the data (author, etc.) 3) rename the file. I think this should be a bug.

    Moreover, I would like to have the attachments automaticaly renamed. How can I manage to have it working?

    Thank you very much,

    Pedro
  • I am posting here because followers of this thread might be interested: ZotPad 1.1 is now available. Check out the original thread:

    http://forums.zotero.org/discussion/24956/new-version-of-zotpad-ipadiphone-client-for-zotero-available/

    (Any follow up should go to the original thread.)
  • HI, I am very excited about zotfile. Thanks for all your hard work in getting this addon working. I was hoping you might help me out. I am unable to get annotation extraction working on some of my pdf files. I am using the latest version of zotero and the latest version of zotfile. My version of FF is 13.0.1 on Mac OS X 10.6.8 Some files work fine but others just wont extract annotations. I can send you the file if that will help. Thanks again for all your hard work.
  • Hi, I'm also excited about zotfiles because I love the idea of having a folder of pdfs that will sync with my ipad so that I can read and annotate them. But I have been trying to set it up and am having problems getting it to do what i hoped it would.

    I have zotero on multiple computers syncing both the library and files with the zotero server.

    So what I have done is
    1) install zotfiles.
    2) Change Zotero on both computers to save my files on a webdav server and synced.
    3) Open a sugarsync account, set a zoterofiles folder on both computers, and in the zotfiles preferences set this folder as a custom location on both computers. I have highlighted everything in the library and renamed the attachments so that they will be moved.

    They did move, but on the computer that did not move them Zotero now reports that it cannot locate the files when I try to open them.

    If someone can help me I'd really appreciate it.

    I'm not even sure if every step I took was necessary or if Zotfiles is capable of allowing the the files to be accessed & synced smoothly by each computer and an ipad.

    It is a pity Zotero cannot just store the files as a list of pdfs in a folder, it would make this so easy!
  • I am having trouble using WebDAV on my IPad 3 with Zotfile 1.1 Although the settings are correct, there was a flashing notice that the security settings (certificate) is invalid before the program crashed. It will no longer allow me to view my library without crashing. I understand that there will be some stability changes to 1.1 coming soon, but I am wondering if others have been able to use their WebDAV zotero storage with the program and how they may have bypassed this security issue.

    Thanks.
  • I won't be able to provide support over the next months - I have to find a job and finish a dissertation. Either someone here on the forum jumps in or you'll have to ask a tech-savvy friend.
  • @goldberghiller - judging by the versions you mention, it sounds like you're talking about zotpad, not Zotfile, in which case you're at the wrong place. See here for getting zotpad support:
    http://www.zotpad.com/node/3
  • edited August 23, 2012
    @sirrahn
    It is a pity Zotero cannot just store the files as a list of pdfs in a folder, it would make this so easy!
    while Zotero directly doesn't do that, your operating system does. Read up on "virtual folders" and you can very easily get all Zotero attachments in a single folder.

    As for your problem, it sounds like you're confusing Zotero by using two different types of syncing:
    You can _either_ use Zotfile and a sugarsync folder to sync your pdfs and not rely on Zotero's file syncing at all or
    you can use WebDav syncing with sugarsync's webdav server and Zotero's file syncing set to that. This may also work well with the ZotPad ipad app.

    Right now you're somehow trying to use both and that doesn't work.
  • @allegorical8

    You are absolutely right that the full file path to the files (e.g. C:\my\stuff\here) is not the same on each machine.

    However, I can't seem to achieve that given each computer is named differently. (e.g. it might be C:\Star7\stuff and C:\StarSeven\stuff on another). How would I go about accomplishing this?

    Your link to sugarsync is really useful for setting up the zotero folder for syncing.
    https://sugarsync.custhelp.com/app/answers/detail/a_id/18

    Thank you.
  • please keep this thread about Zotfile and start new threads for other issues. (and do _not_ use sugarsync or dropbox to sync the entire Zotero data folder between several computers. You're risking irreparable data corruption)
  • @Joscha no worries and good luck with the job and dissertation

    @adamsmith thanks for helping.

    The reason why I took the extra steps I detailed above was that zotfiles didn't seem to take into account that fact that I was using zotero on three different computers (and this doesn't seem to be addressed in instructions anywhere). It seemed that moving the attached pdfs to a 'custom location' on one computer would work great but that problems would be encountered trying to get all the computers to sync to the same 'custom location'. Specifically, I don't think zotfiles on the second computer would recognise that the files are already in the custom directory and would simply duplicate everything and make a big mess. That was why I was separately trying to syncronise the 'storage folder' - because I thought that the links would then sync across computers! Doesn't seem to work!

    I did read up on virtual folders and made a 'smart folder' on my mac that collected all the pdfs nicely. But I didn't seem able to sync this to the ipad with sugarsync (isn't it just virtual). Am I missing something? Apologies if I am being a bit dense - if you can help me find a simple solution I would be really grateful.

    It would be really useful if there was a more simple wiki (I mean for simpletons :))on synchronizing options for ipads somewhere!
  • all of these solution require a certain amount of hackery and figuring things out. It's generally possible, but:

    If you want it simple, pay for Zotero storage and Zotpad (which has just introduced syncing of Zotero attachments) and things will just work out of the box.
  • I have written some stuff about iPad and file synchronizing here. This is obviously focused on ZotPad, but you might find some of it relevant even if you are not ZotPad user

    http://zotpad.uservoice.com/knowledgebase/articles/103784-which-file-storage-solution-should-i-use-
  • edited August 28, 2012
    Files under "Tablet Files" when they have already been removed.

    Here's what happened:
    1) I decided to switch from "Attach stored copy" rather than "Custom location" in ZotFile preference
    2) I did not realize that using the renaming files function will change all pdfs to "Attach stored copy"
    3) Hence, I delete the link to the custom location and reattach the file.
    4) Then I realized that I have some files under "Tablet Files" and I can't "Get from tablet".
    5) I decided to remove the _tablet tag manually.
    6) Its fine.
    7) However, on another computer (sync using webDAV), the files still show up under "Tablet Files" and there isn't a _tablet tag to remove this time round.

    All help appreciated.

    EDIT: I solved this myself by deleting the problematic files, adding the citations and reattaching the pdfs again.
  • Hi, I've been using Zotfile for some time. When I get to using it more frequently (several times a day) to put PDFs on my tablet (I love this feature! Thanks!) Zotfile add-on/configuration seems to get somehow corrupted and I have to re-install it, or, sometimes, I need to re-start Firefox.

    Symptoms: the contextual menu does not allow me to Get/Put files, and in addition to normally displayed items, shows teo-three lines with "Warning", the last line in the menu instead of allowing me to save item to a folder named after a collection, says "Change Folders". At the same time Zotfile preferences usually cannot be opened.
    After re-installing Zotfile, or, sometimes, re-starting Firefox it is fixed. But now it looks I have to do it after every use of Zotfile!

    My setup: Mac OS X, Firefox 11.0, Zotero 3.0.8, Zotfile 2.2

    Has anybody experienced anything similar? Any fixes?
  • no fixes, but you should be using an up-to-date version of Firefox.
  • Hey! I love zotfile, you've saved my life.

    Now, is there a chance this is a zotfile plug in issue? See here.

    I kinda noticed it happens when I use zotfile in toggle mode?

    http://forums.zotero.org/discussion/25242?page=1#Item_8
  • edited September 13, 2012
    Hi,

    I am trying to synchronize Zotfile and Zotero with Jabref and Docear through Autozotbib. Basically, Autozotbib exports my Zotero bibliography as Bibtex. I would like Zotfile to rename PDFs so they match Autozotbib's bibtex key. Jabref could then automatically recognise which PDF belongs to each Bibtex key.

    However, Autozotbib and Zotfile implement different capitalisation rules (think McKie and Mckie, DeCataldo and Decataldo). This messes up Jabref's automatic linking of PDFs with Bibtex entries.

    A solution would be to force lower case in the generated PDF name. Autozotbib makes it trivial to force lower case, but I haven't found a way to do the same in Zotfile.

    Would you think about implementing an option to force lowercase names? Until then, I am stuck to manually naming my PDFs!
  • I have a lot of attachments stored in zotero's way of individual oddly named folders. I have zotfile set up to now store them in a single directory which I can then more easily look through. If I select an individual attachment and then do Manage Attachments > Rename attachment, it moves it from the individual folder to my new storage directory. However, if I select two or more attachments (or two or more zotero items) and do the same thing, nothing happens.

    Since I have tons of items in my zotero library, I don't want to go through them one by one. I know that there are discussions in this forum about manipulating directory structure, but I couldn't follow some of them, and I couldn't find one that specifically dealt with how to do the batch changes and whether what I am seeing is a bug or just needs to be done a different way.
  • Paullouise,

    Yes, I understood that from the zotfile web page. However, the batch processing doesn't work for me. I select a bunch of items and do Manage Attachments > Rename attachment and it does nothing. If I do the exact same thing with only one attachment, it moves it to the zotfile designated directory and renames it appropriately.

    Also, where is this 'single button' you speak of?

    Thanks
  • @grenblau: "paullouise" is a spammer...
  • also, see Joscha's post from Aug 23rd - don't expect much in terms of support in the next months.
  • edited September 25, 2012
    Style of extracted annotations (--> notes)

    Hey there

    I am really curious about the feature that you can extract annotations you highlighted before.
    In combination with e-books in PDF format this offers a great new way of studding.
    After you read and highlighted a passage you can export the annotations and make your own summary.

    THE PROBLEM:
    I would love to export my annotations without "..." (quotation marks) and page information or maybe just once per page.

    THE WAY IT IS:

    "5 years may be required" (p. 661)

    "to" (p. 661)

    "have" (p. 662)

    "caused" (p. 662)

    "a high-risk" (p. 662)

    "for" (p. 662)

    "failure" (p. 662)


    THE WAY I WOULD LIKE IT TO BE:

    5 years may be required

    to

    have

    caused

    a high-risk

    for

    failure


    OR EVEN BETTER.


    5 years may be required to have caused a high-risk for failure

    Thanks a lot for your help in advance.
  • edited September 27, 2012
    Hey ther
    another Problem - maybe discussed before but I could not find the topic anymore..

    I run Win 7; Firefox 15.0.1; Zotero 3.0.8.; PDF XChange Viewer 2.5

    when I extract my highlighted annotations from PDF s with TWO COLUMNS on one Page, Zotero mixes up the order fro Top till buttom.
    __________
    ¦1.....6.......¦
    ¦2.....7.......¦
    ¦3.....8.......¦
    ¦4.....9.......¦
    ¦5.....10......¦
    ¦_________¦

    exportet citation would be 1,6,2,7,3,8,4,9,5,10.

    quite confusing if you have parts with high quantity of important information...

    Maybe if I would have to mark the "middle" of the document between the two columns with a red line so you could solve the coordinates promblem with "first all y-values for x<"red line", second all y-values for x>"red line".

    just a suggestionbut it would make the extracted annotations much more usefull...

    Tanks for the help
  • Any one have Zotfile's "extract annotations" feature working who's using Linux? I've tried with a couple of Ubuntu 12.04 workstations, both with Zotero standalone and the Firefox addon, but every time I try to extract annotations, a progress bar just flashes on the screen for half a second, and then, nothing happens. Any ideas?
  • I don't have any ideas how to fix that for you, but I have it working on Ubuntu 12.04 with annotations made using pdfXchange under Wine.
  • edited November 2, 2012
    I currently sync my Zotero attachments via WebDAV. Can Zotfile be used to upload and download attachments to a tablet if they are stored on a WebDAV server? Specifically, my WebDAV server is openCloud, and I am thinking to purchasing an Android tablet to read and annotate my pdf's, then use Zotfile to sync those annotated pdf's back to my database. I am aware that ZotPad for iPad already has this functionality.
Sign In or Register to comment.