ZotFile - Advanced PDF management for Zotero

1141517192061
  • @hwileniu: I am experiencing the same with Ubuntu 12.10

    Looking at the debug log of Zotero is see these lines:

    [JavaScript Error: "TypeError: zitem.getType is not a function" {file: "chrome://zotfile/content/zotfile.js" line: 702}]

    version => 3.0.8, platform => Linux x86_64, oscpu => Linux x86_64, locale => en-US, appName => Firefox, appVersion => 15.0.1

    Maybe someone knows if this could be the reason and how to fix it. I read that the main developer is busy with other work, but hopefully someone in the community knows how to fix this.
  • I am obviously being really dense, because there are loads of references to zotfile being able to batch move attachments, but I can't see how to do it. It looks like it might be linked to the renaming function, but I can't see how. I currently have a folder that was created many years ago when I wasn't storing many items of this type. I now want to put the files in a more sensible location, and it seemed that zotfile was the thing for the job. All I want to do is move all the files from one folder to another, no renaming, nothing else. Is that possible and how can I do it?
  • cmf5: Yes, you can. But you could also connect your tablet directly to your WebDAV service.

    languageservicesco: You need to set the ZotFile preferences to point to the new destination folder and ZotFile can move the files there. I do not think that it is possible to do this without renaming the files.
  • Thanks for your reply mronkko.
    >You need to set the ZotFile preferences to point to the new destination folder and ZotFile can move the files there.

    I have entered the new destination under General Settings-Location of Files-Custom location, but can find no instructions or even a hint of where to tell ZotFile to go to a specific location and move the files to the custom location given. It is clearly so obvious that nobody thinks it needs explaining, but I am completely at a loss.

    While I am on the subject, assuming I can overcome this current hurdle, if I have to rename the files, does the renaming mask get applied to new files downloaded?
  • You do not need to specify the source folder. Zotero already knows the original location of the files, and that is used as the source.
  • ok but that still doesn't explain how to actually initiate the move. I can find nothingg on this.
  • Check the section about moving files in the documentation

    http://www.jlegewie.com/zotfile.html
  • There is information on renaming, but I can find no instructions whatsoever on moving. I can pretty much recite that page, I have read it so many times. I have tried right-clicking on a Zotero entry, and on an attachment itself, and clicking on "Manage attachments - Rename attachments" and nothing happens, not that any instructions to that effect can be found in the documentation.
  • I just tested and renaming to move works just fine on my computer. Set the "Custom location" on the first preferences tab of ZotFile and then renaming will move the files to that location. This is with the latest versions on Mac.

    If it does not work for you, then it may be that there is a bug in the software. Or that you are doing something differently.
  • No, it doesn't work for me that way. I am using Windows 7 64 bit, so maybe 64 bit is the problem. Anybody using this configuration with the latest FF version, i.e. FF 16.0.2, Windows 7 64 bit, ZotFile 2.0?
  • Thank you very much for this plugin. It would be great if you could add an option to customize the author-separator for file names. I would prefer commas to underscores. (e.g., "First, Second - 2012 - Title" instead of "First_Second - 2012 - Title).
  • @atreffet: I submitted a patch in order to add this option (delimiter between authors). Joscha accepted it and it will be added to next version (ZotFile 2.2.2) when it'll be released.
  • This is like christmas.
  • Hi,

    I am in the process of using Zotfile to move about 100 attachments from Zotero to Tablet, via Dropbox. For some reason, there is one Zotero sub-folder that will not replicate in Dropbox, nor will the atachments move. All the other subfolders have done so without hitch. This one simply won't work.

    My General settings are pointing to the right folder in Dropbox.
    My Tablet preferences are set to "create subfolders from zotero collections." When I right click on my sources to "Manage Attachments,"and "Send to Tabet," the name of the subfolder appears as an option on the bottom. But nothing happens after I select it.

    Any thoughts about what's going on?

    Than you!
  • As a follow-up to my query, I had another go at moving files. This time it worked, soemtimes. Why it started working, I don't know, but one issue seems to relate to entries that are an attachment without a parent. If I try to rename these, or a group of entries including one of these, the process fails completely without any kind of notification. However, having tried to rename all of my library, I find 100-odd files left in the old folder. Some of them may refer to entries in Zotero that I lost when moving computers, but I have found a couple where the file was not renamed or moved, but where the entry is still in Zotero. There doesn't appear to be an easy way to work out which ones relate to Zotero entries and which files are orphaned. The strange thing is, the couple I have found I could rename with no problem.
  • edited November 15, 2012
    new versions: 2.2.2 adds an option to change the delimiter between authors (thanks to Gracile) and 2.2.3 now checks whether the selected attachments are valid, which should avoid a lot of errors! Top-level attachments, web attachments, and attachments with missing files are all sorted out and a warning is shown.

    Both versions are already approved and zotfile should update automatically.

    languageservicesco: 2.2.3 should solve most of these problems. Please confirm.

    Linux issue (mattias): try 2.2.3 and post whether it solves the linux problem. If it does not, post the new error message. I won't follow up right now but I will create a ticket for the future.
  • Thanks for the updates. 2.2.2 installed automatically, but I had to manually install 2.2.3. Afterwards, I tried to rename all the attachments (about 320). This froze FF, but a radio programme I was listening to kept going. I then forced FF to close and started walking through each entry to see if the file had been renamed. I got to "H" and had found two that hadn't been renamed, but when I renamed these individually, it worked fine. I then tried renaming on the remaining entries, but it froze FF again.
    Don't know if that helps.
  • Hi All,

    I've recently tried to use ZotFile in conjunction with Zotero online storage and ZotPad on my iPad. My goal is to read and annotate PDFs on my iPad and then send them back to Zotero, where I would like to be able to extract my highlights through ZotFile.

    So far, I can get the PDFs onto the ipad through ZotPad and Zotero Online storage, mark them up with GoodReader, and send them back marked up to Zotero. The highlighted PDFs show up on my desktop. There, however, the problems begin. When I right click on the PDF in Zotero and ask ZotFile to extract the PDF, I get an error message saying, "Warning: The attachment "[filename of the pdf]" is a web attachment." How do I fix this??

    Thanks in advance!
  • I have seen this message also. As I am trying to solve other issues, I hadn't mentioned it. I am not involved with tablets or annotations though, just trying to rename and move files.
  • That message shows when the selection includes a web attachment. The web attachment is skipped but the others are still processed (there is a similar message for top-level attachments and attachments with missing files).
  • Thanks for the replies. My issue is that even when I just select a single PDF from within, and try to do anything involving ZotFile -- like "Rename Attachments" -- I get the same message, so it appears that I can't do anything with ZotFile... I've tried reinstalling it, but that doesn't seem to help either.
  • Joscha - for me (and my workshop users) the 2.2.3 update broke ZotFile completely - I get the "Web Attachment" message for every item (i.e. right click on an item with just 1 PDF attachment --> Manage Attachment --> Send to Tablet produces this error).
    Reverting to 2.2.1 fixes this (for the exact same operation as above). Let me know if you need any additional debug output & what to look for.
  • edited November 16, 2012
    okay, sorry for that! Everything works for me. Can someone try this version:

    ...

    If it doesn't work, I can upload another attempt within a couple of minutes...
  • sorry, still nothing.
    I installed the new .xpi - still shows up as version 2.2.3 (but that's in the install manifest, so that seems to be right) - I tried:

    1. A top level pdf
    2. A top level item with a pdf attached
    3. An attached pdf

    I get the same error message each time (...cannot be processed (Top Level item, web item, or does not exist).

    Tried disabling all relevant-seeming add-ons (everything else Zotero related and pdf.js) to no effect.

    Cant see anything in the debug - but happy to look if you want to make this noisier.

    This is on Firefox 16.0.2 with Zotero 3.0.9 installed on linux.
    I tried & failed on Zotero Standalone 3.0.8 before, though not with the new version.
  • okay, here is a more verbose version. It should spit out 6 or 7 messages when you try to rename a single item... (same link as above)
  • screenshot of the messages (for trying rename) here:
    http://imgur.com/dgcsf
    (send to tablet produces exactly the same ones)
    Zotfile clearly thinks this is a web attachment - I wonder why?
    I thought this could be a linux issue, but I had a Windows user with the same error (I think it was worded slightly differently) message for the earlier 2.2.3 version.
  • edited November 17, 2012
    I fixed the problem thanks to adamsmith's help. The new version has already been approved by mozilla.
  • Hi Joscha,
    I installed Zotfile. After installing it and opening an entry in my Zotero library which has an attached PDF it opens the PDF and shows the full URL (e.g. file:///Users/christoph/Documents/zotero/storage/43PBAX65/06003808.pdf). However, I would like to see only the Zotero URL like zotero://attachment/678. How can I go back to this? Also deactivating the Zotfile plugin did not help.
    Thanks,
    Christoph
  • Hi Joscha,
    thanks a lot for Zotfile.
    I would like to report one problem - I can't set base folder for tablet files when there is a special character with diacretic in it's path. E.g. I have dropbox folder in windows profile directory including "ř" (R with caron). Zotfile fails to save correct path...
Sign In or Register to comment.