ZotFile - Advanced PDF management for Zotero

  • TrueRony, seem to be a bug or a problem with the setup. I created a ticket but I won't have time to look into it anytime soon. For the meantime yon can just check out whether it's running on a different machine with a different zotero database and whether you can pin it down. I know, you already tried a different computer but it's the first bug report along these lines so it really doesn't seem to be a common problem.

    Pruppert, zotfile doesn't do anythin automatically. You have to right-click the item and select 'Attach New File' (or 'Manage Att.->Rename Att' for existing attachments). Clicking 'Attach New File' looks int he specified download folder for the most recently modified (i.e. downloaded) file.
  • I am having trouble with the annotation extraction using Zotero Standalone on Windows. I can't get extraction to work on any file, even the test file you provided above. When I initiate extraction, the pop-up box comes up and the progress bar never moves; finally I have to escape out of the process. The following error in the log appears to be related:

    [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: chrome://zotfile/content/pdfextract/pdfjs/src/core.js :: getPdf :: line 55" data: no]"]

    Any suggestions?
  • I am having trouble with the annotation extraction using Zotero Standalone on Windows. I can't get extraction to work on any file, even the test file you provided above. When I initiate extraction, the pop-up box comes up and the progress bar never moves; finally I have to escape out of the process. The following error in the log appears to be related:

    [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: chrome://zotfile/content/pdfextract/pdfjs/src/core.js :: getPdf :: line 55" data: no]"]

    Any suggestions?
  • I hope this is the right place to put any Zotfile discussions. Please forgive the duplication, all who have already seen it on the Zotero add-in discussion. Here's the gist:

    Much of my research involves using PDFs that are not searchable. They are just images of pages. Since I can't highlight the text, I use the sticky note to transcribe the bit of text I want to capture, or to summarize it--and I'm very grateful to the Zotfile feature that lets me extract those notes into Zotero. The problem is, it uses the PDF's page number and not the page number that would need to be cited--the number that was on the original document page. I've used Adobe Professional to apply the proper page numbers to every page in the PDFs (things like page "i" on a table of contents, etc., though the Google Books scans might actually see it as page 8, with all the extra images scanned ahead of it.) But the usable page numbers are not extracted, even though I have it flagged in the Zotfile Preferences--Advanced Tab, to "Use actual article/book chapter page for highlighted text snippets." I am assuming this preference must deal only with highlighted text and not sticky notes--but it matters as much to me that the notes I put on a specific page are tied to the page number that was on the original book or article--and not that it happens to be the 130th page in the Google Books PDF.

    I don't know if this is a bug report or a feature request, but it's very important to historians. Otherwise, we have to go to the extracted annotations and change every note, page by page. (But to the Zotfile developers, thanks that you are pulling the text over for us--a great thing. And let me also appeal to you to extract the "Text" items that PDF Expert in Ipad lets you add to a page--probably the same as the "Typewriter" feature in Adobe Professional, which lets you put words on a page that are not buried in a sticky note that has to be opened to be visible.)
  • @jkotter, I can't do much right now. Simply no time to investigate. But I recommend that you restart your computer, try on a fresh Firefox profil where you just install Zotero and Zotfile (http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles), and if that works try to pin it down. Report back here so that I know what's going on when I have some time to look into it. But it won't be anytime soon.

    @DonnaCoxBaker, "Use actual article/book chapter page for highlighted text snippets" determines the page number based on two things: a) the page in the document (three when you are on the third page), and b) Zotero metadata for 'Pages'. When your annotation is on the third page in an article that ranges from 134-160, zotfile will use page 137 for the annotation. I realize that doesn't really work for books but maybe you can trick it into working more like you want. I also created a ticket for this on github.
  • Joscha, fantastic idea (ZotFile) and impressive development. This add-on truly realizes many of the advantages of Zotero in a sensitive and thoughtful way.

    Thanks for creating the ticket for pagination help on GitHub requested by Donna Cox Baker. I second the request as a fellow historian - it would be a real help.

    @Donna Cox Baker - as a temporary fix, I suggest ending each comment with the page number you are on. That's the best I have been able to do thus far.

  • I'm new to Zotero and Zotfile. I've just ordered a tablet and am hoping that the combination will solve all of my dissertation woes!

    I was about to post here and say that I was having trouble extracting annotations, but the problem seems to have resolved itself spontaneously. Yesterday it was coming up with an error message in the lower right hand corner of the screen (it disappeared too quickly for me to note down). Today, it works! Although it still doesn't work with the zotfile-test.pdf oddly enough.
  • Agreed with everyone, zotfile is great.
    I would suggest a multi-stringed forum, somewhere, if possible -- I have tried to search to see if my question has been asked before, but couldn't really figure it out. Apologies for that.

    A question -- is there a size limit on the PDFs that zotfile will extract notes and comments from (with pdf.js)? I notice it is not working on some PDFs, and they seem like longer ones... Smaller sized PDFs are extracting without problem, I think.
  • edited July 12, 2012

    fingersandtoes, here are some instructions for reporting bugs such as the problem with zotfile-test.pdf

    JonEP, a multi-stringed forum sounds like a good idea but I have a couple of reservations: First, there are rarely responses by other people than myself and moving to a separate forum even decreases the number of people who see the zotfile questions. Second, someone has to maintain the forum and I don't want to invest into that. Third, this forum thread is one of the few ways in which people find zotfile.
    Instead, I encourage people to use a FAQ wiki:

    It would be great if people add stuff to the wiki! When I find time, I might add some information about the extraction of annotations but there is already a lot of stuff in my last replies.

    Size limit of PDFs: I don't think that there is any limit but maybe an error makes the extraction crash at a certain page. I suggest that you try the poppler based extraction (if you are using a mac) or split the pdf and try the separate parts. This way you might be able to pin down the problem.
  • Zotfile 2.2 is now under review with one main new feature: automatic renaming of newly attached files. The update should install automatically after it was reviewer by mozilla. Here is the link for early adopters:

    Changes in Zotfile 2.2
    - New feature: automatic renaming of attachment files (thanks to Robin Wilson)
    - Bug fix: zotfile produced error when trying to move open files on Windows (thanks to Dominik)
  • Hi Joscha (and contributors), at first, congratulation for you work on this great tool! Zotero gains a lot whithout zotfile.

    I am experiencing some trouble with the modified detection feature iver a dropbox synced folder. The workflow is pretty simple:

    1. send files do dropbox folder
    2. dropbox syncs with tablet
    3. read/annotate on table
    4. dropbox syncs again
    5. Zotfile does not point any modified files with the Tablet-files-modified custom search.

    A bug? Note sure, but possible. My system is zotero + zotfile + FF 13 (portable). The zotero library is in disk c:.

    I scanned this forum looking for portable FF use, and could not find references of user with zotero and the portable version.

    Some additional, but maybe not relevant info, is the I have set two separate zotero libraries, because I could not find any feasable way to put a single zotero standalone to work with more than a single library.

    One zotero library is for papers, managed with chrome + zotero standalone + ZFile. Its medium sized, near 2GB. EVERYTHING IS OK WITH THIS ONE.

    The second library is for books, above 3Gb and managed with FFPortable 13/zotero extension/zotfile. THIS IS THE ONE THAT DOES NOT RECOGNIZE MODIFIED FILES!

    Considering the main difference in both arrangments is the FFPortable, it is possible that the issue is with zotfile and FF. Can you give some directions on this problems?

    Thanks a lot.
  • Hey samuelcartaxo. sorry, but I don't have time to provide any user support over the next month and won't be able to get into this. Maybe someone else has an idea?
  • Hi Joscha, I think me (and hopefully not others) may live with this. I resend the collections I have modified in the tablet/dropbox, after checking the dates with windows explorer. Zotfile updates them. A manual procedure, but works.

    I just would like to let you know about the issue.

    Thank you.

  • Zotfile 2.2 is out. The update should be automatic for most users.

    Changes in Zotfile 2.2
    - New feature: automatic renaming of attachment files (thanks to Robin Wilson)
    - Bug fix: zotfile produced error when trying to move open files on Windows (thanks to Dominik)
  • Hi Joscha,

    first of all, thank you for your powerful addon!

    I would like just to report you a couple of "bug" that I found:

    1) When you are exporting a file to a tablet directory, your addon is going to insert a command line into the notes window of that specific file like this:

    lastmod{1303813244000}; mode{1}; location{[BaseFolder]\European Journal of Medicinal Chemistry\Kaushik et al\Kaushik et al. - 2010 - Design & synthesis of 2-(substituted aryloxy)-5-(s.pdf}; projectFolder{}

    If a previous note was existing, it is going to add this command at the end of the note (and that is right!)

    The problem comes when you are going to get the file from the tablet directory: in that case everything presents in the note window is deleted (sob!), even though other notes are present before or after the command line inserted by you. is there any way to solve this problem? maybe you could suggest to insert any other notes before the command line and your addon can make a search in the notes and starting to delete stuff after the string "lastmod" for example?

    2) Is there any way to let your addon to delete the folders (and/or subfolders that it created during the exporting phase) after the importing action? I mean, after I send articles to the tablet and then I get them back, I have a lot of empty folders that I need to open, to check whether they are empty or not and if yes to delete them.

    thank you
  • edited July 24, 2012
    1) zotfile uses the attachment note to store information about files on the tablet. It would clearly be better if zotfile did not piggyback on the Zotero database and instead use it's own database. Unfortunately, that won't happen anytime soon. A temporary solution would be that zotfile only deletes zotfile related information from the note, which should be easy to implement (I think it only requires changes in the `clearInfo` function. Here is the ticket). I still won't be able to do it now so feel free to pick it up and sent me a pull request.
    2) Zotfile should delete empty tablet folders. At least it deletes user defined tablet folder (but only if there are no other files in the folder). Please describe you problem in more detail (see the zotfile for submitting a bug report).
  • edited July 26, 2012
    Hi, I noticed since the update when I add a citation from the URL bar in Zotero that it does not add the attachment (PDF) properly. I am using Windows 7, Firefox (latest), Zotero (latest). This worked a week ago, but now there is an attachment to a broken link. I have not changed anything in my configuration since the update. Any suggestion why the PDF is not automatically being saved? The same applies if I drag-and-drop the PDF from Windows Explorer onto the citation in Zotero (being run under Firefox), whereas this also worked a week ago.
    Thanks for the great add-on! Keith
  • Can you give some more details? What are exactly the steps (with url) and how is zotfile set up (most importantly, the location of file setting)?
  • If I am viewing any journal article (abstract) at the publisher's webpage and click on the small paper icon from Zotero in the url line it saves the entry into Zotero as normal, except the attachment which should be a PDF, but shows up as a broken link. The location of file setting is the folder where I store my Zotero database (i.e. z:\PDF Library\Zotero Database\PDF). I have changed nothing since the most recent update, where it worked previously. What other information can I send you?
  • I can't reproduce the problem. In my case, I get the broken link message when I try to open the file right after it was attached. After waiting a moment, I get the zotfile message for automatic renaming though and everything works fine. Might that be the case? Do you get the zotfile message? Do you get any error message in the console? (http://www.columbia.edu/~jpl2136/zotfile.html#bug)
  • I guess the problem you are describing is exactly what happens on my machine, I just did not explain the problem well enough. The only thing is that my computer does not give me a message that Zotfile is automatically renaming anything. I looked around the zotfile preferences and could not find any option to enable this feature. How do I do this?

  • Automatic renaming is enabled by default so that this shouldn't be the problem. You can disable automatic renaming in the advanced setting tab. You can try that and everything should work as it used too but without automatic renaming. You should still check for an error message in the console...
  • I get no error message on the console that I can see. When I save a paper to Zotero, I first get the pop-up message saving citation from Zotero, then I get the message the Zotfile is renaming the attachment. If I am fast I can see the attachment has the PDF icon next to it, but then it turns to the broken link icon. If I try to open it I get an error message that says it cannot locate the file.
  • For some reason the behaviour of Zotero and Zotfile seems to have changed. Previously when I added a citation (and automatically download the PDF) the attachment showed up with a PDF icon symbol on the left. Now it is a link symbol.

    Since I had the previously mentioned problem, I made sure that in the Zotfile preferences "General Settings", I have "Use Firefox download folder, and under "Renaming Rules", I have "Use Zotero to Rename". Everything seems to work correctly now. It now places the attachment in the folder specified in the Zotfile preferences. The icon is still the "link" icon rather than the PDF icon, but it works.

    Thanks for the excellent support and add-on for Zotero!
  • Is there a way to have Zotfile automatically rename and relocate previously attached PDFs to the naming convention and folder specified in the Zotfile preferences? I have over 1000 citations and I do not want to re-download them all. Suggestions?
  • Report ID: 456253798

    I get a "XULRunner has stopped working" error in a dialog box when I try to Extract Annotations from a pdf file. This report was sent immediately after startup following the program crash.

    Steps to reproduce:

    1. Create a reference and then attach a file directly or with a link
    2. Select Manage Attachments / Extract Annotations

    Program crashes with above error. I tried turning off all the plugins and extensions but no dice. Also, shut down all but the bare minimum of applications (i.e. virus scanner). Same result. Tried restarting the computer and the application. Same result.

    2 screenshots ~ http://bit.ly/PcwuCM, http://bit.ly/PcwtyF

  • Hello Joshua and everyone here,

    I work using 3 computers.I use zotero sync for my references, notes, etc, sugarsync for my pdfs, and zotfile to rename and move my file to the sugarsync folder.

    I only installed zotfile on one computer, hence, I can only attach and rename pdfs on that computer. Furthermore, I can only double click an item to open the pdf on that computer.

    My question is, how can I accomplish this on the other 2 computers? I tried installing zotfile on the other 2 computers but it doesn't work. I suspect its due to the file path of the sugarsync folder.

    Any ideas?
  • I do not think that you need to use ZotFile to sync files across computers running Zotero. If I am correct, you can sync any folder on your computer. Just set up a direct sync between the Zotero storage folders (inside the data folder) on the different computers.

    Alternatively, you could set up synchronization with symbolic link. See https://zotpad.uservoice.com/knowledgebase/articles/103395-what-is-a-symbolic-link-and-why-should-i-use-one-w
  • @ Keith: Yes, you can renaming existing attachments. Just right click the zotero item or attachment and click 'Manage Attachments-> Rename Existing Attachment'. The change in behavior you observe is because of zotfile's automatic renaming. You can turn that of if you want but zotfile name automatically renames and moves new attachments as specified in the zotfile preferences.

    @ allegorical8: I am not sure what is going on and I won't have time to investigate anytime
    soon. I can only recommend to update firefox, try on different computers, etc. Maybe that helps to pin down the problem.

    @ Star7: mronkko is correct about the syncing of files but what does not sync are linked attachments and certain zotfile settings. So you have to use imported attachments to sync the files across computers using Zotero (that has nothing to do with zotfile though).
  • @mronkko & @joshua

    Sorry, I'm really unsure what both of you are saying (I'm not really tech savvy).

    Do you mean having the zotero storage folders (the one where you "show data directory") on sugarsync and have all 3 computers point to it?

    What are imported attachements?

    Furthermore, would I experience any errors if I install zotfile on multiple computers and use them in renaming and moving?

    All help appreciated. :D
This discussion has been closed.