LibreOffice plugin

Are there plans and perhaps already a schedule for a LibreOffice plugin?
  • edited October 12, 2010
    The present OO.o plugin already works because LibreOffice is just a rebranded fork.
  • edited October 12, 2010
    let's reformulate the problem; when i open libreoffice i can not see the zotero extension
  • Change the paths to LibreOffice paths according to the last post in the thread I link to (Tools->Addons->Zotero OpenOffice Integration Preferences) & reinstall the components.
  • edited October 12, 2010
    actually it doesn't seem like it's working - at least the person who originally reported that it did has taken that back.
    So no, there is no current version working with Libre Office.
    The original Ooo plugin was community generated - maybe someone can try to figure this out. Because as of now LO is just a fork it shouldn't be too hard? The core dev folks seem quite busy rolling out 2.1 and Zotero Everywhere these days.

    edit: unless noksagt has tested this independently.
  • indeed, it does not work
  • It works for me on Linux.
  • file:///opt/libreoffice3/basis-link/ure-link/share/java/

    Does Windows us the basis-link/ure-link directories? If so, it could be that jimwhitend used the wrong paths
  • To make the story still more complicated, I'm using an Apple and there neither the jimwhitend nor the noksagt proposition works
  • this
    on finding the paths applies to Macs, too.
  • I fear my it-knowledge is too reduced to be able to solve this by myself; still hope that in the near future there will be a proper libreoffice-plugin
  • My case is
    Zotero experienced an error updating your document
    after change the install path for my Libreoffice 3.3 b2
    my report id is 760897241
    zotero 2.0.9
    with the latest integration pluging with openoffice.
    in mac 10.6.4
    with the latest firefox.
  • Java does not work with LibreOffice on OS X as of the latest Java update. Since Zotero makes use of LibreOffice's Java functionality, Zotero cannot function at the moment (nor can several parts of LibreOffice itself). There are some potential solutions in this thread, or you can wait until the next LibreOffice release.
  • I have tried
    to solove the java problem.
    However, the problem of Report ID:227463843
    "Zotero experienced an error updating your document"
    is the same.

    And, almost other functions of Libreoffice is all right.
  • Is not this problem caused by zotero plugin ?
  • The Libreoffice beta 3.3 beta 3 is ok with zotero now.
  • The Zotero plugin appears indeed now in LibreOffice toolbar. I get however the following error message

    "Zotero OpenOffice Integration could not communicate with because the Java UNO runtime directory specified in the Zotero OpenOffice Integration preferences does not contain a "ridl.jar" file."
  • my case is okay.
    you may inquire in libreoffice forum.

    have a check:
    are you using mac?
    are you update the zotero?
    have you restart libreoffice?
  • on mac, libreoffice 3.3 beta 3 connet with zotero plugin well.
  • I do have the Zotero toolbar in my Libre Office Writer. However, I just tried to insert a citation into a doc in Libre Office (3.3.0) and I got first the error message "Action not supported - Invalid procedure call", and then after repeated tries "Open Office could not communicate with Zotero - please check whether Firefox is open". Of course Firefox and Zotero were open. Any idea?
  • OK, thanks! Will wait.
  • Foellmer, I just played around with this a little more and I think I might have something that works. It would be great if you could test the extension at the link I posted in the other thread.
  • It works! Thanks a bunch - your prompt response is highly appreciated!
  • Now, Libreoffice in Mac has update to rc2. It works well with zotero.
  • I just installed LibreOffice 3.3 RC2 on my Mac. The toolbar for Zotero appears, but nothing happens when I click any of the toolbar buttons. I looked at the link for pathing to OO that Adam Smith mentioned above, but this is for Linux; it is not clear how this would work with OS X.

    For those reporting that Zotero works with LibreOffice, did you do anything to make it work?

  • Install
  • Is the connection between zotero and libreoff established?
  • That is :If you've installed the OpenOffice plugin into Firefox but don't see the Zotero toolbar in OpenOffice, close OpenOffice and then, in Firefox, go to Tools→Add-ons→Extensions→Zotero OpenOffice Integration→Preferences and click “Reinstall OpenOffice components”. Then start OpenOffice and check for the toolbar.
  • I just switched to Libreoffice 3.3 and had issues with the zotero plugin (in firefox 3.6) on my 64 bit ubuntu lucid laptop. It worked fine with the openoffice I just removed. The toolbar showed up fin in libreoffice but was reporting a communication issue with zotero. Since the zotero documentation specifies:

    "Zotero requires either the Sun Java plug-in or the older OpenJDK/IcedTea OJI plug-in, which does not work with Firefox 3.6+"

    I did a java-version and found that my default java got changed to the open-jdk -probably after an install of something (maybe even libreoffice itself). I did a:

    sudo update-alternatives --config java

    and followed the menu options to set sun java as my default. The zotero plugin worked fine after that.
Sign In or Register to comment.