LibreOffice plugin

  • * noksagt, Oct 12th 2010, said use these paths:
    > file:///opt/libreoffice3/basis-link/ure-link/share/java/
    > file:///opt/libreoffice3/program/

    ubuntu 10.10, libreoffice 3.3, firefox 3.6, zotero 2.1 beta, I had to use a different java path, as the one suggested does not exist. This is the one that worked for me:

    suggestion to the developers:
    The error message in the zotereo prefs dialog when I had a non-existent path suggested openoffice was still open somewhere, sending me on a (short) wild goose chase to find the process, reboot, etc. Could the error message be modified to indicate path not found if such is the case?
  • I guess I am a bit confused at the state of things at the moment.
    I installed LibreOffice 3.3 (released version) and it came up with the zotero extension in the toolbar, likely because my settings were retained. I deleted the extension from LibreOffice then used the preferences from the zotero FF plugin to relocate the libreOffice paths and reinstall - the plugin indicated that things had been installed and when I opened libreOffice the toolbar was there..... However, when I clicked on any of the toolbar items the items would open up OpenOffice...... So I renamed openOffice and now nothing happens....

    It looks like the java console is saying that there is no office executable to be found and the console is saying live connect failed.....

    Paths appear to be correct:

    SO, why did clicking on the plugin in libreoffice bring up OOo and why is nothing working at present.... I had mistakenly assumed that as LO3.3 was supposed to be largely a rebranded OOo that zotero would work (all my other OOo extnesions are working....
  • Temporary solution for resolving LibreOffice issues on OSX Snow Leopard confirmed.

    Per Simon's comment of Nov 2010 I modified

    /Users/YourUserName/Library/Application Support/LibreOffice/3/user/config/javasettings_MacOSX_x86.xml

    using TextEdit (i.e. you do not have to do this vai terminal nor use any special editor feature) so that the <vendor> tag reads

    <vendor>Apple Computers Inc.</vendor>

    instead of

    <vendor>Apple Inc.</vendor>

    and all works for now.....
  • I just installed libreoffice on another 64 bit lucid machine and was stuck with an unowkrin zotero plugin even after following my own instructions above.

    After some head scratching I realized I needed to uninstall the icetea plugin - after that the zotero plugin would talk to firefox.

    Just in case someone else has issues.
  • FYI the issues with iced tea are (almost certainly) solved for the next generation of Ooo plugins (3.5x) - last I heard there were still remaining issues with some Ooo builds, not sure if Simon has solved that, too.
Sign In or Register to comment.