changing font preference?

Is there a way to set a preference for the font that in-text references appear? I'd love to not have to change them every time to Times New Roman 12 pt. font. Especially since when I do a select all in Word 07 it doesn't seem to adjust the Zotero fields.
  • I have the same problem - how can we make sure that our in-text citations appear in the same font as the rest of the text?
  • I also have this problem. Can anyone help, please? My citations appear in Times New Roman but the rest of my test is Arial. Thanks!
  • I just figured it out. Under 'Format' in Word 2003, and then 'Font', there is a button on the bottom of the window called 'Default'. If prior to clicking that default button you select the font and the size you want all text to appear, and then click the 'Default' button, it will ask if you want to change the default font and font size to what you've selected. Click 'yes' and it will make it standard for all text, including Zotero citations and bibliography.
  • This problem was affecting me too... Thanks for your help swissarah... It's a very good temporary solution. But I really wish there was a way to set the font of the citations, because if you happen to be working in 2 documents at the same time, with different fonts... well, you have a problem.
  • Unless I'm mistaken, the references inserted by Zotero (both in-text and in the list of references at the end) are based on the "Normal" style (i.e. they don't specify a particular font).

    Now, if you're manually changing the font to something else (but do not change the style), I can imagine that you end up with different fonts. In this respect, the solution posted is what you do, not just a temporary solution. Start using the styles feature in Word, and Zotero seems to behave very well.
  • I have the same problem and the above solution doesn't work. I'm using 1.5 with Word 2008 (Mac) and changing the style doesn't seem to cut it: any new citations will be in Times New Roman and a refresh will turn everything into Times New Roman.

    Strangely, if I change the font size, say to from Times NR 12 pt. to 10 pt., that isn't affected by refreshes and so on (that is to say, the style change sticks).

    I didn't have this problem at all with 1.5 and Word 2004, nor does it appear with Neooffice and 1.5.
  • Oops. 1.0 and Word 2004, that should read.
  • Is there a fix for Word 2007? This is really annoying and the style change doesn't fix it (unless I'm not doing something right.)
  • I've spent a while with the different plugins isolating the exact behavior. There are certainly some inconsistencies. I've created a ticket.

    Here's an excerpt explaining the current behavior, warts and all:
    All Plugins: The style of an in-text citation is taken from the line of text in which the citation occurs. Any changes to the style of the text or the citation results in changes to both.

    Word 2007 (Win): If the font of the citation is changed manually, without changing the style, clicking the Zotero Refresh button reverts the style to that of the text. (Note: The citation reverts to the style of the line of text, not the font, if that has been changed.) This is not the case in OpenOffice or Word 2008.

    OpenOffice (Any) / Word 2007 (Win): Bibliographies are created in the active style, not necessarily the default. If the style or font of a section of the bibliography is changed, clicking the Zotero Refresh button reverts to the style of the entire bibliography.

    Word 2008 (Mac): Bibliographies are always created in 12pt Times New Roman. Changes in the style or font are reverted on Refresh.
  • I have Word 2007 (Win), and even changing the normal template won't fix this problem. Has anyone solved this yet? Do we know when the bug should be fixed in Zotero?
  • Which style is the line your citing to in? Have you tried changing that style? (Maybe it's not default but something like "Text Body" or so.
  • Re swevrywhere and sundarama:
    I've just experienced a similar issue in Word 2007: changing the Normal template from Calibri to Times New Roman did not change the text of my citations, including after refreshing. Strangely, when text is highlighted either within or outside citations the template is displayed as "Normal", even though the citation text isn't actually using the Normal settings.

    But - after a ctrl-a and changing all text to Times New Roman, the citation text does change to TNR, and more importantly, stay that way after refreshing or closing the document. It seems maybe the citation style is based on the Normal template *at the time the citation is entered*? The difficulty with this is that one might not want to change everything to a single font/size, making font changes after citation insertion a bit painful.

    The alternative (but, I think, equivalent) route of selecting text with the desired style and clicking font > default to set the style as the default Normal style doesn't change the behaviour either: citation text still doesn't update to the most recent style.
  • Is there a solution for:

    Word 2008 (Mac): Bibliographies are always created in 12pt Times New Roman. Changes in the style or font are reverted on Refresh.
This discussion has been closed.