Turning off automatic upgrades on Linux

This discussion was created from comments split from: Is there a way to turn off auto-upgrade function?.
  • Ok, I installed Zotero on Ubuntu. Painfully inflexible (I tried to put the link in /usr/share/applications rather than .local/share/applications and IIRC it didn't work). Anyway... I used the recommended .local location and can get zotero to run, but updates barf. Something about a missing Release file, download not secure, update disabled. A PITA. Anyway, if the update function worked reliably, I'd be happy to keep updates automagic. But since it throws an error message at every update, I'm killing auto updates. As it happens, with the RELEASE file issue, it doesn't update automatically anyway, so all I'm doing is suppressing a repetitive and uninformative error flag.
  • Good heavens, setting both app.update.auto and app.update.enabled to false still allows the error when I run sudo apt-get upgrade or the software updater.

    E: The repository 'https://downloads.sourceforge.net/project/zotero-deb ./ Release' no longer has a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.

    What a dissapointment. Not only am I repeatedly reminded "Zotero update doesn't work", I can't turn off the message. Grrrrrr.
  • edited May 26, 2022
    You seem to be misunderstanding quite a lot a lot of this.

    1) How the app launcher works on your system — the path you can use, etc. — has absolutely nothing to do with Zotero.

    2) It sounds like you may be referring to a third-party package, not the tarball we make available from this site, in which case your question has nothing to do with Zotero's built-in updater. You'd have to ask the developer of the package you're using if you're having trouble with updates.

    3) In general, no one is going to be able to help you unless you say what exactly you're doing, including the actual software/packages you're running and exact error messages you're receiving.
  • @WizardOfBoz: https://www.zotero.org/support/forum_guidelines#etiquette

    If you're going to post here, skip the editorializing and just calmly explain the problem you're facing so that people can help you. And consider the possibility that you're just confused about something (like, say, about what software you're even using).

    You're using a third-party package, not the official version of Zotero, and the update URL changed. Reinstall it from https://github.com/retorquere/zotero-deb. That's all.
  • And note that you don't have to uninstall zotero before doing this. Re-doing the install.sh just changes the download location for updates; you could change it manually in /etc/apt/sources.list.d/zotero.list. After that, you can just apt install as usual.
  • >skip the editorializing

    >You're using a third-party package, not the official version of Zotero
    I went to zotero.org
    clicked the "Linux" download button
    this downloaded Zotero-6.0.8_linux-x86_64.tar.bz2
    then clicked "installation help" which landed me at
    I followed the instructions on www.zotero.org on that page

    Is the download from zotero.org not the official version? Please let me know where I went wrong, or if there is a better way to do this.
  • edited May 28, 2022
    Is the download from zotero.org not the official version?
    That's the official version, but it's not the version you're describing. The official version is just a tarball — it has nothing to do with apt-get. You're describing the third-party zotero-deb package, linked from the installation page ("A longtime community member maintains zotero-deb, a lightweight wrapper for the official tarball."), which, as we explain above, you just need to reinstall to fix this.
  • edited May 30, 2022
    Thanks for the notes.

    The only version I've ever downloaded (to my knowledge) was the .tar.bz2 I got when I clicked the "download Zotero" on the zotero.org website. If there's another version on my machine I am unaware of it. Is there a way test if there is another (e.g. "not the version you're describing") version on my machine?

    I just deleted all files that I could find that had anytying to do with Zotero, and then reinstalled the version I got when I clicked on the link. Symlinking the .desktop file to the usr/share/applications didn't seem to work (I may have morked up the ln commmand), but symlinking to the ~.local folder did. Anyway Zotero functions.

    My software updater still throws a "Failed to download repository information" error. If I click "Ok" it seems to load other new updates. If I run apt-get update, I get the error
    "Err:20 https://downloads.sourceforge.net/project/zotero-deb ./ Release
    404 Not Found [IP: 443]
    Reading package lists... Done
    E: The repository 'https://downloads.sourceforge.net/project/zotero-deb ./ Release' no longer has a Release file.
    N: Updating from such a repository can't be done securely, and is therefore disabled by default.
    N: See apt-secure(8) manpage for repository creation and user configuration details."

    Maybe some simple questions will help
    1) Is the link on zotero.org downloading an old or corrupted or "modified by a third party" version?
    2) If so, do I need to download the tarball from somewhere else?
    3) I followed the instructions on zotero.org but am still getting an error. Is there an alternate path to installing zotero that is better than what is on the site?
    3) If I do get the proper version properly installed, does it allow updates via software updater in Ubuntu so that updater does not throw errors, or do I need to manually update Zotero and just live with an error from the updater program every few days?

  • edited May 31, 2022
    You're still confusing two ways of installing Zotero.

    The tar.bz2 has no connection whatsoever to the dpkg/apt tools. If you're using apt, you're using my deb packages, and https://github.com/retorquere/zotero-deb (as pointed out above) has instructions on how to get that back up if that's what you want to use.

    If you don't want to use the deb packages:

    sudo apt uninstall zotero

    (which may error out if you don't have zotero installed this way, which is fine)

    and then the instructions in https://raw.githubusercontent.com/retorquere/zotero-deb/master/uninstall.sh will show you how to get rid of the deb repo permanently, so apt won't keep complaining.

    If you trust my handywork, you can have it run on auto using

    curl -L https://raw.githubusercontent.com/retorquere/zotero-deb/master/uninstall.sh| sudo bash

    But if you just want to get the deb repo back up:

    curl -L https://raw.githubusercontent.com/retorquere/zotero-deb/master/install.sh | sudo bash

    I would suggest you choose one method -- either get the deb repo back up on your machine, or uninstall it and concentrate on the tarball install.
  • edited May 30, 2022

    1. No.
    2. Definately no.
    3. Define "better" (and you have two questions "3")
    4. If by "proper" you mean "the official tarball", then no, the Ubuntu updater is not involved and you need to manually update Zotero, but "no" to the "and" part; just remove the deb repo.
    You or someone else certainly did install the deb repo at some point. I introduced the sourceforge mirror because of reasons explained on the zotero-deb site, but the cure was worse than the ailment, so I retired the sourceforge mirror and am now hosting the debs on backblaze.
  • edited May 31, 2022
    I don't recall doing a git, but it's possible that I did a sudo apt install zotero.

    Let me just step back and reiterate my situation: my machine is maintained by my company. Because of the the sophistication of the layered tools we are using, that's not something that can (or should) be changed. We use the system tool Software Updater, which runs periodically.

    I'v e installed Zotero in a way that it works. Right now, the updater throws an error regarding the Release file.

    If I'm grokking what you say, I should probably run
    sudo apt uninstall zotero
    then the curl version of uninstal (in your note above)
    This leaves me with no Zotero remnants.
    Then install the deb repo per your command above

    The deb repo should be updatable by the software updater.

  • I don't recall doing a git, but it's possible that I did a sudo apt install zotero.
    The installation of the deb repo would not have involved git, but you will have executed the curl -L https://...../install.sh | sudo bash at some point, otherwise sudo apt install zotero would just have said "Unable to locate package zotero".
    If I'm grokking what you say
    If you want to use the deb repo, you only have to do

    curl -L https://raw.githubusercontent.com/retorquere/zotero-deb/master/install.sh | sudo bash

    nothing else. The uninstall instructions are for when you want to use the tarball install instead.
  • Ok, I ran the curl ... /install.sh command.
    It seemed to run way too fast (like 0.1 second or somesuch) but it did run.
    Then I ran software update. It ran without error.
    Zotero works

    So I guess my issue is solved. Thanks.
  • It writes a 132 byte file. Of that 0.1 seconds it probably spent the bulk of the time downloading install.sh, since that is substantially bigger at 898 bytes :)
  • So my dual Xeon processor workstation with 128Gb of memory and 44 cores didn't help...

    I just did the same process on my laptop and zotero is downloading through updater. And it works.

    It did take a manual sudo apt update/sudo apt upgrade cycle before software updater stopped throwing the "failure to download". But both machines work. Thanks.
Sign In or Register to comment.