Brave browser: Zotero Connector cannot contact Zotero desktop app

edited March 8, 2021
[Edit: This is now is fixed in Brave 1.21.74. — D.S.]


When I try to use Zotero connector in the Brave browser, I get the error message "Is Zotero running?"

I've completed the following debugging steps:
- Zotero desktop app is installed
- Can load "" -> I get "Zotero Connector Server is Available"
- Zotero connector works on a different browser (Firefox)
- Disabling all other extensions did not help

Furthermore, I've logged the errors via the Advanced Settings and saw
(3)(+0000001): HTTP POST

(3)(+0000016): Connector: Method ping failed with status 0
which seems weird to me since loading the URL worked.

The docs [1] mention "whitelist port 23119 in the extension's settings" but I did not find any such option in the extension's settings.

Could you help me with figuring out where I went wrong? :)

Thanks much for your answer in advance.

  • You're probably better off posting on Brave's support channels. The debug log (specifically the "failed with status 0") indicates, that something in the browser blocked the connection to the Zotero client, possibly something in Brave's privacy extensions/features, but we cannot offer much guidance beyond that.
  • Ok I see. Thanks for your help! :)
  • @c-bg have you resolved this issue?
  • @carlosbornes yes. I had accidentally installed Brave two times, and weirdly enough, it worked with one of the installations but not the other (even though I had already tried disabling all extensions in the debugging process, cf. above). So I got rid of the duplicate installation and now everything seems to work.
  • (if you are in the same situation: if you uninstall _one_ Brave, it may delete the state on what tabs you had open in either of them, if I remember correctly. I suspect this is the case because they might have kept state in the same path. So if you want to keep that, you might want to investigate where Brave stores state/configs/etc. and back that up before you uninstall one of the installations)
  • Hi, I have the same problem... reinstalled and uninstalled both Brave and Zotero Connector to no avail. Anyone had this problem and fixed it?
  • Same problem here. Zotero connector says Zotero Connector Server is Available. Everything works but I cant use zotero in google docs. I get the error.

    Is Zotero Running?
    The Zotero Connector was unable to communicate with the Zotero desktop application. Zotero must be open to use web-based citing.
  • Ditto. This just happened to me today. The one thing I did which may have contributed to this was that I installed Zotero Connector to a second profile in Brave. However, I deleted the browsing and extension data in More Tool --> Clear Browsing Data --> Advanced --> All checkboxes selected over past 24 hours for both Profiles, but this didn't help.

    I posted to the Brave forum here in case you want to watch or chime in:

  • I also filed a bug report with Zotero: Report ID: 1658200881
  • And here's my error message in the plugin:

    [JavaScript Error: "TypeError: Cannot read property 'length' of undefined
    at Object._updateExtensionUI (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js:518:30)
    at onNavigation (chrome-extension://ekhagklcjbdpajgpjgmbionohlpdbjgc/background.js:900:29)"]
  • This wouldn't be a problem in Zotero, so error reports wouldn't be relevant here. It's a problem in your browser or on your computer (e.g., misconfigured firewall). We can't help beyond what's on, though doesn't take any possible Brave-specific issues into consideration.

    (Disabling all of your other extensions would be the first thing to try, if you haven't yet.)
  • Thanks all, I'll keep an eye on that.

    I am able to load the URL to port 23119 (as suggested on the Troubleshooting page) but wasn't able to actually connect to Zotero...

    (I've tried disabling all other extensions, etc.)
  • Thanks, dstillman. I did disable all extensions, as well as lowering all Brave shields, all to no avail.
  • Have the same problem since this night. Anything we could do, like install Zotero on chrome or something? have my deadline today so unfortunate
  • We don't support Brave, so yes, certainly using a supported browser would be the thing to do if you're having trouble.
  • OK, I'm able to just use a different browser for now. Did not work on Chrome but on Firefox it did work. Now I just have to finish my thesis ^^
  • Thanks, dstillman. I've tried it on Chrome and it works.
  • Just chiming in to note that the Connector also stopped working for me on Brave this week, but continues to work in Chrome.
  • I opened a private tab in Brave and Zotero connector worked. I then deactivated many extensions and made the following changes in Brave and it's now fully functional in a normal tab. Still haven't identified the culprit.
  • I tried it in Private with shields down in Brave 1.21.73 on Windows. No success -- same result. Since that didn't work I didn't continue with changing the settings.
  • THANK YOU @mydjtl.
    I disabled only one setting in the options and it worked again, it was this on
    'Trackers & ads blocking' to 'Disabled'

  • THANK YOU @mydjtl and @Hans_Maisert !!

    This seems to be a general problem with Brave and the simple following manip worked out wonderfully for me:

    --> In options : TOGGLE 'Trackers & ads blocking' to 'Disabled'

  • You should report this to Brave. There's no reason it should be necessary to disable something called "Trackers & ads blocking" to allow a browser extension to connect to localhost.
  • It looks like it was broken in an update. People in the Brave forums ( are reporting that version 1.17.73 works, so rolling back is a second option.
  • edited March 5, 2021
    I wonder if Brave starting to block non-secure http localhost is what's causing this issue. Someone else complained about this in a non-Zotero context in the Brave forums here:
  • edited March 8, 2021
    [Edit: No longer necessary. This is fixed in Brave 1.21.74. — D.S.]

    I found a solution! Go to brave://adblock and enter @@ into custom filters. This whitelists localhost port 23119, [which is the one Zotero uses](

    I adapted this solution from [here](, another extension had the same problem.
  • Huzzah! That worked for me. Thanks for the solution, rhezab!

    For others, you can also access the menu where you add the custom filter by clicking the right hamburger menu, and selecting "Brave Ad Block".
  • No worries! I'm so glad I found a solution haha
  • This issue also affects other extensions and has already been fixed in version 1.21.74 (pre-release). You can download it at or maybe wait for the next update. It shouldn't be long.
  • Thanks for letting us know!
Sign In or Register to comment.