Zoo for Zotero - A new android app for viewing zotero libraries

  • @michael29 sorry I meant the author order within a publication.
    E.g. a paper by "Bloggs, Smith & Jones" may appear as by "Jones, Smith & Bloggs" or by "Smith, Bloggs & Jones" etc.
    I can't spot any obvious pattern.
  • @plumbley
    Oh right,
    there is no logic in the app for this so there isn't an order yet.
    I will implement sorting
  • Ok understood.
    Personally I think I often recognise papers as e.g. the Bloggs & Smith (2014) paper or the Jones et. al (2019) paper about "Some Topic", so that would be helpful for me.
    (Otherwise really nice app, great work!)
  • I have to say sorry, I did not test the app properly, almost everything is working very well.
    There is only 1 issue on my 2 devices, a Moto Z and a Samsung Tab Active2:
    The download of all attachments is very slow and has nothing to do with the WebDAV. I used the ZotDroid app from Benjamin before and there, the download was quite fast, so it seems to be an issue with the app itself.
    Thank you very much for this nice app!
  • edited March 6, 2020
    Just to say a big thank you for creating this app. I've only found it so not yet much extensive testing but playing with it for a while it all seems to work nicely for my situation (library with about 12000 entries, my own webdav/nextcloud storage, want like to keep PDFs on the SD card on the device for reading when I'm out without internet).

    It's great to finally have an app that works, it was frustrating to see half a dozen Android apps none of which actually worked completely.

    Some (hopefully helpful) comments:

    The display of the item details could be tidied up a bit. It takes up a lot of space and you have to scroll down to get to the attachments, for papers with a lot of authors that's awkward. So perhaps you could have a more compact display and the link to the attachments further up?

    SD card: It's good you can set the custom path, but not every user will realise that apps can only access files under [XXXX-XXXX]/Android/data/com.mickstarify.zooforzotero, so perhaps you should give this as an explicit option for selecting the path? I was also somewhat confused that "External cache" is not the SD card (I know this is Android terminology but still confusing). Some other apps show all the different available media with their sizes, something like

    * External (8 Gb; 2.3 Gb free)
    * SD Card (64Gb; 29.3 Gb free)
    * Custom path

    Where the first two options automatically chose the data/com.mickstarify.zooforzotero/cache path.

    But generally the main thing is that it works great, these are just cosmetic suggestions.
  • @smatthie
    > items details cleanup
    I agree though i am reluctant to put the attachments section at the top.
    For now, you can turn on the setting that defaults taps to opening attachments.

    >storage naming
    What name do you suggest other than "External Cache"?
    Perhaps "Default Storage"?

    Due to android limitations, the app does not have direct access to sd cards so the only way users can store files to an SD card is by directly selecting it through custom path, so i cannot provide a simple "sd card" option.
  • @michael29
    I know that android restricts access the the SD card very much and you can only write to very specific directories, but many users will not know that and will not know what they have to set in the custom path and can't just put it anywhere on the card. So I just think this should be more intuitive somehow, so that the user doesn't have to find the full path.

    Can the app not get a list of the available storage media? In Osmand (mapping app) there selection menu explicitly lists all the different storage locations with their sizes (eg. "External Storage 2: 23.77Gb free") so it must be possible to get that information somehow.

    Thanks for the suggestion "default opens attachments".
  • This app is amazing! Thanks so much for making it. I have one suggestion: it looks like if I annotate a PDF in a group library, the app does not prompt me to upload the changes to my Zotero storage. Am I doing something wrong, or is this a feature still to be implemented?
  • Great and reliable app. Thanks

    Silly question - I think there is not an option to do something like "Create a bibliography from item". For me, by having access to my library on my phone I'd like to be able to create a bibliography for an item and be able to email someone the (full) details of the paper I was referring to.

    If the option is there, how do I do it, if not, can I request it. As this is just to share the full reference details, I'm not too bothered about which style you would use.
  • @e.a.whitley@lse.ac.u

    Sure, i will try to add this feature.

    in the app, group libraries don't have the attachment annotations feature enabled yet.
    I have no eta on when i will implement it
  • edited April 1, 2020
    Everything works fine on a Boox Note 2 except that edited pdf attachments won't be synced back to server. In my case, I use dav service from Box.com as the storage backend.

    After testing with other pdf viewers on Boox Note 2, it's confirmed the builtin pdf view NeoReader 3.0 from Onyx (vendor of Boox Note 2) is so crappy that each time this NeoReader would copy a pdf from Zoo to /Download directory and save edited files there.

    Thank you very much for the great work, Michael! Sorry for the interruption.
  • Overall, this app works really well however it doesn't seem to remove deleted items/collections when syncing.
  • Great App! thanks @michael29! the possibility to addnotations on an android tablet with XODO and upload them via WEBDAV to zotero works great.
    The only thing that i have noticed is:
    when i delete an entry on my libray from my laptop, even after updating on Zoo for zotero on android, the entry still appears on my tablet, even not beeing also on my online library (accesing with browser). It seems that the android app only updates new entries, and changes on items data, but it doesn't update a deletion of an item...
    I'm using Zotero 5.0.85 on a macbook pro with high sierra and Zoo for Zotero on a tablet with android 9.
    best and thanks againg
  • Thanks a lot for this app, @michael29!
    I want to know if the login and password for my webdav server are safely encrypted on my device using Zoo (these are professional info).
    In fact, I am using Onyx tablet with no screen lock out-of-the-box (plus I shared it with my children nowadays for education purposes).
    Thanks for your time and devotion!
  • Using the app on a tablet and reading/annotating PDFs with XODO, sometimes when i close the PDF and Zoo tries to upload the PDF to my webdav server (pcloud) i get an error message (file not found in the server). I've realized that while in my computer the internal folder/name in zotero/storage for a file is GPIEFIWZ (for example) looking for the same prop file in the webdav cloud storage i find that the name is GPIEFIWZ_NEW.prop
    that's why Zoo can't upload the new changes that i have done in the PDF on the tablet, isn't it? Who and why changes the original name for this "_NEW" filename on the webdav server?
  • ...if i try to change the name on the webdav server directly and delete the "_END" when i try to upload the file form my tablet i get a new error: "403 forbiden"
  • i think Zoo for Zotero is the one that is changing the names in the webdav server and adding the "_END" characters to the prop and zip files
  • @khinsen: you can enable google play for the Boox products and then it works.
  • Hi,

    Thanks a lot for the app! I'm also using it on a Boox Note 2 e-ink device and find that it generally works well, but there are a few problems:

    (1) Although the app has no problem downloading my library entries, it keeps generating an error when trying to download attachments. I use Zotero storage to sync my files and find that the app downloads around 200 out of 600 attachments, then keeps generating errors of the form:

    "The following error occurred: java.10.FileNotFoundException:/storage/emulated/0/Android/data/com.mickstorify.zooforzotero/cache/5DH4Z4RN (Is a directory)"

    Once it gets to this point, I have to cancel the download. I can start it again, but then encounter a similar error message, but with a different directory name at the end. At first, I thought the problem was due to duplicated entries in my library, so I deleted them. However, like other people, I found that deletions weren't synced to the Zoo app, only additions. As a last resort, I tried re-installing the app all over again, but then just encountered the same error.

    (2) Like another Boox Note 2 user on this forum, I also have trouble syncing notes that I make on the PDFs. As mentioned before, it seems as if, when you open the attachment in the default Boox PDF reader app (Neoreader), it downloads a copy of the file in a different downloads folder, so that changes aren't synced back to Zotero. One option would be to try a different PDF reader but, unfortunately, Neoreader is optimised for reading on an e-ink device, whereas other PDF readers (e.g. Xodo) aren't and can be tough to use.

    Any help with either of these problems would be much appreciated! It's a fantastic app and it's frustrating to be *this* close to having it working! Thanks again for all your work on it.

  • @adamlondon: I have no solution for (1), but had the same problem with number (2). After fiddling around with it, trying out lots and lots of ways to save annotated pdfs in Neorader (EMbed, Export etc.), I think I found a solution:

    What works for me was to change the Attachment path in Zoo (Settings->Attachment Location) to a custom path which is *not* in the android folder. It seems like Neoreader can't fully access this path and therefore creates a copy when annotationg, which in return does not get recognized by Zoo. So after setting the path to something in the main folder (where the "Download" folder is in, too), it works. I can now open files with Zoo and annotate them, after going back it automatically saves the file and gives me the upload prompt. Hope that helps!

    @michael: Thanks for the great app by the way, helps a lot with my workflow :)
  • Hi,

    great App! However, since yesterday I am no longer able to see the content of my group library. I reinstalled the App several times and tried all kinds of settings but it is not working anymore. If anyone knows a fix, it would be greatly appreciated.

  • @sophieburkhardt
    apologies, that was a bug in the latest release.
    I have pushed a fix and it's available on google play right now.
  • @michael29 Thank you, it works again!
  • @michael29 Thanks for a great app
    Having a few probs with webdav - where do I find the logs for Zoo?
  • Great app! @michael29

    Two questions:

    1. It doesnt seem to update attachments when it's deleted. I delete an attachment from my computer, and it still shows up in Zoo after I refresh.

    2. Does it support Linked Files with relative path? I have on my computer set all PDFs linked to a relative path. All the PDFs are synced to my Android tablet. However, when I set "Attachments Location" to Android location, it does not open any of the attachments.

    Thank you for developing this app!
  • Does anyone have any good suggestions which ebook reader app to use which works with Zoo AND which allows syncing text highlight?

    For years I have used Moon+ Reader, but trying Zoo out yesterday, it seems to have the same problem, as it creates a copy of a file downloaded with Zoo, and thus, Zoo won't see and sync the correct file.

    I tried the solution as provided above by jntbrt (changing default attachment location of Zoo), but no luck.
  • Hi,
    I'm having a devil of a time with this app. I am so hopeful cause I love zotero and I really need it for Tablet.
    I have downloaded the app to my tablet but I can't get my library from my Laptop onto my tablet.
    Can someone please help me with this?

    Thank you so much in advance!
  • @ngozii Do you have synchronized your library through Zotero web?
  • Hello everyone,
    I am trying to use the Boox Nova2 with Zoo. Connecting and downloading from webdav is working fine, but while uploading the following error occurs:
    "okhttp3.internal.http2.StreamResetException: stream was reset: NO_ERROR"
    Does anybody have a similar error?
  • @Togela What webdav server are you using?
Sign In or Register to comment.