Stuck on "Zotero is updating your document. Please wait" in Google Docs

This discussion was created from comments split from: Zotero Google Docs is very, very slow.
  • I am stuck in
    "Zotero is updating your document.
    Please wait."

    and there is no progress bar to predict, or let me know, how long I should wait.
  • The progress bar is displayed by Zotero, not the browser, so you should look through the Zotero windows. If you cannot find a progress bar try restarting Zotero and your browser and try again.
  • Is there any news on this challenge? I have had the same issue now multiple times and am having trouble finding information about what to do about it. This is rather frustrating, particularly since Zotero doesn't seem to be integrating into my Microsoft Word properly. As such, I do not have a backup plan if troubleshooting Zotero in Google Docs doesn't work.
  • Zotero works well both with Google Docs and Word. If you are never seeing the citation dialog or progress bar pop up, it is likely because you are minimizing the Zotero window which unfortunately makes it impossible for Zotero to focus those dialog windows correctly. You should instead switch away from the Zotero window using the bottom toolbar. There is unlikely to be any changes regarding this.

    If you want help regarding Word integration troubleshooting please create a new thread and describe in detail what the problem is and what troubleshooting steps you have taken.
  • I wrote another thread about this a little while ago but it doesn't have to be posted. You actually have to manually switch, or other, to the Zotero Add/Edit Citation window which will be up and waiting. I am used to Word, where the Add/Edit Citation window pops up on top of Word, so you can choose an article. Pick the item and it will plunk the citation into your Google Doc switching you back automatically to the doc. BTW I am using Chrome with Windows7
  • I was having this same problem and finally thought to check the Windows Defender. I added Zotero to the list of apps allowed through the firewall and then it worked.
  • [solved by myself] I was having this issue for many times when opening a word-format doc through Google Doc. But it was resloved when you copy every text into the Google doc directly, then Zotero can detect the doc and the tool bar shows out! I mean, open file directly from Google Doc, not open a doc. or docx. file via Google doc.
  • @jasmineHZ: Yes, the plugin won't work if you open a .docx file directly in Google Docs via Google Drive. It needs to be a native Google Doc document. We're going to see if we can add a clearer warning about that.
  • I’ve been struggling with this for days. Happy I found this link. How do I change a drive doc to a native doc?
  • Never mind. Figured out the holdup. You have to put a page number the citation page in zotero.
  • I too faced this issue and solved it.

    Hurray!! Here you Go!!

    1. Make sure you create the google doc with same account which you have registered in zotero.

    2. In google doc, once you click the zotero icon, a hidden browser tab opens which asks to link the google doc with the zotero account. This hidden browser tab can be opened by alt+tab. Once you link the account, you are ready to use.

    Happy Research!!
  • 1. Make sure you create the google doc with same account which you have registered in zotero.
    No, this is incorrect. The account you use in Google Docs has no relation to your Zotero account whatsoever. (Zotero doesn't even require an account.) But you need to use the same Google account to create the document and to grant permission to the plugin.
    2. In google doc, once you click the zotero icon, a hidden browser tab opens which asks to link the google doc with the zotero account.
    You mean a window, not a tab, but to be clear, this window opens in the front by default — it's not "hidden" normally. But if it goes behind your other browser windows somehow, then yes, you would need to bring it to the front and select the account that you used to create the document.
  • I too find that when pressing Ctrl+Alt+C to add/edit a citation in GDocs, the QuickFormatCitation window opens 'behind', and not 'in front' and so one needs to find that window on the taskbar and click it to continue.

    Other threads suggested this might be if the Zotero stand-alone window has been minimised, but in my case this bug occurs even if it is not, in about 80% of the times (can't reliably figure out when it does not!).

    Can this be reproduced and maybe fixed? I used Firefox 78.6.1 and Zotero 5.0.94 on WIndows for the above report.
  • Just ignore the message.

    Instead, find the Zotero bar hidden behind the Zotero app. Find your source, enter and everything is fine.
Sign In or Register to comment.